[jira] [Commented] (LOG4J2-374) Add more options to PatternLayout to display more detailed information about a Throwable

2013-09-04 Thread Tibor Benke (JIRA)

[ 
https://issues.apache.org/jira/browse/LOG4J2-374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13757717#comment-13757717
 ] 

Tibor Benke commented on LOG4J2-374:


It's my pleasure :)

I verified the modifications.

 Add more options to PatternLayout to display more detailed information about 
 a Throwable
 

 Key: LOG4J2-374
 URL: https://issues.apache.org/jira/browse/LOG4J2-374
 Project: Log4j 2
  Issue Type: Improvement
  Components: Layouts
Reporter: Tibor Benke
 Fix For: 2.0-beta9

 Attachments: LOG4J2-374.patch, LOG4J2-374_v2.patch


 That would be useful if we got more details about the method which threw the 
 exception. There is a short form, which contains these information, but 
 there can be some cases, when we need them separately.
 For example we would write something like this:
 {noformat}
 %throwable{className}.%throwable{methodName}:%throwable{lineNumber} 
 %throwable{message}
 {noformat}
 And we would get this:
 {noformat}
 foo.bar.ClassName.main:14 java.lang.ArithmeticException: / by zero
 {noformat}
 I think we should only modify the ThrowablePatternConverter and 
 ThrowableFormatOptions classes and the documentation. What do you think about 
 it?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

-
To unsubscribe, e-mail: log4j-dev-unsubscr...@logging.apache.org
For additional commands, e-mail: log4j-dev-h...@logging.apache.org



[jira] [Commented] (LOG4J2-374) Add more options to PatternLayout to display more detailed information about a Throwable

2013-09-02 Thread Tibor Benke (JIRA)

[ 
https://issues.apache.org/jira/browse/LOG4J2-374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13755954#comment-13755954
 ] 

Tibor Benke commented on LOG4J2-374:


You are right. I'm not good in giving names :)

Btw I'm going to attach a new patch. I edited the code, so now this feature is 
part of the ThrowablePatternConverter class.

 Add more options to PatternLayout to display more detailed information about 
 a Throwable
 

 Key: LOG4J2-374
 URL: https://issues.apache.org/jira/browse/LOG4J2-374
 Project: Log4j 2
  Issue Type: Improvement
  Components: Layouts
Affects Versions: 2.0-beta9
Reporter: Tibor Benke
 Attachments: LOG4J2-374.patch, LOG4J2-374_v2.patch


 That would be useful if we got more details about the method which threw the 
 exception. There is a short form, which contains these information, but 
 there can be some cases, when we need them separately.
 For example we would write something like this:
 {noformat}
 %throwable{className}.%throwable{methodName}:%throwable{lineNumber} 
 %throwable{message}
 {noformat}
 And we would get this:
 {noformat}
 foo.bar.ClassName.main:14 java.lang.ArithmeticException: / by zero
 {noformat}
 I think we should only modify the ThrowablePatternConverter and 
 ThrowableFormatOptions classes and the documentation. What do you think about 
 it?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

-
To unsubscribe, e-mail: log4j-dev-unsubscr...@logging.apache.org
For additional commands, e-mail: log4j-dev-h...@logging.apache.org



[jira] [Commented] (LOG4J2-374) Add more options to PatternLayout to display more detailed information about a Throwable

2013-08-31 Thread Gary Gregory (JIRA)

[ 
https://issues.apache.org/jira/browse/LOG4J2-374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13755521#comment-13755521
 ] 

Gary Gregory commented on LOG4J2-374:
-

Any thoughts from others?

I'm not sure this should be a separate class and %name.

It could also be: %throwable{short.className},  %throwable{short.methodName} 
and so on.

If it is a separate class, I would call it %ShortThrowable as opposed to the 
proposed %csThrowable which is too cryptic IMO.

Thoughts?

 Add more options to PatternLayout to display more detailed information about 
 a Throwable
 

 Key: LOG4J2-374
 URL: https://issues.apache.org/jira/browse/LOG4J2-374
 Project: Log4j 2
  Issue Type: Improvement
  Components: Layouts
Affects Versions: 2.0-beta9
Reporter: Tibor Benke
 Attachments: LOG4J2-374.patch


 That would be useful if we got more details about the method which threw the 
 exception. There is a short form, which contains these information, but 
 there can be some cases, when we need them separately.
 For example we would write something like this:
 {noformat}
 %throwable{className}.%throwable{methodName}:%throwable{lineNumber} 
 %throwable{message}
 {noformat}
 And we would get this:
 {noformat}
 foo.bar.ClassName.main:14 java.lang.ArithmeticException: / by zero
 {noformat}
 I think we should only modify the ThrowablePatternConverter and 
 ThrowableFormatOptions classes and the documentation. What do you think about 
 it?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

-
To unsubscribe, e-mail: log4j-dev-unsubscr...@logging.apache.org
For additional commands, e-mail: log4j-dev-h...@logging.apache.org



[jira] [Commented] (LOG4J2-374) Add more options to PatternLayout to display more detailed information about a Throwable

2013-08-28 Thread Tibor Benke (JIRA)

[ 
https://issues.apache.org/jira/browse/LOG4J2-374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13752185#comment-13752185
 ] 

Tibor Benke commented on LOG4J2-374:


I thought about it and I think we should use another pattern name than 
%throwable in this case, because this improvement would imply the use of 
%throwable{short} form, so it would be specious. Maybe the 
DetailedShortThrowablePatternConverter or CustomShortThrowablePatternConverter 
would be more expressive, so we could use the %dsThrowable or %csThrowable 
names.

 Add more options to PatternLayout to display more detailed information about 
 a Throwable
 

 Key: LOG4J2-374
 URL: https://issues.apache.org/jira/browse/LOG4J2-374
 Project: Log4j 2
  Issue Type: Improvement
  Components: Layouts
Affects Versions: 2.0-beta9
Reporter: Tibor Benke

 That would be useful if we got more details about the method which threw the 
 exception. There is a short form, which contains these information, but 
 there can be some cases, when we need them separately.
 For example we would write something like this:
 {noformat}
 %throwable{className}.%throwable{methodName}:%throwable{lineNumber} 
 %throwable{message}
 {noformat}
 And we would get this:
 {noformat}
 foo.bar.ClassName.main:14 java.lang.ArithmeticException: / by zero
 {noformat}
 I think we should only modify the ThrowablePatternConverter and 
 ThrowableFormatOptions classes and the documentation. What do you think about 
 it?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

-
To unsubscribe, e-mail: log4j-dev-unsubscr...@logging.apache.org
For additional commands, e-mail: log4j-dev-h...@logging.apache.org



[jira] [Commented] (LOG4J2-374) Add more options to PatternLayout to display more detailed information about a Throwable

2013-08-27 Thread Gary Gregory (JIRA)

[ 
https://issues.apache.org/jira/browse/LOG4J2-374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13751991#comment-13751991
 ] 

Gary Gregory commented on LOG4J2-374:
-

You might as well throw in %throwable{fileName} while you are in there ;)

Patches welcome.

 Add more options to PatternLayout to display more detailed information about 
 a Throwable
 

 Key: LOG4J2-374
 URL: https://issues.apache.org/jira/browse/LOG4J2-374
 Project: Log4j 2
  Issue Type: Improvement
  Components: Layouts
Affects Versions: 2.0-beta9
Reporter: Tibor Benke

 That would be useful if we got more details about the method which threw the 
 exception. There is a short form, which contains these information, but 
 there can be some cases, when we need them separately.
 For example we would write something like this:
 {noformat}
 %throwable{className}.%throwable{methodName}:%throwable{lineNumber} 
 %throwable{message}
 {noformat}
 And we would get this:
 {noformat}
 foo.bar.ClassName.main:14 java.lang.ArithmeticException: / by zero
 {noformat}
 I think we should only modify the ThrowablePatternConverter and 
 ThrowableFormatOptions classes and the documentation. What do you think about 
 it?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

-
To unsubscribe, e-mail: log4j-dev-unsubscr...@logging.apache.org
For additional commands, e-mail: log4j-dev-h...@logging.apache.org