Re: [Mesa-dev] [PATCH 00/18] anv: Switch to a new emit macro

2016-04-20 Thread Jason Ekstrand
On Wed, Apr 20, 2016 at 11:38 AM, Kristian Høgsberg 
wrote:

> On Mon, Apr 18, 2016 at 5:10 PM, Jason Ekstrand 
> wrote:
> > The first patch in this series adds a short style guide for the Vulkan
> > driver.  The rest adds a new emit macro and updates the entire driver to
> > use it and, while we're there, makes the style more consistent.
> >
> > Jason Ekstrand (18):
> >   anv: Add a short style guide
> >   anv: Add a new block-based batch emit macro
> >   anv/cmd_buffer: Use the new emit macro for 3DPRIMITIVE commands
> >   anv/cmd_buffer: Use the new emit macro for PIPE_CONTROL and
> > STATE_BASE_ADDRESS
> >   anv/cmd_buffer: Use the new emit macro for DEPTH/STENCIL_BUFFER
> >   anv/cmd_buffer: Use the new emit macro for 3DSTATE_CONSTANT
> >   anv/cmd_buffer: Use the new emit macro for compute shader dispatch
> >   anv/cmd_buffer: Use the new emit macro for DRAWING_RECTANGLE
> >   anv/cmd_buffer: Use the new emit macro for quaries
> >   anv/gen8_cmd_buffer: Use the new emit macro
> >   anv/genX_pipeline: Use the new emit macro
> >   anv/gen8_pipeline: Use the new emit macro
> >   anv/state: Use the new emit macro
> >   anv/device: Use the new emit macro
> >   anv/gen7_cmd_buffer: Use the new emit macro
> >   anv/gen7_pipeline: Use the new emit macro
> >   anv: Remove the old emit macro
> >   anv: s/anv_batch_emit_blk/anv_batch_emit/
> >
> >  src/intel/vulkan/STYLE|  67 +
> >  src/intel/vulkan/anv_batch_chain.c|  17 +-
> >  src/intel/vulkan/anv_device.c |   8 +-
> >  src/intel/vulkan/anv_private.h|  19 +-
> >  src/intel/vulkan/gen7_cmd_buffer.c| 115 
> >  src/intel/vulkan/gen7_pipeline.c  | 236 +
> >  src/intel/vulkan/gen8_cmd_buffer.c| 155 ++-
> >  src/intel/vulkan/gen8_pipeline.c  | 367 +-
> >  src/intel/vulkan/genX_cmd_buffer.c| 480
> +++---
> >  src/intel/vulkan/genX_pipeline.c  |  25 +-
> >  src/intel/vulkan/genX_pipeline_util.h |  58 ++--
> >  src/intel/vulkan/genX_state.c | 155 +--
> >  12 files changed, 938 insertions(+), 764 deletions(-)
> >  create mode 100644 src/intel/vulkan/STYLE
>
> That's a lot of lines!
>

I'm just trying to make as much of the Vulkan driver blame to me as
possible. :-P


> Acked-by: Kristian Høgsberg 
>
> >
> > --
> > 2.5.0.400.gff86faf
> >
> > ___
> > mesa-dev mailing list
> > mesa-dev@lists.freedesktop.org
> > https://lists.freedesktop.org/mailman/listinfo/mesa-dev
>
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev


Re: [Mesa-dev] [PATCH 00/18] anv: Switch to a new emit macro

2016-04-20 Thread Kristian Høgsberg
On Mon, Apr 18, 2016 at 5:10 PM, Jason Ekstrand  wrote:
> The first patch in this series adds a short style guide for the Vulkan
> driver.  The rest adds a new emit macro and updates the entire driver to
> use it and, while we're there, makes the style more consistent.
>
> Jason Ekstrand (18):
>   anv: Add a short style guide
>   anv: Add a new block-based batch emit macro
>   anv/cmd_buffer: Use the new emit macro for 3DPRIMITIVE commands
>   anv/cmd_buffer: Use the new emit macro for PIPE_CONTROL and
> STATE_BASE_ADDRESS
>   anv/cmd_buffer: Use the new emit macro for DEPTH/STENCIL_BUFFER
>   anv/cmd_buffer: Use the new emit macro for 3DSTATE_CONSTANT
>   anv/cmd_buffer: Use the new emit macro for compute shader dispatch
>   anv/cmd_buffer: Use the new emit macro for DRAWING_RECTANGLE
>   anv/cmd_buffer: Use the new emit macro for quaries
>   anv/gen8_cmd_buffer: Use the new emit macro
>   anv/genX_pipeline: Use the new emit macro
>   anv/gen8_pipeline: Use the new emit macro
>   anv/state: Use the new emit macro
>   anv/device: Use the new emit macro
>   anv/gen7_cmd_buffer: Use the new emit macro
>   anv/gen7_pipeline: Use the new emit macro
>   anv: Remove the old emit macro
>   anv: s/anv_batch_emit_blk/anv_batch_emit/
>
>  src/intel/vulkan/STYLE|  67 +
>  src/intel/vulkan/anv_batch_chain.c|  17 +-
>  src/intel/vulkan/anv_device.c |   8 +-
>  src/intel/vulkan/anv_private.h|  19 +-
>  src/intel/vulkan/gen7_cmd_buffer.c| 115 
>  src/intel/vulkan/gen7_pipeline.c  | 236 +
>  src/intel/vulkan/gen8_cmd_buffer.c| 155 ++-
>  src/intel/vulkan/gen8_pipeline.c  | 367 +-
>  src/intel/vulkan/genX_cmd_buffer.c| 480 
> +++---
>  src/intel/vulkan/genX_pipeline.c  |  25 +-
>  src/intel/vulkan/genX_pipeline_util.h |  58 ++--
>  src/intel/vulkan/genX_state.c | 155 +--
>  12 files changed, 938 insertions(+), 764 deletions(-)
>  create mode 100644 src/intel/vulkan/STYLE

That's a lot of lines!

Acked-by: Kristian Høgsberg 

>
> --
> 2.5.0.400.gff86faf
>
> ___
> mesa-dev mailing list
> mesa-dev@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/mesa-dev
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev


[Mesa-dev] [PATCH 00/18] anv: Switch to a new emit macro

2016-04-18 Thread Jason Ekstrand
The first patch in this series adds a short style guide for the Vulkan
driver.  The rest adds a new emit macro and updates the entire driver to
use it and, while we're there, makes the style more consistent.

Jason Ekstrand (18):
  anv: Add a short style guide
  anv: Add a new block-based batch emit macro
  anv/cmd_buffer: Use the new emit macro for 3DPRIMITIVE commands
  anv/cmd_buffer: Use the new emit macro for PIPE_CONTROL and
STATE_BASE_ADDRESS
  anv/cmd_buffer: Use the new emit macro for DEPTH/STENCIL_BUFFER
  anv/cmd_buffer: Use the new emit macro for 3DSTATE_CONSTANT
  anv/cmd_buffer: Use the new emit macro for compute shader dispatch
  anv/cmd_buffer: Use the new emit macro for DRAWING_RECTANGLE
  anv/cmd_buffer: Use the new emit macro for quaries
  anv/gen8_cmd_buffer: Use the new emit macro
  anv/genX_pipeline: Use the new emit macro
  anv/gen8_pipeline: Use the new emit macro
  anv/state: Use the new emit macro
  anv/device: Use the new emit macro
  anv/gen7_cmd_buffer: Use the new emit macro
  anv/gen7_pipeline: Use the new emit macro
  anv: Remove the old emit macro
  anv: s/anv_batch_emit_blk/anv_batch_emit/

 src/intel/vulkan/STYLE|  67 +
 src/intel/vulkan/anv_batch_chain.c|  17 +-
 src/intel/vulkan/anv_device.c |   8 +-
 src/intel/vulkan/anv_private.h|  19 +-
 src/intel/vulkan/gen7_cmd_buffer.c| 115 
 src/intel/vulkan/gen7_pipeline.c  | 236 +
 src/intel/vulkan/gen8_cmd_buffer.c| 155 ++-
 src/intel/vulkan/gen8_pipeline.c  | 367 +-
 src/intel/vulkan/genX_cmd_buffer.c| 480 +++---
 src/intel/vulkan/genX_pipeline.c  |  25 +-
 src/intel/vulkan/genX_pipeline_util.h |  58 ++--
 src/intel/vulkan/genX_state.c | 155 +--
 12 files changed, 938 insertions(+), 764 deletions(-)
 create mode 100644 src/intel/vulkan/STYLE

-- 
2.5.0.400.gff86faf

___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev