[Mikrotik] Tracking MAPI

2009-04-30 Thread D. Ryan Spott

I have been asked to track MAPI traffic on a customers network.

According to Microsoft: Microsoft Exchange Server includes several 
system services. When a MAPI client such as Microsoft Outlook connects 
to an Exchange server, the client first connects to the RPC endpoint 
mapper (the RPC Locator Service) on TCP port 135. The RPC endpoint 
mapper tells the client which ports to use to connect to the Exchange 
Server service, which are dynamically assigned.


With this info, I would assume that this would be something I would need 
to look at via layer 7. Can someone here perhaps post a sample of what 
might track this traffic?


t'anks!

ryan
-- next part --
An HTML attachment was scrubbed...
URL: 
http://www.butchevans.com/pipermail/mikrotik/attachments/20090430/7caf459f/attachment.html
___
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS


Re: [Mikrotik] reset and config script

2009-04-30 Thread Butch Evans
On Wed, 2009-04-29 at 21:45 -0500, Terri Kelley wrote:
 with a generic script that they could edit for the changing items such  
 as IP address for the bridge but remove the complete setup on the  
 existing routered cpe. Otherwise they would need to look at the  
 current setup of the existing cpe, remove the unwanted items such as  
 ip addresses on the wlan and ethernet, nat etc., then make the bridge.

If you want a full config, then take a look at my blog for a sample
(it's a CPE router, but the framework is there and you can use it as a
guide).  Alternatively, you can do something like:

/interface bridge add
/interface bridge port
add interface=wlan1 bridge=bridge1
add interface=ether1 bridge=bridge1
/ip address set [find interface=wlan1] interface=bridge1
/ip address remove [find interface=ether1]
/ip firewall nat remove [find]

That should take a standard nat cpe and convert it to bridged config.
You may have to change the wlan1 card config and set it up to be
station-wds (add the following if so)

/interface wireless
set wlan1 mode=station-wds wds-mode=dynamic wds-default-bridge=bridge1

Add the above 2 lines between changing the IP and last interface being
added to the bridge.

This may not work exactly in your configuration, but it's the best I can
do without seeing/knowing your configuration.  When it runs, the IP
address that was assigned to the wlan1 interface will be moved to the
bridge, so you can still manage the device without needing to update
your network documentation.

-- 

* Butch Evans   * Professional Network Consultation*
* http://www.butchevans.com/* Network Engineering  *
* http://www.wispa.org/ * WISPA Board Member   *
* http://blog.butchevans.com/   * Wired or Wireless Networks   *



___
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS


Re: [Mikrotik] reset and config script

2009-04-30 Thread Terri Kelley
Well, my original was done way to late after getting up at 3am to run  
to the hospital. Anyway, I had something similar to what Butch has  
here but I didn't realize you could do a find which will work well,  
finding and removing all entries in say NAT or IP addresses then add  
the new config. I think that will work well and will give it a try.


Terri Kelley
Network Engineer



On Apr 30, 2009, at 6:37 PM, Butch Evans wrote:


On Wed, 2009-04-29 at 21:45 -0500, Terri Kelley wrote:
with a generic script that they could edit for the changing items  
such

as IP address for the bridge but remove the complete setup on the
existing routered cpe. Otherwise they would need to look at the
current setup of the existing cpe, remove the unwanted items such as
ip addresses on the wlan and ethernet, nat etc., then make the  
bridge.


If you want a full config, then take a look at my blog for a sample
(it's a CPE router, but the framework is there and you can use it as a
guide).  Alternatively, you can do something like:

/interface bridge add
/interface bridge port
add interface=wlan1 bridge=bridge1
add interface=ether1 bridge=bridge1
/ip address set [find interface=wlan1] interface=bridge1
/ip address remove [find interface=ether1]
/ip firewall nat remove [find]

That should take a standard nat cpe and convert it to bridged  
config.

You may have to change the wlan1 card config and set it up to be
station-wds (add the following if so)

/interface wireless
set wlan1 mode=station-wds wds-mode=dynamic wds-default-bridge=bridge1

Add the above 2 lines between changing the IP and last interface being
added to the bridge.

This may not work exactly in your configuration, but it's the best I  
can

do without seeing/knowing your configuration.  When it runs, the IP
address that was assigned to the wlan1 interface will be moved to the
bridge, so you can still manage the device without needing to update
your network documentation.

--

* Butch Evans   * Professional Network Consultation*
* http://www.butchevans.com/* Network Engineering  *
* http://www.wispa.org/ * WISPA Board Member   *
* http://blog.butchevans.com/   * Wired or Wireless Networks   *



___
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik  
RouterOS


-- next part --
An HTML attachment was scrubbed...
URL: 
http://www.butchevans.com/pipermail/mikrotik/attachments/20090430/e7c74fea/attachment.html
___
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS