Re: [Mikrotik] reset and config script

2009-04-30 Thread Butch Evans
On Wed, 2009-04-29 at 21:45 -0500, Terri Kelley wrote:
 with a generic script that they could edit for the changing items such  
 as IP address for the bridge but remove the complete setup on the  
 existing routered cpe. Otherwise they would need to look at the  
 current setup of the existing cpe, remove the unwanted items such as  
 ip addresses on the wlan and ethernet, nat etc., then make the bridge.

If you want a full config, then take a look at my blog for a sample
(it's a CPE router, but the framework is there and you can use it as a
guide).  Alternatively, you can do something like:

/interface bridge add
/interface bridge port
add interface=wlan1 bridge=bridge1
add interface=ether1 bridge=bridge1
/ip address set [find interface=wlan1] interface=bridge1
/ip address remove [find interface=ether1]
/ip firewall nat remove [find]

That should take a standard nat cpe and convert it to bridged config.
You may have to change the wlan1 card config and set it up to be
station-wds (add the following if so)

/interface wireless
set wlan1 mode=station-wds wds-mode=dynamic wds-default-bridge=bridge1

Add the above 2 lines between changing the IP and last interface being
added to the bridge.

This may not work exactly in your configuration, but it's the best I can
do without seeing/knowing your configuration.  When it runs, the IP
address that was assigned to the wlan1 interface will be moved to the
bridge, so you can still manage the device without needing to update
your network documentation.

-- 

* Butch Evans   * Professional Network Consultation*
* http://www.butchevans.com/* Network Engineering  *
* http://www.wispa.org/ * WISPA Board Member   *
* http://blog.butchevans.com/   * Wired or Wireless Networks   *



___
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS


Re: [Mikrotik] reset and config script

2009-04-30 Thread Terri Kelley
Well, my original was done way to late after getting up at 3am to run  
to the hospital. Anyway, I had something similar to what Butch has  
here but I didn't realize you could do a find which will work well,  
finding and removing all entries in say NAT or IP addresses then add  
the new config. I think that will work well and will give it a try.


Terri Kelley
Network Engineer



On Apr 30, 2009, at 6:37 PM, Butch Evans wrote:


On Wed, 2009-04-29 at 21:45 -0500, Terri Kelley wrote:
with a generic script that they could edit for the changing items  
such

as IP address for the bridge but remove the complete setup on the
existing routered cpe. Otherwise they would need to look at the
current setup of the existing cpe, remove the unwanted items such as
ip addresses on the wlan and ethernet, nat etc., then make the  
bridge.


If you want a full config, then take a look at my blog for a sample
(it's a CPE router, but the framework is there and you can use it as a
guide).  Alternatively, you can do something like:

/interface bridge add
/interface bridge port
add interface=wlan1 bridge=bridge1
add interface=ether1 bridge=bridge1
/ip address set [find interface=wlan1] interface=bridge1
/ip address remove [find interface=ether1]
/ip firewall nat remove [find]

That should take a standard nat cpe and convert it to bridged  
config.

You may have to change the wlan1 card config and set it up to be
station-wds (add the following if so)

/interface wireless
set wlan1 mode=station-wds wds-mode=dynamic wds-default-bridge=bridge1

Add the above 2 lines between changing the IP and last interface being
added to the bridge.

This may not work exactly in your configuration, but it's the best I  
can

do without seeing/knowing your configuration.  When it runs, the IP
address that was assigned to the wlan1 interface will be moved to the
bridge, so you can still manage the device without needing to update
your network documentation.

--

* Butch Evans   * Professional Network Consultation*
* http://www.butchevans.com/* Network Engineering  *
* http://www.wispa.org/ * WISPA Board Member   *
* http://blog.butchevans.com/   * Wired or Wireless Networks   *



___
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik  
RouterOS


-- next part --
An HTML attachment was scrubbed...
URL: 
http://www.butchevans.com/pipermail/mikrotik/attachments/20090430/e7c74fea/attachment.html
___
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://www.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS


Re: [Mikrotik] reset and config script

2009-04-29 Thread Josh Luthman
Not really what?

On 4/30/09, Terri Kelley net...@farm-market.net wrote:
 Not really. Pseudobridge works just fine for these between my bridged
 AP and a bridged cpe.

 Terri Kelley
 Network Engineer
 254-697-6710



 This email message is intended only for the named recipient(s) above,
 and
 may contain, together with any attachment(s), confidential information
 that
 is privileged.  If you are not the intended recipient, be advised that
 you
 have received this email in error and that any use, dissemination,
 forwarding, printing, copying or distribution of this message and any
 attachment(s) is strictly prohibited.




 On Apr 29, 2009, at 11:12 PM, Josh Luthman wrote:

 I've made templates for bridge customers an NAT ones.  Bridge
 customers have to pppoe in to the AP themselves - NAT customers have
 the cpe MT do the pppoe work.

 On 4/29/09, Terri Kelley net...@farm-market.net wrote:
 Well, a couple of things there and maybe clarification. Our normal
 setup for customers is the cpe is a router. The business decided they
 wanted to run their own servers etc. It becomes much easier in those
 cases to bridge the cpe and let the business do whatever they need on
 their own routers (less work for me).  My thought was to provide
 techs
 with a generic script that they could edit for the changing items
 such
 as IP address for the bridge but remove the complete setup on the
 existing routered cpe. Otherwise they would need to look at the
 current setup of the existing cpe, remove the unwanted items such as
 ip addresses on the wlan and ethernet, nat etc., then make the
 bridge.

 So it is not a matter of restoring a backup but essentially a brand
 new config, a bridge, on an existing cpe that is currently a router.
 Hence the need to remove the current config and add a new via one
 script. I haven't tried yet but was afraid the /sys reset would not
 allow the rest of the bridge config script to finish.


 Terri Kelley
 Network Engineer
 FMB

 On Apr 29, 2009, at 9:31 PM, Josh Luthman wrote:

 You can clear all configuration by typing /sys reset

 What I would do is have the tech plug in the new MT into the network
 and
 then VNC a PC on that LAN.  You can then open the winbox and
 config as
 needed.

 Alternatively (maybe...) you can send the binary backup and have the
 tech
 restore it.  I believe this overwrites everything.

 Josh Luthman
 Office: 937-552-2340
 Direct: 937-552-2343
 1100 Wayne St
 Suite 1337
 Troy, OH 45373

 Those who don't understand UNIX are condemned to reinvent it,
 poorly.
 --- Henry Spencer


 On Wed, Apr 29, 2009 at 10:23 PM, Terri Kelley net...@farm-
 market.netwrote:

 Guys, I ran across something today which I had not planned on. Had
 a family
 emergency and was out of pocket but also had a very important
 config
 scheduled for a business which really needed to be done. I had to
 phone one
 of my techs during a break at the Hospital to walk him through the
 config
 which pointed out to me a need for a script to help them do this.
 What
 needed to be done was to take a Mikrotik CPE configured as a router
 and
 convert it to a bridge.

 In trying to make this as easy as I can on the techs, is there a
 way to
 remove the current config and add the new config for the bridge
 using one
 script via ethernet connection (not serial). My first thought was
 to start
 the script with a reset followed by the bridge config but then
 thought that
 may not work because the bridge config might not happen because of
 the reset
 starting that single script.

 Any thoughts on how to do such a thing?

 Terri Kelley
 Network Engineer
 254-697-6710



 This email message is intended only for the named recipient(s)
 above, and
 may contain, together with any attachment(s), confidential
 information that
 is privileged.  If you are not the intended recipient, be advised
 that you
 have received this email in error and that any use, dissemination,
 forwarding, printing, copying or distribution of this message and
 any
 attachment(s) is strictly prohibited.




 -- next part --
 An HTML attachment was scrubbed...
 URL: 
 http://www.butchevans.com/pipermail/mikrotik/attachments/20090429/91834e3b/attachment.html

 -- next part --
 A non-text attachment was scrubbed...
 Name: LogoHzlsigtest.jpg
 Type: image/jpeg
 Size: 2158 bytes
 Desc: not available
 URL: 
 http://www.butchevans.com/pipermail/mikrotik/attachments/20090429/91834e3b/attachment.jpg

 ___
 Mikrotik mailing list
 Mikrotik@mail.butchevans.com
 http://www.butchevans.com/mailman/listinfo/mikrotik

 Visit http://blog.butchevans.com/ for tutorials related to Mikrotik
 RouterOS

 -- next part --
 An HTML attachment was scrubbed...
 URL:
 http://www.butchevans.com/pipermail/mikrotik/attachments/20090429/f63f813f/attachment.html


 ___
 Mikrotik mailing list
 Mikrotik@mail.butchevans.com