Re: Etherchannel OpenBSD?

2008-12-23 Thread Sevan / Venture37

Stuart Morgan wrote:

Hi Nigel and all,

Thanks very much for the suggestion, unfortunately my 3500XL doesn't 
support LACP - perhaps I need a firmware upgrade?


you'll need a 2950 or newer to do LACP, if you want to play with 
etherchannel have a look at lagg(4) on FreeBSD, I used it for a while 
with my 3500's, didn't have any problems.



Sevan



Re: Etherchannel OpenBSD?

2008-12-23 Thread Martin Toft
On Mon, Dec 22, 2008 at 03:52:33PM +, Stuart Morgan wrote:
 Hi all,
 
 Does anyone known if trunk(4) supports Cisco Etherchannel?
 
 I have a 3500XL with the following port configuration:
 
 interface FastEthernet0/22
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 interface FastEthernet0/24
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 !

FWIW, I've successfully setup a 2x100 Mbps trunk between two D-Link
DGE-530T network cards (sk(4)) in an OpenBSD -current (November 2008)
box and two cobber ports in a Cisco 2924XL.

With regard to the switch, I just added port group X to both
interfaces. I don't have access to the OpenBSD box anymore, but I made a
hostname.trunkY roughly similar to the following:

!ifconfig skZ up
!ifconfig skW up
!ifconfig trunkY trunkport skZ trunkport skW address netmask netmask

Martin



Re: Etherchannel OpenBSD?

2008-12-23 Thread Pete Vickers

From:

http://www.cisco.com/en/US/products/hw/switches/ps607/products_configuration_example09186a0080094789.shtml


Note: Catalyst 2900XL/3500XL switches do not support LACP. Catalyst  
2950/2955 switches support LACP for channel negotiation with Cisco IOS  
Software Release 12.1(6)EA2 or later. Cisco IOS Software Release 12.0  
supports only static configuration. Catalyst 2940 and 2970 support  
LACP in all Cisco IOS Software releases.


/Pete


On 23 Dec 2008, at 08:07, Claudio Jeker wrote:


On Tue, Dec 23, 2008 at 12:45:23AM +, Stuart Morgan wrote:

Hi Nigel and all,

Thanks very much for the suggestion, unfortunately my 3500XL doesn't
support LACP - perhaps I need a firmware upgrade?

*sw1a#sh ver
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC16,
RELEASE SOFTWARE (fc1)
System image file is flash:c3500xl-c3h2s-mz.120-5.WC16.bin



The 3500XL are end of life for a good reason. Those switches are so
limited they're not even fun for a lab. Even if you get a newer IOS  
image

for them I doubt they will support LACP.

--
:wq Claudio




Etherchannel OpenBSD?

2008-12-22 Thread Stuart Morgan

Hi all,

Does anyone known if trunk(4) supports Cisco Etherchannel?

I have a 3500XL with the following port configuration:

interface FastEthernet0/22
port group 1
switchport trunk encapsulation dot1q
switchport mode trunk
interface FastEthernet0/24
port group 1
switchport trunk encapsulation dot1q
switchport mode trunk
!


Within OpenBSD 4.4 (-stable, generic), I have the following interface 
config:


trunk0: flags=8843UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST mtu 1500
   lladdr 00:0c:29:40:2b:dc
   trunk: trunkproto roundrobin
   trunkport vic2 active
   trunkport vic1 master,active
   groups: trunk
   media: Ethernet autoselect
   status: active
   inet6 fe80::20c:29ff:fe40:2bd2%trunk0 prefixlen 64 scopeid 0x9
vlan11: flags=8843UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST mtu 1500
   lladdr 00:0c:29:40:2b:dc
   vlan: 11 priority: 0 parent interface: trunk0
   groups: vlan


However running tcpdump on trunk0 does not give the L3 traffic I would 
expect. The manpage explicitly mentions 802.3ad but other sites on the 
Internet refer to Etherchannels as being supported (but I don't know if 
they are confusingly using 'etherchannel', 'port group' and 'LACP' 
interchangeably)


[r...@gw1-uk]# tcpdump -i vlan11 -vv
tcpdump: listening on vlan11, link-type EN10MB
15:51:09.269539 SSTP STP config root=8000.0:7:eb:93:bb:c7 rootcost=4 
bridge=8000.0:d:ed:79:59:86 port=1 ifcost=128 age=1/0 max=20/0 hello=2/0 
fwdelay=15/0 pvid=11
15:51:11.260602 SSTP STP config root=8000.0:7:eb:93:bb:c7 rootcost=4 
bridge=8000.0:d:ed:79:59:86 port=1 ifcost=128 age=1/0 max=20/0 hello=2/0 
fwdelay=15/0 pvid=11
15:51:13.260017 SSTP STP config root=8000.0:7:eb:93:bb:c7 rootcost=4 
bridge=8000.0:d:ed:79:59:86 port=1 ifcost=128 age=1/0 max=20/0 hello=2/0 
fwdelay=15/0 pvid=11


Any advice would be appreciated!

Stu



Re: Etherchannel OpenBSD?

2008-12-22 Thread Nigel Wohlers

On 23/12/08 4:52 AM, Stuart Morgan wrote:

Hi all,

Does anyone known if trunk(4) supports Cisco Etherchannel?

I have a 3500XL with the following port configuration:

interface FastEthernet0/22
port group 1
switchport trunk encapsulation dot1q
switchport mode trunk
interface FastEthernet0/24
port group 1
switchport trunk encapsulation dot1q
switchport mode trunk
!



[snip]


Any advice would be appreciated!

Stu



Hi

I'm not sure that Etherchannel is supported, however LACP works on a 
channel-group:


interface FastEthernet0/22
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
 channel-protocol lacp

interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
 channel-protocol lacp


N.



Re: Etherchannel OpenBSD?

2008-12-22 Thread Stuart Morgan

Hi Nigel and all,

Thanks very much for the suggestion, unfortunately my 3500XL doesn't 
support LACP - perhaps I need a firmware upgrade?


*sw1a#sh ver
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC16, 
RELEASE SOFTWARE (fc1)

System image file is flash:c3500xl-c3h2s-mz.120-5.WC16.bin

*Stu
___

Nigel Wohlers wrote:

/* .. */
interface FastEthernet0/22
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
 channel-protocol lacp

interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
 channel-protocol lacp
/* .. */




Re: Etherchannel OpenBSD?

2008-12-22 Thread Claudio Jeker
On Tue, Dec 23, 2008 at 12:45:23AM +, Stuart Morgan wrote:
 Hi Nigel and all,

 Thanks very much for the suggestion, unfortunately my 3500XL doesn't  
 support LACP - perhaps I need a firmware upgrade?

 *sw1a#sh ver
 IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC16,  
 RELEASE SOFTWARE (fc1)
 System image file is flash:c3500xl-c3h2s-mz.120-5.WC16.bin


The 3500XL are end of life for a good reason. Those switches are so
limited they're not even fun for a lab. Even if you get a newer IOS image
for them I doubt they will support LACP.

-- 
:wq Claudio