Re: [PATCH] net: decnet: dn_nsp_out: use swap macro in dn_mk_ack_header

2017-10-31 Thread David Miller
From: "Gustavo A. R. Silva" 
Date: Sat, 28 Oct 2017 15:39:48 -0500

> Make use of the swap macro and remove unnecessary variable tmp.
> This makes the code easier to read and maintain.
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva 

Applied.


[PATCH] net: decnet: dn_nsp_out: use swap macro in dn_mk_ack_header

2017-10-28 Thread Gustavo A. R. Silva
Make use of the swap macro and remove unnecessary variable tmp.
This makes the code easier to read and maintain.

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva 
---
 net/decnet/dn_nsp_out.c | 7 ++-
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/net/decnet/dn_nsp_out.c b/net/decnet/dn_nsp_out.c
index e50a4ad..56a52a0 100644
--- a/net/decnet/dn_nsp_out.c
+++ b/net/decnet/dn_nsp_out.c
@@ -313,11 +313,8 @@ static __le16 *dn_mk_ack_header(struct sock *sk, struct 
sk_buff *skb, unsigned c
ackcrs |= 0x8000;
 
/* If this is an "other data/ack" message, swap acknum and ackcrs */
-   if (other) {
-   unsigned short tmp = acknum;
-   acknum = ackcrs;
-   ackcrs = tmp;
-   }
+   if (other)
+   swap(acknum, ackcrs);
 
/* Set "cross subchannel" bit in ackcrs */
ackcrs |= 0x2000;
-- 
2.7.4