Re: [PATCH 1/2] remove CONFIG_HAVE_ARCH_DEV_ALLOC_SKB

2006-07-26 Thread Christoph Hellwig
On Mon, Jul 24, 2006 at 03:44:15PM -0700, Roland Dreier wrote:
  skbuff.h has an #ifndef CONFIG_HAVE_ARCH_DEV_ALLOC_SKB to allow
  architectures to reimplement __dev_alloc_skb.  It's not set on any
  architecture and now that we have an architecture-overrideable
  NET_SKB_PAD there is not point at all to have one either.
 
 I missed this when hch first posted it, sorry.
 
 But my impression was that the intent of the config option was to let
 Xen hook __dev_alloc_skb() to allocate special receive skbs to handle
 their page-flipping virtual network device.  Which goes beyond
 NET_SKB_PAD.
 
 So the real question is about Xen hooks I guess -- and given where the
 rest of Xen is, it probably does make sense to go ahead and strip this
 out.

If xen wants to use something else then dev_alloc_skb in their virtual
network driver that's totall fine.  No need to override the definiton of
dev_alloc_skb for that, though.  They can add their own xen_alloc_skb or
opencode the operation they want for it.

Note that overriding dev_alloc_skb is not just utterly pointless but would
even be harmfull in the case they'd finally add pci support for non-dom0
domains and used normaly NIC drivers in there.
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 1/2] remove CONFIG_HAVE_ARCH_DEV_ALLOC_SKB

2006-07-24 Thread David Miller
From: Christoph Hellwig [EMAIL PROTECTED]
Date: Fri, 7 Jul 2006 11:10:08 +0200

 skbuff.h has an #ifndef CONFIG_HAVE_ARCH_DEV_ALLOC_SKB to allow
 architectures to reimplement __dev_alloc_skb.  It's not set on any
 architecture and now that we have an architecture-overrideable
 NET_SKB_PAD there is not point at all to have one either.
 
 
 Signed-off-by: Christoph Hellwig [EMAIL PROTECTED]

Applied, thanks Christoph.
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 1/2] remove CONFIG_HAVE_ARCH_DEV_ALLOC_SKB

2006-07-24 Thread Roland Dreier
 skbuff.h has an #ifndef CONFIG_HAVE_ARCH_DEV_ALLOC_SKB to allow
 architectures to reimplement __dev_alloc_skb.  It's not set on any
 architecture and now that we have an architecture-overrideable
 NET_SKB_PAD there is not point at all to have one either.

I missed this when hch first posted it, sorry.

But my impression was that the intent of the config option was to let
Xen hook __dev_alloc_skb() to allocate special receive skbs to handle
their page-flipping virtual network device.  Which goes beyond
NET_SKB_PAD.

So the real question is about Xen hooks I guess -- and given where the
rest of Xen is, it probably does make sense to go ahead and strip this
out.

 - R.
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH 1/2] remove CONFIG_HAVE_ARCH_DEV_ALLOC_SKB

2006-07-07 Thread Christoph Hellwig
skbuff.h has an #ifndef CONFIG_HAVE_ARCH_DEV_ALLOC_SKB to allow
architectures to reimplement __dev_alloc_skb.  It's not set on any
architecture and now that we have an architecture-overrideable
NET_SKB_PAD there is not point at all to have one either.


Signed-off-by: Christoph Hellwig [EMAIL PROTECTED]

Index: linux-2.6/include/linux/skbuff.h
===
--- linux-2.6.orig/include/linux/skbuff.h   2006-07-06 14:21:20.0 
+0200
+++ linux-2.6/include/linux/skbuff.h2006-07-06 15:11:00.0 +0200
@@ -1066,7 +1066,6 @@
kfree_skb(skb);
 }
 
-#ifndef CONFIG_HAVE_ARCH_DEV_ALLOC_SKB
 /**
  * __dev_alloc_skb - allocate an skbuff for sending
  * @length: length to allocate
@@ -1087,9 +1086,6 @@
skb_reserve(skb, NET_SKB_PAD);
return skb;
 }
-#else
-extern struct sk_buff *__dev_alloc_skb(unsigned int length, int gfp_mask);
-#endif
 
 /**
  * dev_alloc_skb - allocate an skbuff for sending
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html