Re: [RFC][PATCH -mm 0/5] proposal for dynamic configurable netconsole

2006-12-25 Thread Keiichi KII

Thank you for your comments.


So, I propose the following extended features for netconsole.

1) support for multiple logging agents.
2) add interface to access each parameter of netconsole
   using sysfs.

This patch is for linux-2.6.20-rc1-mm1 and is divided to each function.
Your comments are very welcome.


Rather than extending the existing kludge with module parameter, to
sysfs. I would rather see a better API for this. Please build think
about doing a better API with a basic set of ioctl's. Some additional


What advantage do we use a set of ioctl's compared to sysfs?
I think that sysfs is easier and more readable than the ioctl's 
to change configurations(IP address and port number and so on).


ex)
# cat /sys/class/misc/netconsole/port1/remote_ip
192.168.0.1
# echo 172.16.0.1  /sys/class/misc/netconsole/port1/remote_ip
# cat /sys/class/misc/netconsole/port1/remote_ip
172.16.0.1

And the sysfs doesn't need to create access program such as the ioctl's.
If you change configurations related to netconsole through the sysfs interface, 
a simple script file including a set of commands such as above echo 
will help you set up automatically.



things:
- shouldn't just be IPV4 specific, should handle IPV6 as well


I would like to implement handling IPV6 on demand in the future.


- shouldn't specify MAC address, it can do network discovery/arp to
  find that when adding addresses


I think a userland application would rather find target MAC address and 
change it through the sysfs.


--
Keiichi KII
NEC Corporation OSS Promotion Center
E-mail: [EMAIL PROTECTED]




-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[RFC][PATCH -mm 0/5] proposal for dynamic configurable netconsole

2006-12-22 Thread Keiichi KII
From: Keiichi KII [EMAIL PROTECTED]

The netconsole is a very useful module for collecting kernel message under
certain circumstances(e.g. disk logging fails, serial port is unavailable).

But current netconsole is not flexible. For example, if you want to change ip
address for logging agent, in the case of built-in netconsole, you can't change
config except for changing boot parameter and rebooting your system, or in the
case of module netconsole, you need to reload netconsole module.

So, I propose the following extended features for netconsole.

1) support for multiple logging agents.
2) add interface to access each parameter of netconsole
   using sysfs.

This patch is for linux-2.6.20-rc1-mm1 and is divided to each function.
Your comments are very welcome.

Signed-off-by: Keiichi KII [EMAIL PROTECTED]
---
[changes]
1. change kernel base from 2.6.19 to 2.6.20-rc1-mm1.
-- 
Keiichi KII
NEC Corporation OSS Promotion Center
E-mail: [EMAIL PROTECTED]
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [RFC][PATCH -mm 0/5] proposal for dynamic configurable netconsole

2006-12-22 Thread Stephen Hemminger
On Fri, 22 Dec 2006 21:01:09 +0900
Keiichi KII [EMAIL PROTECTED] wrote:

 From: Keiichi KII [EMAIL PROTECTED]
 
 The netconsole is a very useful module for collecting kernel message under
 certain circumstances(e.g. disk logging fails, serial port is unavailable).
 
 But current netconsole is not flexible. For example, if you want to change ip
 address for logging agent, in the case of built-in netconsole, you can't 
 change
 config except for changing boot parameter and rebooting your system, or in the
 case of module netconsole, you need to reload netconsole module.

If netconsole is a module, you should be able to remove it and reload
with different parameters.

 So, I propose the following extended features for netconsole.
 
 1) support for multiple logging agents.
 2) add interface to access each parameter of netconsole
using sysfs.
 
 This patch is for linux-2.6.20-rc1-mm1 and is divided to each function.
 Your comments are very welcome.

Rather than extending the existing kludge with module parameter, to
sysfs. I would rather see a better API for this. Please build think
about doing a better API with a basic set of ioctl's. Some additional
things:
- shouldn't just be IPV4 specific, should handle IPV6 as well
- shouldn't specify MAC address, it can do network discovery/arp to
  find that when adding addresses
-
To unsubscribe from this list: send the line unsubscribe netdev in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html