Re: [PATCH 2/6] e1000e: remove namespace collisions with e1000

2007-08-14 Thread Kok, Auke

Rick Jones wrote:
if you grep around this effort was already started using the 'e1e_' 
prefix.  I like the shorter prefix, but your call ultimately.  Either 
way, make sure to make the driver consistent there too.


should it then be consistent with the overall driver name too? 
certainly calling things e1e or e1ke  or heck, even elke if one wanted 
to be a triffle playful would certainly help distinguish this driver 
from its grandfather.


I think we are passed the time for the name-a-driver raffle now. We've informed 
a lot of people that the name will be "e1000e", so I definately prefer using 
this internally as well.


As for the e1000_get_speed_and_duplex_fiber_serdes long names, those are an 
eyesore to me as well...


Auke
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 2/6] e1000e: remove namespace collisions with e1000

2007-08-14 Thread Rick Jones
if you grep around this effort was already started using the 'e1e_' 
prefix.  I like the shorter prefix, but your call ultimately.  Either 
way, make sure to make the driver consistent there too.


should it then be consistent with the overall driver name too? 
certainly calling things e1e or e1ke  or heck, even elke if one wanted 
to be a triffle playful would certainly help distinguish this driver 
from its grandfather.


rick jones
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 2/6] e1000e: remove namespace collisions with e1000

2007-08-13 Thread Jeff Garzik

Auke Kok wrote:

To prevent future collisions we rename all extern's from e1000_
to e1000e_*. The list of changed symbols was taken from e1000.h
Compile tested with CONFIG_E1000=y and CONFIG_E1000E=y.

Signed-off-by: Auke Kok <[EMAIL PROTECTED]>
---

 drivers/net/e1000e/82571.c   |  129 +-
 drivers/net/e1000e/e1000.h   |  194 +++
 drivers/net/e1000e/es2lan.c  |  118 
 drivers/net/e1000e/ethtool.c |   62 ++--
 drivers/net/e1000e/ich8lan.c |   92 +-
 drivers/net/e1000e/lib.c |  210 +-
 drivers/net/e1000e/netdev.c  |  168 +-
 drivers/net/e1000e/param.c   |8 +-
 drivers/net/e1000e/phy.c |  138 ++--
 9 files changed, 559 insertions(+), 560 deletions(-)


if you grep around this effort was already started using the 'e1e_' 
prefix.  I like the shorter prefix, but your call ultimately.  Either 
way, make sure to make the driver consistent there too.


e1e_flush(), e1e_wphy(), etc.

Overall I still want to push the driver towards shorter function and 
variable names.  Things like

e1000e_get_speed_and_duplex_fiber_serdes are just way too long.

Jeff


-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html