Re: mwifiex: Use to_delayed_work()

2016-03-07 Thread Kalle Valo

> Introduce the use of to_delayed_work() helper function instead of open
> coding it with container_of()
> 
> A simplified version of the Coccinelle semantic patch used to make
> this change is:
> 
> //
> @@
> expression a;
> symbol work;
> @@
> - container_of(a, struct delayed_work, work)
> + to_delayed_work(a)
> //
> 
> Signed-off-by: Amitoj Kaur Chawla 
> Reviewed-by: Julian Calaby 

Thanks, applied to wireless-drivers-next.git.

Kalle Valo


Re: [PATCH] mwifiex: Use to_delayed_work()

2016-02-17 Thread Julian Calaby
Hi All,

On Wed, Feb 17, 2016 at 11:33 PM, Amitoj Kaur Chawla
 wrote:
> Introduce the use of to_delayed_work() helper function instead of open
> coding it with container_of()
>
> A simplified version of the Coccinelle semantic patch used to make
> this change is:
>
> //
> @@
> expression a;
> symbol work;
> @@
> - container_of(a, struct delayed_work, work)
> + to_delayed_work(a)
> //
>
> Signed-off-by: Amitoj Kaur Chawla 

Looks right to me.

Reviewed-by: Julian Calaby 

Thanks,

> ---
>  drivers/net/wireless/marvell/mwifiex/11h.c | 6 ++
>  1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/net/wireless/marvell/mwifiex/11h.c 
> b/drivers/net/wireless/marvell/mwifiex/11h.c
> index 71a1b58..81c60d0 100644
> --- a/drivers/net/wireless/marvell/mwifiex/11h.c
> +++ b/drivers/net/wireless/marvell/mwifiex/11h.c
> @@ -123,8 +123,7 @@ void mwifiex_11h_process_join(struct mwifiex_private 
> *priv, u8 **buffer,
>  void mwifiex_dfs_cac_work_queue(struct work_struct *work)
>  {
> struct cfg80211_chan_def chandef;
> -   struct delayed_work *delayed_work =
> -   container_of(work, struct delayed_work, work);
> +   struct delayed_work *delayed_work = to_delayed_work(work);
> struct mwifiex_private *priv =
> container_of(delayed_work, struct mwifiex_private,
>  dfs_cac_work);
> @@ -289,8 +288,7 @@ int mwifiex_11h_handle_radar_detected(struct 
> mwifiex_private *priv,
>  void mwifiex_dfs_chan_sw_work_queue(struct work_struct *work)
>  {
> struct mwifiex_uap_bss_param *bss_cfg;
> -   struct delayed_work *delayed_work =
> -   container_of(work, struct delayed_work, work);
> +   struct delayed_work *delayed_work = to_delayed_work(work);
> struct mwifiex_private *priv =
> container_of(delayed_work, struct mwifiex_private,
>  dfs_chan_sw_work);
> --
> 1.9.1
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
> the body of a message to majord...@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html



-- 
Julian Calaby

Email: julian.cal...@gmail.com
Profile: http://www.google.com/profiles/julian.calaby/


[PATCH] mwifiex: Use to_delayed_work()

2016-02-17 Thread Amitoj Kaur Chawla
Introduce the use of to_delayed_work() helper function instead of open
coding it with container_of()

A simplified version of the Coccinelle semantic patch used to make
this change is:

//
@@
expression a;
symbol work;
@@
- container_of(a, struct delayed_work, work)
+ to_delayed_work(a)
//

Signed-off-by: Amitoj Kaur Chawla 
---
 drivers/net/wireless/marvell/mwifiex/11h.c | 6 ++
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/drivers/net/wireless/marvell/mwifiex/11h.c 
b/drivers/net/wireless/marvell/mwifiex/11h.c
index 71a1b58..81c60d0 100644
--- a/drivers/net/wireless/marvell/mwifiex/11h.c
+++ b/drivers/net/wireless/marvell/mwifiex/11h.c
@@ -123,8 +123,7 @@ void mwifiex_11h_process_join(struct mwifiex_private *priv, 
u8 **buffer,
 void mwifiex_dfs_cac_work_queue(struct work_struct *work)
 {
struct cfg80211_chan_def chandef;
-   struct delayed_work *delayed_work =
-   container_of(work, struct delayed_work, work);
+   struct delayed_work *delayed_work = to_delayed_work(work);
struct mwifiex_private *priv =
container_of(delayed_work, struct mwifiex_private,
 dfs_cac_work);
@@ -289,8 +288,7 @@ int mwifiex_11h_handle_radar_detected(struct 
mwifiex_private *priv,
 void mwifiex_dfs_chan_sw_work_queue(struct work_struct *work)
 {
struct mwifiex_uap_bss_param *bss_cfg;
-   struct delayed_work *delayed_work =
-   container_of(work, struct delayed_work, work);
+   struct delayed_work *delayed_work = to_delayed_work(work);
struct mwifiex_private *priv =
container_of(delayed_work, struct mwifiex_private,
 dfs_chan_sw_work);
-- 
1.9.1



[PATCH 5/6] mwifiex: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang 
---
 drivers/net/wireless/marvell/mwifiex/11h.c | 6 ++
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/drivers/net/wireless/marvell/mwifiex/11h.c 
b/drivers/net/wireless/marvell/mwifiex/11h.c
index 71a1b58..81c60d0 100644
--- a/drivers/net/wireless/marvell/mwifiex/11h.c
+++ b/drivers/net/wireless/marvell/mwifiex/11h.c
@@ -123,8 +123,7 @@ void mwifiex_11h_process_join(struct mwifiex_private *priv, 
u8 **buffer,
 void mwifiex_dfs_cac_work_queue(struct work_struct *work)
 {
struct cfg80211_chan_def chandef;
-   struct delayed_work *delayed_work =
-   container_of(work, struct delayed_work, work);
+   struct delayed_work *delayed_work = to_delayed_work(work);
struct mwifiex_private *priv =
container_of(delayed_work, struct mwifiex_private,
 dfs_cac_work);
@@ -289,8 +288,7 @@ int mwifiex_11h_handle_radar_detected(struct 
mwifiex_private *priv,
 void mwifiex_dfs_chan_sw_work_queue(struct work_struct *work)
 {
struct mwifiex_uap_bss_param *bss_cfg;
-   struct delayed_work *delayed_work =
-   container_of(work, struct delayed_work, work);
+   struct delayed_work *delayed_work = to_delayed_work(work);
struct mwifiex_private *priv =
container_of(delayed_work, struct mwifiex_private,
 dfs_chan_sw_work);
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html