Re: [OE-core] [PATCH 00/10] devtool refactoring

2015-06-10 Thread Markus Lehtonen
Hi,

On 09/06/15 18:01, Paul Eggleton paul.eggle...@linux.intel.com wrote:

Hi Markus,

On Thursday 04 June 2015 19:31:44 Markus Lehtonen wrote:
 This patchset contains contains some refactoring of the devtool code,
 hopefully making the code more maintainable and somewhat easier to read.

Unfortunately something in here breaks the QA tests - and this time I've
double-checked that they pass without this patchset (well, deploy_target
seems 
to be failing on one of my machines but not another - am looking into
that). 

Could you please investigate?

Hmm, strange. I will investigate and get back to this.


Thanks,
   Markus


-- 
___
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core


Re: [OE-core] [PATCH 00/10] devtool refactoring

2015-06-09 Thread Paul Eggleton
Hi Markus,

On Thursday 04 June 2015 19:31:44 Markus Lehtonen wrote:
 This patchset contains contains some refactoring of the devtool code,
 hopefully making the code more maintainable and somewhat easier to read.

Unfortunately something in here breaks the QA tests - and this time I've 
double-checked that they pass without this patchset (well, deploy_target seems 
to be failing on one of my machines but not another - am looking into that). 

Could you please investigate?

Thanks,
Paul

-- 

Paul Eggleton
Intel Open Source Technology Centre
-- 
___
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core


[OE-core] [PATCH 00/10] devtool refactoring

2015-06-04 Thread Markus Lehtonen
This patchset contains contains some refactoring of the devtool code, hopefully
making the code more maintainable and somewhat easier to read.

The following changes since commit c91ffdb8fff4a62ccb80196a3d735e4b9a3056a3:

  dosfstools: Add recipe for v3.0.28 (2015-06-03 16:38:14 +0100)

are available in the git repository at:

  ssh://oegit/openembedded-core-contrib marquiz/devtool/refactor
  
http://git.openembedded.org/openembedded-core-contrib/commit/?h=marquiz/devtool/refactor

Markus Lehtonen (10):
  devtool: fix wrong indentation
  devtool: refactor bb task execution into a separate class
  devtool: update-recipe: do rev parsing in a separate function
  devtool: simplify the logic of determining patches to be removed
  devtool: simplify few conditionals a bit
  devtool: slight simplification of path splitting logic
  devtool: split out 'srcrev' update mode into a separate function
  devtool: split out 'patch' update mode into a separate function
  devtool: remove some unused return values
  devtool: use DevtoolError for error handling

 scripts/devtool |   9 +-
 scripts/lib/devtool/__init__.py |   6 +
 scripts/lib/devtool/deploy.py   |  31 +-
 scripts/lib/devtool/standard.py | 646 +---
 4 files changed, 369 insertions(+), 323 deletions(-)

-- 
2.1.4

-- 
___
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core