[Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread Alexandre Fayolle - camptocamp
Alexandre Fayolle - camptocamp has proposed merging 
lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into 
lp:stock-logistic-barcode.

Requested reviews:
  Sébastien Gendre - Open-Net (sge-8)
  Stock and Logistic Core Editors (stock-logistic-core-editors)
Related bugs:
  Bug #1330459 in Stock And Logistic Bar Code: "Bar-code generation ignore the 
height value"
  https://bugs.launchpad.net/stock-logistic-barcode/+bug/1330459

For more details, see:
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866

Rename hight to heigh

Integrate and enhance Sébastien Gendre's fix, add a migration script.
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is requested to review the proposed 
merge of lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into 
lp:stock-logistic-barcode.
=== modified file 'tr_barcode/__openerp__.py'
--- tr_barcode/__openerp__.py	2014-04-08 12:03:02 +
+++ tr_barcode/__openerp__.py	2014-06-20 07:40:31 +
@@ -21,7 +21,7 @@
 
 {
 'name': 'TR Barcode',
-'version': '1.1.1',
+'version': '1.1.4',
 'category': 'Warehouse Management',
 'description': """
 

=== added directory 'tr_barcode/migrations'
=== added directory 'tr_barcode/migrations/1.1.4'
=== added file 'tr_barcode/migrations/1.1.4/pre-migrate.py'
--- tr_barcode/migrations/1.1.4/pre-migrate.py	1970-01-01 00:00:00 +
+++ tr_barcode/migrations/1.1.4/pre-migrate.py	2014-06-20 07:40:31 +
@@ -0,0 +1,24 @@
+# -*- coding: utf-8 -*-
+#/#
+#
+#Author: Alexandre Fayolle 
+#Copyright (C) 2014 Camptocamp.
+#
+#This program is free software: you can redistribute it and/or modify
+#it under the terms of the GNU Affero General Public License as
+#published by the Free Software Foundation, either version 3 of the
+#License, or (at your option) any later version.
+#
+#This program is distributed in the hope that it will be useful,
+#but WITHOUT ANY WARRANTY; without even the implied warranty of
+#MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+#GNU Affero General Public License for more details.
+#
+#You should have received a copy of the GNU Affero General Public License
+#along with this program.  If not, see .
+#
+#/#
+
+def migrate(cr, version):
+if version:
+cr.execute('ALTER TABLE tr_barcode RENAME COLUMN hight TO height')

=== modified file 'tr_barcode/tr_barcode.py'
--- tr_barcode/tr_barcode.py	2014-04-08 12:03:02 +
+++ tr_barcode/tr_barcode.py	2014-06-20 07:40:31 +
@@ -64,19 +64,22 @@
 'image': fields.binary('Data'),
 'width':fields.integer("Width",
 help="Leave Blank or 0(ZERO) for default size"),
-'hight':fields.integer("Hight",
+'height':fields.integer("Height",
 help="Leave Blank or 0(ZERO) for default size"),
 'hr_form':fields.boolean("Human Readable",
 help="To genrate Barcode In Human readable form"),
 'barcode_type':fields.selection(_get_code, 'Type'),
 }
 
-def get_image(self, value, width, hight, hr, code='QR'):
+def get_image(self, value, width, height, hr, code='QR'):
 """ genrating image for barcode """
 options = {}
-if width:options['width'] = width
-if hight:options['hight'] = hight
-if hr:options['humanReadable'] = hr
+if width:
+options['width'] = width
+if height:
+options['height'] = height
+if hr:
+options['humanReadable'] = hr
 options['quiet'] = False
 options['barWidth'] = 2
 #options['isoScale'] = 1
@@ -108,7 +111,7 @@
 for self_obj in self.browse(cr, uid, ids, context=context):
 image = self.get_image(self_obj.code,
 code=self_obj.barcode_type or 'qrcode',
-width=self_obj.width, hight=self_obj.hight,
+width=self_obj.width, height=self_obj.height,
 hr=self_obj.hr_form)
 self.write(cr, uid, self_obj.id,
 {'image':image},context=context)

=== modified file 'tr_barcode/tr_barcode_view.xml'
--- tr_barcode/tr_barcode_view.xml	2013-02-18 09:27:15 +
+++ tr_barcode/tr_barcode_view.xml	2014-06-20 07:40:31 +
@@ -10,7 +10,7 @@
 
 
 
-
+
 
 
 

=== modified file 'tr_barcode/wizard/tr_barcode_wizard.py'
--- tr_barcode/wizard/tr_barcode_wizard.py	2014-02-28 09:20:57 +
+++ tr_barcode/wizard/tr_barcode_wizard.py	2014-06-20 07:40:31 +
@@ -53

[Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread Alexandre Fayolle - camptocamp
The proposal to merge 
lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into 
lp:stock-logistic-barcode has been updated.

Description changed to:

Rename hight to heigh

Integrate and enhance Sébastien Gendre's fix, add a migration script.

For more details, see:
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is requested to review the proposed 
merge of lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into 
lp:stock-logistic-barcode.

-- 
Mailing list: https://launchpad.net/~openerp-community-reviewer
Post to : openerp-community-reviewer@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openerp-community-reviewer
More help   : https://help.launchpad.net/ListHelp


[Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread Pedro Manuel Baeza
The proposal to merge 
lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into 
lp:stock-logistic-barcode has been updated.

Description changed to:

Rename hight to height

Integrate and enhance Sébastien Gendre's fix, add a migration script.

For more details, see:
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is subscribed to branch 
lp:stock-logistic-barcode.

-- 
Mailing list: https://launchpad.net/~openerp-community-reviewer
Post to : openerp-community-reviewer@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openerp-community-reviewer
More help   : https://help.launchpad.net/ListHelp


[Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread noreply
The proposal to merge 
lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into 
lp:stock-logistic-barcode has been updated.

Status: Needs review => Merged

For more details, see:
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is subscribed to branch 
lp:stock-logistic-barcode.

-- 
Mailing list: https://launchpad.net/~openerp-community-reviewer
Post to : openerp-community-reviewer@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openerp-community-reviewer
More help   : https://help.launchpad.net/ListHelp


Re: [Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread Guewen Baconnier @ Camptocamp
Review: Approve code review

When you want to rename a field, you can also use the 'oldname' argument, 
example in crm:

'opt_out': fields.boolean('Opt-Out', oldname='optout',
help="If opt-out is checked, this contact has refused to receive 
emails for mass mailing and marketing campaign. "
"Filter 'Available for Mass Mailing' allows users to filter 
the leads when performing mass mailing."),

The ORM would automatically rename the field.

Your version is also a valid way to rename the field so LGTM.
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is subscribed to branch 
lp:stock-logistic-barcode.

-- 
Mailing list: https://launchpad.net/~openerp-community-reviewer
Post to : openerp-community-reviewer@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openerp-community-reviewer
More help   : https://help.launchpad.net/ListHelp


Re: [Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread Pedro Manuel Baeza
Review: Approve code review

Thank you very much for the MP and the migration script.

LGTM.

Regards.
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is subscribed to branch 
lp:stock-logistic-barcode.

-- 
Mailing list: https://launchpad.net/~openerp-community-reviewer
Post to : openerp-community-reviewer@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openerp-community-reviewer
More help   : https://help.launchpad.net/ListHelp


Re: [Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread Pedro Manuel Baeza
Good trick, Guewen. I didn't know about oldname argument!

Regards.
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is subscribed to branch 
lp:stock-logistic-barcode.

-- 
Mailing list: https://launchpad.net/~openerp-community-reviewer
Post to : openerp-community-reviewer@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openerp-community-reviewer
More help   : https://help.launchpad.net/ListHelp


Re: [Openerp-community-reviewer] [Merge] lp:~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe into lp:stock-logistic-barcode

2014-06-20 Thread Yannick Vaucher @ Camptocamp
Review: Approve code review no tests

LGTM thanks
-- 
https://code.launchpad.net/~camptocamp/stock-logistic-barcode/7.0-fix_1330459-sge+afe/+merge/223866
Your team Stock and Logistic Core Editors is subscribed to branch 
lp:stock-logistic-barcode.

-- 
Mailing list: https://launchpad.net/~openerp-community-reviewer
Post to : openerp-community-reviewer@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openerp-community-reviewer
More help   : https://help.launchpad.net/ListHelp