Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-04-27 Thread Raoul Snyman
Review: Needs Fixing

Looks good.

One thing I would prefer to change though, is "VLC additions" aka "VLC 
additional commands". They are not commands, they are command line arguments, 
so I would call them "VLC arguments". In my opinion, "additions" is ambiguous 
and unclear.
-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366608
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


[Openlp-core] macOS Test Results: Passed

2019-04-27 Thread Raoul Snyman
macOS tests passed!
-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366608
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


[Openlp-core] Linux Test Results: Passed

2019-04-27 Thread Raoul Snyman
Linux tests passed!
-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366608
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


[Openlp-core] Linting: Passed

2019-04-27 Thread Raoul Snyman
Linting passed!
-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366608
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


[Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-04-27 Thread Tim Bentley
Tim Bentley has proposed merging lp:~trb143/openlp/more_media into lp:openlp.

Commit message:
Media plays successfully and cleanups.
Added VLC additions 

Requested reviews:
  Tomas Groth (tomasgroth)

For more details, see:
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366608

Media now plays, stops, seeks and repeats.
Media Tab now works but needs more love.
VLC addtitions is now added and usable.
Experimental flag added to UI.  Set this and it may go bang.  You will need to 
edit settings manually to release this!
Add code (provided by tgc and superfly) to get media components. Works fine 
outside OpenLP but takes out OpenLP on Fedora 30.  Activate by using 
experimental and restart.
Fixed the imagemanager bug on saving themes.  Now works except preview image is 
black!
Removed many bits of commented out code.
-- 
Your team OpenLP Core is subscribed to branch lp:openlp.
=== modified file 'openlp/core/common/settings.py'
--- openlp/core/common/settings.py	2019-04-09 17:21:35 +
+++ openlp/core/common/settings.py	2019-04-27 15:20:26 +
@@ -188,7 +188,7 @@
 'core/click live slide to unblank': False,
 'core/blank warning': False,
 'core/ccli number': '',
-'core/experimental': False,
+'advanced/experimental': False,
 'core/has run wizard': False,
 'core/language': '[en]',
 'core/last version test': '',
@@ -213,6 +213,7 @@
 'images/background color': '#00',
 'media/media auto start': QtCore.Qt.Unchecked,
 'media/stream command': '',
+'media/vlc additions': '',
 'remotes/download version': '0.0',
 'players/background color': '#00',
 'servicemanager/last directory': None,

=== modified file 'openlp/core/ui/__init__.py'
--- openlp/core/ui/__init__.py	2019-02-14 15:09:09 +
+++ openlp/core/ui/__init__.py	2019-04-27 15:20:26 +
@@ -93,4 +93,4 @@
 self.resizeRowsToContents()
 
 
-__all__ = ['SingleColumnTableWidget']
+__all__ = ['SingleColumnTableWidget', 'DisplayControllerType']

=== modified file 'openlp/core/ui/advancedtab.py'
--- openlp/core/ui/advancedtab.py	2019-03-15 20:56:32 +
+++ openlp/core/ui/advancedtab.py	2019-04-27 15:20:26 +
@@ -117,6 +117,9 @@
 self.enable_auto_close_check_box = QtWidgets.QCheckBox(self.ui_group_box)
 self.enable_auto_close_check_box.setObjectName('enable_auto_close_check_box')
 self.ui_layout.addRow(self.enable_auto_close_check_box)
+self.experimental_check_box = QtWidgets.QCheckBox(self.ui_group_box)
+self.experimental_check_box.setObjectName('experimental_check_box')
+self.ui_layout.addRow(self.experimental_check_box)
 self.left_layout.addWidget(self.ui_group_box)
 if HAS_DARK_STYLE:
 self.use_dark_style_checkbox = QtWidgets.QCheckBox(self.ui_group_box)
@@ -291,6 +294,8 @@
 'Auto-scroll the next slide to bottom'))
 self.enable_auto_close_check_box.setText(translate('OpenLP.AdvancedTab',
'Enable application exit confirmation'))
+self.experimental_check_box.setText(translate('OpenLP.GeneralTab',
+  'Experimental features (use at your own risk)'))
 if HAS_DARK_STYLE:
 self.use_dark_style_checkbox.setText(translate('OpenLP.AdvancedTab', 'Use dark style (needs restart)'))
 self.service_name_group_box.setTitle(translate('OpenLP.AdvancedTab', 'Default Service Name'))
@@ -360,6 +365,7 @@
 if self.autoscroll_map[i] == autoscroll_value and i < self.autoscroll_combo_box.count():
 self.autoscroll_combo_box.setCurrentIndex(i)
 self.enable_auto_close_check_box.setChecked(settings.value('enable exit confirmation'))
+self.experimental_check_box.setChecked(settings.value('experimental'))
 if HAS_DARK_STYLE:
 self.use_dark_style_checkbox.setChecked(settings.value('use_dark_style'))
 self.hide_mouse_check_box.setChecked(settings.value('hide mouse'))
@@ -423,6 +429,7 @@
 slide_max_height_value = self.slide_max_height_combo_box.itemData(slide_max_height_index)
 settings.setValue('slide max height', slide_max_height_value)
 settings.setValue('autoscrolling', self.autoscroll_map[self.autoscroll_combo_box.currentIndex()])
+settings.setValue('experimental', self.experimental_check_box.isChecked())
 settings.setValue('enable exit confirmation', self.enable_auto_close_check_box.isChecked())
 settings.setValue('hide mouse', self.hide_mouse_check_box.isChecked())
 settings.setValue('alternate rows', self.alternate_rows_check_box.isChecked())

=== modified file 'openlp/core/ui/media/mediacontroller.py'
--- openlp/core/ui/media/mediacontroller.py	2019-04-12 16:37:45 +
+++ openlp/core/ui/media/mediacontroller.py	2019-04-27 

[Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-04-27 Thread Tim Bentley
The proposal to merge lp:~trb143/openlp/more_media into lp:openlp has been 
updated.

Status: Needs review => Superseded

For more details, see:
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366336
-- 
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp