[OpenWrt-Devel] system reboot command from ssh failed sometimes on my ar9344 board

2014-11-02 Thread zhang zhao
It's just weird that sometimes when I perform reboot operation on my
tp-link wdr6300v2(ar9344), the reboot procedure just hang up with all leds
on and doesn't go any further. So I can only re-plug the power line then
system boots normally. the firmware was built from there:
https://github.com/981213/openwrt . This is a cloned CC version and the
author added wdr6300 support. Note that this problem doesn't happen every
time when I reboot, and when this happen, ssh connection is already closed.
So it's difficult for me to find out where the problem is. Any one have any
idea where can I go find out the problem is? Thanks ahead~
-- 
Best Regards,

Zhao Zhang,
Undergraduate from
Dept. of Computer Science  Technology,
Ocean University of China,
Qingdao, China, 266100
Phone 18678430893
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] system reboot command from ssh failed sometimes on my ar9344 board

2014-11-02 Thread Bastian Bittorf
* zhang zhao formywillcan...@gmail.com [02.11.2014 08:32]:
 It's just weird that sometimes when I perform reboot operation on my
 tp-link wdr6300v2(ar9344), the reboot procedure just hang up with all leds

see https://dev.openwrt.org/ticket/17839

bye, bastian
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] comgt: add ncm proto support

2014-11-02 Thread Jamie Lenehan
On Thu, Oct 30, 2014 at 12:58:40PM +0200, Matti Laakso wrote:
 Hi Sami,
 
 Using John's version:
 
 config interface 'wan'
  option proto 'wwan'
  option apn 'opengate'
 #   option device '/dev/cdc-wdm0' (with or without commenting this)
 
 Does absolutely nothing, nothing in logread...
 
 However now when using
 
 config interface 'wan'
  option proto 'ncm'
  option apn 'opengate'
  option device '/dev/ttyUSB1'
 
 I believe that device should be /dev/cdc-wdm0 also here, at least
 when using huawei_cdc_ncm. The /dev/ttyUSBx terminals created by the
 option driver do not necessarily support all necessary AT-commands.
 Also, (at least when using proto ncm) you need to specify in
 addition
 
 option ifname wwan0

That wasn't enough to get it to find the device for me for some
reason. The following change to proto_ncm_setup does make it work:

echo ncm[$$] Connected, starting DHCP
-   proto_init_update * 1
+   proto_init_update wwan0 1
proto_send_update $interface

For bringing the interface down the control device can't be found.
The following change in proto_ncm_teardown makes that work:

json_get_vars device
+
+   device=/dev/ttyUSB0
 
echo ncm[$$] Stopping network

With the above two changes in place this all works fine. I don't know
enough about how this is all meant to work to know why this is needed
or why those configuration values are not making it to where they
need to be.

This is the configuration:

config interface optus
option proto 'ncm'
option ifname 'wwan0'
option device '/dev/ttyUSB0'
option apn 'connect'
option ip4table 'optus'

The ip4table part didn't work either. I added this to proto_ncm_setup
when setting up the dhcp sub-interface parameters to make it work:

+   json_add_string ip4table optus

[...]
-- 
 Jamie Lenehan lene...@twibble.org
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] No users added while installing packages

2014-11-02 Thread Denis Shulyaka
Hi Mike,

2014-11-01 20:45 GMT+03:00 W. Michael Petullo m...@flyn.org:

 1. lighttpd, which makes use of user_add in /etc/init.d/lighttpd,
 created an http user, but it was not assigned a UID.


According to /lib/functions.sh, user_add has the following arguments:

user_add() {
local name=${1}
local uid=${2}
local gid=${3:-$2}
local desc=${4:-$1}
local home=${5:-/var/run/$1}
local shell=${6:-/bin/false}
.

So, if you don't provide UID as a second argument, the user would be
created without UID. Same for group_add.

3. postfix, which provides a create_users shell function in
 /etc/init.d/postfix, did not create a user. Not that /etc/init.d/postfix
 does not explicitly call the create_users function.


postfix package executes the following command in its postinst script:

EXTRA_COMMANDS=create_users /etc/init.d/postfix create_users

It successfully creates users on my system. Could you please test it again
on your system by running just the above command?


 I am also curious to know
 how packages should reserve a UID; for example, postfix seems to assume
 that no other package will claim 87 and 88.


For postfix, I just picked those UIDs that were unlikely to be used by a
user. Then I checked the repository and couldn't find any other packages
using same UIDs. Please advise if there is a better way.

Best regards,
Denis Shulyaka
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] kernel/modules/vxlan: add +kmod-iptunnel as dependency

2014-11-02 Thread Alexandru Ardelean
According to this ticket:
   https://dev.openwrt.org/ticket/18264
Some builds fail because kmod-ip_tunnel is not specified as
a dependency for kmod-vxlan.
The build seems to occur on buildbot and I cannot reproduce
this locally.

However, adding +kmod-ip_tunnel is not a bad idea.

Maybe it has to do with the order in how how modules are
being built on buildbot and kmod-ip_tunnel has not been
installed when kmod-vxlan is being built.
So, adding it as dependency should fix that.

Signed-off-by: Alexandru Ardelean ardeleana...@gmail.com
---
 package/kernel/linux/modules/netsupport.mk | 1 +
 1 file changed, 1 insertion(+)

diff --git a/package/kernel/linux/modules/netsupport.mk 
b/package/kernel/linux/modules/netsupport.mk
index 376b588..8671df1 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -147,6 +147,7 @@ $(eval $(call KernelPackage,8021q))
 define KernelPackage/vxlan
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Native VXLAN Kernel support
+  DEPENDS:=+kmod-iptunnel
   KCONFIG:=CONFIG_VXLAN
   FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
   AUTOLOAD:=$(call AutoLoad,13,vxlan)
-- 
1.8.4.5
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] Add more license tags with SPDX identifiers

2014-11-02 Thread Michael Heimpold
Note, that licensing stuff is a nightmare: many packages does not clearly
state their licenses, and often multiple source files are simply copied
together - each with different licensing information in the file headers.

I tried hard to ensure, that the license information extracted into the 
OpenWRT's
makefiles fit the spirit of the packages, e.g. such small packages which
come without a dedicated source archive inherites the OpenWRT's own license
in my opinion.

However, I can not garantee that I always picked the correct information
and/or did not miss license information.

Signed-off-by: Michael Heimpold m...@heimpold.de
---

Hi,

this is a rebased version of the patch I sent in June, see
http://patchwork.openwrt.org/patch/5636

Changes can also be pulled from https://github.com/mhei/openwrt/tree/spdx

Regards,
Michael

 package/base-files/Makefile|2 ++
 package/boot/apex/Makefile |3 +++
 package/boot/fconfig/Makefile  |3 +++
 package/boot/grub2/Makefile|3 +++
 package/boot/imx-bootlets/Makefile |3 +++
 package/boot/kexec-tools/Makefile  |3 +++
 package/boot/kobs-ng/Makefile  |2 +-
 package/boot/rbcfg/Makefile|3 +++
 package/boot/uboot-ar71xx/Makefile |3 +++
 package/boot/uboot-envtools/Makefile   |3 +++
 package/boot/uboot-imx6/Makefile   |3 +++
 package/boot/uboot-kirkwood/Makefile   |3 +++
 package/boot/uboot-lantiq/Makefile |3 +++
 package/boot/uboot-mxs/Makefile|3 +++
 package/boot/uboot-omap/Makefile   |3 +++
 package/boot/uboot-pxa/Makefile|3 +++
 package/boot/uboot-sunxi/Makefile  |3 +++
 package/boot/uboot-xburst/Makefile |3 +++
 package/boot/yamonenv/Makefile |3 +++
 package/devel/gdb/Makefile |3 +++
 package/devel/oprofile/Makefile|3 +++
 package/devel/trace-cmd/Makefile   |3 +++
 package/devel/valgrind/Makefile|3 +++
 package/libs/cyassl/Makefile   |3 +++
 package/libs/gettext-full/Makefile |3 +++
 package/libs/libbsd/Makefile   |1 -
 package/libs/libconfig/Makefile|3 +++
 package/libs/libevent2/Makefile|3 +++
 package/libs/libiconv-full/Makefile|3 +++
 package/libs/libmnl/Makefile   |3 +++
 package/libs/libnetfilter-conntrack/Makefile   |3 +++
 package/libs/libnfnetlink/Makefile |3 +++
 package/libs/libnl/Makefile|3 +++
 package/libs/libpcap/Makefile  |3 +++
 package/libs/libreadline/Makefile  |2 +-
 package/libs/libroxml/Makefile |3 +++
 package/libs/librpc/Makefile   |2 +-
 package/libs/libtool/Makefile  |4 ++--
 package/libs/libubox/Makefile  |2 +-
 package/libs/libusb-compat/Makefile|3 +++
 package/libs/libusb/Makefile   |3 +++
 package/libs/lzo/Makefile  |3 +++
 package/libs/ocf-crypto-headers/Makefile   |2 +-
 package/libs/openssl/Makefile  |1 +
 package/libs/polarssl/Makefile |3 +++
 package/libs/popt/Makefile |4 +++-
 package/libs/sysfsutils/Makefile   |2 +-
 package/libs/uclibc++/Makefile |3 +++
 package/network/config/firewall/Makefile   |2 ++
 package/network/config/qos-scripts/Makefile|3 +++
 package/network/config/soloscli/Makefile   |3 +++
 package/network/config/swconfig/Makefile   |3 +++
 package/network/ipv6/6in4/Makefile |3 +++
 package/network/ipv6/6rd/Makefile  |3 +++
 package/network/ipv6/6to4/Makefile |3 +++
 package/network/ipv6/ds-lite/Makefile  |3 +++
 package/network/ipv6/map/Makefile  |3 +++
 package/network/ipv6/odhcp6c/Makefile  |3 +++
 package/network/ipv6/thc-ipv6/Makefile |3 +++
 package/network/services/authsae/Makefile  |3 +++
 package/network/services/dnsmasq/Makefile  |4 ++--
 package/network/services/ead/Makefile  |3 +++
 package/network/services/hostapd/Makefile  |3 +++
 package/network/services/igmpproxy/Makefile|3 +++
 package/network/services/lldpd/Makefile|3 +++
 package/network/services/odhcpd/Makefile   |3 +++