[OpenWrt-Devel] Regarding UCI for multi-point GRE on OpenWRT

2019-08-22 Thread pothuganti sridhar
Hello All,

I am trying to implement DMVPN with OpenWRT. That requires multipoint GRE
tunnels. In case of the multipoint GRE tunnel, the remote endpoint/peer
address will be resolved dynamically using NHRPD protocol/daemon.

I have gone through the GRE documentation at the following link.

https://openwrt.org/docs/guide-user/network/tunneling_interface_protocols

In the above documentation, it is mentioned that "peeraddr" is the must
require field.

Is anyone tried to create multipoint GRE using UCI?

To make it(peeraddr) optional field, what are the changes required?

Any points will be helpful.

Thanks in advance.

Regards,
Sridhar
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Unable to create GRE interface using netifd

2015-11-19 Thread pothuganti sridhar
Hi Steven,

Thank you so much for your valuable info. I have missed this route and
struggled more than a week. Very grateful for your suggestion.
With the added route I am able to proceed further. But still stuck in below
point.

>From gre.sh, we are calling "proto_send_update" in the interface setup
function. From "proto_send_update" function we are calling "_proto_notify"
which intern calls below ubus call.

ubus -S call network.interface notify_proto { "action": 6, "host":
"192.168.11.5", "ifname": "wan1", "interface": "gre1" }:
Jan  5 10:50:46 RV340 netif: SRI:ubus  call network.interface notify_proto
{ "action": 0, "ifname": "gre-gre1", "link_up": true, "tunnel": { "mode":
"greip", "mtu": 1280, "df": true, "ttl": 64, "local": "172.31.3.8",
"remote": "192.168.11.5", "link": "wan1", "info": "0,0,0,0,0,0" }, "data":
{ "zone": "tunnel" }, "keep": false, "interface": "gre1" }

But above command is returning with "Invalid argument error". This error is
being thrown from netifd from function "proto_shell_update_link". In this
function "if (!tb[NOTIFY_LINK_UP])" statement becomes true and
"UBUS_STATUS_INVALID_ARGUMENT" is being returned.

I tried to understand the "tb" structure, but could not understand the json
to "json_object" conversion. Could you please help how to debug this
further.

I think, I am missing some thing in config (as u suggest in previous mail)
and debugging from the code to find it out. I tried multiple examples
available over net, but nothing worked out for me. Can you please review my
config once again.

Thanks for your help.

Regards,
Sridhar

On Thu, Nov 19, 2015 at 7:06 PM, Steven Barth  wrote:

> You are most likely missing a route to the remote tunnel endpoint
> (192.168.11.5).
> The system doesn't know which interface and next hop to send the tunneled
> packets to, thats why its blocking the tunnel bringup.
>
>
> Cheers,
>
> Steven
> ___
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Unable to create GRE interface using netifd

2015-11-19 Thread pothuganti sridhar
Hi All,

I am using netifd version "PKG_VERSION:=2014-09-08.1". Following is my
network config file.


*config interface loopback*

*option ifname   lo*

*option protostatic*

*option ipaddr   127.0.0.1*

*option netmask  255.0.0.0*



*config interface vlan1*

*option ifname   eth2*

*option protostatic*

*option ipaddr   192.168.0.1*

*option netmask  255.255.255.0*



*config interface wan1*

*option ifname   eth0*

*option protostatic*

*option ipaddr   172.31.3.8*

*option netmask  255.255.0.0*



*config interface gre1*

*option peeraddr 192.168.11.5*

*option ipaddr 172.31.3.8*

*option proto gre*

*option df true*

*option zone tunnel*

*option tunlink wan1*



*config interface 'gre1_static'*

*option proto 'static'*

*option ifname '@gre1'*

*option ipaddr '10.232.90.101'*

*option netmask '255.255.255.0'*


With the above configuration I am unable to create the GRE interface.  With
further debugging I found out that, GRE interface addition is failing in
function “proto_shell_check_dependencies” with check “if (dep->dep.iface)”
being NULL for interface WAN1. Following are the logs.

*Jan  2 16:21:02 RV340 netifd: proto_shell_notify:723
blobmsg_get_u32(tb[NOTIFY_ACTION]):6*

*Jan  2 16:21:02 RV340 netifd: proto_shell_check_dependencies:87
ifname:(null) name:gre1*

*Jan  2 16:21:02 RV340 netifd: proto_shell_check_dependencies:90
interface:wan1*

*Jan  2 16:21:02 RV340 netifd: proto_shell_check_dependencies:94 making
false  interface:wan1*

*Jan  2 16:21:02 RV340 netifd: Interface 'gre1', available=0*

*Jan  2 16:21:02 RV340 netifd: interface_set_available:369 calling
__interface_set_down*

*Jan  2 16:21:02 RV340 netifd: run teardown for interface 'gre1'*

*Jan  2 16:21:02 RV340 netifd: netifd_start_process:138*

*Jan  2 16:21:02 RV340 netifd: netifd_start_process:174  bin:./gre.sh*



Note: I have added some more logs to find out where it is getting failed.

Is my configuration proper? Or any thing am I missing? I am unable find out
where I am going wrong. any pointers would be grateful.

Thanks,
Sridhar
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Regarding strongswan UCI support

2015-02-25 Thread pothuganti sridhar
Hi All,

   I have compiled strongswan5.2.1 on openwrt attitude adjustment and
enabled UCI plugin. I am not observing init script to configure ipsec.conf
and ipsec.secrets from /etc/config/strongswan  configuration file. Is this
available in any patch or in any other release?  where can I find the init
script for it?

   I have one more question,  As per my understanding UCI infra will
take the configuration from /etc/config/ and update the module's
configuration file  and reload/restarts the daemon. Then what is the role
of UCI plugin in strongswan?

Regards,
-Sridhar
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel