Re: [ovs-dev] [PATCH 1/6] dpif-netdev: Rename pmd-maxsleep config option.

2023-07-10 Thread Kevin Traynor

On 29/06/2023 15:30, Simon Horman wrote:

On Wed, Jun 14, 2023 at 02:36:39PM +0100, Kevin Traynor wrote:

other_config:pmd-maxsleep is a config option to allow
PMD thread cores to sleep under low or no load conditions.

Rename it to 'pmd-sleep-max' to allow a more structured
name and so that additional options or command can follow
the 'pmd-sleep-xyz' pattern.

Signed-off-by: Kevin Traynor 


Hi Kevin,

are there any backwards compatibility considerations for this change?



Hi Simon,

It does mean the previous config option would not work anymore, yes.
However, that is an experimental option for a new feature in OVS 3.1, so 
I don't think in practice it will be widely used. Also, with it being 
experimental it carries the health risk that it may be changed.


I considered leaving it as a type of alias, but the later patches 
extend the functionality to using a string and per core, so having both 
might confusion for the user too.


For example, a user might set both strings with competing values etc. or 
think the new one is only for per core etc. e.g. pmd-maxsleep=50 
(general default sleep is 50) and pmd-sleep-max=12:200 (general default 
sleep is 0).


A clearer way might be to add a warning if the user sets pmd-maxsleep 
just for the chance that anyone starts using with 3.1 and hops to 3.2+ 
and doesn't notice the change.


I've added the below to v3. We could remove it sometime in the future 
when we think OVS 3.1 has become a bit old for users to start trying 
experimental features with it.


What do you think?

+if (smap_get_ullong(other_config, "pmd-maxsleep", 0)) {
+VLOG_WARN("pmd-maxsleep is not supported. "
+  "Please use pmd-sleep-max instead.");
+}

ovs-vsctl set Open_vSwitch . other_config:pmd-maxsleep=200
2023-07-10T10:55:21Z|00108|dpif_netdev|WARN|pmd-maxsleep is not 
supported. Please use pmd-sleep-max instead.


___
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev


Re: [ovs-dev] [PATCH 1/6] dpif-netdev: Rename pmd-maxsleep config option.

2023-07-03 Thread David Marchand
On Thu, Jun 29, 2023 at 4:30 PM Simon Horman  wrote:
>
> On Wed, Jun 14, 2023 at 02:36:39PM +0100, Kevin Traynor wrote:
> > other_config:pmd-maxsleep is a config option to allow
> > PMD thread cores to sleep under low or no load conditions.
> >
> > Rename it to 'pmd-sleep-max' to allow a more structured
> > name and so that additional options or command can follow
> > the 'pmd-sleep-xyz' pattern.
> >
> > Signed-off-by: Kevin Traynor 
>
> Hi Kevin,
>
> are there any backwards compatibility considerations for this change?

The PMD sleep feature is pretty recent (well, it was introduced in the
previous release), and marked as experimental.
https://docs.openvswitch.org/en/latest/topics/dpdk/pmd/#pmd-load-based-sleeping-experimental

I don't have a strong opinion for or against this change, but I think
it is ok to update the param name now for the reason Kevin gave in the
commitlog.


-- 
David Marchand

___
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev


Re: [ovs-dev] [PATCH 1/6] dpif-netdev: Rename pmd-maxsleep config option.

2023-06-29 Thread Simon Horman
On Wed, Jun 14, 2023 at 02:36:39PM +0100, Kevin Traynor wrote:
> other_config:pmd-maxsleep is a config option to allow
> PMD thread cores to sleep under low or no load conditions.
> 
> Rename it to 'pmd-sleep-max' to allow a more structured
> name and so that additional options or command can follow
> the 'pmd-sleep-xyz' pattern.
> 
> Signed-off-by: Kevin Traynor 

Hi Kevin,

are there any backwards compatibility considerations for this change?
___
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev