mmd_dispatch_numval

2003-10-16 Thread Simon Glover

From mmd.pod:

=item FLOATVAL mmd_dispatch_numval(interp, left, right, func_num)

Like Cmmd_dispatch_string, only it returns a FLOATVAL.

Wouldn't it be more sensible to call the function mmd_dispatch_floatval ?

Simon



Re: mmd_dispatch_numval

2003-10-16 Thread Dan Sugalski
On Thu, 16 Oct 2003, Simon Glover wrote:


 From mmd.pod:

 =item FLOATVAL mmd_dispatch_numval(interp, left, right, func_num)

 Like Cmmd_dispatch_string, only it returns a FLOATVAL.

 Wouldn't it be more sensible to call the function mmd_dispatch_floatval ?

Yep. The terminology's mixed in a number of places--we should probably go
fix it everywhere and be done with it. (Unless I'm just behind the times
and its already been done :)

Dan


Re: mmd_dispatch_numval

2003-10-16 Thread Simon Glover

On Thu, 16 Oct 2003, Dan Sugalski wrote:

 On Thu, 16 Oct 2003, Simon Glover wrote:
 
 
  From mmd.pod:
 
  =item FLOATVAL mmd_dispatch_numval(interp, left, right, func_num)
 
  Like Cmmd_dispatch_string, only it returns a FLOATVAL.
 
  Wouldn't it be more sensible to call the function mmd_dispatch_floatval ?
 
 Yep. The terminology's mixed in a number of places--we should probably go
 fix it everywhere and be done with it. (Unless I'm just behind the times
 and its already been done :)

 OK, I've changed it over to mmd_dispatch_floatval in mmd.c, mmd.h and 
 mmd.pod; as far as I can tell, it's not yet being used anywhere else.

 Simon




Re: mmd_dispatch_numval

2003-10-16 Thread Jeff Clites
On Oct 16, 2003, at 2:40 PM, Simon Glover wrote:

On Thu, 16 Oct 2003, Dan Sugalski wrote:

On Thu, 16 Oct 2003, Simon Glover wrote:

From mmd.pod:
=item FLOATVAL mmd_dispatch_numval(interp, left, right, func_num)

Like Cmmd_dispatch_string, only it returns a FLOATVAL.

Wouldn't it be more sensible to call the function 
mmd_dispatch_floatval ?
Yep. The terminology's mixed in a number of places--we should 
probably go
fix it everywhere and be done with it. (Unless I'm just behind the 
times
and its already been done :)
 OK, I've changed it over to mmd_dispatch_floatval in mmd.c, mmd.h and
 mmd.pod; as far as I can tell, it's not yet being used anywhere else.
Although I think float is clearer than number (in that it's clearly 
different than integer), it might be easier to go with 
number--since we have set_number vtable methods, and N registers 
rather than F registers

JEff



Re: mmd_dispatch_numval

2003-10-16 Thread Simon Glover

On Thu, 16 Oct 2003, Jeff Clites wrote:

 On Oct 16, 2003, at 2:40 PM, Simon Glover wrote:
 
  On Thu, 16 Oct 2003, Dan Sugalski wrote:
 
  On Thu, 16 Oct 2003, Simon Glover wrote:
 
  From mmd.pod:
 
  =item FLOATVAL mmd_dispatch_numval(interp, left, right, func_num)
 
  Like Cmmd_dispatch_string, only it returns a FLOATVAL.
 
  Wouldn't it be more sensible to call the function 
  mmd_dispatch_floatval ?
 
  Yep. The terminology's mixed in a number of places--we should 
  probably go
  fix it everywhere and be done with it. (Unless I'm just behind the 
  times
  and its already been done :)
 
   OK, I've changed it over to mmd_dispatch_floatval in mmd.c, mmd.h and
   mmd.pod; as far as I can tell, it's not yet being used anywhere else.
 
 Although I think float is clearer than number (in that it's clearly 
 different than integer), it might be easier to go with 
 number--since we have set_number vtable methods, and N registers 
 rather than F registers

 Ah, but we currently use floatval and FLOATVAL in a lot more places than
 we do numval or NUMVAL (or number). 

 Simon