Re: QML and Plasma - progress()

2010-09-17 Thread Marco Martin
On Thursday 16 September 2010, Marco Martin wrote:
 Hi all,
 the status of an AppletScript for writing plasmoids in pure QML is
 progressing rather well, i thought to write a detailed status
 report/documentation before significative design problems go too far in
 the implementation, be patient, is really long, but it can be used as a
 basis for a future documentation.

Almost implemented services support (there is a qml nowplaying plasmoid to 
test it), but there are two quite ugly problems (that derive from not having 
access to the engine):
services:
we need to manipulate kconfiggroup from javascript, but we can't registed the 
conversion to scriptvalues: that is valid for any type tht is not a qobject, 
oh joy.
at the moment resolved with a function 
AppletInterface::setOperationValue(KConfiggroup, key, value)

that's rather ugly.
i was also thinking bout registering an object for operations that would be 
declared in qml directly like
ServiceOperation {
id: operation
service: dataEngine.service
operationDescription: seek
}

then one would set the operation parameters with something like 
operation.setParameter(seconds, 120);  operation.start() (because dynamic 
properties are not available in qml, so no operation.seconds=120 :/)


second problem:
services support the neat feature of being automatically associated to a 
widget, so doing someting like service.associateWidget(stop, stop);

now, i can call this from the qml javascript, but the thing that gets in the 
parameter instead of the widget is some misterious value that i'm not even 
sure it started as a pointer (no, it's not a QObject*)
so anohter thing that would not be possible is to pass pointers to the 
internal qml items passed by id in an external c++ object.
i see this as another potentially limiting thing.

still have to give a crack to event listeners, that one looks slightly more 
feasible

Cheers,
Marco Martin
___
Plasma-devel mailing list
Plasma-devel@kde.org
https://mail.kde.org/mailman/listinfo/plasma-devel


Re: Review Request: Cleanups in pager

2010-09-17 Thread Aaron Seigo

---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/5355/#review7667
---


the patch doesn't apply to current trunk .. could you update the review board 
request? thanks :)

- Aaron


On 2010-09-17 02:29:59, Anthony Bryant wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 http://svn.reviewboard.kde.org/r/5355/
 ---
 
 (Updated 2010-09-17 02:29:59)
 
 
 Review request for Plasma.
 
 
 Summary
 ---
 
 * Make configAccepted() just write the new config, and make configChanged() 
 conditionally update the plasmoid after reading the config back in.
 * Split the grid resizing logic into its own method: recalculateGridSizes(int 
 rows), and make it detect more edge cases.
 * Rename the main size calculation method to updateSizes(bool allowResize), 
 which will resize the applet to its preferred size if allowResize is true.
 * Fix a bug which caused applet resizes to be wrongly cancelled in some 
 situations.
 * Code style cleanups, remove unused variables, etc.
 
 (Sorry for putting so many changes into one patch)
 
 
 This addresses bug 250756.
 https://bugs.kde.org/show_bug.cgi?id=250756
 
 
 Diffs
 -
 
   /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.h 1176214 
   /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.cpp 1176214 
 
 Diff: http://svn.reviewboard.kde.org/r/5355/diff
 
 
 Testing
 ---
 
 Tested configuring the pager from the config interface and the desktop 
 console, and that it responds correctly to changes in desktop count, and in 
 FormFactor and size.
 
 
 Thanks,
 
 Anthony
 


___
Plasma-devel mailing list
Plasma-devel@kde.org
https://mail.kde.org/mailman/listinfo/plasma-devel


Re: Review Request: Cleanups in pager

2010-09-17 Thread Anthony Bryant


 On 2010-09-17 16:18:36, Aaron Seigo wrote:
  the patch doesn't apply to current trunk .. could you update the review 
  board request? thanks :)

I thought I did that yesterday (and there haven't been any commits to pager 
since then), does it still not apply?


- Anthony


---
This is an automatically generated e-mail. To reply, visit:
http://svn.reviewboard.kde.org/r/5355/#review7667
---


On 2010-09-17 02:29:59, Anthony Bryant wrote:
 
 ---
 This is an automatically generated e-mail. To reply, visit:
 http://svn.reviewboard.kde.org/r/5355/
 ---
 
 (Updated 2010-09-17 02:29:59)
 
 
 Review request for Plasma.
 
 
 Summary
 ---
 
 * Make configAccepted() just write the new config, and make configChanged() 
 conditionally update the plasmoid after reading the config back in.
 * Split the grid resizing logic into its own method: recalculateGridSizes(int 
 rows), and make it detect more edge cases.
 * Rename the main size calculation method to updateSizes(bool allowResize), 
 which will resize the applet to its preferred size if allowResize is true.
 * Fix a bug which caused applet resizes to be wrongly cancelled in some 
 situations.
 * Code style cleanups, remove unused variables, etc.
 
 (Sorry for putting so many changes into one patch)
 
 
 This addresses bug 250756.
 https://bugs.kde.org/show_bug.cgi?id=250756
 
 
 Diffs
 -
 
   /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.h 1176214 
   /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.cpp 1176214 
 
 Diff: http://svn.reviewboard.kde.org/r/5355/diff
 
 
 Testing
 ---
 
 Tested configuring the pager from the config interface and the desktop 
 console, and that it responds correctly to changes in desktop count, and in 
 FormFactor and size.
 
 
 Thanks,
 
 Anthony
 


___
Plasma-devel mailing list
Plasma-devel@kde.org
https://mail.kde.org/mailman/listinfo/plasma-devel