Re: python packaging

2016-06-20 Thread Elan Ruusamäe

On 20.06.2016 22:06, Jakub Bogusz wrote:

On Mon, Jun 20, 2016 at 04:11:41PM +0200, Jacek Konieczny wrote:

On 2016-06-20 14:58, Elan Ruusamäe wrote:

so, what way we should do the package naming?

1. egg name

That probably makes most sense today.


2. python module name [*]

That was decided before python eggs started being a thing. And that is
how most of our packages are named now.

Also, some packages contain more than one module without own namespace,
thus making using import name for whole package impossible.

but egg name or pypi name?

i would prefer pypi name, because most docs say install from pypi:

$ pip install foothing

and then can just type instead:
$ poldek -u python-foothing

--
glen

___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en


Re: [packages/boost] future todo: use .7z download

2016-06-20 Thread Elan Ruusamäe

On 20.06.2016 22:05, Jakub Bogusz wrote:

On Mon, Jun 20, 2016 at 08:01:33PM +0200, glen wrote:

commit aaeb56b0e6b7f2a6f5e636a50ab7e67f1c047aff
Author: Elan Ruusamäe 
Date:   Mon Jun 20 21:01:12 2016 +0300

 future todo: use .7z download

.7z (and .zip) boost archives are targeted to Windows (with CRLF line
endings inside).


there .7z is smaller than .bz2, and if the only difference is EOL-style, 
then gcc doesn't mind source file encoding...



--
glen

___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en


Re: python packaging

2016-06-20 Thread Jakub Bogusz
On Mon, Jun 20, 2016 at 04:11:41PM +0200, Jacek Konieczny wrote:
> On 2016-06-20 14:58, Elan Ruusamäe wrote:
> >so, what way we should do the package naming?
> >
> >1. egg name
> 
> That probably makes most sense today.
> 
> >2. python module name [*]
> 
> That was decided before python eggs started being a thing. And that is 
> how most of our packages are named now.

Also, some packages contain more than one module without own namespace,
thus making using import name for whole package impossible.


-- 
Jakub Boguszhttp://qboosh.pl/
___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en


Re: [packages/boost] future todo: use .7z download

2016-06-20 Thread Jakub Bogusz
On Mon, Jun 20, 2016 at 08:01:33PM +0200, glen wrote:
> commit aaeb56b0e6b7f2a6f5e636a50ab7e67f1c047aff
> Author: Elan Ruusamäe 
> Date:   Mon Jun 20 21:01:12 2016 +0300
> 
> future todo: use .7z download

.7z (and .zip) boost archives are targeted to Windows (with CRLF line
endings inside).


-- 
Jakub Boguszhttp://qboosh.pl/
___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en


Re: python packaging

2016-06-20 Thread Jeff Johnson

On Jun 20, 2016, at 10:11 AM, Jacek Konieczny wrote:

> 
>> reality is that we have no consistency,
> 
> Some people seem to don't care at all. :-(
> I am afraid, that whatever scheme we decide on, people will still commit 
> crap. That is minority, but quite annoying.
> 

Distro package naming is up to distros ... BUT ...

If you wish naming consistency, then you will likely need detection and 
enforcement.
rpmbuild implementations is one mechanism.

rpmbuild already runs *RE's against package name  (and more) to prevent
(essentially) cross-scripting attacks on contexts where NVR are used in 
scripting.

The *RE's are doing nothing more than limiting the character set being used 
currently.
It would not be hard to apply additional *RE's against, say, python package 
naming.

There is also RPM+SED (i.e. a PCRE sed-like embedding) intended as a better
way to do %{?dist} branding in build releases. Basically the equivalent of 
running

rpm -qp --qf '%{release}'  *.rpm | sed -e 's/$/%{?dist}/'

while building, without adding dependencies on external sed(1). There are
many other usage cases for an internal/embedded find-and-replace in RPM.

hth

73 de Jeff


___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en


Re: python packaging

2016-06-20 Thread Elan Ruusamäe

On 20.06.2016 17:11, Jacek Konieczny wrote:


I think the best naming scheme would be python-${egg_name} now. But 
that is inconsistent with what we used to do. Renaming all the 
affected packages might be quite problematic
what about name cases, should we lowercase them? (i'd like that, ensures 
some what consistency)

or pyp index names already enforce lowercase?

but pyp index name != egg_name likely too?

github mirror can't distinguish python-South with python-south (it's all 
same to it)
also i've had case where i used case insensitive filesystem for storing 
pld mirror


--
glen

___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en


Re: python packaging

2016-06-20 Thread Jacek Konieczny

On 2016-06-20 14:58, Elan Ruusamäe wrote:

so, what way we should do the package naming?

1. egg name


That probably makes most sense today.


2. python module name [*]


That was decided before python eggs started being a thing. And that is 
how most of our packages are named now.



3. upstream tarball name
4. pld own convention


Both would give quite random results.


[*] this is said to be the recommendation in template-specs


As it was decided long time ago, when it made sense.


reality is that we have no consistency,


Some people seem to don't care at all. :-(
I am afraid, that whatever scheme we decide on, people will still commit 
crap. That is minority, but quite annoying.



the package naming is from any of the four choices:

the results vary from name letter cases (South vs south), separators (_
vs -), name itself (picklefield module vs django_picklefield egg)


I hate this too. Especially when I find out a package exists after I 
package it again under a more standard name.


I think the best naming scheme would be python-${egg_name} now. But that 
is inconsistent with what we used to do. Renaming all the affected 
packages might be quite problematic.


Anything that doesn't match 1. or 2. should be renamed, but doing it 
after it went to th causes compatibility problems.


Jacek
___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en


python packaging

2016-06-20 Thread Elan Ruusamäe

so, what way we should do the package naming?

1. egg name
2. python module name [*]
3. upstream tarball name
4. pld own convention

[*] this is said to be the recommendation in template-specs

reality is that we have no consistency, the package naming is from any 
of the four choices:


the results vary from name letter cases (South vs south), separators (_ 
vs -), name itself (picklefield module vs django_picklefield egg)



[~/relup/python-django-contact-form(1.1) (master)⚡] ➔ grep -n 
'^%{py_sitescriptdir}' ~/all-specs/python-django[-_]*.spec

/home/users/glen/all-specs/python-django-assets.spec:59:%{py_sitescriptdir}/django_assets
/home/users/glen/all-specs/python-django-assets.spec:60:%{py_sitescriptdir}/django_assets-%{version}-py*.egg-info

/home/users/glen/all-specs/python-django-celery.spec:54:%{py_sitescriptdir}/djcelery
/home/users/glen/all-specs/python-django-celery.spec:56:%{py_sitescriptdir}/django_celery-%{version}-*.egg-info

/home/users/glen/all-specs/python-django-evolution.spec:70:%{py_sitescriptdir}/django_evolution
/home/users/glen/all-specs/python-django-evolution.spec:72:%{py_sitescriptdir}/django_evolution-%{version}-*.egg-info

/home/users/glen/all-specs/python-django-picklefield.spec:56:%{py_sitescriptdir}/picklefield
/home/users/glen/all-specs/python-django-picklefield.spec:58:%{py_sitescriptdir}/django_picklefield-%{version}-*.egg-info/

/home/users/glen/all-specs/python-django-pipeline.spec:58:%{py_sitescriptdir}/pipeline/*.py[co]
/home/users/glen/all-specs/python-django-pipeline.spec:59:%{py_sitescriptdir}/pipeline/compilers/*.py[co]
/home/users/glen/all-specs/python-django-pipeline.spec:60:%{py_sitescriptdir}/pipeline/compressors/*.py[co]
/home/users/glen/all-specs/python-django-pipeline.spec:61:%{py_sitescriptdir}/pipeline/conf/*.py[co]
/home/users/glen/all-specs/python-django-pipeline.spec:62:%{py_sitescriptdir}/pipeline/jinja2/*.py[co]
/home/users/glen/all-specs/python-django-pipeline.spec:63:%{py_sitescriptdir}/pipeline/templates
/home/users/glen/all-specs/python-django-pipeline.spec:64:%{py_sitescriptdir}/pipeline/templatetags/*.py[co]
/home/users/glen/all-specs/python-django-pipeline.spec:65:%{py_sitescriptdir}/django_pipeline*.egg-info

/home/users/glen/all-specs/python-django-profiles.spec:44:%{py_sitescriptdir}/profiles/*.py[co]
/home/users/glen/all-specs/python-django-profiles.spec:45:%{py_sitescriptdir}/django_profiles-%{version}-py*.egg-info

/home/users/glen/all-specs/python-django-registration.spec:59:%{py_sitescriptdir}/registration/*.py[co]
/home/users/glen/all-specs/python-django-registration.spec:60:%{py_sitescriptdir}/registration/backends
/home/users/glen/all-specs/python-django-registration.spec:61:%{py_sitescriptdir}/registration/management
/home/users/glen/all-specs/python-django-registration.spec:63:%{py_sitescriptdir}/django_registration-%{version}-py*.egg-info

/home/users/glen/all-specs/python-django-skypehub.spec:38:%{py_sitescriptdir}/skypehub
/home/users/glen/all-specs/python-django-skypehub.spec:40:%{py_sitescriptdir}/django_skypehub-%{version}-*.egg-info

/home/users/glen/all-specs/python-django-south.spec:46:%{py_sitescriptdir}/south
/home/users/glen/all-specs/python-django-south.spec:48:%{py_sitescriptdir}/South-*.egg-info

/home/users/glen/all-specs/python-django-voting.spec:45:%{py_sitescriptdir}/voting/*.py[co]
/home/users/glen/all-specs/python-django-voting.spec:46:%{py_sitescriptdir}/voting/migrations
/home/users/glen/all-specs/python-django-voting.spec:47:%{py_sitescriptdir}/voting/templatetags
/home/users/glen/all-specs/python-django-voting.spec:48:%{py_sitescriptdir}/django_voting-%{version}-py*.egg-info

/home/users/glen/all-specs/python-django_extensions.spec:108:%{py_sitescriptdir}/%{module}
/home/users/glen/all-specs/python-django_extensions.spec:109:%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info

/home/users/glen/all-specs/python-django_profile.spec:53:%{py_sitescriptdir}/userprofile

/home/users/glen/all-specs/python-django_reversion.spec:59:%{py_sitescriptdir}/%{module}
/home/users/glen/all-specs/python-django_reversion.spec:60:%{py_sitescriptdir}/django_reversion-%{version}-*.egg-info

/home/users/glen/all-specs/python-django_tagging.spec:44:%{py_sitescriptdir}/%{module}/*.py[co]
/home/users/glen/all-specs/python-django_tagging.spec:45:%{py_sitescriptdir}/%{module}/templatetags
/home/users/glen/all-specs/python-django_tagging.spec:46:%{py_sitescriptdir}/django_tagging-%{version}-py*.egg-info

[~/relup/python-django-contact-form(1.1) (master)⚡] ➔

--
glen

___
pld-devel-en mailing list
pld-devel-en@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-devel-en