[issue33544] Asyncio Event.wait() is a hold over from before awaitable, and should be awaitable

2018-05-21 Thread Andrew Svetlov

Change by Andrew Svetlov :


--
resolution:  -> rejected
stage: patch review -> resolved
status: open -> closed

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue33544] Asyncio Event.wait() is a hold over from before awaitable, and should be awaitable

2018-05-19 Thread Andrew Svetlov

Andrew Svetlov  added the comment:

-1 for the proposal

--

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue33544] Asyncio Event.wait() is a hold over from before awaitable, and should be awaitable

2018-05-17 Thread Yury Selivanov

Yury Selivanov  added the comment:

> Deprecating Event.wait would be incorrect because Event was designed to mimic 
> the threading.Event class which has a (blocking) wait() method[1].

This is rather important. I'd like to continue maintaining this similarity. 
Adding 'await event' would be similar (in a way) to making instances of 
threading.Event callable.  So deprecation of '.wait()' isn't something we will 
do.

Having *both* 'await event.wait()' and 'await event' worries me.  IMO the 
slight readability improvement isn't worth the added complexity.

--

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue33544] Asyncio Event.wait() is a hold over from before awaitable, and should be awaitable

2018-05-16 Thread Hrvoje Nikšić

Hrvoje Nikšić  added the comment:

Deprecating Event.wait would be incorrect because Event was designed to mimic 
the threading.Event class which has a (blocking) wait() method[1].

Supporting `await event` is still worthwhile, though.

[1]
https://docs.python.org/2/library/threading.html#threading.Event.wait

--
nosy: +hniksic

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue33544] Asyncio Event.wait() is a hold over from before awaitable, and should be awaitable

2018-05-16 Thread Jason Fried

Change by Jason Fried :


--
keywords: +patch
pull_requests: +6584
stage:  -> patch review

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue33544] Asyncio Event.wait() is a hold over from before awaitable, and should be awaitable

2018-05-16 Thread Jason Fried

Jason Fried  added the comment:

Removed Condition from this request, because it has an __await__ method for 
supporting the the deprecated pattern

  with async cond:

I'll open a different bug, for Condition behavior for 3.9 when we can remove 
the deprecated pattern.

--
title: Asyncio Event.wait() and Condition.wait() is a hold over from before 
awaitable, and should be awaitable -> Asyncio Event.wait() is a hold over from 
before awaitable, and should be awaitable

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com