Re: [PATCH 0/8] configure: Change to -std=gnu11

2021-06-14 Thread no-reply
Patchew URL: 
https://patchew.org/QEMU/20210611233347.653129-1-richard.hender...@linaro.org/



Hi,

This series seems to have some coding style problems. See output below for
more information:

Type: series
Message-id: 20210611233347.653129-1-richard.hender...@linaro.org
Subject: [PATCH 0/8] configure: Change to -std=gnu11

=== TEST SCRIPT BEGIN ===
#!/bin/bash
git rev-parse base > /dev/null || exit 0
git config --local diff.renamelimit 0
git config --local diff.renames True
git config --local diff.algorithm histogram
./scripts/checkpatch.pl --mailback base..
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
From https://github.com/patchew-project/qemu
 * [new tag] patchew/20210610100802.5888-1-vsement...@virtuozzo.com -> 
patchew/20210610100802.5888-1-vsement...@virtuozzo.com
 * [new tag] 
patchew/20210610142549.33220-1-zhangjiachen.jay...@bytedance.com -> 
patchew/20210610142549.33220-1-zhangjiachen.jay...@bytedance.com
Switched to a new branch 'test'
e40a971 configure: Remove probe for _Static_assert
1d4e941 qemu/compiler: Remove QEMU_GENERIC
c6f4654 include/qemu/lockable: Use _Generic instead of QEMU_GENERIC
f158a02 util: Use unique type for QemuRecMutex in thread-posix.h
a26bcbe util: Pass file+line to qemu_rec_mutex_unlock_impl
e1ba627 util: Use real functions for thread-posix QemuRecMutex
096aebf softfloat: Use _Generic instead of QEMU_GENERIC
1781658 configure: Use -std=gnu11

=== OUTPUT BEGIN ===
1/8 Checking commit 178165898450 (configure: Use -std=gnu11)
2/8 Checking commit 096aebfff18d (softfloat: Use _Generic instead of 
QEMU_GENERIC)
ERROR: spaces required around that '*' (ctx:WxO)
#22: FILE: fpu/softfloat.c:689:
+_Generic((P), FloatParts64 *: parts64_##NAME, \
^

ERROR: spaces required around that ':' (ctx:OxW)
#22: FILE: fpu/softfloat.c:689:
+_Generic((P), FloatParts64 *: parts64_##NAME, \
 ^

ERROR: spaces required around that '*' (ctx:WxO)
#23: FILE: fpu/softfloat.c:690:
+  FloatParts128 *: parts128_##NAME)
 ^

ERROR: spaces required around that ':' (ctx:OxW)
#23: FILE: fpu/softfloat.c:690:
+  FloatParts128 *: parts128_##NAME)
  ^

ERROR: spaces required around that '*' (ctx:WxO)
#28: FILE: fpu/softfloat.c:693:
+_Generic((P), FloatParts64 *: parts64_##NAME, \
^

ERROR: spaces required around that ':' (ctx:OxW)
#28: FILE: fpu/softfloat.c:693:
+_Generic((P), FloatParts64 *: parts64_##NAME, \
 ^

ERROR: spaces required around that '*' (ctx:WxO)
#29: FILE: fpu/softfloat.c:694:
+  FloatParts128 *: parts128_##NAME, \
 ^

ERROR: spaces required around that ':' (ctx:OxW)
#29: FILE: fpu/softfloat.c:694:
+  FloatParts128 *: parts128_##NAME, \
  ^

ERROR: spaces required around that '*' (ctx:WxO)
#30: FILE: fpu/softfloat.c:695:
+  FloatParts256 *: parts256_##NAME)
 ^

ERROR: spaces required around that ':' (ctx:OxW)
#30: FILE: fpu/softfloat.c:695:
+  FloatParts256 *: parts256_##NAME)
  ^

ERROR: spaces required around that '*' (ctx:WxO)
#39: FILE: fpu/softfloat.c:897:
+_Generic((P), FloatParts64 *: frac64_##NAME, \
^

ERROR: spaces required around that ':' (ctx:OxW)
#39: FILE: fpu/softfloat.c:897:
+_Generic((P), FloatParts64 *: frac64_##NAME, \
 ^

ERROR: spaces required around that '*' (ctx:WxO)
#40: FILE: fpu/softfloat.c:898:
+  FloatParts128 *: frac128_##NAME)
 ^

ERROR: spaces required around that ':' (ctx:OxW)
#40: FILE: fpu/softfloat.c:898:
+  FloatParts128 *: frac128_##NAME)
  ^

ERROR: spaces required around that '*' (ctx:WxO)
#45: FILE: fpu/softfloat.c:901:
+_Generic((P), FloatParts64 *: frac64_##NAME, \
^

ERROR: spaces required around that ':' (ctx:OxW)
#45: FILE: fpu/softfloat.c:901:
+_Generic((P), FloatParts64 *: frac64_##NAME, \
 ^

ERROR: spaces required around that '*' (ctx:WxO)
#46: FILE: fpu/softfloat.c:902:
+  FloatParts128 *: frac128_##NAME, \
 ^

ERROR: spaces required around that ':' (ctx:OxW)
#46: FILE: fpu/softfloat.c:902:
+  FloatParts128 *: frac128_##NAME, \
  ^

ERROR: spaces required around that '*' (ctx:WxO)
#47: FILE: fpu/softfloat.c:903:
+  FloatParts256 *: frac256_##NAME)
 ^

ERROR: spaces required around that ':' (ctx:OxW)
#47: FILE: fpu/softfloat.c:903:
+  FloatParts256 *: frac2

Re: [PATCH 0/8] configure: Change to -std=gnu11

2021-06-14 Thread Paolo Bonzini

On 12/06/21 01:33, Richard Henderson wrote:

Now that we assume gcc 7.5 as a minimum, we have the option
of changing to a newer C standard.  The two major ones that
I think apply are _Generic and _Static_assert.

While Paolo created a remarkably functional replacement for _Generic
using builtins, the error messages that you get out of the keyword
are*vastly*  more intelligable, and the syntax is easier to read.

While I'd like to prefer _Static_assert over QEMU_BUILD_BUG_ON
going forward, and would like to convert existing uses, that is
a much bigger job.  Especially since the test condition is inverted.
In the meantime, can drop the configure detection.



Looks good, thanks.  QEMU_GENERIC is the kind of thing that one can be 
both proud and ashamed of. :)


Paolo




Re: [PATCH 0/8] configure: Change to -std=gnu11

2021-06-11 Thread Richard Henderson

On 6/11/21 4:33 PM, Richard Henderson wrote:

Now that we assume gcc 7.5 as a minimum, we have the option
of changing to a newer C standard.  The two major ones that
I think apply are _Generic and _Static_assert.


Poor editing there.  How about s/ones/new features/.


r~



[PATCH 0/8] configure: Change to -std=gnu11

2021-06-11 Thread Richard Henderson
Now that we assume gcc 7.5 as a minimum, we have the option
of changing to a newer C standard.  The two major ones that
I think apply are _Generic and _Static_assert.

While Paolo created a remarkably functional replacement for _Generic
using builtins, the error messages that you get out of the keyword
are *vastly* more intelligable, and the syntax is easier to read.

While I'd like to prefer _Static_assert over QEMU_BUILD_BUG_ON
going forward, and would like to convert existing uses, that is
a much bigger job.  Especially since the test condition is inverted.
In the meantime, can drop the configure detection.


r~


Richard Henderson (8):
  configure: Use -std=gnu11
  softfloat: Use _Generic instead of QEMU_GENERIC
  util: Use real functions for thread-posix QemuRecMutex
  util: Pass file+line to qemu_rec_mutex_unlock_impl
  util: Use unique type for QemuRecMutex in thread-posix.h
  include/qemu/lockable: Use _Generic instead of QEMU_GENERIC
  qemu/compiler: Remove QEMU_GENERIC
  configure: Remove probe for _Static_assert

 configure   | 22 +-
 meson.build |  2 +-
 include/qemu/compiler.h | 51 --
 include/qemu/lockable.h | 85 +++--
 include/qemu/thread-posix.h | 14 +++---
 include/qemu/thread-win32.h |  6 ---
 include/qemu/thread.h   | 15 ++-
 fpu/softfloat.c | 16 ---
 util/qemu-thread-posix.c| 24 ++-
 util/qemu-thread-win32.c|  2 +-
 10 files changed, 100 insertions(+), 137 deletions(-)

-- 
2.25.1