Re: [PULL 00/19] SD/MMC patches for 2024-06-24
On 6/24/24 06:14, Philippe Mathieu-Daudé wrote: The following changes since commit c9ba79baca7c673098361e3a687f72d458e0d18a: Merge tag 'pull-target-arm-20240622' ofhttps://git.linaro.org/people/pmaydell/qemu-arm into staging (2024-06-22 09:56:49 -0700) are available in the Git repository at: https://github.com/philmd/qemu.git tags/sdmmc-20240624 for you to fetch changes up to 76ae9a231487a2b127c90bcb657fd42a1f6c06f8: hw/sd/sdcard: Add comments around registers and commands (2024-06-24 15:08:40 +0200) SD/MMC patches queue One fix and various cleanups for the SD card model. Applied, thanks. Please update https://wiki.qemu.org/ChangeLog/9.1 as appropriate. r~
[PULL 00/19] SD/MMC patches for 2024-06-24
The following changes since commit c9ba79baca7c673098361e3a687f72d458e0d18a: Merge tag 'pull-target-arm-20240622' of https://git.linaro.org/people/pmaydell/qemu-arm into staging (2024-06-22 09:56:49 -0700) are available in the Git repository at: https://github.com/philmd/qemu.git tags/sdmmc-20240624 for you to fetch changes up to 76ae9a231487a2b127c90bcb657fd42a1f6c06f8: hw/sd/sdcard: Add comments around registers and commands (2024-06-24 15:08:40 +0200) SD/MMC patches queue One fix and various cleanups for the SD card model. Philippe Mathieu-Daudé (19): bswap: Add st24_be_p() to store 24 bits in big-endian order hw/sd/sdcard: Avoid OOB in sd_read_byte() during unexpected CMD switch hw/sd/sdcard: Correct code indentation hw/sd/sdcard: Rewrite sd_cmd_ALL_SEND_CID using switch case (CMD2) hw/sd/sdcard: Fix typo in SEND_OP_COND command name hw/sd/sdcard: Use HWBLOCK_SHIFT definition instead of magic values hw/sd/sdcard: Use registerfield CSR::CURRENT_STATE definition hw/sd/sdcard: Use Load/Store API to fill some CID/CSD registers hw/sd/sdcard: Remove ACMD6 handler for SPI mode hw/sd/sdcard: Remove explicit entries for illegal commands hw/sd/sdcard: Trace update of block count (CMD23) hw/sd/sdcard: Have cmd_valid_while_locked() return a boolean value hw/sd/sdcard: Factor sd_req_get_rca() method out hw/sd/sdcard: Only call sd_req_get_rca() where RCA is used hw/sd/sdcard: Factor sd_req_get_address() method out hw/sd/sdcard: Only call sd_req_get_address() where address is used hw/sd/sdcard: Add sd_invalid_mode_for_cmd to report invalid mode switch hw/sd/sdcard: Inline BLK_READ_BLOCK / BLK_WRITE_BLOCK macros hw/sd/sdcard: Add comments around registers and commands include/qemu/bswap.h | 7 ++ hw/sd/sd.c | 245 - hw/sd/sdmmc-internal.c | 2 +- hw/sd/trace-events | 3 +- 4 files changed, 151 insertions(+), 106 deletions(-) -- 2.41.0