Re: [Qemu-devel] [PATCH v10 00/25] qapi visitor cleanups part 1 (post-introspection cleanups subset E)

2016-02-02 Thread Markus Armbruster
Markus Armbruster  writes:

> Eric Blake  writes:
>
>> Based on qemu.git master. No pending prerequisites
>>
>> Also available as a tag at this location:
>> git fetch git://repo.or.cz/qemu/ericb.git qapi-cleanupv10e
>>
>> and will soon be part of my branch with the rest of the v5 series, at:
>> http://repo.or.cz/qemu/ericb.git/shortlog/refs/heads/qapi
>>
>> v10 notes:
>> This is patches 1-20 of v9; 21-37 of that series will come later,
>> but this half was relatively clean and should be ready to merge.
>> Plus, this half includes the argument reordering, which touches
>> a lot of the tree, so getting it in sooner rather than later will
>> minimize rebase churn.  A couple patches were split differently
>> or retitled.  Reviewed-by was kept on patches that didn't change
>> in content (even if the content was split across different patch
>> boundaries).
>>
>> Most of the work here was addressing Markus' review comments,
>> or rebasing later patches on top of earlier changes.
>
> I found one harmless rebase mistake, and got a few suggestions on commit
> messages, nothing that can't be touched up on commit.
>
> With the harmless rebase mistake cleaned up, series
> Reviewed-by: Markus Armbruster 
>
> [...]

Applied to qapi-next with these nits addressed.

Marc-André, Eric dropped a few of your R-bys.  I'll wait a few days in
case you'd like to put them back.



Re: [Qemu-devel] [PATCH v10 00/25] qapi visitor cleanups part 1 (post-introspection cleanups subset E)

2016-02-01 Thread Markus Armbruster
Eric Blake  writes:

> Based on qemu.git master. No pending prerequisites
>
> Also available as a tag at this location:
> git fetch git://repo.or.cz/qemu/ericb.git qapi-cleanupv10e
>
> and will soon be part of my branch with the rest of the v5 series, at:
> http://repo.or.cz/qemu/ericb.git/shortlog/refs/heads/qapi
>
> v10 notes:
> This is patches 1-20 of v9; 21-37 of that series will come later,
> but this half was relatively clean and should be ready to merge.
> Plus, this half includes the argument reordering, which touches
> a lot of the tree, so getting it in sooner rather than later will
> minimize rebase churn.  A couple patches were split differently
> or retitled.  Reviewed-by was kept on patches that didn't change
> in content (even if the content was split across different patch
> boundaries).
>
> Most of the work here was addressing Markus' review comments,
> or rebasing later patches on top of earlier changes.

I found one harmless rebase mistake, and got a few suggestions on commit
messages, nothing that can't be touched up on commit.

With the harmless rebase mistake cleaned up, series
Reviewed-by: Markus Armbruster 

[...]



[Qemu-devel] [PATCH v10 00/25] qapi visitor cleanups part 1 (post-introspection cleanups subset E)

2016-01-29 Thread Eric Blake
Based on qemu.git master. No pending prerequisites

Also available as a tag at this location:
git fetch git://repo.or.cz/qemu/ericb.git qapi-cleanupv10e

and will soon be part of my branch with the rest of the v5 series, at:
http://repo.or.cz/qemu/ericb.git/shortlog/refs/heads/qapi

v10 notes:
This is patches 1-20 of v9; 21-37 of that series will come later,
but this half was relatively clean and should be ready to merge.
Plus, this half includes the argument reordering, which touches
a lot of the tree, so getting it in sooner rather than later will
minimize rebase churn.  A couple patches were split differently
or retitled.  Reviewed-by was kept on patches that didn't change
in content (even if the content was split across different patch
boundaries).

Most of the work here was addressing Markus' review comments,
or rebasing later patches on top of earlier changes.

001/25:[0013] [FC] 'qobject: Document more shortcomings in our number handling'
002/25:[] [--] 'qapi: Avoid use of misnamed DO_UPCAST()'
003/25:[] [--] 'qapi: Drop dead dealloc visitor variable'
004/25:[down] 'qapi: Dealloc visitor does not need a type_size()'
005/25:[down] 'qapi: Drop dead parameter in gen_params()'
006/25:[down] 'hmp: Drop pointless allocation during qapi visit'
007/25:[down] 'hmp: Cache use of qapi visitor'
008/25:[down] 'vl: Ensure qapi visitor properly ends struct visit'
009/25:[0003] [FC] 'balloon: Improve use of qapi visitor'
010/25:[0004] [FC] 'qapi: Improve generated event use of qapi visitor'
011/25:[0004] [FC] 'qapi: Track all failures between visit_start/stop'
012/25:[down] 'qapi-visit: Kill unused visit_end_union()'
013/25:[0012] [FC] 'qapi: Prefer type_int64 over type_int in visitors'
014/25:[0012] [FC] 'qapi: Make all visitors supply uint64 callbacks'
015/25:[0014] [FC] 'qapi: Consolidate visitor small integer callbacks'
016/25:[0006] [FC] 'qapi: Don't cast Enum* to int*'
017/25:[] [--] 'qom: Use typedef for Visitor'
018/25:[0004] [FC] 'qapi: Swap visit_* arguments for consistent 'name' 
placement'
019/25:[0005] [FC] 'qom: Swap 'name' next to visitor in ObjectPropertyAccessor'
020/25:[0010] [FC] 'qapi: Swap 'name' in visit_* callbacks to match public API'
021/25:[0018] [FC] 'qapi: Drop unused 'kind' for struct/enum visit'
022/25:[down] 'qapi: Tighten qmp_input_end_list()'
023/25:[0046] [FC] 'qapi: Drop unused error argument for list and implicit 
struct'
024/25:[0008] [FC] 'qmp: Fix reference-counting of qnull on empty output visit'
025/25:[0018] [FC] 'qmp: Don't abuse stack to track qmp-output root'

v9 notes:
https://lists.gnu.org/archive/html/qemu-devel/2016-01/msg03504.html
Rebase to master, incorporate findings from Marc-André.

v8 notes:
https://lists.gnu.org/archive/html/qemu-devel/2015-12/msg03863.html
For notes here and earlier, look in the archives

 include/qapi/visitor.h |  60 +
 include/qapi/visitor-impl.h|  63 +-
 scripts/qapi-commands.py   |   4 +-
 scripts/qapi-event.py  |  16 ++-
 scripts/qapi-types.py  |   2 +-
 scripts/qapi-visit.py  |  72 ++-
 scripts/qapi.py|  13 +-
 include/qom/object.h   |  13 +-
 qapi/qapi-visit-core.c | 252 +++--
 backends/hostmem.c |  24 ++--
 block/qapi.c   |   2 +-
 blockdev.c |   4 +-
 bootdevice.c   |  12 +-
 hmp.c  |  18 +--
 hw/acpi/core.c |   4 +-
 hw/acpi/ich9.c |  49 
 hw/block/nvme.c|  12 +-
 hw/core/machine.c  |  24 ++--
 hw/core/qdev-properties-system.c   |  44 +++
 hw/core/qdev-properties.c  | 180 +-
 hw/core/qdev.c |   7 +-
 hw/i386/pc.c   |  43 +++
 hw/ide/qdev.c  |  12 +-
 hw/intc/xics.c |  20 +--
 hw/isa/lpc_ich9.c  |   7 +-
 hw/mem/pc-dimm.c   |   6 +-
 hw/misc/edu.c  |   6 +-
 hw/misc/tmp105.c   |  12 +-
 hw/net/ne2000-isa.c|  14 ++-
 hw/pci-host/piix.c |  18 +--
 hw/pci-host/q35.c  |  23 ++--
 hw/ppc/spapr_drc.c |  34 +++--
 hw/usb/dev-storage.c   |  12 +-
 hw/virtio/virtio-balloon.c |  30 ++---
 memory.c   |  26 ++--
 net/dump.c |  12 +-
 net/filter-buffer.c|  14 ++-
 net/net.c  |   4 +-
 numa.c |   6 +-
 qapi/opts-visitor.c|  52 
 qapi/qapi-dealloc-visitor.c|  48 ---
 qapi/qmp-input-visitor.c   |  54 
 qapi/qmp-output-visitor.c  | 120 +-
 qapi/string-input-visitor.c|  62 +
 qapi/string-output-visitor.c   |  54