Re: [Qemu-devel] [PATCH v4 01/16] s390: cio: introduce cio_cancel_halt_clear
* Sebastian Ott [2017-03-23 12:51:40 +0100]: > On Fri, 17 Mar 2017, Dong Jia Shi wrote: > > For future code reuse purpose, this decouples the cio code with > > the ccw device specific parts from ccw_device_cancel_halt_clear, > > and makes a new common I/O interface named cio_cancel_halt_clear. > > > > Reviewed-by: Pierre Morel > > Signed-off-by: Dong Jia Shi > > Cc: Sebastian Ott > > Cc: Peter Oberparleiter > [...] > > +/** > > + * cio_cancel_halt_clear - Cancel running I/O by performing cancel, halt > > + * and clear ordinally if subchannel is valid. > > + * @sch: subchannel on which to perform the cancel_halt_clear operation > > + * @iretry: the number of the times remained to retry the next operation > > + * > > + * This should be called repeatedly since halt/clear are asynchronous > > + * operations. We do one try with cio_cancel, two tries with cio_halt, > ^ > three Ok. Nice catch! > > Acked-by: Sebastian Ott Thanks. -- Dong Jia Shi
Re: [Qemu-devel] [PATCH v4 01/16] s390: cio: introduce cio_cancel_halt_clear
On Fri, 17 Mar 2017, Dong Jia Shi wrote: > For future code reuse purpose, this decouples the cio code with > the ccw device specific parts from ccw_device_cancel_halt_clear, > and makes a new common I/O interface named cio_cancel_halt_clear. > > Reviewed-by: Pierre Morel > Signed-off-by: Dong Jia Shi > Cc: Sebastian Ott > Cc: Peter Oberparleiter [...] > +/** > + * cio_cancel_halt_clear - Cancel running I/O by performing cancel, halt > + * and clear ordinally if subchannel is valid. > + * @sch: subchannel on which to perform the cancel_halt_clear operation > + * @iretry: the number of the times remained to retry the next operation > + * > + * This should be called repeatedly since halt/clear are asynchronous > + * operations. We do one try with cio_cancel, two tries with cio_halt, ^ three Acked-by: Sebastian Ott
Re: [Qemu-devel] [PATCH v4 01/16] s390: cio: introduce cio_cancel_halt_clear
* Sebastian Ott [2017-03-17 10:51:20 +0100]: > On Fri, 17 Mar 2017, Dong Jia Shi wrote: > > * Sebastian Ott [2017-03-17 10:26:51 +0100]: > > > > > On Fri, 17 Mar 2017, Dong Jia Shi wrote: > > > > For future code reuse purpose, this decouples the cio code with > > > > the ccw device specific parts from ccw_device_cancel_halt_clear, > > > > and makes a new common I/O interface named cio_cancel_halt_clear. > > > > > > What would the user of cio_cancel_halt_clear be? > > Hi Sebastian, > > > > We are trying to introduce a new I/O subchannel driver to enable usage > > of I/O subchannels via VFIO-CCW, so we can passthru a subchannel to a > > KVM guest. And that new vfio-ccw subchannel driver is the user. :> > > OK, thanks for the explanation. May I suggest that you put these patches > in the series that actually introduces the new subchannel driver. > Hi Sebastian, For your reference, information of the current patch series could be found by searching/accessing: Subject: [PATCH v4 00/16] basic vfio-ccw infrastructure Message-Id: <20170317031743.40128-1-bjsdj...@linux.vnet.ibm.com> https://www.mail-archive.com/qemu-devel@nongnu.org/msg438029.html I could put you on Cc, if you would like to recieve updates of the whole patch series. > Sebastian -- Dong Jia
Re: [Qemu-devel] [PATCH v4 01/16] s390: cio: introduce cio_cancel_halt_clear
On Fri, 17 Mar 2017, Dong Jia Shi wrote: > * Sebastian Ott [2017-03-17 10:26:51 +0100]: > > > On Fri, 17 Mar 2017, Dong Jia Shi wrote: > > > For future code reuse purpose, this decouples the cio code with > > > the ccw device specific parts from ccw_device_cancel_halt_clear, > > > and makes a new common I/O interface named cio_cancel_halt_clear. > > > > What would the user of cio_cancel_halt_clear be? > Hi Sebastian, > > We are trying to introduce a new I/O subchannel driver to enable usage > of I/O subchannels via VFIO-CCW, so we can passthru a subchannel to a > KVM guest. And that new vfio-ccw subchannel driver is the user. :> OK, thanks for the explanation. May I suggest that you put these patches in the series that actually introduces the new subchannel driver. Sebastian
Re: [Qemu-devel] [PATCH v4 01/16] s390: cio: introduce cio_cancel_halt_clear
* Sebastian Ott [2017-03-17 10:26:51 +0100]: > On Fri, 17 Mar 2017, Dong Jia Shi wrote: > > For future code reuse purpose, this decouples the cio code with > > the ccw device specific parts from ccw_device_cancel_halt_clear, > > and makes a new common I/O interface named cio_cancel_halt_clear. > > What would the user of cio_cancel_halt_clear be? Hi Sebastian, We are trying to introduce a new I/O subchannel driver to enable usage of I/O subchannels via VFIO-CCW, so we can passthru a subchannel to a KVM guest. And that new vfio-ccw subchannel driver is the user. :> > > Sebastian -- Dong Jia
Re: [Qemu-devel] [PATCH v4 01/16] s390: cio: introduce cio_cancel_halt_clear
On Fri, 17 Mar 2017, Dong Jia Shi wrote: > For future code reuse purpose, this decouples the cio code with > the ccw device specific parts from ccw_device_cancel_halt_clear, > and makes a new common I/O interface named cio_cancel_halt_clear. What would the user of cio_cancel_halt_clear be? Sebastian