Re: [PATCH 1/5] reiserfs: use more consistent printk formatting

2005-07-18 Thread Hans Reiser
Jeff Mahoney wrote:

 The output format between a warning/error/panic/info/etc changes with
 which one is used.

 The following patch makes the messages more internally consistent, but also
 more consistent with other Linux filesystems.

Signed-off-by: Jeff Mahoney [EMAIL PROTECTED]
diff -ruNpX dontdiff linux-2.6.13-rc3/fs/reiserfs/prints.c 
linux-2.6.13-rc3.errors/fs/reiserfs/prints.c
--- linux-2.6.13-rc3/fs/reiserfs/prints.c  2005-07-13 13:57:32.0 
-0400
+++ linux-2.6.13-rc3.errors/fs/reiserfs/prints.c   2005-07-14 
16:36:47.0 -0400
@@ -269,10 +269,10 @@ void reiserfs_warning(struct super_block
 {
   do_reiserfs_warning(fmt);
   if (sb)
-  printk(KERN_WARNING ReiserFS: %s: warning: %s\n,
- reiserfs_bdevname(sb), error_buf);
+  printk(KERN_WARNING REISERFS warning (device %s): %s\n,
+ sb-s_id, error_buf);
   else
-  printk(KERN_WARNING ReiserFS: warning: %s\n, error_buf);
+  printk(KERN_WARNING REISERFS warning: %s\n, error_buf);
  

why are you changing it to the harder to read all upper case?  It is
known from various studies that all uppercase is harder for users to read.




[PATCH 1/5] reiserfs: use more consistent printk formatting

2005-07-18 Thread Jeff Mahoney

 The output format between a warning/error/panic/info/etc changes with
 which one is used.

 The following patch makes the messages more internally consistent, but also
 more consistent with other Linux filesystems.

Signed-off-by: Jeff Mahoney [EMAIL PROTECTED]
diff -ruNpX dontdiff linux-2.6.13-rc3/fs/reiserfs/prints.c 
linux-2.6.13-rc3.errors/fs/reiserfs/prints.c
--- linux-2.6.13-rc3/fs/reiserfs/prints.c   2005-07-13 13:57:32.0 
-0400
+++ linux-2.6.13-rc3.errors/fs/reiserfs/prints.c2005-07-14 
16:36:47.0 -0400
@@ -269,10 +269,10 @@ void reiserfs_warning(struct super_block
 {
do_reiserfs_warning(fmt);
if (sb)
-   printk(KERN_WARNING ReiserFS: %s: warning: %s\n,
-  reiserfs_bdevname(sb), error_buf);
+   printk(KERN_WARNING REISERFS warning (device %s): %s\n,
+  sb-s_id, error_buf);
else
-   printk(KERN_WARNING ReiserFS: warning: %s\n, error_buf);
+   printk(KERN_WARNING REISERFS warning: %s\n, error_buf);
 }
 
 /* No newline.. reiserfs_info calls can be followed by printk's */
@@ -280,10 +280,10 @@ void reiserfs_info(struct super_block *s
 {
do_reiserfs_warning(fmt);
if (sb)
-   printk(KERN_NOTICE ReiserFS: %s: %s,
-  reiserfs_bdevname(sb), error_buf);
+   printk(KERN_NOTICE REISERFS (device %s): %s,
+  sb-s_id, error_buf);
else
-   printk(KERN_NOTICE ReiserFS: %s, error_buf);
+   printk(KERN_NOTICE REISERFS %s:, error_buf);
 }
 
 /* No newline.. reiserfs_printk calls can be followed by printk's */
@@ -298,10 +298,10 @@ void reiserfs_debug(struct super_block *
 #ifdef CONFIG_REISERFS_CHECK
do_reiserfs_warning(fmt);
if (s)
-   printk(KERN_DEBUG ReiserFS: %s: %s\n,
-  reiserfs_bdevname(s), error_buf);
+   printk(KERN_DEBUG REISERFS debug (device %s): %s\n,
+  s-s_id, error_buf);
else
-   printk(KERN_DEBUG ReiserFS: %s\n, error_buf);
+   printk(KERN_DEBUG REISERFS debug: %s\n, error_buf);
 #endif
 }
 
@@ -366,17 +366,17 @@ void reiserfs_panic(struct super_block *
 void reiserfs_abort(struct super_block *sb, int errno, const char *fmt, ...)
 {
do_reiserfs_warning(fmt);
 
if (reiserfs_error_panic(sb)) {
-   panic(KERN_CRIT REISERFS: panic (device %s): %s\n,
- reiserfs_bdevname(sb), error_buf);
+   panic(KERN_CRIT REISERFS panic (device %s): %s\n, sb-s_id,
+ error_buf);
}
 
-   if (sb-s_flags  MS_RDONLY)
+   if (reiserfs_is_journal_aborted(SB_JOURNAL(sb))) 
return;
 
-   printk(KERN_CRIT REISERFS: abort (device %s): %s\n,
-  reiserfs_bdevname(sb), error_buf);
+   printk(KERN_CRIT REISERFS abort (device %s): %s\n, sb-s_id,
+  error_buf);
 
sb-s_flags |= MS_RDONLY;
reiserfs_journal_abort(sb, errno);
-- 
Jeff Mahoney
SuSE Labs


Re: [PATCH 1/5] reiserfs: use more consistent printk formatting

2005-07-18 Thread Jeff Mahoney
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

Hans Reiser wrote:
 Jeff Mahoney wrote:
 
The output format between a warning/error/panic/info/etc changes with
which one is used.

The following patch makes the messages more internally consistent, but also
more consistent with other Linux filesystems.

Signed-off-by: Jeff Mahoney [EMAIL PROTECTED]
diff -ruNpX dontdiff linux-2.6.13-rc3/fs/reiserfs/prints.c 
linux-2.6.13-rc3.errors/fs/reiserfs/prints.c
--- linux-2.6.13-rc3/fs/reiserfs/prints.c 2005-07-13 13:57:32.0 
-0400
+++ linux-2.6.13-rc3.errors/fs/reiserfs/prints.c  2005-07-14 
16:36:47.0 -0400
@@ -269,10 +269,10 @@ void reiserfs_warning(struct super_block
{
  do_reiserfs_warning(fmt);
  if (sb)
- printk(KERN_WARNING ReiserFS: %s: warning: %s\n,
-reiserfs_bdevname(sb), error_buf);
+ printk(KERN_WARNING REISERFS warning (device %s): %s\n,
+sb-s_id, error_buf);
  else
- printk(KERN_WARNING ReiserFS: warning: %s\n, error_buf);
+ printk(KERN_WARNING REISERFS warning: %s\n, error_buf);
 

 why are you changing it to the harder to read all upper case?  It is
 known from various studies that all uppercase is harder for users to read.

My argument is that it makes the subsystem more prominent in a quick
visual search, and is easier on the eyes than the mixed case variant.

- -Jeff

- --
Jeff Mahoney
SuSE Labs
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFC3ExoLPWxlyuTD7IRAnYUAKCUN2YK5VSK50jcQgD8y+UfKmvjEQCfYBGE
fk+gGoOC9WlFHJ3+AlDwEdI=
=qYIP
-END PGP SIGNATURE-


Re: [PATCH 1/5] reiserfs: use more consistent printk formatting

2005-07-18 Thread Hans Reiser
Jeff Mahoney wrote:

 Hans Reiser wrote:

 Jeff Mahoney wrote:

 The output format between a warning/error/panic/info/etc changes with
 which one is used.
 
 The following patch makes the messages more internally consistent,
 but also
 more consistent with other Linux filesystems.
 
 Signed-off-by: Jeff Mahoney [EMAIL PROTECTED]
 diff -ruNpX dontdiff linux-2.6.13-rc3/fs/reiserfs/prints.c
 linux-2.6.13-rc3.errors/fs/reiserfs/prints.c
 --- linux-2.6.13-rc3/fs/reiserfs/prints.c2005-07-13
 13:57:32.0 -0400
 +++ linux-2.6.13-rc3.errors/fs/reiserfs/prints.c2005-07-14
 16:36:47.0 -0400
 @@ -269,10 +269,10 @@ void reiserfs_warning(struct super_block
 {
 do_reiserfs_warning(fmt);
 if (sb)
 -printk(KERN_WARNING ReiserFS: %s: warning: %s\n,
 -   reiserfs_bdevname(sb), error_buf);
 +printk(KERN_WARNING REISERFS warning (device %s): %s\n,
 +   sb-s_id, error_buf);
 else
 -printk(KERN_WARNING ReiserFS: warning: %s\n, error_buf);
 +printk(KERN_WARNING REISERFS warning: %s\n, error_buf);
 
 
 why are you changing it to the harder to read all upper case?  It is
 known from various studies that all uppercase is harder for users to
 read.


 My argument is that it makes the subsystem more prominent in a quick
 visual search, and is easier on the eyes than the mixed case variant.

Please used mixed case, see literature on all uppercase for why.


Thanks for your other changes.


 -Jeff

 --
 Jeff Mahoney
 SuSE Labs