[kudu-CR] threadpool: per-token metrics

2017-06-27 Thread Todd Lipcon (Code Review)
Todd Lipcon has submitted this change and it was merged.

Change subject: threadpool: per-token metrics
..


threadpool: per-token metrics

This patch makes thread pool metrics configurable on a token by token basis.
The idea is simple: if a pool is shared by multiple entities in a server
(i.e. one token per tablet), pool operation metrics should reflect those
entities rather than be server-wide.

Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Reviewed-on: http://gerrit.cloudera.org:8080/7149
Tested-by: Adar Dembo 
Reviewed-by: Todd Lipcon 
---
M src/kudu/kserver/kserver.cc
M src/kudu/tablet/tablet_replica.cc
M src/kudu/util/threadpool-test.cc
M src/kudu/util/threadpool.cc
M src/kudu/util/threadpool.h
5 files changed, 119 insertions(+), 75 deletions(-)

Approvals:
  Adar Dembo: Verified
  Todd Lipcon: Looks good to me, approved



-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 8
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] threadpool: per-token metrics

2017-06-27 Thread Todd Lipcon (Code Review)
Todd Lipcon has posted comments on this change.

Change subject: threadpool: per-token metrics
..


Patch Set 7: Code-Review+2

-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 7
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon 
Gerrit-HasComments: No


[kudu-CR] threadpool: per-token metrics

2017-06-26 Thread Adar Dembo (Code Review)
Hello Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

http://gerrit.cloudera.org:8080/7149

to look at the new patch set (#6).

Change subject: threadpool: per-token metrics
..

threadpool: per-token metrics

This patch makes thread pool metrics configurable on a token by token basis.
The idea is simple: if a pool is shared by multiple entities in a server
(i.e. one token per tablet), pool operation metrics should reflect those
entities rather than be server-wide.

Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
---
M src/kudu/kserver/kserver.cc
M src/kudu/tablet/tablet_replica.cc
M src/kudu/util/threadpool-test.cc
M src/kudu/util/threadpool.cc
M src/kudu/util/threadpool.h
5 files changed, 119 insertions(+), 75 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/49/7149/6
-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 6
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] threadpool: per-token metrics

2017-06-20 Thread Adar Dembo (Code Review)
Hello David Ribeiro Alves, Todd Lipcon, Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

http://gerrit.cloudera.org:8080/7149

to look at the new patch set (#5).

Change subject: threadpool: per-token metrics
..

threadpool: per-token metrics

This patch makes thread pool metrics configurable on a token by token basis.
The idea is simple: if a pool is shared by multiple entities in a server
(i.e. one token per tablet), pool operation metrics should reflect those
entities rather than be server-wide.

Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
---
M src/kudu/kserver/kserver.cc
M src/kudu/tablet/tablet_replica.cc
M src/kudu/util/threadpool-test.cc
M src/kudu/util/threadpool.cc
M src/kudu/util/threadpool.h
5 files changed, 121 insertions(+), 75 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/49/7149/5
-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 5
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] threadpool: per-token metrics

2017-06-20 Thread Adar Dembo (Code Review)
Adar Dembo has posted comments on this change.

Change subject: threadpool: per-token metrics
..


Patch Set 4:

(2 comments)

http://gerrit.cloudera.org:8080/#/c/7149/4/src/kudu/util/threadpool.cc
File src/kudu/util/threadpool.cc:

PS4, Line 531: queue_length
> I think keeping the original name to be clear that it's _histogram is impor
Renaming the histogram methods themselves is more yak shaving than I want right 
now. I want to keep metrics_ generic in case we want to add non-histogram 
metrics in the future, so I'll restore the _histogram suffixes instead.


http://gerrit.cloudera.org:8080/#/c/7149/4/src/kudu/util/threadpool.h
File src/kudu/util/threadpool.h:

Line 214:   // Like NewToken(), but lets the caller provide metrics for the 
token.
> worth specifying whether these are incremented in addition to or in prefere
Done


-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon 
Gerrit-HasComments: Yes


[kudu-CR] threadpool: per-token metrics

2017-06-19 Thread Todd Lipcon (Code Review)
Todd Lipcon has posted comments on this change.

Change subject: threadpool: per-token metrics
..


Patch Set 4:

(2 comments)

http://gerrit.cloudera.org:8080/#/c/7149/4/src/kudu/util/threadpool.cc
File src/kudu/util/threadpool.cc:

PS4, Line 531: queue_length
I think keeping the original name to be clear that it's _histogram is important 
here. At first when I read this new code I thought it was a bug in that 
"queue_length" should be a gauge and its value set to (rather than incremented 
by) length_at_submit.

Or perhaps rename 'metrics_' to 'histograms_' since they are all histos?

Perhaps another thing we might consider is renaming Increment() to 
IncrementBin() or RecordValue() something to make it more obviously a histogram 
rather than a gauge/counter?

(same goes for the cases below)


http://gerrit.cloudera.org:8080/#/c/7149/4/src/kudu/util/threadpool.h
File src/kudu/util/threadpool.h:

Line 214:   // Like NewToken(), but lets the caller provide metrics for the 
token.
worth specifying whether these are incremented in addition to or in preference 
to the threadpool-wide ones (if both are configured).


-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon 
Gerrit-HasComments: Yes


[kudu-CR] threadpool: per-token metrics

2017-06-12 Thread Adar Dembo (Code Review)
Hello Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

http://gerrit.cloudera.org:8080/7149

to look at the new patch set (#3).

Change subject: threadpool: per-token metrics
..

threadpool: per-token metrics

This patch makes thread pool metrics configurable on a token by token basis.
The idea is simple: if a pool is shared by multiple entities in a server
(i.e. one token per tablet), pool operation metrics should reflect those
entities rather than be server-wide.

Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
---
M src/kudu/server/server_base.cc
M src/kudu/tablet/tablet_replica.cc
M src/kudu/util/threadpool-test.cc
M src/kudu/util/threadpool.cc
M src/kudu/util/threadpool.h
5 files changed, 119 insertions(+), 75 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/49/7149/3
-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 3
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon 


[kudu-CR] threadpool: per-token metrics

2017-06-12 Thread Adar Dembo (Code Review)
Hello David Ribeiro Alves, Todd Lipcon,

I'd like you to do a code review.  Please visit

http://gerrit.cloudera.org:8080/7149

to review the following change.

Change subject: threadpool: per-token metrics
..

threadpool: per-token metrics

This patch makes thread pool metrics configurable on a token by token basis.
The idea is simple: if a pool is shared by multiple entities in a server
(i.e. one token per tablet), pool operation metrics should reflect those
entities rather than be server-wide.

Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
---
M src/kudu/server/server_base.cc
M src/kudu/tablet/tablet_replica.cc
M src/kudu/util/threadpool-test.cc
M src/kudu/util/threadpool.cc
M src/kudu/util/threadpool.h
5 files changed, 115 insertions(+), 78 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/49/7149/1
-- 
To view, visit http://gerrit.cloudera.org:8080/7149
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I29e3f78d0c033ff24f675cd84e7f7d65bf19954b
Gerrit-PatchSet: 1
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Adar Dembo 
Gerrit-Reviewer: David Ribeiro Alves 
Gerrit-Reviewer: Todd Lipcon