Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Yong Tang

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/
---

Review request for mesos, Anand Mazumdar and Vinod Kone.


Bugs: MESOS-4583
https://issues.apache.org/jira/browse/MESOS-4583


Repository: mesos


Description
---

This change rename event_call_framework to test_http_framework
in order to correctly reflect that it's an example for HTTP based
framework. (MESOS-4583)


Diffs
-

  src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
  src/examples/event_call_framework.cpp  
  src/tests/event_call_framework_test.sh 
cddb5208bce29cf84c40ff76aff0163d110a98d1 
  src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 

Diff: https://reviews.apache.org/r/44266/diff/


Testing
---

make check (Ubuntu 14.04)


Thanks,

Yong Tang



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Mesos ReviewBot

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/#review121670
---



Patch looks great!

Reviews applied: [44266]

Passed command: export OS='ubuntu:14.04' CONFIGURATION='--verbose' 
COMPILER='gcc' ENVIRONMENT='GLOG_v=1 MESOS_VERBOSE=1'; ./support/docker_build.sh

- Mesos ReviewBot


On March 2, 2016, 3:11 p.m., Yong Tang wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44266/
> ---
> 
> (Updated March 2, 2016, 3:11 p.m.)
> 
> 
> Review request for mesos, Anand Mazumdar and Vinod Kone.
> 
> 
> Bugs: MESOS-4583
> https://issues.apache.org/jira/browse/MESOS-4583
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This change rename event_call_framework to test_http_framework
> in order to correctly reflect that it's an example for HTTP based
> framework. (MESOS-4583)
> 
> 
> Diffs
> -
> 
>   src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
>   src/examples/event_call_framework.cpp  
>   src/tests/event_call_framework_test.sh 
> cddb5208bce29cf84c40ff76aff0163d110a98d1 
>   src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 
> 
> Diff: https://reviews.apache.org/r/44266/diff/
> 
> 
> Testing
> ---
> 
> make check (Ubuntu 14.04)
> 
> 
> Thanks,
> 
> Yong Tang
> 
>



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/#review121753
---



Looks great.

Can you also rename the class name in test_http_framework.cpp? 
s/EventCallScheduler/HTTPScheduler/

- Vinod Kone


On March 2, 2016, 3:11 p.m., Yong Tang wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44266/
> ---
> 
> (Updated March 2, 2016, 3:11 p.m.)
> 
> 
> Review request for mesos, Anand Mazumdar and Vinod Kone.
> 
> 
> Bugs: MESOS-4583
> https://issues.apache.org/jira/browse/MESOS-4583
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This change rename event_call_framework to test_http_framework
> in order to correctly reflect that it's an example for HTTP based
> framework. (MESOS-4583)
> 
> 
> Diffs
> -
> 
>   src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
>   src/examples/event_call_framework.cpp  
>   src/tests/event_call_framework_test.sh 
> cddb5208bce29cf84c40ff76aff0163d110a98d1 
>   src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 
> 
> Diff: https://reviews.apache.org/r/44266/diff/
> 
> 
> Testing
> ---
> 
> make check (Ubuntu 14.04)
> 
> 
> Thanks,
> 
> Yong Tang
> 
>



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Yong Tang


> On March 3, 2016, 1 a.m., Vinod Kone wrote:
> > Looks great.
> > 
> > Can you also rename the class name in test_http_framework.cpp? 
> > s/EventCallScheduler/HTTPScheduler/

Thanks Vinod. Will update the review request shortly.


- Yong


---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/#review121753
---


On March 2, 2016, 3:11 p.m., Yong Tang wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44266/
> ---
> 
> (Updated March 2, 2016, 3:11 p.m.)
> 
> 
> Review request for mesos, Anand Mazumdar and Vinod Kone.
> 
> 
> Bugs: MESOS-4583
> https://issues.apache.org/jira/browse/MESOS-4583
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This change rename event_call_framework to test_http_framework
> in order to correctly reflect that it's an example for HTTP based
> framework. (MESOS-4583)
> 
> 
> Diffs
> -
> 
>   src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
>   src/examples/event_call_framework.cpp  
>   src/tests/event_call_framework_test.sh 
> cddb5208bce29cf84c40ff76aff0163d110a98d1 
>   src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 
> 
> Diff: https://reviews.apache.org/r/44266/diff/
> 
> 
> Testing
> ---
> 
> make check (Ubuntu 14.04)
> 
> 
> Thanks,
> 
> Yong Tang
> 
>



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Yong Tang

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/
---

(Updated March 3, 2016, 4:27 a.m.)


Review request for mesos, Anand Mazumdar and Vinod Kone.


Changes
---

Change EventCallScheduler to HTTPScheduler in test_http_framework.cpp


Bugs: MESOS-4583
https://issues.apache.org/jira/browse/MESOS-4583


Repository: mesos


Description
---

This change rename event_call_framework to test_http_framework
in order to correctly reflect that it's an example for HTTP based
framework. (MESOS-4583)


Diffs (updated)
-

  src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
  src/examples/event_call_framework.cpp 
d07d05d4b1eae5d2286d3fc1fdc32247bc19cada 
  src/tests/event_call_framework_test.sh 
cddb5208bce29cf84c40ff76aff0163d110a98d1 
  src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 

Diff: https://reviews.apache.org/r/44266/diff/


Testing
---

make check (Ubuntu 14.04)


Thanks,

Yong Tang



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Yong Tang


> On March 3, 2016, 1 a.m., Vinod Kone wrote:
> > Looks great.
> > 
> > Can you also rename the class name in test_http_framework.cpp? 
> > s/EventCallScheduler/HTTPScheduler/
> 
> Yong Tang wrote:
> Thanks Vinod. Will update the review request shortly.

Just updated the review request. Let me know if there are any other issues.


- Yong


---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/#review121753
---


On March 3, 2016, 4:27 a.m., Yong Tang wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44266/
> ---
> 
> (Updated March 3, 2016, 4:27 a.m.)
> 
> 
> Review request for mesos, Anand Mazumdar and Vinod Kone.
> 
> 
> Bugs: MESOS-4583
> https://issues.apache.org/jira/browse/MESOS-4583
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This change rename event_call_framework to test_http_framework
> in order to correctly reflect that it's an example for HTTP based
> framework. (MESOS-4583)
> 
> 
> Diffs
> -
> 
>   src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
>   src/examples/event_call_framework.cpp 
> d07d05d4b1eae5d2286d3fc1fdc32247bc19cada 
>   src/tests/event_call_framework_test.sh 
> cddb5208bce29cf84c40ff76aff0163d110a98d1 
>   src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 
> 
> Diff: https://reviews.apache.org/r/44266/diff/
> 
> 
> Testing
> ---
> 
> make check (Ubuntu 14.04)
> 
> 
> Thanks,
> 
> Yong Tang
> 
>



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/#review121788
---


Fix it, then Ship it!





src/tests/examples_tests.cpp (line 27)


s/EventCall/TestHTTP/


- Vinod Kone


On March 3, 2016, 4:27 a.m., Yong Tang wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44266/
> ---
> 
> (Updated March 3, 2016, 4:27 a.m.)
> 
> 
> Review request for mesos, Anand Mazumdar and Vinod Kone.
> 
> 
> Bugs: MESOS-4583
> https://issues.apache.org/jira/browse/MESOS-4583
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This change rename event_call_framework to test_http_framework
> in order to correctly reflect that it's an example for HTTP based
> framework. (MESOS-4583)
> 
> 
> Diffs
> -
> 
>   src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
>   src/examples/event_call_framework.cpp 
> d07d05d4b1eae5d2286d3fc1fdc32247bc19cada 
>   src/tests/event_call_framework_test.sh 
> cddb5208bce29cf84c40ff76aff0163d110a98d1 
>   src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 
> 
> Diff: https://reviews.apache.org/r/44266/diff/
> 
> 
> Testing
> ---
> 
> make check (Ubuntu 14.04)
> 
> 
> Thanks,
> 
> Yong Tang
> 
>



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/#review121789
---




src/tests/event_call_framework_test.sh (line 42)


s/C++ low level scheduler/C++ HTTP scheduler/


- Vinod Kone


On March 3, 2016, 4:27 a.m., Yong Tang wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44266/
> ---
> 
> (Updated March 3, 2016, 4:27 a.m.)
> 
> 
> Review request for mesos, Anand Mazumdar and Vinod Kone.
> 
> 
> Bugs: MESOS-4583
> https://issues.apache.org/jira/browse/MESOS-4583
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This change rename event_call_framework to test_http_framework
> in order to correctly reflect that it's an example for HTTP based
> framework. (MESOS-4583)
> 
> 
> Diffs
> -
> 
>   src/Makefile.am fe549a881e778e094d3f957e5119eeb2f55e7915 
>   src/examples/event_call_framework.cpp 
> d07d05d4b1eae5d2286d3fc1fdc32247bc19cada 
>   src/tests/event_call_framework_test.sh 
> cddb5208bce29cf84c40ff76aff0163d110a98d1 
>   src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 
> 
> Diff: https://reviews.apache.org/r/44266/diff/
> 
> 
> Testing
> ---
> 
> make check (Ubuntu 14.04)
> 
> 
> Thanks,
> 
> Yong Tang
> 
>



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-02 Thread Yong Tang

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/
---

(Updated March 3, 2016, 6:49 a.m.)


Review request for mesos, Anand Mazumdar and Vinod Kone.


Changes
---

Change s/EventCall/TestHTTP/ in example_tests.cpp, change s/C++ low level 
scheduler/C++ HTTP scheduler/ in test_http_framework_test.sh.


Bugs: MESOS-4583
https://issues.apache.org/jira/browse/MESOS-4583


Repository: mesos


Description
---

This change rename event_call_framework to test_http_framework
in order to correctly reflect that it's an example for HTTP based
framework. (MESOS-4583)


Diffs (updated)
-

  src/Makefile.am b30cc25f61856d6417437547baaa0bb338a30d63 
  src/examples/event_call_framework.cpp 
9bac8021394675d416967f507fbc2556e08d 
  src/tests/event_call_framework_test.sh 
cddb5208bce29cf84c40ff76aff0163d110a98d1 
  src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 

Diff: https://reviews.apache.org/r/44266/diff/


Testing
---

make check (Ubuntu 14.04)


Thanks,

Yong Tang



Re: Review Request 44266: Rename event_call_framework.cpp to test_http_framework.cpp.

2016-03-03 Thread Vinod Kone

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44266/#review121948
---


Ship it!




The ReviewBot failure is unrelated (see 
https://issues.apache.org/jira/browse/MESOS-4852)

- Vinod Kone


On March 3, 2016, 6:49 a.m., Yong Tang wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44266/
> ---
> 
> (Updated March 3, 2016, 6:49 a.m.)
> 
> 
> Review request for mesos, Anand Mazumdar and Vinod Kone.
> 
> 
> Bugs: MESOS-4583
> https://issues.apache.org/jira/browse/MESOS-4583
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> This change rename event_call_framework to test_http_framework
> in order to correctly reflect that it's an example for HTTP based
> framework. (MESOS-4583)
> 
> 
> Diffs
> -
> 
>   src/Makefile.am b30cc25f61856d6417437547baaa0bb338a30d63 
>   src/examples/event_call_framework.cpp 
> 9bac8021394675d416967f507fbc2556e08d 
>   src/tests/event_call_framework_test.sh 
> cddb5208bce29cf84c40ff76aff0163d110a98d1 
>   src/tests/examples_tests.cpp 9b8b30f3718aa0fa9d02a3aa344634f0c03e61e6 
> 
> Diff: https://reviews.apache.org/r/44266/diff/
> 
> 
> Testing
> ---
> 
> make check (Ubuntu 14.04)
> 
> 
> Thanks,
> 
> Yong Tang
> 
>