svn commit: r314839 - head/sys/dev/iwn

2017-03-06 Thread Andriy Voskoboinyk
Author: avos
Date: Tue Mar  7 07:49:25 2017
New Revision: 314839
URL: https://svnweb.freebsd.org/changeset/base/314839

Log:
  iwn: deduplicate (RXON + txpower + broadcast node) command sequence.
  
  Was previously applied to wpi(4) as a part of r278366.
  
  Tested with Intel 6205, STA / MONITOR modes.

Modified:
  head/sys/dev/iwn/if_iwn.c

Modified: head/sys/dev/iwn/if_iwn.c
==
--- head/sys/dev/iwn/if_iwn.c   Tue Mar  7 06:46:38 2017(r314838)
+++ head/sys/dev/iwn/if_iwn.c   Tue Mar  7 07:49:25 2017(r314839)
@@ -278,6 +278,7 @@ static int  iwn_set_pslevel(struct iwn_so
 static int iwn_send_btcoex(struct iwn_softc *);
 static int iwn_send_advanced_btcoex(struct iwn_softc *);
 static int iwn5000_runtime_calib(struct iwn_softc *);
+static int iwn_send_rxon(struct iwn_softc *, int, int);
 static int iwn_config(struct iwn_softc *);
 static int iwn_scan(struct iwn_softc *, struct ieee80211vap *,
struct ieee80211_scan_state *, struct ieee80211_channel *);
@@ -6534,9 +6535,49 @@ iwn_get_rxon_ht_flags(struct iwn_softc *
 }
 
 static int
-iwn_config(struct iwn_softc *sc)
+iwn_send_rxon(struct iwn_softc *sc, int assoc, int async)
 {
struct iwn_ops *ops = &sc->ops;
+   int error;
+
+   IWN_LOCK_ASSERT(sc);
+
+   if (sc->sc_is_scanning)
+   device_printf(sc->sc_dev,
+   "%s: is_scanning set, before RXON\n",
+   __func__);
+   error = iwn_cmd(sc, IWN_CMD_RXON, sc->rxon, sc->rxonsz, async);
+   if (error != 0) {
+   device_printf(sc->sc_dev, "%s: RXON command failed\n",
+   __func__);
+   return (error);
+   }
+
+   /*
+* Reconfiguring RXON clears the firmware nodes table so we must
+* add the broadcast node again.
+*/
+   if ((sc->rxon->filter & htole32(IWN_FILTER_BSS)) == 0) {
+   if ((error = iwn_add_broadcast_node(sc, async)) != 0) {
+   device_printf(sc->sc_dev,
+   "%s: could not add broadcast node\n", __func__);
+   return (error);
+   }
+   }
+
+   /* Configuration has changed, set TX power accordingly. */
+   if ((error = ops->set_txpower(sc, async)) != 0) {
+   device_printf(sc->sc_dev, "%s: could not set TX power\n",
+   __func__);
+   return (error);
+   }
+
+   return (0);
+}
+
+static int
+iwn_config(struct iwn_softc *sc)
+{
struct ieee80211com *ic = &sc->sc_ic;
struct ieee80211vap *vap = TAILQ_FIRST(&ic->ic_vaps);
const uint8_t *macaddr;
@@ -6671,26 +6712,8 @@ iwn_config(struct iwn_softc *sc)
DPRINTF(sc, IWN_DEBUG_RESET,
"%s: setting configuration; flags=0x%08x\n",
__func__, le32toh(sc->rxon->flags));
-   if (sc->sc_is_scanning)
-   device_printf(sc->sc_dev,
-   "%s: is_scanning set, before RXON\n",
-   __func__);
-   error = iwn_cmd(sc, IWN_CMD_RXON, sc->rxon, sc->rxonsz, 0);
-   if (error != 0) {
-   device_printf(sc->sc_dev, "%s: RXON command failed\n",
-   __func__);
-   return error;
-   }
-
-   if ((error = iwn_add_broadcast_node(sc, 0)) != 0) {
-   device_printf(sc->sc_dev, "%s: could not add broadcast node\n",
-   __func__);
-   return error;
-   }
-
-   /* Configuration has changed, set TX power accordingly. */
-   if ((error = ops->set_txpower(sc, 0)) != 0) {
-   device_printf(sc->sc_dev, "%s: could not set TX power\n",
+   if ((error = iwn_send_rxon(sc, 0, 0)) != 0) {
+   device_printf(sc->sc_dev, "%s: could not send RXON\n",
__func__);
return error;
}
@@ -7044,7 +7067,6 @@ iwn_scan(struct iwn_softc *sc, struct ie
 static int
 iwn_auth(struct iwn_softc *sc, struct ieee80211vap *vap)
 {
-   struct iwn_ops *ops = &sc->ops;
struct ieee80211com *ic = &sc->sc_ic;
struct ieee80211_node *ni = vap->iv_bss;
int error;
@@ -7080,37 +7102,16 @@ iwn_auth(struct iwn_softc *sc, struct ie
DPRINTF(sc, IWN_DEBUG_STATE, "rxon chan %d flags %x cck %x ofdm %x\n",
sc->rxon->chan, sc->rxon->flags, sc->rxon->cck_mask,
sc->rxon->ofdm_mask);
-   if (sc->sc_is_scanning)
-   device_printf(sc->sc_dev,
-   "%s: is_scanning set, before RXON\n",
-   __func__);
-   error = iwn_cmd(sc, IWN_CMD_RXON, sc->rxon, sc->rxonsz, 1);
-   if (error != 0) {
-   device_printf(sc->sc_dev, "%s: RXON command failed, error %d\n",
-   __func__, error);
-   return error;
-   }
 
-   /* Configuration has changed, set TX power accordingly. */
-   if ((error = ops->set_txpower(sc

Re: svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Warner Losh
On Tue, Mar 7, 2017 at 12:44 AM, Ngie Cooper (yaneurabeya)
 wrote:
>
>> On Mar 6, 2017, at 21:56, Rodney W. Grimes  
>> wrote:
>>
>>> On Mon, Mar 6, 2017 at 9:10 PM, Rodney W. Grimes  
>>> wrote:
 Author: rgrimes
 Date: Tue Mar  7 05:10:38 2017
 New Revision: 314833
 URL: https://svnweb.freebsd.org/changeset/base/314833

 Log:
  Convert absolute links to relative links.
  Style.Makefile(9) has been ignored to produce minimal diffs.
>>>
>>> Hey Rod,
>>>
>>> Not to pick nits excessively, but the style.Makefile manual page
>>> (which I'd never heard of before today) appears to be in section 5,
>>> not 9.  That may be wrong ? I thought 5 was for configuration files.
>>
>> *sigh*   Yet more messes to sweep up.  It defanitly does not belong
>> in 5, I had just assumed it was in 9 as that is where style(9) is.
>>
>> I am in no hurry to fix this, but glad you get to read some new
>> info.
>
> Why does it belong in 9 (also, thanks Conrad for noting my faux pas too)?
>
>5.   FreeBSD File Formats Manual
> ...
>9.   FreeBSD Kernel Developer's Manual
>
> 9 looks inappropriate in this case according to `man man` :).

style(9) is there because it started out life for the kernel.

It belongs in section 5. This was extensively debated when it went
into the tree.

Please do not move it.

Warner
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 21:56, Rodney W. Grimes  
> wrote:
> 
>> On Mon, Mar 6, 2017 at 9:10 PM, Rodney W. Grimes  wrote:
>>> Author: rgrimes
>>> Date: Tue Mar  7 05:10:38 2017
>>> New Revision: 314833
>>> URL: https://svnweb.freebsd.org/changeset/base/314833
>>> 
>>> Log:
>>>  Convert absolute links to relative links.
>>>  Style.Makefile(9) has been ignored to produce minimal diffs.
>> 
>> Hey Rod,
>> 
>> Not to pick nits excessively, but the style.Makefile manual page
>> (which I'd never heard of before today) appears to be in section 5,
>> not 9.  That may be wrong ? I thought 5 was for configuration files.
> 
> *sigh*   Yet more messes to sweep up.  It defanitly does not belong
> in 5, I had just assumed it was in 9 as that is where style(9) is.
> 
> I am in no hurry to fix this, but glad you get to read some new
> info.

Why does it belong in 9 (also, thanks Conrad for noting my faux pas too)?

   5.   FreeBSD File Formats Manual
...
   9.   FreeBSD Kernel Developer's Manual

9 looks inappropriate in this case according to `man man` :).
Thanks,
-Ngie


signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314813 - head/sys/kern

2017-03-06 Thread Hiren Panchasara
On 03/06/17 at 07:08P, Ngie Cooper (yaneurabeya) wrote:
> 
> > On Mar 6, 2017, at 16:20, Hiren Panchasara  wrote:
> > 
> > Author: hiren
> > Date: Tue Mar  7 00:20:01 2017
> > New Revision: 314813
> > URL: https://svnweb.freebsd.org/changeset/base/314813
> > 
> > Log:
> >  We've found a recurring problem where some userland process would be
> >  stuck spinning at 100% cpu around sbcut_internal(). Inside
> >  sbflush_internal(), sb_ccc reached to about 4GB and before passing it
> >  to sbcut_internal(), we type-cast it from uint to int making it -ve.
> > 
> >  The root cause of sockbuf growing this large is unknown. Correct fix
> >  is also not clear but based on mailing list discussions, adding
> >  KASSERTs to panic instead of looping endlessly.
> > 
> >  Reviewed by:   glebius
> >  Sponsored by:  Limelight Networks
> > 
> > Modified:
> >  head/sys/kern/uipc_sockbuf.c
> > 
> > Modified: head/sys/kern/uipc_sockbuf.c
> > ==
> > --- head/sys/kern/uipc_sockbuf.cTue Mar  7 00:13:53 2017
> > (r314812)
> > +++ head/sys/kern/uipc_sockbuf.cTue Mar  7 00:20:01 2017
> > (r314813)
> > @@ -1043,6 +1043,11 @@ sbcut_internal(struct sockbuf *sb, int l
> > {
> > struct mbuf *m, *next, *mfree;
> > 
> > +   KASSERT(len > 0, ("%s: len is %d but it is supposed to be +ve",
> > +   __func__, len));
> > +   KASSERT(len <= sb->sb_ccc, ("%s: len: %d is > ccc: %u",
> > +   __func__, len, sb->sb_ccc));
> > +
> > next = (m = sb->sb_mb) ? m->m_nextpkt : 0;
> > mfree = NULL;
> 
> The KASSERT is bad ? please fix it. From 
> https://ci.freebsd.org/job/FreeBSD-head-amd64-test/1994/console :
> 
> add host 127.0.0.1panic: sbcut_internal: len is 0 but it is supposed to be +ve

Thanks, fixed in r314838.

Cheers,
Hiren


pgpSjs8GsOtO4.pgp
Description: PGP signature


svn commit: r314838 - head/sys/kern

2017-03-06 Thread Hiren Panchasara
Author: hiren
Date: Tue Mar  7 06:46:38 2017
New Revision: 314838
URL: https://svnweb.freebsd.org/changeset/base/314838

Log:
  Fix the KASSERT check from r314813.
  len being 0 is valid.
  
  Submitted by: ngie
  Reported by:  ngie (via jenkins test run)
  Sponsored by: Limelight Networks

Modified:
  head/sys/kern/uipc_sockbuf.c

Modified: head/sys/kern/uipc_sockbuf.c
==
--- head/sys/kern/uipc_sockbuf.cTue Mar  7 06:11:36 2017
(r314837)
+++ head/sys/kern/uipc_sockbuf.cTue Mar  7 06:46:38 2017
(r314838)
@@ -1043,7 +1043,7 @@ sbcut_internal(struct sockbuf *sb, int l
 {
struct mbuf *m, *next, *mfree;
 
-   KASSERT(len > 0, ("%s: len is %d but it is supposed to be +ve",
+   KASSERT(len >= 0, ("%s: len is %d but it is supposed to be >= 0",
__func__, len));
KASSERT(len <= sb->sb_ccc, ("%s: len: %d is > ccc: %u",
__func__, len, sb->sb_ccc));
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314831 - head/usr.bin/fortune

2017-03-06 Thread Rodney W. Grimes
> 
> Is it true you still use mutt to read your e-mail? :-)

Oh, its far older than Mutt... elm2.4me  and I have
a port of gated that runs on 12-current.

I am considering an upgrade to mutt :-)

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314831 - head/usr.bin/fortune

2017-03-06 Thread Alfred Perlstein



On 3/6/17 10:07 PM, Jordan Hubbard wrote:

[ Charset ISO-Latin1 unsupported, converting… ]

Is it true you still use mutt to read your e-mail? :-)

- Jordan


I had to use mutt(1) to send a patch to the git project to support 
FreeBSD's propset commands a couple years back.


was... fun?  I sorta miss it!

-Alfred
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"

svn commit: r314837 - head/lib/libxo/tests/encoder

2017-03-06 Thread Rodney W. Grimes
Author: rgrimes
Date: Tue Mar  7 06:11:36 2017
New Revision: 314837
URL: https://svnweb.freebsd.org/changeset/base/314837

Log:
  The relative symlink fix causes downstream issues for
  EMC DELL Isilon so revert the relative symlink fix
  pending a better solution.
  
  Reported by:  ngie
  Approved by:  greham (mentor) Implicit as reverting
  MFC after:1 week

Modified:
  head/lib/libxo/tests/encoder/Makefile

Modified: head/lib/libxo/tests/encoder/Makefile
==
--- head/lib/libxo/tests/encoder/Makefile   Tue Mar  7 05:57:18 2017
(r314836)
+++ head/lib/libxo/tests/encoder/Makefile   Tue Mar  7 06:11:36 2017
(r314837)
@@ -8,7 +8,7 @@ SHLIB_NAME= libenc_test.so
 
 LIBDIR=${TESTSBASE}/lib/libxo
 
-SYMLINKS+= ../../../tests/lib/libxo/${SHLIB_NAME} 
/usr/lib/libxo/encoder/test.enc
+SYMLINKS+= ${LIBDIR}/${SHLIB_NAME} /usr/lib/libxo/encoder/test.enc
 
 SRCS=  enc_test.c
 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314831 - head/usr.bin/fortune

2017-03-06 Thread Jordan Hubbard

[ Charset ISO-Latin1 unsupported, converting… ]

Is it true you still use mutt to read your e-mail? :-)

- Jordan

___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"

svn commit: r314836 - stable/10/sys/dev/firewire

2017-03-06 Thread Alexander Motin
Author: mav
Date: Tue Mar  7 05:57:18 2017
New Revision: 314836
URL: https://svnweb.freebsd.org/changeset/base/314836

Log:
  MFC r314374: Add safety check against too long CDB.
  
  SBP-2 specification defined maximum CDB length as 12 bytes.  Newer SBP-3
  specification allows CDB of any size, but this driver is too old.  Proper
  solution would be to look on maximal ORB size supported by the target.

Modified:
  stable/10/sys/dev/firewire/sbp.c
Directory Properties:
  stable/10/   (props changed)

Modified: stable/10/sys/dev/firewire/sbp.c
==
--- stable/10/sys/dev/firewire/sbp.cTue Mar  7 05:56:48 2017
(r314835)
+++ stable/10/sys/dev/firewire/sbp.cTue Mar  7 05:57:18 2017
(r314836)
@@ -2403,6 +2403,11 @@ END_DEBUG
xpt_done(ccb);
return;
}
+   if (csio->cdb_len > sizeof(ocb->orb) - 5 * sizeof(uint32_t)) {
+   ccb->ccb_h.status = CAM_REQ_INVALID;
+   xpt_done(ccb);
+   return;
+   }
 #if 0
/* if we are in probe stage, pass only probe commands */
if (sdev->status == SBP_DEV_PROBE) {
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314835 - stable/11/sys/dev/firewire

2017-03-06 Thread Alexander Motin
Author: mav
Date: Tue Mar  7 05:56:48 2017
New Revision: 314835
URL: https://svnweb.freebsd.org/changeset/base/314835

Log:
  MFC r314374: Add safety check against too long CDB.
  
  SBP-2 specification defined maximum CDB length as 12 bytes.  Newer SBP-3
  specification allows CDB of any size, but this driver is too old.  Proper
  solution would be to look on maximal ORB size supported by the target.

Modified:
  stable/11/sys/dev/firewire/sbp.c
Directory Properties:
  stable/11/   (props changed)

Modified: stable/11/sys/dev/firewire/sbp.c
==
--- stable/11/sys/dev/firewire/sbp.cTue Mar  7 05:35:14 2017
(r314834)
+++ stable/11/sys/dev/firewire/sbp.cTue Mar  7 05:56:48 2017
(r314835)
@@ -2367,6 +2367,11 @@ END_DEBUG
xpt_done(ccb);
return;
}
+   if (csio->cdb_len > sizeof(ocb->orb) - 5 * sizeof(uint32_t)) {
+   ccb->ccb_h.status = CAM_REQ_INVALID;
+   xpt_done(ccb);
+   return;
+   }
 #if 0
/* if we are in probe stage, pass only probe commands */
if (sdev->status == SBP_DEV_PROBE) {
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Rodney W. Grimes
> On Mon, Mar 6, 2017 at 9:10 PM, Rodney W. Grimes  wrote:
> > Author: rgrimes
> > Date: Tue Mar  7 05:10:38 2017
> > New Revision: 314833
> > URL: https://svnweb.freebsd.org/changeset/base/314833
> >
> > Log:
> >   Convert absolute links to relative links.
> >   Style.Makefile(9) has been ignored to produce minimal diffs.
> 
> Hey Rod,
> 
> Not to pick nits excessively, but the style.Makefile manual page
> (which I'd never heard of before today) appears to be in section 5,
> not 9.  That may be wrong ? I thought 5 was for configuration files.

*sigh*   Yet more messes to sweep up.  It defanitly does not belong
in 5, I had just assumed it was in 9 as that is where style(9) is.

I am in no hurry to fix this, but glad you get to read some new
info.

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314685 - head/bin/ps

2017-03-06 Thread Bruce Evans

On Mon, 6 Mar 2017, Bryan Drewery wrote:


On 3/6/17 8:11 PM, Bryan Drewery wrote:

On 3/4/17 2:38 PM, Conrad Meyer wrote:

Author: cem
Date: Sat Mar  4 22:38:10 2017
New Revision: 314685
URL: https://svnweb.freebsd.org/changeset/base/314685

Log:
  ps(1): Only detect terminal width if stdout is a tty

  If stdout isn't a tty, use unlimited width output rather than truncating to
  79 characters.  This is helpful for shell scripts or e.g., 'ps | grep foo'.


This change actually makes things worse for me for 'ps uaxwd|less'


No surprise.


Before:

nobody  839790.0  0.09016   1364  3  I+J  20:03   0:00.06 | |   
  `-- /usr/bin/make -C /usr/ports/lang/perl5.24 build


After:

nobody  897430.0  0.09016   1368  3  S+J  20:07   0:00.05 | |   
  `-- /usr/bin/make -C /usr/ports/lang/perl5.24


I now have to specify -ww to not cut things off, but that's far more
than I want to see.


The problem is that -w is parsed *after* termwidth = UNLIMITED is set
(which is 0).  This patch fixes it, but I haven't tested it extensively:


Index: ps.c
===
--- ps.c(revision 314708)
+++ ps.c(working copy)
@@ -401,7 +401,7 @@ main(int argc, char *argv[])
case 'w':
if (wflag)
termwidth = UNLIMITED;
-   else if (termwidth < 131)
+   else if (termwidth < 131 && termwidth != UNLIMITED)
termwidth = 131;


I pointed out many nearby bugs, but missed this one.  0 is a fail-unsafe
value for UNLIMITED.  0 for the default width of 79 unless modified by
-w and INT_MAX for UNLIMITED would be less magic.

ps now has complications using xo.  It now uses the POSIX mistake
_POSIX2_LINE_MAX for at least xo output, so UNLIMITED no longer means
unlimited.  _POSIX2_LINE_MAX is only 2048.  Probably good enough for
ps.  So UNLIMITED should be unobfuscated by spelling it
(_POSIX2_LINE_MAX - 1).  The user's COLUMNS is not honored when it is
larger than this, and the user can do foot shooting by setting COLUMNS
to the current internal magic value for UNLIMIT or exercise sign extension
and overflow bugs by setting it to negative.  'COLUMNS=-1 ps' actually
gives normal output except for messing up the COMAMND column (e.g.,
"-bash (bash)" becomes "[bash]".  I forget what the brackets mean, and
this is not documented in ps.1.


wflag++;
break;


-1 for the original commit. If I wanted -ww I would specify it.  The
original commit causes some text to wrap on my terminal even with some
extending right.


Bruce
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Rodney W. Grimes
> > On Mar 6, 2017, at 21:10, Rodney W. Grimes  wrote:
> > 
> > Author: rgrimes
> > Date: Tue Mar  7 05:10:38 2017
> > New Revision: 314833
> > URL: https://svnweb.freebsd.org/changeset/base/314833
...

> > 
> > -SYMLINKS+= ${LIBDIR}/${SHLIB_NAME} /usr/lib/libxo/encoder/test.enc
> > +SYMLINKS+= ../../../tests/lib/libxo/${SHLIB_NAME} 
> > /usr/lib/libxo/encoder/test.enc
> 
>   This change breaks setting TESTSBASE != /usr/tests . Please fix (my 
> employer depends on this being functional).
> Thanks,

I am just going to revert this until the issue with SYMLINKS vs RSYMLINKS and
probably a much better fix in bsd.*.mk can be implemented.  I can live with
one last nasty wart of an absolute link in DESTDIR until then.  The important
functional ones are gone now.

To fix this without changing SYMLINKS would involve adding a local install:
target which would be more mess than having the one absolute link.

> -Ngie

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Conrad Meyer
On Mon, Mar 6, 2017 at 9:10 PM, Rodney W. Grimes  wrote:
> Author: rgrimes
> Date: Tue Mar  7 05:10:38 2017
> New Revision: 314833
> URL: https://svnweb.freebsd.org/changeset/base/314833
>
> Log:
>   Convert absolute links to relative links.
>   Style.Makefile(9) has been ignored to produce minimal diffs.

Hey Rod,

Not to pick nits excessively, but the style.Makefile manual page
(which I'd never heard of before today) appears to be in section 5,
not 9.  That may be wrong — I thought 5 was for configuration files.

Best,
Conrad
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"

svn commit: r314834 - in stable: 10/contrib/ipfilter/lib 11/contrib/ipfilter/lib

2017-03-06 Thread Cy Schubert
Author: cy
Date: Tue Mar  7 05:35:14 2017
New Revision: 314834
URL: https://svnweb.freebsd.org/changeset/base/314834

Log:
  MFC r314627:
  
  Fix leak (free str before returning when ctx's calloc fails).
  
  Submitted by: trix_juniper.net (Tom Rix)
  Reviewed by:  cy, ngie
  Discovered by:clang's static analyzer
  Differential Revision:D9877

Modified:
  stable/10/contrib/ipfilter/lib/save_v2trap.c
Directory Properties:
  stable/10/   (props changed)

Changes in other areas also in this revision:
Modified:
  stable/11/contrib/ipfilter/lib/save_v2trap.c
Directory Properties:
  stable/11/   (props changed)

Modified: stable/10/contrib/ipfilter/lib/save_v2trap.c
==
--- stable/10/contrib/ipfilter/lib/save_v2trap.cTue Mar  7 05:10:38 
2017(r314833)
+++ stable/10/contrib/ipfilter/lib/save_v2trap.cTue Mar  7 05:35:14 
2017(r314834)
@@ -124,8 +124,10 @@ snmpv2_parse(char **strings)
str = strdup(*strings);
 
ctx = calloc(1, sizeof(*ctx));
-   if (ctx == NULL)
+   if (ctx == NULL) {
+   free(str);
return NULL;
+   }
 
ctx->fd = -1;
 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314834 - in stable: 10/contrib/ipfilter/lib 11/contrib/ipfilter/lib

2017-03-06 Thread Cy Schubert
Author: cy
Date: Tue Mar  7 05:35:14 2017
New Revision: 314834
URL: https://svnweb.freebsd.org/changeset/base/314834

Log:
  MFC r314627:
  
  Fix leak (free str before returning when ctx's calloc fails).
  
  Submitted by: trix_juniper.net (Tom Rix)
  Reviewed by:  cy, ngie
  Discovered by:clang's static analyzer
  Differential Revision:D9877

Modified:
  stable/11/contrib/ipfilter/lib/save_v2trap.c
Directory Properties:
  stable/11/   (props changed)

Changes in other areas also in this revision:
Modified:
  stable/10/contrib/ipfilter/lib/save_v2trap.c
Directory Properties:
  stable/10/   (props changed)

Modified: stable/11/contrib/ipfilter/lib/save_v2trap.c
==
--- stable/11/contrib/ipfilter/lib/save_v2trap.cTue Mar  7 05:10:38 
2017(r314833)
+++ stable/11/contrib/ipfilter/lib/save_v2trap.cTue Mar  7 05:35:14 
2017(r314834)
@@ -124,8 +124,10 @@ snmpv2_parse(char **strings)
str = strdup(*strings);
 
ctx = calloc(1, sizeof(*ctx));
-   if (ctx == NULL)
+   if (ctx == NULL) {
+   free(str);
return NULL;
+   }
 
ctx->fd = -1;
 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Rodney W. Grimes
-- Start of PGP signed section.
> 
> > On Mar 6, 2017, at 21:10, Rodney W. Grimes  wrote:
> > 
> > Author: rgrimes
> > Date: Tue Mar  7 05:10:38 2017
> > New Revision: 314833
> > URL: https://svnweb.freebsd.org/changeset/base/314833
> > 
> > Log:
> >  Convert absolute links to relative links.
> >  Style.Makefile(9) has been ignored to produce minimal diffs.
> > 
> >  Approved by:   grehan (mentor)
> >  MFC after: 1 week
> > 
> > Modified:
> >  head/bin/pkill/Makefile
> >  head/lib/libxo/tests/encoder/Makefile
> >  head/libexec/rtld-elf/Makefile
> >  head/share/termcap/Makefile
> >  head/usr.bin/chpass/Makefile
> >  head/usr.bin/passwd/Makefile
> >  head/usr.sbin/bsdinstall/partedit/Makefile
> >  head/usr.sbin/mailwrapper/Makefile
> >  head/usr.sbin/nologin/Makefile
> > 
> > Modified: head/bin/pkill/Makefile
> > ==
> > --- head/bin/pkill/Makefile Tue Mar  7 04:51:35 2017(r314832)
> > +++ head/bin/pkill/Makefile Tue Mar  7 05:10:38 2017(r314833)
> > @@ -16,8 +16,8 @@ MLINKS=   pkill.1 pgrep.1
> > # keep in mind that pkill is installed to /usr/bin in other
> > # OS types, e.g., NetBSD, OpenBSD, Solaris, and Linux.
> > #
> > -SYMLINKS=  ${BINDIR}/pkill /usr/bin/pkill
> > -SYMLINKS+= ${BINDIR}/pgrep /usr/bin/pgrep
> > +SYMLINKS=  ../..${BINDIR}/pkill /usr/bin/pkill
> > +SYMLINKS+= ../..${BINDIR}/pgrep /usr/bin/pgrep
> > 
> > .if ${MK_TESTS} != "no"
> > SUBDIR+= tests
> > 
> > Modified: head/lib/libxo/tests/encoder/Makefile
> > ==
> > --- head/lib/libxo/tests/encoder/Makefile   Tue Mar  7 04:51:35 2017
> > (r314832)
> > +++ head/lib/libxo/tests/encoder/Makefile   Tue Mar  7 05:10:38 2017
> > (r314833)
> > @@ -8,7 +8,7 @@ SHLIB_NAME= libenc_test.so
> > 
> > LIBDIR= ${TESTSBASE}/lib/libxo
> > 
> > -SYMLINKS+= ${LIBDIR}/${SHLIB_NAME} /usr/lib/libxo/encoder/test.enc
> > +SYMLINKS+= ../../../tests/lib/libxo/${SHLIB_NAME} 
> > /usr/lib/libxo/encoder/test.enc
> 
>   This change breaks setting TESTSBASE != /usr/tests . Please fix (my 
> employer depends on this being functional).

That well happen when I resolve the SYMLINKS .mk glue that should probalby be 
calling
INSTALL_RSYMLINKS and not INSTALL_SYMLINKS.  For now this was the minimal diff 
that
corrected the contents of DESTDIR.

I did not get a response from either Bdrewery or Bapt on my direct question
about the issue that SYMLINKS has no relative mechansim, other than we
could add a RSYMLINKS possibly. 

> Thanks,
> -Ngie
-- End of PGP section, PGP failed!

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 21:10, Rodney W. Grimes  wrote:
> 
> Author: rgrimes
> Date: Tue Mar  7 05:10:38 2017
> New Revision: 314833
> URL: https://svnweb.freebsd.org/changeset/base/314833
> 
> Log:
>  Convert absolute links to relative links.
>  Style.Makefile(9) has been ignored to produce minimal diffs.
> 
>  Approved by: grehan (mentor)
>  MFC after:   1 week
> 
> Modified:
>  head/bin/pkill/Makefile
>  head/lib/libxo/tests/encoder/Makefile
>  head/libexec/rtld-elf/Makefile
>  head/share/termcap/Makefile
>  head/usr.bin/chpass/Makefile
>  head/usr.bin/passwd/Makefile
>  head/usr.sbin/bsdinstall/partedit/Makefile
>  head/usr.sbin/mailwrapper/Makefile
>  head/usr.sbin/nologin/Makefile
> 
> Modified: head/bin/pkill/Makefile
> ==
> --- head/bin/pkill/Makefile   Tue Mar  7 04:51:35 2017(r314832)
> +++ head/bin/pkill/Makefile   Tue Mar  7 05:10:38 2017(r314833)
> @@ -16,8 +16,8 @@ MLINKS= pkill.1 pgrep.1
> # keep in mind that pkill is installed to /usr/bin in other
> # OS types, e.g., NetBSD, OpenBSD, Solaris, and Linux.
> #
> -SYMLINKS=${BINDIR}/pkill /usr/bin/pkill
> -SYMLINKS+=   ${BINDIR}/pgrep /usr/bin/pgrep
> +SYMLINKS=../..${BINDIR}/pkill /usr/bin/pkill
> +SYMLINKS+=   ../..${BINDIR}/pgrep /usr/bin/pgrep
> 
> .if ${MK_TESTS} != "no"
> SUBDIR+= tests
> 
> Modified: head/lib/libxo/tests/encoder/Makefile
> ==
> --- head/lib/libxo/tests/encoder/Makefile Tue Mar  7 04:51:35 2017
> (r314832)
> +++ head/lib/libxo/tests/encoder/Makefile Tue Mar  7 05:10:38 2017
> (r314833)
> @@ -8,7 +8,7 @@ SHLIB_NAME=   libenc_test.so
> 
> LIBDIR=   ${TESTSBASE}/lib/libxo
> 
> -SYMLINKS+=   ${LIBDIR}/${SHLIB_NAME} /usr/lib/libxo/encoder/test.enc
> +SYMLINKS+=   ../../../tests/lib/libxo/${SHLIB_NAME} 
> /usr/lib/libxo/encoder/test.enc

This change breaks setting TESTSBASE != /usr/tests . Please fix (my 
employer depends on this being functional).
Thanks,
-Ngie


signature.asc
Description: Message signed with OpenPGP using GPGMail


svn commit: r314833 - in head: bin/pkill lib/libxo/tests/encoder libexec/rtld-elf share/termcap usr.bin/chpass usr.bin/passwd usr.sbin/bsdinstall/partedit usr.sbin/mailwrapper usr.sbin/nologin

2017-03-06 Thread Rodney W. Grimes
Author: rgrimes
Date: Tue Mar  7 05:10:38 2017
New Revision: 314833
URL: https://svnweb.freebsd.org/changeset/base/314833

Log:
  Convert absolute links to relative links.
  Style.Makefile(9) has been ignored to produce minimal diffs.
  
  Approved by:  grehan (mentor)
  MFC after:1 week

Modified:
  head/bin/pkill/Makefile
  head/lib/libxo/tests/encoder/Makefile
  head/libexec/rtld-elf/Makefile
  head/share/termcap/Makefile
  head/usr.bin/chpass/Makefile
  head/usr.bin/passwd/Makefile
  head/usr.sbin/bsdinstall/partedit/Makefile
  head/usr.sbin/mailwrapper/Makefile
  head/usr.sbin/nologin/Makefile

Modified: head/bin/pkill/Makefile
==
--- head/bin/pkill/Makefile Tue Mar  7 04:51:35 2017(r314832)
+++ head/bin/pkill/Makefile Tue Mar  7 05:10:38 2017(r314833)
@@ -16,8 +16,8 @@ MLINKS=   pkill.1 pgrep.1
 # keep in mind that pkill is installed to /usr/bin in other
 # OS types, e.g., NetBSD, OpenBSD, Solaris, and Linux.
 #
-SYMLINKS=  ${BINDIR}/pkill /usr/bin/pkill
-SYMLINKS+= ${BINDIR}/pgrep /usr/bin/pgrep
+SYMLINKS=  ../..${BINDIR}/pkill /usr/bin/pkill
+SYMLINKS+= ../..${BINDIR}/pgrep /usr/bin/pgrep
 
 .if ${MK_TESTS} != "no"
 SUBDIR+= tests

Modified: head/lib/libxo/tests/encoder/Makefile
==
--- head/lib/libxo/tests/encoder/Makefile   Tue Mar  7 04:51:35 2017
(r314832)
+++ head/lib/libxo/tests/encoder/Makefile   Tue Mar  7 05:10:38 2017
(r314833)
@@ -8,7 +8,7 @@ SHLIB_NAME= libenc_test.so
 
 LIBDIR=${TESTSBASE}/lib/libxo
 
-SYMLINKS+= ${LIBDIR}/${SHLIB_NAME} /usr/lib/libxo/encoder/test.enc
+SYMLINKS+= ../../../tests/lib/libxo/${SHLIB_NAME} 
/usr/lib/libxo/encoder/test.enc
 
 SRCS=  enc_test.c
 

Modified: head/libexec/rtld-elf/Makefile
==
--- head/libexec/rtld-elf/Makefile  Tue Mar  7 04:51:35 2017
(r314832)
+++ head/libexec/rtld-elf/Makefile  Tue Mar  7 05:10:38 2017
(r314833)
@@ -34,7 +34,7 @@ WARNS?=   2
 INSTALLFLAGS=  -C -b
 PRECIOUSPROG=
 BINDIR=/libexec
-SYMLINKS=  ${BINDIR}/${PROG} ${LIBEXECDIR}/${PROG}
+SYMLINKS=  ../..${BINDIR}/${PROG} ${LIBEXECDIR}/${PROG}
 MLINKS=rtld.1 ld-elf.so.1.1 \
rtld.1 ld.so.1
 

Modified: head/share/termcap/Makefile
==
--- head/share/termcap/Makefile Tue Mar  7 04:51:35 2017(r314832)
+++ head/share/termcap/Makefile Tue Mar  7 05:10:38 2017(r314833)
@@ -24,6 +24,6 @@ termcap.db: termcap
cap_mkdb ${CAP_MKDB_ENDIAN} -f ${.TARGET:R} ${.ALLSRC}
 
 etc-termcap:
-   ${INSTALL_SYMLINK} ${BINDIR}/misc/termcap ${DESTDIR}/etc/termcap
+   ${INSTALL_RSYMLINK} ${BINDIR}/misc/termcap ${DESTDIR}/etc/termcap
 
 .include 

Modified: head/usr.bin/chpass/Makefile
==
--- head/usr.bin/chpass/MakefileTue Mar  7 04:51:35 2017
(r314832)
+++ head/usr.bin/chpass/MakefileTue Mar  7 05:10:38 2017
(r314833)
@@ -22,12 +22,12 @@ LIBADD= crypt util
 LIBADD+=   ypclnt
 .endif 
 
-SYMLINKS=  ${BINDIR}/chpass ${BINDIR}/chfn
-SYMLINKS+= ${BINDIR}/chpass ${BINDIR}/chsh
+SYMLINKS=  chpass ${BINDIR}/chfn
+SYMLINKS+= chpass ${BINDIR}/chsh
 .if ${MK_NIS} != "no"
-SYMLINKS+= ${BINDIR}/chpass ${BINDIR}/ypchpass
-SYMLINKS+= ${BINDIR}/chpass ${BINDIR}/ypchfn
-SYMLINKS+= ${BINDIR}/chpass ${BINDIR}/ypchsh
+SYMLINKS+= chpass ${BINDIR}/ypchfn
+SYMLINKS+= chpass ${BINDIR}/ypchpass
+SYMLINKS+= chpass ${BINDIR}/ypchsh
 .endif
 
 MLINKS=chpass.1 chfn.1 chpass.1 chsh.1

Modified: head/usr.bin/passwd/Makefile
==
--- head/usr.bin/passwd/MakefileTue Mar  7 04:51:35 2017
(r314832)
+++ head/usr.bin/passwd/MakefileTue Mar  7 05:10:38 2017
(r314833)
@@ -9,7 +9,7 @@ BINMODE  = 4555
 PRECIOUSPROG=
 LIBADD   = pam
 .if ${MK_NIS} != "no"
-SYMLINKS = ${BINDIR}/passwd ${BINDIR}/yppasswd
+SYMLINKS = passwd ${BINDIR}/yppasswd
 MLINKS  = passwd.1 yppasswd.1
 .endif
 

Modified: head/usr.sbin/bsdinstall/partedit/Makefile
==
--- head/usr.sbin/bsdinstall/partedit/Makefile  Tue Mar  7 04:51:35 2017
(r314832)
+++ head/usr.sbin/bsdinstall/partedit/Makefile  Tue Mar  7 05:10:38 2017
(r314833)
@@ -4,7 +4,7 @@ BINDIR= ${LIBEXECDIR}/bsdinstall
 PROG=  partedit
 LINKS= ${BINDIR}/partedit ${BINDIR}/autopart \
${BINDIR}/partedit ${BINDIR}/scriptedpart
-SYMLINKS= ${BINDIR}/partedit /usr/sbin/sade
+SYMLINKS= ../libexec/bsdinstall/partedit /usr/sbin/sade
 LIBADD+=   

Re: svn commit: r314831 - head/usr.bin/fortune

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 21:01, Ngie Cooper (yaneurabeya)  
> wrote:
> 
> 
>> On Mar 6, 2017, at 21:00, Rodney W. Grimes  
>> wrote:
>> 
>> [ Charset UTF-8 unsupported, converting... ]
>>> Author: ngie
>>> Date: Tue Mar  7 04:33:17 2017
>>> New Revision: 314831
>>> URL: https://svnweb.freebsd.org/changeset/base/314831
>>> 
>>> Log:
>>> Don't rely on dependency in Makefile.inc1 for strfile; make datfiles depend 
>>> on strfile
>>> 
>>> In most cases strfile is built as part of build-tools, but in the event 
>>> that someone
>>> cd'ed to the directory, tried to build from scratch, and had MK_GAMES=no 
>>> previously,
>>> the build would fail in .../datfiles , trying to find strfile .
>>> 
>>> Mark this directory tree "SUBDIR_PARALLEL" safe to help facilitate this, 
>>> instead of
>>> shuffling around the SUBDIR entries (all of the other Makefiles will build 
>>> standalone).
>>> 
>>> MFC after:  1 week
>>> Sponsored by:   Dell EMC Isilon
>>> 
>>> Modified:
>>> head/usr.bin/fortune/Makefile
>>> 
>>> Modified: head/usr.bin/fortune/Makefile
>>> ==
>>> --- head/usr.bin/fortune/Makefile   Tue Mar  7 04:13:22 2017
>>> (r314830)
>>> +++ head/usr.bin/fortune/Makefile   Tue Mar  7 04:33:17 2017
>>> (r314831)
>>> @@ -1,5 +1,11 @@
>>> #   @(#)Makefile8.1 (Berkeley) 5/31/93
>>> +#
>>> +# $FreeBSD$
>>> 
>>> -SUBDIR= fortune strfile datfiles unstr
>>> +SUBDIR=fortune strfile datfiles unstr
>>> +
>>> +SUBDIR_DEPEND_datfiles=strfile
>> That should be a space, variable ends past column 9.
> 
> "An ASCII space is allowed for variable names that extend beyond column 9. “
> 
> "is allowed” != “must”.

And being extremely aesthetically nitpicky, as the queer person I am with my 
attention to colors and design (:P..), I would be kind of annoyed with right 
hand sides being unaligned, e.g.,

SOMETHING_REALLY_LONG=  foo # 1 hard tab
SOMETHING_SHORTER=  bar # 2 hard tabs

vs

SOMETHING_REALLY_LONG= foo # 1 space
SOMETHING_SHORTER= bar  # 2 spaces


signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314831 - head/usr.bin/fortune

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 21:00, Rodney W. Grimes  
> wrote:
> 
> [ Charset UTF-8 unsupported, converting... ]
>> Author: ngie
>> Date: Tue Mar  7 04:33:17 2017
>> New Revision: 314831
>> URL: https://svnweb.freebsd.org/changeset/base/314831
>> 
>> Log:
>>  Don't rely on dependency in Makefile.inc1 for strfile; make datfiles depend 
>> on strfile
>> 
>>  In most cases strfile is built as part of build-tools, but in the event 
>> that someone
>>  cd'ed to the directory, tried to build from scratch, and had MK_GAMES=no 
>> previously,
>>  the build would fail in .../datfiles , trying to find strfile .
>> 
>>  Mark this directory tree "SUBDIR_PARALLEL" safe to help facilitate this, 
>> instead of
>>  shuffling around the SUBDIR entries (all of the other Makefiles will build 
>> standalone).
>> 
>>  MFC after:  1 week
>>  Sponsored by:   Dell EMC Isilon
>> 
>> Modified:
>>  head/usr.bin/fortune/Makefile
>> 
>> Modified: head/usr.bin/fortune/Makefile
>> ==
>> --- head/usr.bin/fortune/MakefileTue Mar  7 04:13:22 2017
>> (r314830)
>> +++ head/usr.bin/fortune/MakefileTue Mar  7 04:33:17 2017
>> (r314831)
>> @@ -1,5 +1,11 @@
>> #@(#)Makefile8.1 (Berkeley) 5/31/93
>> +#
>> +# $FreeBSD$
>> 
>> -SUBDIR= fortune strfile datfiles unstr
>> +SUBDIR= fortune strfile datfiles unstr
>> +
>> +SUBDIR_DEPEND_datfiles= strfile
> That should be a space, variable ends past column 9.

"An ASCII space is allowed for variable names that extend beyond column 9. “

"is allowed” != “must”.

Thanks,
-Ngie


signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314831 - head/usr.bin/fortune

2017-03-06 Thread Rodney W. Grimes
[ Charset UTF-8 unsupported, converting... ]
> Author: ngie
> Date: Tue Mar  7 04:33:17 2017
> New Revision: 314831
> URL: https://svnweb.freebsd.org/changeset/base/314831
> 
> Log:
>   Don't rely on dependency in Makefile.inc1 for strfile; make datfiles depend 
> on strfile
>   
>   In most cases strfile is built as part of build-tools, but in the event 
> that someone
>   cd'ed to the directory, tried to build from scratch, and had MK_GAMES=no 
> previously,
>   the build would fail in .../datfiles , trying to find strfile .
>   
>   Mark this directory tree "SUBDIR_PARALLEL" safe to help facilitate this, 
> instead of
>   shuffling around the SUBDIR entries (all of the other Makefiles will build 
> standalone).
>   
>   MFC after:  1 week
>   Sponsored by:   Dell EMC Isilon
> 
> Modified:
>   head/usr.bin/fortune/Makefile
> 
> Modified: head/usr.bin/fortune/Makefile
> ==
> --- head/usr.bin/fortune/Makefile Tue Mar  7 04:13:22 2017
> (r314830)
> +++ head/usr.bin/fortune/Makefile Tue Mar  7 04:33:17 2017
> (r314831)
> @@ -1,5 +1,11 @@
>  #@(#)Makefile8.1 (Berkeley) 5/31/93
> +#
> +# $FreeBSD$
>  
> -SUBDIR= fortune strfile datfiles unstr
> +SUBDIR=  fortune strfile datfiles unstr
> +
> +SUBDIR_DEPEND_datfiles=  strfile
That should be a space, variable ends past column 9.

> +
> +SUBDIR_PARALLEL=
>  
>  .include 

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314832 - head/bin/ps

2017-03-06 Thread Conrad Meyer
Author: cem
Date: Tue Mar  7 04:51:35 2017
New Revision: 314832
URL: https://svnweb.freebsd.org/changeset/base/314832

Log:
  ps(1): Fix -w + UNLIMITED handling
  
  A follow-up fix for r314685.
  
  Because the -w flag is parsed after ps(1) infers termwidth from COLUMNS and
  stdout, and UNLIMITED happens to be the zero value, the single -w flag in
  combination with a non-terminal stdout or COLUMNS=0 could result in output
  truncated at 131 characters.  (Despite the output being unlimited without
  -w.)
  
  Obviously, adding more -w shouldn't truncate output lines.
  
  The committed patch is from bdrewery@, and I've reviewed and tested it.
  
  Submitted by: bdrewery@
  Reported by:  bdrewery@
  Sponsored by: Dell EMC Isilon

Modified:
  head/bin/ps/ps.c

Modified: head/bin/ps/ps.c
==
--- head/bin/ps/ps.cTue Mar  7 04:33:17 2017(r314831)
+++ head/bin/ps/ps.cTue Mar  7 04:51:35 2017(r314832)
@@ -401,7 +401,7 @@ main(int argc, char *argv[])
case 'w':
if (wflag)
termwidth = UNLIMITED;
-   else if (termwidth < 131)
+   else if (termwidth < 131 && termwidth != UNLIMITED)
termwidth = 131;
wflag++;
break;
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314831 - head/usr.bin/fortune

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 04:33:17 2017
New Revision: 314831
URL: https://svnweb.freebsd.org/changeset/base/314831

Log:
  Don't rely on dependency in Makefile.inc1 for strfile; make datfiles depend 
on strfile
  
  In most cases strfile is built as part of build-tools, but in the event that 
someone
  cd'ed to the directory, tried to build from scratch, and had MK_GAMES=no 
previously,
  the build would fail in .../datfiles , trying to find strfile .
  
  Mark this directory tree "SUBDIR_PARALLEL" safe to help facilitate this, 
instead of
  shuffling around the SUBDIR entries (all of the other Makefiles will build 
standalone).
  
  MFC after:1 week
  Sponsored by: Dell EMC Isilon

Modified:
  head/usr.bin/fortune/Makefile

Modified: head/usr.bin/fortune/Makefile
==
--- head/usr.bin/fortune/Makefile   Tue Mar  7 04:13:22 2017
(r314830)
+++ head/usr.bin/fortune/Makefile   Tue Mar  7 04:33:17 2017
(r314831)
@@ -1,5 +1,11 @@
 #  @(#)Makefile8.1 (Berkeley) 5/31/93
+#
+# $FreeBSD$
 
-SUBDIR= fortune strfile datfiles unstr
+SUBDIR=fortune strfile datfiles unstr
+
+SUBDIR_DEPEND_datfiles=strfile
+
+SUBDIR_PARALLEL=
 
 .include 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314685 - head/bin/ps

2017-03-06 Thread Bryan Drewery
On 3/6/17 8:11 PM, Bryan Drewery wrote:
> On 3/4/17 2:38 PM, Conrad Meyer wrote:
>> Author: cem
>> Date: Sat Mar  4 22:38:10 2017
>> New Revision: 314685
>> URL: https://svnweb.freebsd.org/changeset/base/314685
>>
>> Log:
>>   ps(1): Only detect terminal width if stdout is a tty
>>   
>>   If stdout isn't a tty, use unlimited width output rather than truncating to
>>   79 characters.  This is helpful for shell scripts or e.g., 'ps | grep foo'.
> 
> This change actually makes things worse for me for 'ps uaxwd|less'
> 
> Before:
>> nobody  839790.0  0.09016   1364  3  I+J  20:03   0:00.06 | 
>> | `-- /usr/bin/make -C /usr/ports/lang/perl5.24 build
> 
> After:
>> nobody  897430.0  0.09016   1368  3  S+J  20:07   0:00.05 | 
>> | `-- /usr/bin/make -C /usr/ports/lang/perl5.24
> 
> 
> I now have to specify -ww to not cut things off, but that's far more
> than I want to see.
> 

The problem is that -w is parsed *after* termwidth = UNLIMITED is set
(which is 0).  This patch fixes it, but I haven't tested it extensively:

> Index: ps.c
> ===
> --- ps.c(revision 314708)
> +++ ps.c(working copy)
> @@ -401,7 +401,7 @@ main(int argc, char *argv[])
> case 'w':
> if (wflag)
> termwidth = UNLIMITED;
> -   else if (termwidth < 131)
> +   else if (termwidth < 131 && termwidth != UNLIMITED)
> termwidth = 131;
> wflag++;
> break;



-1 for the original commit. If I wanted -ww I would specify it.  The
original commit causes some text to wrap on my terminal even with some
extending right.

> 
>>   
>>   This hardcoded width has some history: In The Beginning of History[0], the
>>   width of ps was hardcoded as 80 bytes.  In 1985, Bloom@ added detection
>>   using TIOCGWINSZ on stdin.[1]  In 1986, Kirk merged a change to check
>>   stdout's window size instead.  In 1990, the fallback checks to stderr and
>>   stdin's TIOCGWINSZ were added by Marc@, with the commit message "new
>>   version."[2]
>>   
>>   OS X Darwin has a very similar modification to ps(1), which simply sets
>>   UNLIMITED for all non-tty outputs.[3]  I've chosen to respect COLUMNS
>>   instead of behaving identically to Darwin here, but I don't feel strongly
>>   about that.  We could match OS X for parity if that is desired.
>>   
>>   [0]: https://svnweb.freebsd.org/csrg/bin/ps/ps.c?annotate=1065
>>   [1]: https://svnweb.freebsd.org/csrg/bin/ps/ps.c?r1=18105&r2=18106
>>   [2]:
>>   https://svnweb.freebsd.org/csrg/bin/ps/ps.c?r1=40675&r2=40674&pathrev=40675
>>   [3]:
>>   https://opensource.apple.com/source/adv_cmds/adv_cmds-168/ps/ps.c.auto.html
>>   
>>   PR:217159
>>   Reported by:   Deepak Nagaraj 
>>
>> Modified:
>>   head/bin/ps/ps.c
>>
>> Modified: head/bin/ps/ps.c
>> ==
>> --- head/bin/ps/ps.c Sat Mar  4 22:23:59 2017(r314684)
>> +++ head/bin/ps/ps.c Sat Mar  4 22:38:10 2017(r314685)
>> @@ -194,6 +194,8 @@ main(int argc, char *argv[])
>>  
>>  if ((cols = getenv("COLUMNS")) != NULL && *cols != '\0')
>>  termwidth = atoi(cols);
>> +else if (!isatty(STDOUT_FILENO))
>> +termwidth = UNLIMITED;
>>  else if ((ioctl(STDOUT_FILENO, TIOCGWINSZ, (char *)&ws) == -1 &&
>>   ioctl(STDERR_FILENO, TIOCGWINSZ, (char *)&ws) == -1 &&
>>   ioctl(STDIN_FILENO,  TIOCGWINSZ, (char *)&ws) == -1) ||
>>
> 
> 


-- 
Regards,
Bryan Drewery



signature.asc
Description: OpenPGP digital signature


Re: svn commit: r314830 - head/usr.sbin/mergemaster

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 20:14, Ngie Cooper (yaneurabeya)  
> wrote:
> 
>> 
>> On Mar 6, 2017, at 20:13, Ngie Cooper  wrote:
>> 
>> Author: ngie
>> Date: Tue Mar  7 04:13:22 2017
>> New Revision: 314830
>> URL: https://svnweb.freebsd.org/changeset/base/314830
>> 
>> Log:
>> mergemaster: fix description of -p
>> 
>> -p only handles updating /etc/master.passwd and /etc/group . No more,
>> no less.
>> 
>> Also, mergemaster (and no other portions of the vanilla FreeBSD build
>> process) should be messing with __MAKECONF or SRCCONF as part of the
> 
> *should not

Pfft. Stupid double-negative with “and no” as well.

Time to step away from the keyboard.
-Ngie


signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314830 - head/usr.sbin/mergemaster

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 20:13, Ngie Cooper  wrote:
> 
> Author: ngie
> Date: Tue Mar  7 04:13:22 2017
> New Revision: 314830
> URL: https://svnweb.freebsd.org/changeset/base/314830
> 
> Log:
>  mergemaster: fix description of -p
> 
>  -p only handles updating /etc/master.passwd and /etc/group . No more,
>  no less.
> 
>  Also, mergemaster (and no other portions of the vanilla FreeBSD build
>  process) should be messing with __MAKECONF or SRCCONF as part of the

*should not

Bleh.
-Ngie


signature.asc
Description: Message signed with OpenPGP using GPGMail


svn commit: r314830 - head/usr.sbin/mergemaster

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 04:13:22 2017
New Revision: 314830
URL: https://svnweb.freebsd.org/changeset/base/314830

Log:
  mergemaster: fix description of -p
  
  -p only handles updating /etc/master.passwd and /etc/group . No more,
  no less.
  
  Also, mergemaster (and no other portions of the vanilla FreeBSD build
  process) should be messing with __MAKECONF or SRCCONF as part of the
  installworld or distribution process. Don't insinuate that mergemaster
  does that as it's a false claim.
  
  MFC after:1 week
  Sponsored by: Dell EMC Isilon

Modified:
  head/usr.sbin/mergemaster/mergemaster.8

Modified: head/usr.sbin/mergemaster/mergemaster.8
==
--- head/usr.sbin/mergemaster/mergemaster.8 Tue Mar  7 03:53:09 2017
(r314829)
+++ head/usr.sbin/mergemaster/mergemaster.8 Tue Mar  7 04:13:22 2017
(r314830)
@@ -24,7 +24,7 @@
 .\"
 .\" $FreeBSD$
 .\"
-.Dd September 29, 2015
+.Dd March 6, 2017
 .Dt MERGEMASTER 8
 .Os
 .Sh NAME
@@ -226,9 +226,10 @@ destination directory.
 .It Fl p
 Pre-buildworld mode.
 Compares only files known to be essential to the success of
-{build|install}world,
-including
-.Pa /etc/make.conf .
+{build|install}world, i.e.,
+.Pa /etc/group
+and
+.Pa /etc/master.passwd .
 .It Fl F
 If the files differ only by VCS Id ($FreeBSD)
 install the new file.
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314685 - head/bin/ps

2017-03-06 Thread Bryan Drewery
On 3/4/17 2:38 PM, Conrad Meyer wrote:
> Author: cem
> Date: Sat Mar  4 22:38:10 2017
> New Revision: 314685
> URL: https://svnweb.freebsd.org/changeset/base/314685
> 
> Log:
>   ps(1): Only detect terminal width if stdout is a tty
>   
>   If stdout isn't a tty, use unlimited width output rather than truncating to
>   79 characters.  This is helpful for shell scripts or e.g., 'ps | grep foo'.

This change actually makes things worse for me for 'ps uaxwd|less'

Before:
> nobody  839790.0  0.09016   1364  3  I+J  20:03   0:00.06 | | 
> `-- /usr/bin/make -C /usr/ports/lang/perl5.24 build

After:
> nobody  897430.0  0.09016   1368  3  S+J  20:07   0:00.05 | | 
> `-- /usr/bin/make -C /usr/ports/lang/perl5.24


I now have to specify -ww to not cut things off, but that's far more
than I want to see.


>   
>   This hardcoded width has some history: In The Beginning of History[0], the
>   width of ps was hardcoded as 80 bytes.  In 1985, Bloom@ added detection
>   using TIOCGWINSZ on stdin.[1]  In 1986, Kirk merged a change to check
>   stdout's window size instead.  In 1990, the fallback checks to stderr and
>   stdin's TIOCGWINSZ were added by Marc@, with the commit message "new
>   version."[2]
>   
>   OS X Darwin has a very similar modification to ps(1), which simply sets
>   UNLIMITED for all non-tty outputs.[3]  I've chosen to respect COLUMNS
>   instead of behaving identically to Darwin here, but I don't feel strongly
>   about that.  We could match OS X for parity if that is desired.
>   
>   [0]: https://svnweb.freebsd.org/csrg/bin/ps/ps.c?annotate=1065
>   [1]: https://svnweb.freebsd.org/csrg/bin/ps/ps.c?r1=18105&r2=18106
>   [2]:
>   https://svnweb.freebsd.org/csrg/bin/ps/ps.c?r1=40675&r2=40674&pathrev=40675
>   [3]:
>   https://opensource.apple.com/source/adv_cmds/adv_cmds-168/ps/ps.c.auto.html
>   
>   PR: 217159
>   Reported by:Deepak Nagaraj 
> 
> Modified:
>   head/bin/ps/ps.c
> 
> Modified: head/bin/ps/ps.c
> ==
> --- head/bin/ps/ps.c  Sat Mar  4 22:23:59 2017(r314684)
> +++ head/bin/ps/ps.c  Sat Mar  4 22:38:10 2017(r314685)
> @@ -194,6 +194,8 @@ main(int argc, char *argv[])
>  
>   if ((cols = getenv("COLUMNS")) != NULL && *cols != '\0')
>   termwidth = atoi(cols);
> + else if (!isatty(STDOUT_FILENO))
> + termwidth = UNLIMITED;
>   else if ((ioctl(STDOUT_FILENO, TIOCGWINSZ, (char *)&ws) == -1 &&
>ioctl(STDERR_FILENO, TIOCGWINSZ, (char *)&ws) == -1 &&
>ioctl(STDIN_FILENO,  TIOCGWINSZ, (char *)&ws) == -1) ||
> 


-- 
Regards,
Bryan Drewery



signature.asc
Description: OpenPGP digital signature


Re: svn commit: r314813 - head/sys/kern

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 19:08, Ngie Cooper (yaneurabeya)  
> wrote:

…

> The KASSERT is bad — please fix it. From 
> https://ci.freebsd.org/job/FreeBSD-head-amd64-test/1994/console :
> 
> add host 127.0.0.1panic: sbcut_internal: len is 0 but it is supposed to be +ve

len == 0 has special meaning; please see sbflush_internal. This works.
Thanks,
-Ngie

$ svn diff sys/kern/uipc_sockbuf.c
Index: sys/kern/uipc_sockbuf.c
===
--- sys/kern/uipc_sockbuf.c (revision 314827)
+++ sys/kern/uipc_sockbuf.c (working copy)
@@ -1043,8 +1043,7 @@
 {
struct mbuf *m, *next, *mfree;

-   KASSERT(len > 0, ("%s: len is %d but it is supposed to be +ve",
-   __func__, len));
+   KASSERT(len >= 0, ("%s: len is negative (%d)", __func__, len));
KASSERT(len <= sb->sb_ccc, ("%s: len: %d is > ccc: %u",
__func__, len, sb->sb_ccc));




signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314274 - head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs

2017-03-06 Thread Slawa Olhovchenkov
On Sat, Feb 25, 2017 at 05:03:49PM +, Andriy Gapon wrote:

> Author: avg
> Date: Sat Feb 25 17:03:48 2017
> New Revision: 314274
> URL: https://svnweb.freebsd.org/changeset/base/314274
> 
> Log:
>   l2arc: try to fix write size calculation broken by Compressed ARC commit
>   
>   While there, make a change to not evict a first buffer outside the
>   requested eviciton range.
>   
>   To do:
>   - give more consistent names to the size variables
>   - upstream to OpenZFS

Mem: 6647M Active, 8399M Inact, 87G Wired, 49K Buf, 23G Free
^
ARC: 130G Total, 255M MFU, 80G MRU, 267M Anon, 72M Header, 41M Other
 ^

128GB phys mem
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314829 - stable/10/sys/netinet6

2017-03-06 Thread Andrey V. Elsukov
Author: ae
Date: Tue Mar  7 03:53:09 2017
New Revision: 314829
URL: https://svnweb.freebsd.org/changeset/base/314829

Log:
  MFC r314430:
When IPv6 fragments reassembly is complete, update mbuf's csum_data
and csum_flags using information from all fragments. This fixes
dropping of reassembled packets due to wrong checksum when the IPv6
checksum offloading is enabled on a network card.

Modified:
  stable/10/sys/netinet6/frag6.c
Directory Properties:
  stable/10/   (props changed)

Modified: stable/10/sys/netinet6/frag6.c
==
--- stable/10/sys/netinet6/frag6.c  Tue Mar  7 03:35:50 2017
(r314828)
+++ stable/10/sys/netinet6/frag6.c  Tue Mar  7 03:53:09 2017
(r314829)
@@ -533,6 +533,11 @@ insert:
af6 = ip6af->ip6af_down;
frag6_deq(ip6af);
while (af6 != (struct ip6asfrag *)q6) {
+   m->m_pkthdr.csum_flags &=
+   IP6_REASS_MBUF(af6)->m_pkthdr.csum_flags;
+   m->m_pkthdr.csum_data +=
+   IP6_REASS_MBUF(af6)->m_pkthdr.csum_data;
+
af6dwn = af6->ip6af_down;
frag6_deq(af6);
while (t->m_next)
@@ -543,6 +548,10 @@ insert:
af6 = af6dwn;
}
 
+   while (m->m_pkthdr.csum_data & 0x)
+   m->m_pkthdr.csum_data = (m->m_pkthdr.csum_data & 0x) +
+   (m->m_pkthdr.csum_data >> 16);
+
/* adjust offset to point where the original next header starts */
offset = ip6af->ip6af_offset - sizeof(struct ip6_frag);
free(ip6af, M_FTABLE);
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314828 - head/sys/boot/efi/loader

2017-03-06 Thread Dexuan Cui
Author: dexuan
Date: Tue Mar  7 03:35:50 2017
New Revision: 314828
URL: https://svnweb.freebsd.org/changeset/base/314828

Log:
  loader.efi: fix an off-by-one bug in efi_verify_staging_size()
  
  Also remove the warning message: it may not be unusual to see
  the memory range containing 2MB is not of EfiConventionalMemory.
  
  MFC after:2 weeks2 weeks
  Sponsored by: Microsoft

Modified:
  head/sys/boot/efi/loader/copy.c

Modified: head/sys/boot/efi/loader/copy.c
==
--- head/sys/boot/efi/loader/copy.c Tue Mar  7 03:01:09 2017
(r314827)
+++ head/sys/boot/efi/loader/copy.c Tue Mar  7 03:35:50 2017
(r314828)
@@ -79,10 +79,6 @@ efi_verify_staging_size(unsigned long *n
KERNEL_PHYSICAL_BASE >= end)
continue;
 
-   if (p->Type != EfiConventionalMemory)
-   printf("Warning: wrong EFI memory type: %d\n",
-   p->Type);
-
available_pages = p->NumberOfPages -
((KERNEL_PHYSICAL_BASE - start) >> EFI_PAGE_SHIFT);
break;
@@ -93,6 +89,7 @@ efi_verify_staging_size(unsigned long *n
goto out;
}
 
+   i++;
for ( ; i < ndesc;
 i++, p = NextMemoryDescriptor(p, dsz)) {
if (p->Type != EfiConventionalMemory &&
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314819 - stable/11/lib/libutil

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 19:31, Rodney W. Grimes  
> wrote:

…

> I am less concered about fixing this and more concerned about making sure you
> understood what the actual sytle.Makeilfe(9) rules are becuase it appeared
> that given the counter style changes you thought there should be no white
> space after VAR= in a Makefile.
> 
> You probably understand that better than most and this is just a poor
> choice of words in the commit message.

I was intentionally fixing single space in leading whitespace in this commit 
along with unnecessary/incorrect trailing whitespace. That’s all I was trying 
to do, and I suppose the style.Makefile(9) portion of the commit message was 
overkill—technically it was fixing as little as possible so my eyes didn’t hurt 
whenever I opened the Makefile with vim, which also suited this requirement.

So yes, "opportunistic whitespace cleaning to fix my eyes bleeding from the red 
colorization from my editor — vim” might have been more accurate.
-Ngie


signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314819 - stable/11/lib/libutil

2017-03-06 Thread Rodney W. Grimes
[ Charset UTF-8 unsupported, converting... ]
> 
> > On Mar 6, 2017, at 19:10, Ngie Cooper (yaneurabeya)  
> > wrote:
> > 
> >> 
> >> On Mar 6, 2017, at 19:00, Rodney W. Grimes 
> >>  wrote:
> >> 
> >> [ Charset UTF-8 unsupported, converting... ]
> >>> Author: ngie
> >>> Date: Tue Mar  7 01:58:39 2017
> >>> New Revision: 314819
> >>> URL: https://svnweb.freebsd.org/changeset/base/314819
> >>> 
> >>> Log:
> >>> MFC r313438:
> >>> 
> >>> Clean up trailing and leading whitespace for variables to make it
> >>> consistent with the rest of the file and style.Makefile(9) a bit
> >>> more
> >>> 
> >>> Modified:
> >>> stable/11/lib/libutil/Makefile
> >>> Directory Properties:
> >>> stable/11/   (props changed)
> >>> 
> >>> Modified: stable/11/lib/libutil/Makefile
> >>> ==
> >>> --- stable/11/lib/libutil/MakefileTue Mar  7 01:52:56 2017
> >>> (r314818)
> >>> +++ stable/11/lib/libutil/MakefileTue Mar  7 01:58:39 2017
> >>> (r314819)
> >>> @@ -35,7 +35,7 @@ MAN+=   expand_number.3 flopen.3 fparseln.
> >>>   property.3 pty.3 quotafile.3 realhostname.3 realhostname_sa.3 \
> >>>   _secure_path.3 trimdomain.3 uucplock.3 pw_util.3
> >>> MAN+= login.conf.5
> >>> -MLINKS+= kld.3 kld_isloaded.3 kld.3 kld_load.3
> >>> +MLINKS+=kld.3 kld_isloaded.3 kld.3 kld_load.3
> >>> MLINKS+=login_auth.3 auth_cat.3 login_auth.3 auth_checknologin.3
> >>> MLINKS+=login_cap.3 login_close.3 login_cap.3 login_getcapbool.3 \
> >> 
> >> Thats actually counter style.Makefile(9), Normally you have a tab here,
> >> or a space should the variable name extend beyond column 9.
> >> 
> >>>   login_cap.3 login_getcaplist.3 login_cap.3 login_getcapnum.3 \
> >>> @@ -57,9 +57,9 @@ MLINKS+=pidfile.3 pidfile_close.3 \
> >>>   pidfile.3 pidfile_open.3 \
> >>>   pidfile.3 pidfile_remove.3 \
> >>>   pidfile.3 pidfile_write.3
> >>> -MLINKS+= property.3 property_find.3  property.3 properties_free.3
> >>> -MLINKS+= property.3 properties_read.3
> >>> -MLINKS+= pty.3 forkpty.3  pty.3 openpty.3
> >>> +MLINKS+=property.3 property_find.3  property.3 properties_free.3
> >>> +MLINKS+=property.3 properties_read.3
> >>> +MLINKS+=pty.3 forkpty.3  pty.3 openpty.3
> >> 
> >> Ditto.
> > 
> > Yeah, I tried to leave things alone (except is surrounding areas for the 
> > following change), but I?ll go and hack away at the Makefile some more.
> > Thanks,
> 
> Actually, on second thought, I?m not going to modify the Makefile to just 
> introduce gratuitous whitespace. If I need to touch this again, I?ll do it, 
> but it doesn?t make sense churning over this Makefile like that (it?s a 
> mishmash of different ?styles?).

I am less concered about fixing this and more concerned about making sure you
understood what the actual sytle.Makeilfe(9) rules are becuase it appeared
that given the counter style changes you thought there should be no white
space after VAR= in a Makefile.

You probably understand that better than most and this is just a poor
choice of words in the commit message.

> -Ngie
-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314819 - stable/11/lib/libutil

2017-03-06 Thread Rodney W. Grimes
[ Charset UTF-8 unsupported, converting... ]
> 
> > On Mar 6, 2017, at 19:00, Rodney W. Grimes  
> > wrote:
> > 
> > [ Charset UTF-8 unsupported, converting... ]
> >> Author: ngie
> >> Date: Tue Mar  7 01:58:39 2017
> >> New Revision: 314819
> >> URL: https://svnweb.freebsd.org/changeset/base/314819
> >> 
> >> Log:
> >>  MFC r313438:
> >> 
> >>  Clean up trailing and leading whitespace for variables to make it
> >>  consistent with the rest of the file and style.Makefile(9) a bit
> >>  more
> >> 
> >> Modified:
> >>  stable/11/lib/libutil/Makefile
> >> Directory Properties:
> >>  stable/11/   (props changed)
> >> 
> >> Modified: stable/11/lib/libutil/Makefile
> >> ==
> >> --- stable/11/lib/libutil/Makefile Tue Mar  7 01:52:56 2017
> >> (r314818)
> >> +++ stable/11/lib/libutil/Makefile Tue Mar  7 01:58:39 2017
> >> (r314819)
> >> @@ -35,7 +35,7 @@ MAN+=expand_number.3 flopen.3 fparseln.
> >>property.3 pty.3 quotafile.3 realhostname.3 realhostname_sa.3 \
> >>_secure_path.3 trimdomain.3 uucplock.3 pw_util.3
> >> MAN+=  login.conf.5
> >> -MLINKS+= kld.3 kld_isloaded.3 kld.3 kld_load.3
> >> +MLINKS+=kld.3 kld_isloaded.3 kld.3 kld_load.3
> >> MLINKS+=login_auth.3 auth_cat.3 login_auth.3 auth_checknologin.3
> >> MLINKS+=login_cap.3 login_close.3 login_cap.3 login_getcapbool.3 \
> > 
> > Thats actually counter style.Makefile(9), Normally you have a tab here,
> > or a space should the variable name extend beyond column 9.
> > 
> >>login_cap.3 login_getcaplist.3 login_cap.3 login_getcapnum.3 \
> >> @@ -57,9 +57,9 @@ MLINKS+=pidfile.3 pidfile_close.3 \
> >>pidfile.3 pidfile_open.3 \
> >>pidfile.3 pidfile_remove.3 \
> >>pidfile.3 pidfile_write.3
> >> -MLINKS+= property.3 property_find.3  property.3 properties_free.3
> >> -MLINKS+= property.3 properties_read.3
> >> -MLINKS+= pty.3 forkpty.3  pty.3 openpty.3
> >> +MLINKS+=property.3 property_find.3  property.3 properties_free.3
> >> +MLINKS+=property.3 properties_read.3
> >> +MLINKS+=pty.3 forkpty.3  pty.3 openpty.3
> > 
> > Ditto.
> 
> Yeah, I tried to leave things alone (except is surrounding areas for the 
> following change), but I?ll go and hack away at the Makefile some more.
> Thanks,

Its fine to counter style.Makefile(9) if these results in a minimized diff
for work your doing in the Makefile, but then the commit should say something
like ignoring style.Makeifle(9) to minimize diff.   I am fine with that,
its just you stated a style(9).Makefile cleanup and thats not what this
commit does.

Several of my absolute to relative symbolic link fixes coming well have
that very issue, basically I ignored all the style errors I was seeing
and just fixed my goal keeping the style of the Makefile exactly as it
was.

> -Ngie
-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314819 - stable/11/lib/libutil

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 19:10, Ngie Cooper (yaneurabeya)  
> wrote:
> 
>> 
>> On Mar 6, 2017, at 19:00, Rodney W. Grimes  
>> wrote:
>> 
>> [ Charset UTF-8 unsupported, converting... ]
>>> Author: ngie
>>> Date: Tue Mar  7 01:58:39 2017
>>> New Revision: 314819
>>> URL: https://svnweb.freebsd.org/changeset/base/314819
>>> 
>>> Log:
>>> MFC r313438:
>>> 
>>> Clean up trailing and leading whitespace for variables to make it
>>> consistent with the rest of the file and style.Makefile(9) a bit
>>> more
>>> 
>>> Modified:
>>> stable/11/lib/libutil/Makefile
>>> Directory Properties:
>>> stable/11/   (props changed)
>>> 
>>> Modified: stable/11/lib/libutil/Makefile
>>> ==
>>> --- stable/11/lib/libutil/Makefile  Tue Mar  7 01:52:56 2017
>>> (r314818)
>>> +++ stable/11/lib/libutil/Makefile  Tue Mar  7 01:58:39 2017
>>> (r314819)
>>> @@ -35,7 +35,7 @@ MAN+= expand_number.3 flopen.3 fparseln.
>>> property.3 pty.3 quotafile.3 realhostname.3 realhostname_sa.3 \
>>> _secure_path.3 trimdomain.3 uucplock.3 pw_util.3
>>> MAN+=   login.conf.5
>>> -MLINKS+= kld.3 kld_isloaded.3 kld.3 kld_load.3
>>> +MLINKS+=kld.3 kld_isloaded.3 kld.3 kld_load.3
>>> MLINKS+=login_auth.3 auth_cat.3 login_auth.3 auth_checknologin.3
>>> MLINKS+=login_cap.3 login_close.3 login_cap.3 login_getcapbool.3 \
>> 
>> Thats actually counter style.Makefile(9), Normally you have a tab here,
>> or a space should the variable name extend beyond column 9.
>> 
>>> login_cap.3 login_getcaplist.3 login_cap.3 login_getcapnum.3 \
>>> @@ -57,9 +57,9 @@ MLINKS+=pidfile.3 pidfile_close.3 \
>>> pidfile.3 pidfile_open.3 \
>>> pidfile.3 pidfile_remove.3 \
>>> pidfile.3 pidfile_write.3
>>> -MLINKS+= property.3 property_find.3  property.3 properties_free.3
>>> -MLINKS+= property.3 properties_read.3
>>> -MLINKS+= pty.3 forkpty.3  pty.3 openpty.3
>>> +MLINKS+=property.3 property_find.3  property.3 properties_free.3
>>> +MLINKS+=property.3 properties_read.3
>>> +MLINKS+=pty.3 forkpty.3  pty.3 openpty.3
>> 
>> Ditto.
> 
> Yeah, I tried to leave things alone (except is surrounding areas for the 
> following change), but I’ll go and hack away at the Makefile some more.
> Thanks,

Actually, on second thought, I’m not going to modify the Makefile to just 
introduce gratuitous whitespace. If I need to touch this again, I’ll do it, but 
it doesn’t make sense churning over this Makefile like that (it’s a mishmash of 
different “styles”).
Thanks,
-Ngie



signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314819 - stable/11/lib/libutil

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 19:00, Rodney W. Grimes  
> wrote:
> 
> [ Charset UTF-8 unsupported, converting... ]
>> Author: ngie
>> Date: Tue Mar  7 01:58:39 2017
>> New Revision: 314819
>> URL: https://svnweb.freebsd.org/changeset/base/314819
>> 
>> Log:
>>  MFC r313438:
>> 
>>  Clean up trailing and leading whitespace for variables to make it
>>  consistent with the rest of the file and style.Makefile(9) a bit
>>  more
>> 
>> Modified:
>>  stable/11/lib/libutil/Makefile
>> Directory Properties:
>>  stable/11/   (props changed)
>> 
>> Modified: stable/11/lib/libutil/Makefile
>> ==
>> --- stable/11/lib/libutil/Makefile   Tue Mar  7 01:52:56 2017
>> (r314818)
>> +++ stable/11/lib/libutil/Makefile   Tue Mar  7 01:58:39 2017
>> (r314819)
>> @@ -35,7 +35,7 @@ MAN+=  expand_number.3 flopen.3 fparseln.
>>  property.3 pty.3 quotafile.3 realhostname.3 realhostname_sa.3 \
>>  _secure_path.3 trimdomain.3 uucplock.3 pw_util.3
>> MAN+=login.conf.5
>> -MLINKS+= kld.3 kld_isloaded.3 kld.3 kld_load.3
>> +MLINKS+=kld.3 kld_isloaded.3 kld.3 kld_load.3
>> MLINKS+=login_auth.3 auth_cat.3 login_auth.3 auth_checknologin.3
>> MLINKS+=login_cap.3 login_close.3 login_cap.3 login_getcapbool.3 \
> 
> Thats actually counter style.Makefile(9), Normally you have a tab here,
> or a space should the variable name extend beyond column 9.
> 
>>  login_cap.3 login_getcaplist.3 login_cap.3 login_getcapnum.3 \
>> @@ -57,9 +57,9 @@ MLINKS+=pidfile.3 pidfile_close.3 \
>>  pidfile.3 pidfile_open.3 \
>>  pidfile.3 pidfile_remove.3 \
>>  pidfile.3 pidfile_write.3
>> -MLINKS+= property.3 property_find.3  property.3 properties_free.3
>> -MLINKS+= property.3 properties_read.3
>> -MLINKS+= pty.3 forkpty.3  pty.3 openpty.3
>> +MLINKS+=property.3 property_find.3  property.3 properties_free.3
>> +MLINKS+=property.3 properties_read.3
>> +MLINKS+=pty.3 forkpty.3  pty.3 openpty.3
> 
> Ditto.

Yeah, I tried to leave things alone (except is surrounding areas for the 
following change), but I’ll go and hack away at the Makefile some more.
Thanks,
-Ngie


signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314813 - head/sys/kern

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 16:20, Hiren Panchasara  wrote:
> 
> Author: hiren
> Date: Tue Mar  7 00:20:01 2017
> New Revision: 314813
> URL: https://svnweb.freebsd.org/changeset/base/314813
> 
> Log:
>  We've found a recurring problem where some userland process would be
>  stuck spinning at 100% cpu around sbcut_internal(). Inside
>  sbflush_internal(), sb_ccc reached to about 4GB and before passing it
>  to sbcut_internal(), we type-cast it from uint to int making it -ve.
> 
>  The root cause of sockbuf growing this large is unknown. Correct fix
>  is also not clear but based on mailing list discussions, adding
>  KASSERTs to panic instead of looping endlessly.
> 
>  Reviewed by: glebius
>  Sponsored by:Limelight Networks
> 
> Modified:
>  head/sys/kern/uipc_sockbuf.c
> 
> Modified: head/sys/kern/uipc_sockbuf.c
> ==
> --- head/sys/kern/uipc_sockbuf.c  Tue Mar  7 00:13:53 2017
> (r314812)
> +++ head/sys/kern/uipc_sockbuf.c  Tue Mar  7 00:20:01 2017
> (r314813)
> @@ -1043,6 +1043,11 @@ sbcut_internal(struct sockbuf *sb, int l
> {
>   struct mbuf *m, *next, *mfree;
> 
> + KASSERT(len > 0, ("%s: len is %d but it is supposed to be +ve",
> + __func__, len));
> + KASSERT(len <= sb->sb_ccc, ("%s: len: %d is > ccc: %u",
> + __func__, len, sb->sb_ccc));
> +
>   next = (m = sb->sb_mb) ? m->m_nextpkt : 0;
>   mfree = NULL;

The KASSERT is bad — please fix it. From 
https://ci.freebsd.org/job/FreeBSD-head-amd64-test/1994/console :

add host 127.0.0.1panic: sbcut_internal: len is 0 but it is supposed to be +ve


signature.asc
Description: Message signed with OpenPGP using GPGMail


svn commit: r314827 - stable/11/sys/netinet6

2017-03-06 Thread Andrey V. Elsukov
Author: ae
Date: Tue Mar  7 03:01:09 2017
New Revision: 314827
URL: https://svnweb.freebsd.org/changeset/base/314827

Log:
  MFC r314430:
When IPv6 fragments reassembly is complete, update mbuf's csum_data
and csum_flags using information from all fragments. This fixes
dropping of reassembled packets due to wrong checksum when the IPv6
checksum offloading is enabled on a network card.

Modified:
  stable/11/sys/netinet6/frag6.c
Directory Properties:
  stable/11/   (props changed)

Modified: stable/11/sys/netinet6/frag6.c
==
--- stable/11/sys/netinet6/frag6.c  Tue Mar  7 02:17:38 2017
(r314826)
+++ stable/11/sys/netinet6/frag6.c  Tue Mar  7 03:01:09 2017
(r314827)
@@ -528,6 +528,11 @@ insert:
af6 = ip6af->ip6af_down;
frag6_deq(ip6af);
while (af6 != (struct ip6asfrag *)q6) {
+   m->m_pkthdr.csum_flags &=
+   IP6_REASS_MBUF(af6)->m_pkthdr.csum_flags;
+   m->m_pkthdr.csum_data +=
+   IP6_REASS_MBUF(af6)->m_pkthdr.csum_data;
+
af6dwn = af6->ip6af_down;
frag6_deq(af6);
while (t->m_next)
@@ -538,6 +543,10 @@ insert:
af6 = af6dwn;
}
 
+   while (m->m_pkthdr.csum_data & 0x)
+   m->m_pkthdr.csum_data = (m->m_pkthdr.csum_data & 0x) +
+   (m->m_pkthdr.csum_data >> 16);
+
/* adjust offset to point where the original next header starts */
offset = ip6af->ip6af_offset - sizeof(struct ip6_frag);
free(ip6af, M_FTABLE);
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314819 - stable/11/lib/libutil

2017-03-06 Thread Rodney W. Grimes
[ Charset UTF-8 unsupported, converting... ]
> Author: ngie
> Date: Tue Mar  7 01:58:39 2017
> New Revision: 314819
> URL: https://svnweb.freebsd.org/changeset/base/314819
> 
> Log:
>   MFC r313438:
>   
>   Clean up trailing and leading whitespace for variables to make it
>   consistent with the rest of the file and style.Makefile(9) a bit
>   more
> 
> Modified:
>   stable/11/lib/libutil/Makefile
> Directory Properties:
>   stable/11/   (props changed)
> 
> Modified: stable/11/lib/libutil/Makefile
> ==
> --- stable/11/lib/libutil/MakefileTue Mar  7 01:52:56 2017
> (r314818)
> +++ stable/11/lib/libutil/MakefileTue Mar  7 01:58:39 2017
> (r314819)
> @@ -35,7 +35,7 @@ MAN+=   expand_number.3 flopen.3 fparseln.
>   property.3 pty.3 quotafile.3 realhostname.3 realhostname_sa.3 \
>   _secure_path.3 trimdomain.3 uucplock.3 pw_util.3
>  MAN+=login.conf.5
> -MLINKS+= kld.3 kld_isloaded.3 kld.3 kld_load.3
> +MLINKS+=kld.3 kld_isloaded.3 kld.3 kld_load.3
>  MLINKS+=login_auth.3 auth_cat.3 login_auth.3 auth_checknologin.3
>  MLINKS+=login_cap.3 login_close.3 login_cap.3 login_getcapbool.3 \

Thats actually counter style.Makefile(9), Normally you have a tab here,
or a space should the variable name extend beyond column 9.

>   login_cap.3 login_getcaplist.3 login_cap.3 login_getcapnum.3 \
> @@ -57,9 +57,9 @@ MLINKS+=pidfile.3 pidfile_close.3 \
>   pidfile.3 pidfile_open.3 \
>   pidfile.3 pidfile_remove.3 \
>   pidfile.3 pidfile_write.3
> -MLINKS+= property.3 property_find.3  property.3 properties_free.3
> -MLINKS+= property.3 properties_read.3
> -MLINKS+= pty.3 forkpty.3  pty.3 openpty.3
> +MLINKS+=property.3 property_find.3  property.3 properties_free.3
> +MLINKS+=property.3 properties_read.3
> +MLINKS+=pty.3 forkpty.3  pty.3 openpty.3

Ditto.

>  MLINKS+=quotafile.3 quota_close.3 \
>   quotafile.3 quota_fsname.3 \
>   quotafile.3 quota_open.3 \
> @@ -69,7 +69,7 @@ MLINKS+=quotafile.3 quota_close.3 \
>   quotafile.3 quota_write_limits.3 \
>   quotafile.3 quota_write_usage.3
>  MLINKS+=uucplock.3 uu_lock.3 uucplock.3 uu_lock_txfr.3 \
> - uucplock.3 uu_lockerr.3 uucplock.3 uu_unlock.3 
> + uucplock.3 uu_lockerr.3 uucplock.3 uu_unlock.3
>  MLINKS+=pw_util.3 pw_copy.3 \
>   pw_util.3 pw_dup.3 \
>   pw_util.3 pw_edit.3 \
> 

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314826 - head/lib/csu/powerpc64

2017-03-06 Thread Justin Hibbits
Author: jhibbits
Date: Tue Mar  7 02:17:38 2017
New Revision: 314826
URL: https://svnweb.freebsd.org/changeset/base/314826

Log:
  Clang in base now supports -mlongcall, so remove this hack
  
  PR:   215947
  MFC after:2 weeks

Modified:
  head/lib/csu/powerpc64/Makefile

Modified: head/lib/csu/powerpc64/Makefile
==
--- head/lib/csu/powerpc64/Makefile Tue Mar  7 02:16:40 2017
(r314825)
+++ head/lib/csu/powerpc64/Makefile Tue Mar  7 02:17:38 2017
(r314826)
@@ -9,16 +9,6 @@ CFLAGS+=   -I${.CURDIR:H}/common \
-I${SRCTOP}/lib/libc/include \
-mlongcall
 
-# XXX: See the log for r232932 as to why the above -mlongcall is needed.  Since
-# clang doesn't support -mlongcall, and testing shows a clang linked with a
-# clang-built csu segfaults, this must currently be compiled with gcc.  Once
-# clang supports -mlongcall, or we get a fixed ld, this can be revisited.
-.include 
-.if ${COMPILER_TYPE} != "gcc"
-CC:=   gcc
-COMPILER_TYPE:=gcc
-.endif
-
 FILES= ${OBJS}
 FILESMODE= ${LIBMODE}
 FILESOWN=  ${LIBOWN}
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314825 - stable/11/tools/build/mk

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 02:16:40 2017
New Revision: 314825
URL: https://svnweb.freebsd.org/changeset/base/314825

Log:
  MFC r314242:
  
  Remove MK_CRYPT stub
  
  It doesn't directly control what gets installed today; it indirectly
  pulls other knobs (like MK_KERBEROS, etc).

Modified:
  stable/11/tools/build/mk/OptionalObsoleteFiles.inc
Directory Properties:
  stable/11/   (props changed)

Modified: stable/11/tools/build/mk/OptionalObsoleteFiles.inc
==
--- stable/11/tools/build/mk/OptionalObsoleteFiles.inc  Tue Mar  7 02:02:51 
2017(r314824)
+++ stable/11/tools/build/mk/OptionalObsoleteFiles.inc  Tue Mar  7 02:16:40 
2017(r314825)
@@ -1518,10 +1518,6 @@ OLD_FILES+=usr/bin/cpp
 OLD_FILES+=usr/share/man/man1/cpp.1.gz
 .endif
 
-#.if ${MK_CRYPT} == no
-# to be filled in
-#.endif
-
 .if ${MK_CTM} == no
 OLD_FILES+=usr/sbin/ctm
 OLD_FILES+=usr/sbin/ctm_dequeue
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314780 - head/lib/libpam/modules/pam_exec

2017-03-06 Thread Conrad Meyer
Thanks for fixing the commit log this way.  It makes 'svn annotate'
history correct.  IMO this is strongly preferable to a "forced
commit."

Best,
Conrad

On Mon, Mar 6, 2017 at 7:45 AM, Pedro F. Giffuni  wrote:
> Author: pfg
> Date: Mon Mar  6 15:45:46 2017
> New Revision: 314780
> URL: https://svnweb.freebsd.org/changeset/base/314780
>
> Log:
>   libpam: extra bounds checking through reallocarray(3).
>
>   Reviewed by:  des
>   MFC after:1 week
>
> Modified:
>   head/lib/libpam/modules/pam_exec/pam_exec.c
>
> Modified: head/lib/libpam/modules/pam_exec/pam_exec.c
> ==
> --- head/lib/libpam/modules/pam_exec/pam_exec.c Mon Mar  6 15:42:03 2017  
>   (r314779)
> +++ head/lib/libpam/modules/pam_exec/pam_exec.c Mon Mar  6 15:45:46 2017  
>   (r314780)
> @@ -138,7 +138,7 @@ _pam_exec(pam_handle_t *pamh __unused,
> nitems = sizeof(env_items) / sizeof(*env_items);
> /* Count PAM return values put in the environment. */
> nitems_rv = options->return_prog_exit_status ? PAM_RV_COUNT : 0;
> -   tmp = realloc(envlist, (envlen + nitems + 1 + nitems_rv + 1) *
> +   tmp = reallocarray(envlist, envlen + nitems + 1 + nitems_rv + 1,
> sizeof(*envlist));
> if (tmp == NULL) {
> openpam_free_envlist(envlist);
>
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314823 - stable/11/usr.sbin/syslogd

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 02:02:23 2017
New Revision: 314823
URL: https://svnweb.freebsd.org/changeset/base/314823

Log:
  MFC r314226:
  
  Use SRCTOP instead of .CURDIR relative paths with ".."
  
  This simplifies pathing in make/displayed output

Modified:
  stable/11/usr.sbin/syslogd/Makefile
Directory Properties:
  stable/11/   (props changed)

Modified: stable/11/usr.sbin/syslogd/Makefile
==
--- stable/11/usr.sbin/syslogd/Makefile Tue Mar  7 02:01:32 2017
(r314822)
+++ stable/11/usr.sbin/syslogd/Makefile Tue Mar  7 02:02:23 2017
(r314823)
@@ -3,7 +3,7 @@
 
 .include 
 
-.PATH: ${.CURDIR}/../../usr.bin/wall
+.PATH: ${SRCTOP}/usr.bin/wall
 
 PROG=  syslogd
 MAN=   syslog.conf.5 syslogd.8
@@ -17,6 +17,6 @@ WARNS?= 3
 CFLAGS+= -DINET6
 .endif
 
-CFLAGS+= -I${.CURDIR}/../../usr.bin/wall
+CFLAGS+= -I${SRCTOP}/usr.bin/wall
 
 .include 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314824 - stable/10/tools/build/mk

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 02:02:51 2017
New Revision: 314824
URL: https://svnweb.freebsd.org/changeset/base/314824

Log:
  MFC r314242:
  
  Remove MK_CRYPT stub
  
  It doesn't directly control what gets installed today; it indirectly
  pulls other knobs (like MK_KERBEROS, etc).

Modified:
  stable/10/tools/build/mk/OptionalObsoleteFiles.inc
Directory Properties:
  stable/10/   (props changed)

Modified: stable/10/tools/build/mk/OptionalObsoleteFiles.inc
==
--- stable/10/tools/build/mk/OptionalObsoleteFiles.inc  Tue Mar  7 02:02:23 
2017(r314823)
+++ stable/10/tools/build/mk/OptionalObsoleteFiles.inc  Tue Mar  7 02:02:51 
2017(r314824)
@@ -1033,10 +1033,6 @@ OLD_FILES+=usr/bin/cpp
 OLD_FILES+=usr/share/man/man1/cpp.1.gz
 .endif
 
-#.if ${MK_CRYPT} == no
-# to be filled in
-#.endif
-
 .if ${MK_CTM} == no
 OLD_FILES+=usr/sbin/ctm
 OLD_FILES+=usr/sbin/ctm_dequeue
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314822 - stable/10/usr.sbin/syslogd

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 02:01:32 2017
New Revision: 314822
URL: https://svnweb.freebsd.org/changeset/base/314822

Log:
  MFC r314226:
  
  Use SRCTOP instead of .CURDIR relative paths with ".."
  
  This simplifies pathing in make/displayed output

Modified:
  stable/10/usr.sbin/syslogd/Makefile
Directory Properties:
  stable/10/   (props changed)

Modified: stable/10/usr.sbin/syslogd/Makefile
==
--- stable/10/usr.sbin/syslogd/Makefile Tue Mar  7 02:01:02 2017
(r314821)
+++ stable/10/usr.sbin/syslogd/Makefile Tue Mar  7 02:01:32 2017
(r314822)
@@ -3,7 +3,7 @@
 
 .include 
 
-.PATH: ${.CURDIR}/../../usr.bin/wall
+.PATH: ${SRCTOP}/usr.bin/wall
 
 PROG=  syslogd
 MAN=   syslog.conf.5 syslogd.8
@@ -18,6 +18,6 @@ WARNS?= 3
 CFLAGS+= -DINET6
 .endif
 
-CFLAGS+= -I${.CURDIR}/../../usr.bin/wall
+CFLAGS+= -I${SRCTOP}/usr.bin/wall
 
 .include 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314821 - stable/11/lib/libclang_rt/profile

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 02:01:02 2017
New Revision: 314821
URL: https://svnweb.freebsd.org/changeset/base/314821

Log:
  MFC r313009:
  
  Expose symbols in lib/libclang_rt/profile to fix --coverage
  
  The symbols currently hidden in libprofile_rt are needed for linking with
  `clang --coverage` to add coverage counters at link time and produce
  coverage numbers at runtime.
  
  In collaboration with:dim

Modified:
  stable/11/lib/libclang_rt/profile/Makefile
Directory Properties:
  stable/11/   (props changed)

Modified: stable/11/lib/libclang_rt/profile/Makefile
==
--- stable/11/lib/libclang_rt/profile/Makefile  Tue Mar  7 01:58:56 2017
(r314820)
+++ stable/11/lib/libclang_rt/profile/Makefile  Tue Mar  7 02:01:02 2017
(r314821)
@@ -4,6 +4,9 @@
 
 LIB=   clang_rt.profile-${CRTARCH}
 
+# This is needed for --coverage
+CFLAGS+=   -fvisibility=default
+
 SRCS+= profile/GCDAProfiling.c
 SRCS+= profile/InstrProfiling.c
 SRCS+= profile/InstrProfilingBuffer.c
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314820 - stable/10/lib/libutil

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 01:58:56 2017
New Revision: 314820
URL: https://svnweb.freebsd.org/changeset/base/314820

Log:
  MFC r313438:
  
  Clean up trailing and leading whitespace for variables to make it
  consistent with the rest of the file and style.Makefile(9) a bit
  more

Modified:
  stable/10/lib/libutil/Makefile
Directory Properties:
  stable/10/   (props changed)

Modified: stable/10/lib/libutil/Makefile
==
--- stable/10/lib/libutil/Makefile  Tue Mar  7 01:58:39 2017
(r314819)
+++ stable/10/lib/libutil/Makefile  Tue Mar  7 01:58:56 2017
(r314820)
@@ -34,7 +34,7 @@ MAN+= expand_number.3 flopen.3 fparseln.
property.3 pty.3 quotafile.3 realhostname.3 realhostname_sa.3 \
_secure_path.3 trimdomain.3 uucplock.3 pw_util.3
 MAN+=  login.conf.5
-MLINKS+= kld.3 kld_isloaded.3 kld.3 kld_load.3
+MLINKS+=kld.3 kld_isloaded.3 kld.3 kld_load.3
 MLINKS+=login_auth.3 auth_cat.3 login_auth.3 auth_checknologin.3
 MLINKS+=login_cap.3 login_close.3 login_cap.3 login_getcapbool.3 \
login_cap.3 login_getcaplist.3 login_cap.3 login_getcapnum.3 \
@@ -56,9 +56,9 @@ MLINKS+=pidfile.3 pidfile_close.3 \
pidfile.3 pidfile_open.3 \
pidfile.3 pidfile_remove.3 \
pidfile.3 pidfile_write.3
-MLINKS+= property.3 property_find.3  property.3 properties_free.3
-MLINKS+= property.3 properties_read.3
-MLINKS+= pty.3 forkpty.3  pty.3 openpty.3
+MLINKS+=property.3 property_find.3  property.3 properties_free.3
+MLINKS+=property.3 properties_read.3
+MLINKS+=pty.3 forkpty.3  pty.3 openpty.3
 MLINKS+=quotafile.3 quota_close.3 \
quotafile.3 quota_fsname.3 \
quotafile.3 quota_open.3 \
@@ -68,7 +68,7 @@ MLINKS+=quotafile.3 quota_close.3 \
quotafile.3 quota_write_limits.3 \
quotafile.3 quota_write_usage.3
 MLINKS+=uucplock.3 uu_lock.3 uucplock.3 uu_lock_txfr.3 \
-   uucplock.3 uu_lockerr.3 uucplock.3 uu_unlock.3 
+   uucplock.3 uu_lockerr.3 uucplock.3 uu_unlock.3
 MLINKS+=pw_util.3 pw_copy.3 \
pw_util.3 pw_dup.3 \
pw_util.3 pw_edit.3 \
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314819 - stable/11/lib/libutil

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 01:58:39 2017
New Revision: 314819
URL: https://svnweb.freebsd.org/changeset/base/314819

Log:
  MFC r313438:
  
  Clean up trailing and leading whitespace for variables to make it
  consistent with the rest of the file and style.Makefile(9) a bit
  more

Modified:
  stable/11/lib/libutil/Makefile
Directory Properties:
  stable/11/   (props changed)

Modified: stable/11/lib/libutil/Makefile
==
--- stable/11/lib/libutil/Makefile  Tue Mar  7 01:52:56 2017
(r314818)
+++ stable/11/lib/libutil/Makefile  Tue Mar  7 01:58:39 2017
(r314819)
@@ -35,7 +35,7 @@ MAN+= expand_number.3 flopen.3 fparseln.
property.3 pty.3 quotafile.3 realhostname.3 realhostname_sa.3 \
_secure_path.3 trimdomain.3 uucplock.3 pw_util.3
 MAN+=  login.conf.5
-MLINKS+= kld.3 kld_isloaded.3 kld.3 kld_load.3
+MLINKS+=kld.3 kld_isloaded.3 kld.3 kld_load.3
 MLINKS+=login_auth.3 auth_cat.3 login_auth.3 auth_checknologin.3
 MLINKS+=login_cap.3 login_close.3 login_cap.3 login_getcapbool.3 \
login_cap.3 login_getcaplist.3 login_cap.3 login_getcapnum.3 \
@@ -57,9 +57,9 @@ MLINKS+=pidfile.3 pidfile_close.3 \
pidfile.3 pidfile_open.3 \
pidfile.3 pidfile_remove.3 \
pidfile.3 pidfile_write.3
-MLINKS+= property.3 property_find.3  property.3 properties_free.3
-MLINKS+= property.3 properties_read.3
-MLINKS+= pty.3 forkpty.3  pty.3 openpty.3
+MLINKS+=property.3 property_find.3  property.3 properties_free.3
+MLINKS+=property.3 properties_read.3
+MLINKS+=pty.3 forkpty.3  pty.3 openpty.3
 MLINKS+=quotafile.3 quota_close.3 \
quotafile.3 quota_fsname.3 \
quotafile.3 quota_open.3 \
@@ -69,7 +69,7 @@ MLINKS+=quotafile.3 quota_close.3 \
quotafile.3 quota_write_limits.3 \
quotafile.3 quota_write_usage.3
 MLINKS+=uucplock.3 uu_lock.3 uucplock.3 uu_lock_txfr.3 \
-   uucplock.3 uu_lockerr.3 uucplock.3 uu_unlock.3 
+   uucplock.3 uu_lockerr.3 uucplock.3 uu_unlock.3
 MLINKS+=pw_util.3 pw_copy.3 \
pw_util.3 pw_dup.3 \
pw_util.3 pw_edit.3 \
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314818 - in stable/11: contrib/netbsd-tests/dev/audio contrib/netbsd-tests/dev/cgd contrib/netbsd-tests/dev/clock_subr contrib/netbsd-tests/dev/scsipi contrib/netbsd-tests/dev/sysmon c...

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 01:52:56 2017
New Revision: 314818
URL: https://svnweb.freebsd.org/changeset/base/314818

Log:
  MFC r313439,r314450:
  
  r313439:
  
  Merge content from ^/projects/netbsd-tests-upstream-01-2017 into ^/head
  
  The primary end-goal of this drop is ease future merges with NetBSD and
  collaborate further with the NetBSD project.
  
  The goal was (largely, not completely as some items are still oustanding
  in the NetBSD GNATS system) achieved by doing the following:
  - Pushing as many changes required to port contrib/netbsd-tests
back to NetBSD as possible, then pull the upstream applied changes
back in to FreeBSD.
  - Diff reduce with upstream where possible by:
  -- Improving libnetbsd header, etc compat glue.
  -- Using _SED variables to modify test scripts on the fly for items
 that could not be upstreamed to NetBSD.
  
  As a bonus for this work, this change also introduces testcases for
  uniq(1).
  
  Many thanks to Christos for working with me to get many of the changes
  back into the NetBSD project.
  
  In collaboration with:Christos Zoulas 
  
  r314450:
  
  Add additional __FreeBSD_version guards around the hsearch_r testcases
  
  The reasoning for this is the same as r276046: to ease MFCing the tests
  to ^/stable/10 .
  
  This was accidentally missed in r313439

Added:
  stable/11/contrib/netbsd-tests/dev/clock_subr/
 - copied from r313439, head/contrib/netbsd-tests/dev/clock_subr/
  stable/11/contrib/netbsd-tests/fs/vfs/t_mtime_otrunc.c
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/fs/vfs/t_mtime_otrunc.c
  stable/11/contrib/netbsd-tests/fs/vfs/t_rwtoro.c
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/fs/vfs/t_rwtoro.c
  stable/11/contrib/netbsd-tests/kernel/arch/
 - copied from r313439, head/contrib/netbsd-tests/kernel/arch/
  stable/11/contrib/netbsd-tests/lib/libc/gen/exect/
 - copied from r313439, head/contrib/netbsd-tests/lib/libc/gen/exect/
  stable/11/contrib/netbsd-tests/lib/libc/hash/t_hmac.c
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/lib/libc/hash/t_hmac.c
  stable/11/contrib/netbsd-tests/lib/libpthread_dbg/
 - copied from r313439, head/contrib/netbsd-tests/lib/libpthread_dbg/
  stable/11/contrib/netbsd-tests/lib/librefuse/
 - copied from r313439, head/contrib/netbsd-tests/lib/librefuse/
  stable/11/contrib/netbsd-tests/net/carp/t_basic.sh
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/net/carp/t_basic.sh
  stable/11/contrib/netbsd-tests/net/if_tun/
 - copied from r313439, head/contrib/netbsd-tests/net/if_tun/
  stable/11/contrib/netbsd-tests/net/if_vlan/
 - copied from r313439, head/contrib/netbsd-tests/net/if_vlan/
  stable/11/contrib/netbsd-tests/sys/uvm/
 - copied from r313439, head/contrib/netbsd-tests/sys/uvm/
  stable/11/contrib/netbsd-tests/usr.bin/mixerctl/
 - copied from r313439, head/contrib/netbsd-tests/usr.bin/mixerctl/
  stable/11/contrib/netbsd-tests/usr.bin/uniq/
 - copied from r313439, head/contrib/netbsd-tests/usr.bin/uniq/
  stable/11/usr.bin/uniq/tests/
 - copied from r313439, head/usr.bin/uniq/tests/
Deleted:
  stable/11/contrib/netbsd-tests/net/carp/t_basic.c
Modified:
  stable/11/contrib/netbsd-tests/dev/audio/t_pad_output.bz2.uue
  stable/11/contrib/netbsd-tests/dev/cgd/t_cgd_3des.c
  stable/11/contrib/netbsd-tests/dev/cgd/t_cgd_aes.c
  stable/11/contrib/netbsd-tests/dev/cgd/t_cgd_blowfish.c
  stable/11/contrib/netbsd-tests/dev/scsipi/t_cd.c
  stable/11/contrib/netbsd-tests/dev/sysmon/t_swwdog.c
  stable/11/contrib/netbsd-tests/fs/common/h_fsmacros.h
  stable/11/contrib/netbsd-tests/fs/ffs/h_quota2_tests.c
  stable/11/contrib/netbsd-tests/fs/ffs/t_fifos.c
  stable/11/contrib/netbsd-tests/fs/ffs/t_mount.c
  stable/11/contrib/netbsd-tests/fs/ffs/t_quota2_1.c
  stable/11/contrib/netbsd-tests/fs/ffs/t_quota2_remount.c
  stable/11/contrib/netbsd-tests/fs/ffs/t_snapshot.c
  stable/11/contrib/netbsd-tests/fs/ffs/t_snapshot_log.c
  stable/11/contrib/netbsd-tests/fs/ffs/t_snapshot_v2.c
  stable/11/contrib/netbsd-tests/fs/hfs/t_pathconvert.c
  stable/11/contrib/netbsd-tests/fs/kernfs/t_basic.c
  stable/11/contrib/netbsd-tests/fs/lfs/t_pr.c
  stable/11/contrib/netbsd-tests/fs/msdosfs/t_snapshot.c
  stable/11/contrib/netbsd-tests/fs/nfs/t_mountd.c
  stable/11/contrib/netbsd-tests/fs/nullfs/t_basic.c
  stable/11/contrib/netbsd-tests/fs/ptyfs/t_nullpts.c
  stable/11/contrib/netbsd-tests/fs/ptyfs/t_ptyfs.c
  stable/11/contrib/netbsd-tests/fs/puffs/t_basic.c
  stable/11/contrib/netbsd-tests/fs/puffs/t_fuzz.c
  stable/11/contrib/netbsd-tests/fs/puffs/t_io.c
  stable/11/contrib/netbsd-tests/fs/tmpfs/t_mknod.sh
  stable/11/contrib/netbsd-tests/fs/tmpfs/t_readdir.sh
  stable/11/contrib/netbsd-tests/fs/tmpfs/t_renamerace.c
  stable/11/contrib/netbsd-tests/fs/umapfs/t_basic.c
  stable/11/contrib/netbsd-tests/fs/union/t_pr.c
  stable/11/contrib/netbsd-tests/fs/vfs/t_full.c
  stable/11/contrib/netbsd-tests

svn commit: r314817 - in stable/10: contrib/netbsd-tests/dev/audio contrib/netbsd-tests/dev/cgd contrib/netbsd-tests/dev/clock_subr contrib/netbsd-tests/dev/scsipi contrib/netbsd-tests/dev/sysmon c...

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Tue Mar  7 01:52:50 2017
New Revision: 314817
URL: https://svnweb.freebsd.org/changeset/base/314817

Log:
  MFC r314450,r313439:
  
  r314450:
  
  Add additional __FreeBSD_version guards around the hsearch_r testcases
  
  The reasoning for this is the same as r276046: to ease MFCing the tests
  to ^/stable/10 .
  
  This was accidentally missed in r313439
  
  r313439 | ngie | 2017-02-08 01:46:15 -0800 (Wed, 08 Feb 2017) | 25 lines
  
  Merge content from ^/projects/netbsd-tests-upstream-01-2017 into ^/head
  
  The primary end-goal of this drop is ease future merges with NetBSD and
  collaborate further with the NetBSD project.
  
  The goal was (largely, not completely as some items are still oustanding
  in the NetBSD GNATS system) achieved by doing the following:
  - Pushing as many changes required to port contrib/netbsd-tests
back to NetBSD as possible, then pull the upstream applied changes
back in to FreeBSD.
  - Diff reduce with upstream where possible by:
  -- Improving libnetbsd header, etc compat glue.
  -- Using _SED variables to modify test scripts on the fly for items
 that could not be upstreamed to NetBSD.
  
  As a bonus for this work, this change also introduces testcases for
  uniq(1).
  
  Many thanks to Christos for working with me to get many of the changes
  back into the NetBSD project.
  
  In collaboration with:Christos Zoulas 

Added:
  stable/10/contrib/netbsd-tests/dev/clock_subr/
 - copied from r313439, head/contrib/netbsd-tests/dev/clock_subr/
  stable/10/contrib/netbsd-tests/fs/vfs/t_mtime_otrunc.c
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/fs/vfs/t_mtime_otrunc.c
  stable/10/contrib/netbsd-tests/fs/vfs/t_rwtoro.c
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/fs/vfs/t_rwtoro.c
  stable/10/contrib/netbsd-tests/kernel/arch/
 - copied from r313439, head/contrib/netbsd-tests/kernel/arch/
  stable/10/contrib/netbsd-tests/lib/libc/gen/exect/
 - copied from r313439, head/contrib/netbsd-tests/lib/libc/gen/exect/
  stable/10/contrib/netbsd-tests/lib/libc/hash/t_hmac.c
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/lib/libc/hash/t_hmac.c
  stable/10/contrib/netbsd-tests/lib/libpthread_dbg/
 - copied from r313439, head/contrib/netbsd-tests/lib/libpthread_dbg/
  stable/10/contrib/netbsd-tests/lib/librefuse/
 - copied from r313439, head/contrib/netbsd-tests/lib/librefuse/
  stable/10/contrib/netbsd-tests/net/carp/t_basic.sh
 - copied unchanged from r313439, 
head/contrib/netbsd-tests/net/carp/t_basic.sh
  stable/10/contrib/netbsd-tests/net/if_tun/
 - copied from r313439, head/contrib/netbsd-tests/net/if_tun/
  stable/10/contrib/netbsd-tests/net/if_vlan/
 - copied from r313439, head/contrib/netbsd-tests/net/if_vlan/
  stable/10/contrib/netbsd-tests/sys/uvm/
 - copied from r313439, head/contrib/netbsd-tests/sys/uvm/
  stable/10/contrib/netbsd-tests/usr.bin/mixerctl/
 - copied from r313439, head/contrib/netbsd-tests/usr.bin/mixerctl/
  stable/10/contrib/netbsd-tests/usr.bin/uniq/
 - copied from r313439, head/contrib/netbsd-tests/usr.bin/uniq/
  stable/10/usr.bin/uniq/tests/
 - copied from r313439, head/usr.bin/uniq/tests/
Deleted:
  stable/10/contrib/netbsd-tests/net/carp/t_basic.c
Modified:
  stable/10/contrib/netbsd-tests/dev/audio/t_pad_output.bz2.uue
  stable/10/contrib/netbsd-tests/dev/cgd/t_cgd_3des.c
  stable/10/contrib/netbsd-tests/dev/cgd/t_cgd_aes.c
  stable/10/contrib/netbsd-tests/dev/cgd/t_cgd_blowfish.c
  stable/10/contrib/netbsd-tests/dev/scsipi/t_cd.c
  stable/10/contrib/netbsd-tests/dev/sysmon/t_swwdog.c
  stable/10/contrib/netbsd-tests/fs/common/h_fsmacros.h
  stable/10/contrib/netbsd-tests/fs/ffs/h_quota2_tests.c
  stable/10/contrib/netbsd-tests/fs/ffs/t_fifos.c
  stable/10/contrib/netbsd-tests/fs/ffs/t_mount.c
  stable/10/contrib/netbsd-tests/fs/ffs/t_quota2_1.c
  stable/10/contrib/netbsd-tests/fs/ffs/t_quota2_remount.c
  stable/10/contrib/netbsd-tests/fs/ffs/t_snapshot.c
  stable/10/contrib/netbsd-tests/fs/ffs/t_snapshot_log.c
  stable/10/contrib/netbsd-tests/fs/ffs/t_snapshot_v2.c
  stable/10/contrib/netbsd-tests/fs/hfs/t_pathconvert.c
  stable/10/contrib/netbsd-tests/fs/kernfs/t_basic.c
  stable/10/contrib/netbsd-tests/fs/lfs/t_pr.c
  stable/10/contrib/netbsd-tests/fs/msdosfs/t_snapshot.c
  stable/10/contrib/netbsd-tests/fs/nfs/t_mountd.c
  stable/10/contrib/netbsd-tests/fs/nullfs/t_basic.c
  stable/10/contrib/netbsd-tests/fs/ptyfs/t_nullpts.c
  stable/10/contrib/netbsd-tests/fs/ptyfs/t_ptyfs.c
  stable/10/contrib/netbsd-tests/fs/puffs/t_basic.c
  stable/10/contrib/netbsd-tests/fs/puffs/t_fuzz.c
  stable/10/contrib/netbsd-tests/fs/puffs/t_io.c
  stable/10/contrib/netbsd-tests/fs/tmpfs/t_mknod.sh
  stable/10/contrib/netbsd-tests/fs/tmpfs/t_readdir.sh
  stable/10/contrib/netbsd-tests/fs/tmpfs/t_renamerace.c
  stable/10/contrib/netbsd-tests/fs/umapfs/t_basic.c
  stable/10/contrib/netbsd-tests/fs/union/t_pr.c
  stable/10/contr

svn commit: r314816 - head/share/mk

2017-03-06 Thread Simon J. Gerraty
Author: sjg
Date: Tue Mar  7 01:42:30 2017
New Revision: 314816
URL: https://svnweb.freebsd.org/changeset/base/314816

Log:
  Fix typo in comment.

Modified:
  head/share/mk/dirdeps.mk

Modified: head/share/mk/dirdeps.mk
==
--- head/share/mk/dirdeps.mkTue Mar  7 01:15:57 2017(r314815)
+++ head/share/mk/dirdeps.mkTue Mar  7 01:42:30 2017(r314816)
@@ -58,7 +58,7 @@
 #  distinguish them from others.
 #  
 #  Before each Makefile.depend file is read, we set 
-#  DEP_RELDIR to be the the RELDIR (path relative to SRCTOP) for
+#  DEP_RELDIR to be the RELDIR (path relative to SRCTOP) for
 #  its directory, and DEP_MACHINE etc according to the .
 #  represented by the suffix of the corresponding target.
 #  
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314809 - head/share/mk

2017-03-06 Thread Simon J. Gerraty
Bryan Drewery  wrote:

> On 3/6/17 3:13 PM, Simon J. Gerraty wrote:
> > -#  DEP_RELDIR to be the RELDIR (path relative to SRCTOP) for
> > +#  DEP_RELDIR to be the the RELDIR (path relative to SRCTOP) for
> 
> Oops, "the the".

Doh!
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314809 - head/share/mk

2017-03-06 Thread Bryan Drewery
On 3/6/17 3:13 PM, Simon J. Gerraty wrote:
> -#DEP_RELDIR to be the RELDIR (path relative to SRCTOP) for
> +#DEP_RELDIR to be the the RELDIR (path relative to SRCTOP) for

Oops, "the the".

-- 
Regards,
Bryan Drewery



signature.asc
Description: OpenPGP digital signature


svn commit: r314815 - svnadmin/conf

2017-03-06 Thread Sepherosa Ziehau
Author: sephe
Date: Tue Mar  7 01:15:57 2017
New Revision: 314815
URL: https://svnweb.freebsd.org/changeset/base/314815

Log:
  Release Dexuan from mentorship.

Modified:
  svnadmin/conf/mentors

Modified: svnadmin/conf/mentors
==
--- svnadmin/conf/mentors   Tue Mar  7 01:13:26 2017(r314814)
+++ svnadmin/conf/mentors   Tue Mar  7 01:15:57 2017(r314815)
@@ -14,7 +14,6 @@ achim scottl  Co-mentor: emaste
 anish  neelCo-mentor: grehan
 dabvangyzen
 defpjd
-dexuan sephe
 eriae  Co-mentor: thompsa
 ivadaszadrian  Co-mentor: cognet
 jceel  trasz
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314814 - head/sys/dev/cxgbe/iw_cxgbe

2017-03-06 Thread Navdeep Parhar
Author: np
Date: Tue Mar  7 01:13:26 2017
New Revision: 314814
URL: https://svnweb.freebsd.org/changeset/base/314814

Log:
  cxgbe/iw_cxgbe: Abort connection if there is an error during c4iw_modify_qp.
  
  Submitted by: KrishnamRaju ErapaRaju @ Chelsio
  MFC after:3 days
  Sponsored by: Chelsio Communications

Modified:
  head/sys/dev/cxgbe/iw_cxgbe/qp.c

Modified: head/sys/dev/cxgbe/iw_cxgbe/qp.c
==
--- head/sys/dev/cxgbe/iw_cxgbe/qp.cTue Mar  7 00:20:01 2017
(r314813)
+++ head/sys/dev/cxgbe/iw_cxgbe/qp.cTue Mar  7 01:13:26 2017
(r314814)
@@ -1427,6 +1427,7 @@ err:
qhp->ep = NULL;
set_state(qhp, C4IW_QP_STATE_ERROR);
free = 1;
+   abort = 1;
BUG_ON(!ep);
flush_qp(qhp);
wake_up(&qhp->wait);
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314813 - head/sys/kern

2017-03-06 Thread Hiren Panchasara
Author: hiren
Date: Tue Mar  7 00:20:01 2017
New Revision: 314813
URL: https://svnweb.freebsd.org/changeset/base/314813

Log:
  We've found a recurring problem where some userland process would be
  stuck spinning at 100% cpu around sbcut_internal(). Inside
  sbflush_internal(), sb_ccc reached to about 4GB and before passing it
  to sbcut_internal(), we type-cast it from uint to int making it -ve.
  
  The root cause of sockbuf growing this large is unknown. Correct fix
  is also not clear but based on mailing list discussions, adding
  KASSERTs to panic instead of looping endlessly.
  
  Reviewed by:  glebius
  Sponsored by: Limelight Networks

Modified:
  head/sys/kern/uipc_sockbuf.c

Modified: head/sys/kern/uipc_sockbuf.c
==
--- head/sys/kern/uipc_sockbuf.cTue Mar  7 00:13:53 2017
(r314812)
+++ head/sys/kern/uipc_sockbuf.cTue Mar  7 00:20:01 2017
(r314813)
@@ -1043,6 +1043,11 @@ sbcut_internal(struct sockbuf *sb, int l
 {
struct mbuf *m, *next, *mfree;
 
+   KASSERT(len > 0, ("%s: len is %d but it is supposed to be +ve",
+   __func__, len));
+   KASSERT(len <= sb->sb_ccc, ("%s: len: %d is > ccc: %u",
+   __func__, len, sb->sb_ccc));
+
next = (m = sb->sb_mb) ? m->m_nextpkt : 0;
mfree = NULL;
 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314812 - in head: lib/libipsec sbin/setkey sys/net sys/netipsec

2017-03-06 Thread Andrey V. Elsukov
Author: ae
Date: Tue Mar  7 00:13:53 2017
New Revision: 314812
URL: https://svnweb.freebsd.org/changeset/base/314812

Log:
  Introduce the concept of IPsec security policies scope.
  
  Currently are defined three scopes: global, ifnet, and pcb.
  Generic security policies that IKE daemon can add via PF_KEY interface
  or an administrator creates with setkey(8) utility have GLOBAL scope.
  Such policies can be applied by the kernel to outgoing packets and checked
  agains inbound packets after IPsec processing.
  Security policies created by if_ipsec(4) interfaces have IFNET scope.
  Such policies are applied to packets that are passed through if_ipsec(4)
  interface.
  And security policies created by application using setsockopt()
  IP_IPSEC_POLICY option have PCB scope. Such policies are applied to
  packets related to specific socket. Currently there is no way to list
  PCB policies via setkey(8) utility.
  
  Modify setkey(8) and libipsec(3) to be able distinguish the scope of
  security policies in the `setkey -DP` listing. Add two optional flags:
  '-t' to list only policies related to virtual *tunneling* interfaces,
  i.e. policies with IFNET scope, and '-g' to list only policies with GLOBAL
  scope. By default policies from all scopes are listed.
  
  To implement this PF_KEY's sadb_x_policy structure was modified.
  sadb_x_policy_reserved field is used to pass the policy scope from the
  kernel to userland. SADB_SPDDUMP message extended to support filtering
  by scope: sadb_msg_satype field is used to specify bit mask of requested
  scopes.
  
  For IFNET policies the sadb_x_policy_priority field of struct sadb_x_policy
  is used to pass if_ipsec's interface if_index to the userland. For GLOBAL
  policies sadb_x_policy_priority is used only to manage order of security
  policies in the SPDB. For IFNET policies it is not used, so it can be used
  to keep if_index.
  
  After this change the output of `setkey -DP` now looks like:
  # setkey -DPt
  0.0.0.0/0[any] 0.0.0.0/0[any] any
in ipsec
esp/tunnel/87.250.242.144-87.250.242.145/unique:145
spid=7 seq=3 pid=58025 scope=ifnet ifname=ipsec0
refcnt=1
  # setkey -DPg
  ::/0 ::/0 icmp6 135,0
out none
spid=5 seq=1 pid=872 scope=global
refcnt=1
  
  No objection from:#network
  Obtained from:Yandex LLC
  MFC after:2 weeks
  Sponsored by: Yandex LLC
  Differential Revision:https://reviews.freebsd.org/D9805

Modified:
  head/lib/libipsec/pfkey_dump.c
  head/sbin/setkey/setkey.8
  head/sbin/setkey/setkey.c
  head/sys/net/if_ipsec.c
  head/sys/net/pfkeyv2.h
  head/sys/netipsec/ipsec.h
  head/sys/netipsec/key.c

Modified: head/lib/libipsec/pfkey_dump.c
==
--- head/lib/libipsec/pfkey_dump.c  Mon Mar  6 23:47:59 2017
(r314811)
+++ head/lib/libipsec/pfkey_dump.c  Tue Mar  7 00:13:53 2017
(r314812)
@@ -35,8 +35,9 @@ __FBSDID("$FreeBSD$");
 #include 
 #include 
 #include 
-#include 
+#include 
 #include 
+#include 
 #include 
 #include 
 
@@ -204,6 +205,13 @@ static struct val2str str_alg_comp[] = {
{ -1, NULL, },
 };
 
+static struct val2str str_sp_scope[] = {
+   { IPSEC_POLICYSCOPE_GLOBAL, "global" },
+   { IPSEC_POLICYSCOPE_IFNET, "ifnet" },
+   { IPSEC_POLICYSCOPE_PCB, "pcb"},
+   { -1, NULL },
+};
+
 /*
  * dump SADB_MSG formated.  For debugging, you should use kdebug_sadb().
  */
@@ -398,8 +406,7 @@ pfkey_sadump(m)
 }
 
 void
-pfkey_spdump(m)
-   struct sadb_msg *m;
+pfkey_spdump(struct sadb_msg *m)
 {
char pbuf[NI_MAXSERV];
caddr_t mhp[SADB_EXT_MAX + 1];
@@ -507,10 +514,15 @@ pfkey_spdump(m)
}
 
 
-   printf("\tspid=%ld seq=%ld pid=%ld\n",
+   printf("\tspid=%ld seq=%ld pid=%ld scope=",
(u_long)m_xpl->sadb_x_policy_id,
(u_long)m->sadb_msg_seq,
(u_long)m->sadb_msg_pid);
+   GETMSGV2S(str_sp_scope, m_xpl->sadb_x_policy_scope);
+   if (m_xpl->sadb_x_policy_scope == IPSEC_POLICYSCOPE_IFNET &&
+   if_indextoname(m_xpl->sadb_x_policy_ifindex, pbuf) != NULL)
+   printf("ifname=%s", pbuf);
+   printf("\n");
 
/* XXX TEST */
printf("\trefcnt=%u\n", m->sadb_msg_reserved);

Modified: head/sbin/setkey/setkey.8
==
--- head/sbin/setkey/setkey.8   Mon Mar  6 23:47:59 2017(r314811)
+++ head/sbin/setkey/setkey.8   Tue Mar  7 00:13:53 2017(r314812)
@@ -29,7 +29,7 @@
 .\"
 .\" $FreeBSD$
 .\"
-.Dd February 27, 2017
+.Dd March 7, 2017
 .Dt SETKEY 8
 .Os
 .\"
@@ -45,7 +45,7 @@
 .Op Fl v
 .Fl f Ar filename
 .Nm
-.Op Fl aPlv
+.Op Fl Pgltv
 .Fl D
 .Nm
 .Op Fl Pv
@@ -81,18 +81,21 @@ Flush the SAD entries.
 If with
 .Fl P ,
 the SPD entries are flushed.
-.It Fl a
-The
-.Nm
-utility
-usually does not display dead SAD entries with
-.Fl D .
-If with
-.Fl a ,
-the dea

svn commit: r314811 - in head/sys: arm/allwinner arm/amlogic/aml8726 arm/at91 arm/broadcom/bcm2835 arm/lpc arm/nvidia arm/ti dev/mmc dev/mmc/host dev/sdhci mips/ingenic

2017-03-06 Thread Marius Strobl
Author: marius
Date: Mon Mar  6 23:47:59 2017
New Revision: 314811
URL: https://svnweb.freebsd.org/changeset/base/314811

Log:
  o Another round fixes for mmc(4), mmcsd(4) and sdhci(4) regarding
comments, marking unused parameters as such, style(9), whitespace,
etc.
  o In the mmc(4) bridges and sdhci(4) (bus) front-ends:
- Remove redundant assignments of the default bus_generic_print_child
  device method (I've whipped these out of the tree as part of r227843
  once, but they keep coming back ...),
- use DEVMETHOD_END,
- use NULL instead of 0 for pointers.
  o Trim/adjust includes.

Modified:
  head/sys/arm/allwinner/a10_mmc.c
  head/sys/arm/amlogic/aml8726/aml8726_mmc.c
  head/sys/arm/amlogic/aml8726/aml8726_sdxc-m8.c
  head/sys/arm/at91/at91_mci.c
  head/sys/arm/broadcom/bcm2835/bcm2835_sdhci.c
  head/sys/arm/lpc/lpc_mmc.c
  head/sys/arm/nvidia/tegra_sdhci.c
  head/sys/arm/ti/ti_sdhci.c
  head/sys/dev/mmc/bridge.h
  head/sys/dev/mmc/host/dwmmc.c
  head/sys/dev/mmc/mmc.c
  head/sys/dev/mmc/mmcbrvar.h
  head/sys/dev/mmc/mmcsd.c
  head/sys/dev/mmc/mmcvar.h
  head/sys/dev/sdhci/fsl_sdhci.c
  head/sys/dev/sdhci/sdhci.c
  head/sys/dev/sdhci/sdhci_acpi.c
  head/sys/dev/sdhci/sdhci_fdt.c
  head/sys/dev/sdhci/sdhci_pci.c
  head/sys/mips/ingenic/jz4780_mmc.c

Modified: head/sys/arm/allwinner/a10_mmc.c
==
--- head/sys/arm/allwinner/a10_mmc.cMon Mar  6 23:41:23 2017
(r314810)
+++ head/sys/arm/allwinner/a10_mmc.cMon Mar  6 23:47:59 2017
(r314811)
@@ -45,7 +45,6 @@ __FBSDID("$FreeBSD$");
 #include 
 
 #include 
-#include 
 #include 
 
 #include 
@@ -898,7 +897,6 @@ static device_method_t a10_mmc_methods[]
/* Bus interface */
DEVMETHOD(bus_read_ivar,a10_mmc_read_ivar),
DEVMETHOD(bus_write_ivar,   a10_mmc_write_ivar),
-   DEVMETHOD(bus_print_child,  bus_generic_print_child),
 
/* MMC bridge interface */
DEVMETHOD(mmcbr_update_ios, a10_mmc_update_ios),
@@ -918,6 +916,7 @@ static driver_t a10_mmc_driver = {
sizeof(struct a10_mmc_softc),
 };
 
-DRIVER_MODULE(a10_mmc, simplebus, a10_mmc_driver, a10_mmc_devclass, 0, 0);
+DRIVER_MODULE(a10_mmc, simplebus, a10_mmc_driver, a10_mmc_devclass, NULL,
+NULL);
 DRIVER_MODULE(mmc, a10_mmc, mmc_driver, mmc_devclass, NULL, NULL);
 MODULE_DEPEND(a10_mmc, mmc, 1, 1, 1);

Modified: head/sys/arm/amlogic/aml8726/aml8726_mmc.c
==
--- head/sys/arm/amlogic/aml8726/aml8726_mmc.c  Mon Mar  6 23:41:23 2017
(r314810)
+++ head/sys/arm/amlogic/aml8726/aml8726_mmc.c  Mon Mar  6 23:47:59 2017
(r314811)
@@ -33,7 +33,6 @@ __FBSDID("$FreeBSD$");
 
 #include 
 #include 
-#include 
 #include 
 #include 
 #include 
@@ -51,7 +50,6 @@ __FBSDID("$FreeBSD$");
 #include 
 
 #include 
-#include 
 #include 
 
 #include 
@@ -1095,7 +1093,7 @@ static driver_t aml8726_mmc_driver = {
 static devclass_t aml8726_mmc_devclass;
 
 DRIVER_MODULE(aml8726_mmc, simplebus, aml8726_mmc_driver,
-aml8726_mmc_devclass, 0, 0);
+aml8726_mmc_devclass, NULL, NULL);
 MODULE_DEPEND(aml8726_mmc, aml8726_gpio, 1, 1, 1);
 DRIVER_MODULE(mmc, aml8726_mmc, mmc_driver, mmc_devclass, NULL, NULL);
 MODULE_DEPEND(aml8726_mmc, mmc, 1, 1, 1);

Modified: head/sys/arm/amlogic/aml8726/aml8726_sdxc-m8.c
==
--- head/sys/arm/amlogic/aml8726/aml8726_sdxc-m8.c  Mon Mar  6 23:41:23 
2017(r314810)
+++ head/sys/arm/amlogic/aml8726/aml8726_sdxc-m8.c  Mon Mar  6 23:47:59 
2017(r314811)
@@ -33,7 +33,6 @@ __FBSDID("$FreeBSD$");
 
 #include 
 #include 
-#include 
 #include 
 #include 
 #include 
@@ -1374,7 +1373,7 @@ static driver_t aml8726_sdxc_driver = {
 static devclass_t aml8726_sdxc_devclass;
 
 DRIVER_MODULE(aml8726_sdxc, simplebus, aml8726_sdxc_driver,
-aml8726_sdxc_devclass, 0, 0);
+aml8726_sdxc_devclass, NULL, NULL);
 MODULE_DEPEND(aml8726_sdxc, aml8726_gpio, 1, 1, 1);
 DRIVER_MODULE(mmc, aml8726_sdxc, mmc_driver, mmc_devclass, NULL, NULL);
 MODULE_DEPEND(aml8726_sdxc, mmc, 1, 1, 1);

Modified: head/sys/arm/at91/at91_mci.c
==
--- head/sys/arm/at91/at91_mci.cMon Mar  6 23:41:23 2017
(r314810)
+++ head/sys/arm/at91/at91_mci.cMon Mar  6 23:47:59 2017
(r314811)
@@ -32,23 +32,16 @@ __FBSDID("$FreeBSD$");
 
 #include 
 #include 
-#include 
 #include 
-#include 
 #include 
 #include 
-#include 
 #include 
 #include 
 #include 
 #include 
-#include 
 #include 
 #include 
 #include 
-#include 
-#include 
-#include 
 
 #include 
 #include 
@@ -59,7 +52,6 @@ __FBSDID("$FreeBSD$");
 #include 
 
 #include 
-#include 
 #include 
 
 #ifdef FDT

Modified: head/sys/arm/broadcom/bcm2835/bcm2835_sdhci.c
=

Re: svn commit: r314702 - stable/11/sys/netpfil/pf

2017-03-06 Thread Kristof Provost

Oops. That’ll teach me to commit things while jet-lagged.
It’s been committed on head in r314810.

Thanks for the heads up.

Regards,
Kristof

On 7 Mar 2017, at 8:01, Gleb Smirnoff wrote:


  Kristof,

  this seems accidentially committed to stable branch. Please add it
to head.

And thanks a lot for the fix. Very likely this is my mistake back from 
2012.


On Sun, Mar 05, 2017 at 01:14:18PM +, Kristof Provost wrote:
K> Author: kp
K> Date: Sun Mar  5 13:14:18 2017
K> New Revision: 314702
K> URL: https://svnweb.freebsd.org/changeset/base/314702
K>
K> Log:
K>   pf: Fix a crash in low-memory situations
K>
K>   If the call to pf_state_key_clone() in pf_get_translation() fails 
(i.e. there's
K>   no more memory for it) it frees skp. This is wrong, because skp 
is a
K>   pf_state_key **, so we need to free *skp, as is done later in the 
function.
K>   Getting it wrong means we try to free a stack variable of the 
calling

K>   pf_test_rule() function, and we panic.
K>
K> Modified:
K>   stable/11/sys/netpfil/pf/pf_lb.c
K>
K> Modified: stable/11/sys/netpfil/pf/pf_lb.c
K> 
==
K> --- stable/11/sys/netpfil/pf/pf_lb.c	Sun Mar  5 12:06:45 
2017	(r314701)
K> +++ stable/11/sys/netpfil/pf/pf_lb.c	Sun Mar  5 13:14:18 
2017	(r314702)

K> @@ -553,7 +553,7 @@ pf_get_translation(struct pf_pdesc *pd,
K>   return (NULL);
K>   *nkp = pf_state_key_clone(*skp);
K>   if (*nkp == NULL) {
K> - uma_zfree(V_pf_state_key_z, skp);
K> + uma_zfree(V_pf_state_key_z, *skp);
K>   *skp = NULL;
K>   return (NULL);
K>   }
K> ___
K> svn-src-all@freebsd.org mailing list
K> https://lists.freebsd.org/mailman/listinfo/svn-src-all
K> To unsubscribe, send any mail to 
"svn-src-all-unsubscr...@freebsd.org"


--
Totus tuus, Glebius.

___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"

svn commit: r314810 - head/sys/netpfil/pf

2017-03-06 Thread Kristof Provost
Author: kp
Date: Mon Mar  6 23:41:23 2017
New Revision: 314810
URL: https://svnweb.freebsd.org/changeset/base/314810

Log:
  pf: Fix a crash in low-memory situations
  
  If the call to pf_state_key_clone() in pf_get_translation() fails (i.e. 
there's
  no more memory for it) it frees skp. This is wrong, because skp is a
  pf_state_key **, so we need to free *skp, as is done later in the function.
  Getting it wrong means we try to free a stack variable of the calling
  pf_test_rule() function, and we panic.

Modified:
  head/sys/netpfil/pf/pf_lb.c

Modified: head/sys/netpfil/pf/pf_lb.c
==
--- head/sys/netpfil/pf/pf_lb.c Mon Mar  6 23:13:25 2017(r314809)
+++ head/sys/netpfil/pf/pf_lb.c Mon Mar  6 23:41:23 2017(r314810)
@@ -553,7 +553,7 @@ pf_get_translation(struct pf_pdesc *pd, 
return (NULL);
*nkp = pf_state_key_clone(*skp);
if (*nkp == NULL) {
-   uma_zfree(V_pf_state_key_z, skp);
+   uma_zfree(V_pf_state_key_z, *skp);
*skp = NULL;
return (NULL);
}
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314654 - in head/cddl: lib/drti lib/libavl lib/libctf lib/libdtrace lib/libnvpair lib/libumem lib/libuutil lib/libzfs lib/libzfs_core lib/libzpool sbin/zfs sbin/zpool usr.bin/ctfconve

2017-03-06 Thread Kurt Lidl

On 3/4/17 3:39 PM, Rodney W. Grimes wrote:


Idk, maybe I am to personally attached to the relative paths.. cause I
had a major part in helping them all to work, or perhaps its my been
burned by absolute paths that had to be reworked too many times in
my past.  But my gutt is telling me this change is Bad(tm).



At my prior job, where we ended up starting off with a bunch of userland
programs in a repository, we had a variable that was set to get you
to the top of the source tree.  It was set in ../Makefile.inc, so if
one just used ".include " in the Makefile, one got
the variable "for free", as the stock bsd.prog.mk file would include
the ../Makefile.inc by default.

While there were maintenance issues with this scheme, I ultimately
ended up coding up something similar to the SRCTOP for our purposes,
once we decided to start moving programs around in the tree.

I think one of the big issues with relative locations of other resources
in the tree is that one has to encode two pieces of information in
the Makefiles.  Both the location of the program being compiled (so
it can find the top), and the location of the resource that is being
accessed (so the compile can walk down the tree to find whatever is
being referenced).

With something like SRCTOP, only the second piece of information needs
to be encoded in the Makefile.  I think that eliminating half of the
information about how to find the external resources is actually a good
thing.

-Kurt

___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314809 - head/share/mk

2017-03-06 Thread Simon J. Gerraty
Author: sjg
Date: Mon Mar  6 23:13:25 2017
New Revision: 314809
URL: https://svnweb.freebsd.org/changeset/base/314809

Log:
  Update dirdeps/meta bits from latest bmake.

Modified:
  head/share/mk/dirdeps.mk
  head/share/mk/meta.stage.mk
  head/share/mk/meta2deps.py

Modified: head/share/mk/dirdeps.mk
==
--- head/share/mk/dirdeps.mkMon Mar  6 23:02:33 2017(r314808)
+++ head/share/mk/dirdeps.mkMon Mar  6 23:13:25 2017(r314809)
@@ -1,5 +1,5 @@
 # $FreeBSD$
-# $Id: dirdeps.mk,v 1.84 2016/11/27 02:44:34 sjg Exp $
+# $Id: dirdeps.mk,v 1.86 2017/03/01 20:26:51 sjg Exp $
 
 # Copyright (c) 2010-2013, Juniper Networks, Inc.
 # All rights reserved.
@@ -58,7 +58,7 @@
 #  distinguish them from others.
 #  
 #  Before each Makefile.depend file is read, we set 
-#  DEP_RELDIR to be the RELDIR (path relative to SRCTOP) for
+#  DEP_RELDIR to be the the RELDIR (path relative to SRCTOP) for
 #  its directory, and DEP_MACHINE etc according to the .
 #  represented by the suffix of the corresponding target.
 #  
@@ -198,7 +198,9 @@ DEP_$v ?= ${$v}
 # we compute below are fully qualified wrt DEP_TARGET_SPEC.
 # The makefiles may only partially specify (eg. MACHINE only),
 # so we need to construct a set of modifiers to fill in the gaps.
-.if ${TARGET_SPEC_VARS:[#]} > 10
+.if ${MAKE_VERSION} >= 20170130
+_tspec_x := ${TARGET_SPEC_VARS:range}
+.elif ${TARGET_SPEC_VARS:[#]} > 10
 # seriously? better have jot(1) or equivalent to produce suitable sequence
 _tspec_x := ${${JOT:Ujot} ${TARGET_SPEC_VARS:[#]}:L:sh}
 .else
@@ -613,11 +615,11 @@ _build_dirs += \
 # qualify everything now
 _build_dirs := ${_build_dirs:${M_dep_qual_fixes:ts:}:O:u}
 
+.endif # empty DIRDEPS
+
 _build_all_dirs += ${_build_dirs}
 _build_all_dirs := ${_build_all_dirs:O:u}
 
-.endif # empty DIRDEPS
-
 # Normally if doing make -V something,
 # we do not want to waste time chasing DIRDEPS
 # but if we want to count the number of Makefile.depend* read, we do.

Modified: head/share/mk/meta.stage.mk
==
--- head/share/mk/meta.stage.mk Mon Mar  6 23:02:33 2017(r314808)
+++ head/share/mk/meta.stage.mk Mon Mar  6 23:13:25 2017(r314809)
@@ -1,7 +1,7 @@
 # $FreeBSD$
-# $Id: meta.stage.mk,v 1.47 2016/12/07 23:07:49 sjg Exp $
+# $Id: meta.stage.mk,v 1.48 2017/03/01 22:48:07 sjg Exp $
 #
-#  @(#) Copyright (c) 2011, Simon J. Gerraty
+#  @(#) Copyright (c) 2011-2017, Simon J. Gerraty
 #
 #  This file is provided in the hope that it will
 #  be of use.  There is absolutely NO WARRANTY.
@@ -15,7 +15,7 @@
 #
 
 .if !target(__${.PARSEFILE}__)
-__${.PARSEFILE}__:
+# the guard target is defined later
 
 .if ${.MAKE.DEPENDFILE_PREFERENCE:U${.MAKE.DEPENDFILE}:M*.${MACHINE}} != ""
 # this is generally safer anyway
@@ -128,26 +128,17 @@ STAGE_AS_SCRIPT = ${STAGE_DIRDEP_SCRIPT}
   done; :; }
 
 # this is simple, a list of the "staged" files depends on this,
-_STAGE_BASENAME_USE:   .USE ${.TARGET:T}
+_STAGE_BASENAME_USE:   .USE .dirdep ${.TARGET:T}
@${STAGE_FILE_SCRIPT}; StageFiles ${.TARGET:H:${STAGE_DIR_FILTER}} 
${.TARGET:T}
 
-_STAGE_AS_BASENAME_USE:.USE ${.TARGET:T}
+_STAGE_AS_BASENAME_USE:.USE .dirdep ${.TARGET:T}
@${STAGE_AS_SCRIPT}; StageAs ${.TARGET:H:${STAGE_DIR_FILTER}} 
${.TARGET:T} ${STAGE_AS_${.TARGET:T}:U${.TARGET:T}}
 
-.if !empty(STAGE_INCSDIR)
-STAGE_TARGETS += stage_incs
-STAGE_INCS ?= ${.ALLSRC:N.dirdep:Nstage_*}
 
 stage_includes: stage_incs
 stage_incs:.dirdep
@${STAGE_FILE_SCRIPT}; StageFiles ${STAGE_INCSDIR:${STAGE_DIR_FILTER}} 
${STAGE_INCS}
@touch $@
-.endif
-
-.if !empty(STAGE_LIBDIR)
-STAGE_TARGETS += stage_libs
-
-STAGE_LIBS ?= ${.ALLSRC:N.dirdep:Nstage_*}
 
 stage_libs:.dirdep
@${STAGE_FILE_SCRIPT}; StageFiles ${STAGE_LIBDIR:${STAGE_DIR_FILTER}} 
${STAGE_LIBS}
@@ -160,6 +151,18 @@ stage_libs:.dirdep
 .endif
 .endif
@touch $@
+
+.endif # first time
+
+
+.if !empty(STAGE_INCSDIR)
+STAGE_TARGETS += stage_incs
+STAGE_INCS ?= ${.ALLSRC:N.dirdep:Nstage_*}
+.endif
+
+.if !empty(STAGE_LIBDIR)
+STAGE_TARGETS += stage_libs
+STAGE_LIBS ?= ${.ALLSRC:N.dirdep:Nstage_*}
 .endif
 
 .if !empty(STAGE_DIR)
@@ -185,6 +188,8 @@ STAGE_LINKS_DIR.$s ?= ${STAGE_OBJTOP}
 STAGE_SYMLINKS_DIR.$s ?= ${STAGE_OBJTOP}
 
 STAGE_TARGETS += stage_files
+.if !target(.stage_files.$s)
+.stage_files.$s:
 .if $s != "_default"
 stage_files:   stage_files.$s
 stage_files.$s:.dirdep
@@ -193,8 +198,11 @@ stage_files:   .dirdep
 .endif
@${STAGE_FILE_SCRIPT}; StageFiles ${FLAGS.$@} 
${STAGE_FILES_DIR.$s:U${STAGE_DIR.$s}:${STAGE_DIR_FILTER}} ${STAGE_FILES.$s}
@touch $@
+.endif
 
 STAGE_TARGETS += stage_links
+.if !target(.stage_links.$s)
+.stage_links.$s:
 .if $s != "_default"
 stage_links: 

svn commit: r314808 - in head: contrib/bmake contrib/bmake/PSD.doc contrib/bmake/mk contrib/bmake/unit-tests usr.bin/bmake

2017-03-06 Thread Simon J. Gerraty
Author: sjg
Date: Mon Mar  6 23:02:33 2017
New Revision: 314808
URL: https://svnweb.freebsd.org/changeset/base/314808

Log:
  Merge bmake-20170301

Modified:
  head/contrib/bmake/ChangeLog
  head/contrib/bmake/Makefile
  head/contrib/bmake/PSD.doc/tutorial.ms
  head/contrib/bmake/bmake.1
  head/contrib/bmake/bmake.cat1
  head/contrib/bmake/dir.c
  head/contrib/bmake/main.c
  head/contrib/bmake/make.1
  head/contrib/bmake/meta.c
  head/contrib/bmake/mk/ChangeLog
  head/contrib/bmake/mk/dirdeps.mk
  head/contrib/bmake/mk/dpadd.mk
  head/contrib/bmake/mk/install-mk
  head/contrib/bmake/mk/meta.stage.mk
  head/contrib/bmake/mk/meta2deps.py
  head/contrib/bmake/mk/prog.mk
  head/contrib/bmake/mk/subdir.mk
  head/contrib/bmake/mk/sys.mk
  head/contrib/bmake/mk/sys.vars.mk
  head/contrib/bmake/os.sh
  head/contrib/bmake/parse.c
  head/contrib/bmake/unit-tests/varmisc.exp
  head/contrib/bmake/unit-tests/varmisc.mk
  head/contrib/bmake/var.c
  head/usr.bin/bmake/Makefile
Directory Properties:
  head/contrib/bmake/   (props changed)

Modified: head/contrib/bmake/ChangeLog
==
--- head/contrib/bmake/ChangeLogMon Mar  6 22:46:49 2017
(r314807)
+++ head/contrib/bmake/ChangeLogMon Mar  6 23:02:33 2017
(r314808)
@@ -1,3 +1,32 @@
+2017-03-01  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170301
+ Merge with NetBSD make, pick up
+ o main.c: use -C arg as is rather than getcwd()
+   if they identify the same directory.
+ o parse.c: ensure loadfile buffer is \n terminated in non-mmap case
+
+2017-02-01  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170201
+ Merge with NetBSD make, pick up
+ o var.c: allow :_=var and avoid use of special context.
+
+2017-01-30  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170130
+ Merge with NetBSD make, pick up
+ o var.c: add :range and :_
+ o main.c: partially initialize Dir_* before MainParseArgs()
+   can be called.
+   If -V, skip Main_ExportMAKEFLAGS()
+
+2017-01-14  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170114
+ Merge with NetBSD make, pick up
+ o var.c: allow specifying the utc value used by :{gm,local}time
+
 2016-12-12  Simon J. Gerraty  
 
* Makefile (_MAKE_VERSION): 20161212

Modified: head/contrib/bmake/Makefile
==
--- head/contrib/bmake/Makefile Mon Mar  6 22:46:49 2017(r314807)
+++ head/contrib/bmake/Makefile Mon Mar  6 23:02:33 2017(r314808)
@@ -1,7 +1,7 @@
-#  $Id: Makefile,v 1.77 2016/12/12 07:34:19 sjg Exp $
+#  $Id: Makefile,v 1.81 2017/03/01 17:01:23 sjg Exp $
 
 # Base version on src date
-_MAKE_VERSION= 20161212
+_MAKE_VERSION= 20170301
 
 PROG=  bmake
 

Modified: head/contrib/bmake/PSD.doc/tutorial.ms
==
--- head/contrib/bmake/PSD.doc/tutorial.ms  Mon Mar  6 22:46:49 2017
(r314807)
+++ head/contrib/bmake/PSD.doc/tutorial.ms  Mon Mar  6 23:02:33 2017
(r314808)
@@ -1,4 +1,4 @@
-.\"$NetBSD: tutorial.ms,v 1.12 2014/09/30 21:33:14 christos Exp $
+.\"$NetBSD: tutorial.ms,v 1.13 2017/03/01 13:05:11 kre Exp $
 .\" Copyright (c) 1988, 1989, 1993
 .\"The Regents of the University of California.  All rights reserved.
 .\"
@@ -117,6 +117,15 @@
 .de No
 .br
 .ne 0.5i
+.ie n \{\
+.nr g3 \w'NOTE '
+.po -\\n(g3u
+.br
+NOTE
+.br
+.po +\\n(g3u
+.\}
+.el \{\
 .po -0.5i
 .br
 .mk 
@@ -148,12 +157,14 @@
 .rt 
 .ft \\n(g3
 .ps \\n(g4
+.\}
 ..
 .de Bp
 .ie !\\n(.$ .IP \(bu 2
 .el .IP "\&" 2
 ..
-.po +.3i
+.ie n .po +\w'NOTE  'u
+.el .po +.3i
 .TL
 PMake \*- A Tutorial
 .AU

Modified: head/contrib/bmake/bmake.1
==
--- head/contrib/bmake/bmake.1  Mon Mar  6 22:46:49 2017(r314807)
+++ head/contrib/bmake/bmake.1  Mon Mar  6 23:02:33 2017(r314808)
@@ -1,4 +1,4 @@
-.\"$NetBSD: make.1,v 1.263 2016/08/26 23:37:54 dholland Exp $
+.\"$NetBSD: make.1,v 1.266 2017/02/01 18:39:27 sjg Exp $
 .\"
 .\" Copyright (c) 1990, 1993
 .\"The Regents of the University of California.  All rights reserved.
@@ -29,7 +29,7 @@
 .\"
 .\"from: @(#)make.18.4 (Berkeley) 3/19/94
 .\"
-.Dd August 26, 2016
+.Dd February 1, 2017
 .Dt BMAKE 1
 .Os
 .Sh NAME
@@ -1205,18 +1205,28 @@ safely through recursive invocations of
 .Nm .
 .It Cm \&:R
 Replaces each word in the variable with everything but its suffix.
-.It Cm \&:gmtime
+.It Cm \&:range[=count]
+The value is an integer sequence representing the words of the original
+value, or the supplied
+.Va count .
+.It Cm \&:gmtime[=utc]
 The value is a format string for
 .Xr strftime 3 ,
-using the current
+using
 .Xr gmtime 3 .
+If a
+.Va utc
+value is not provided or is 0, the current t

Re: svn commit: r314702 - stable/11/sys/netpfil/pf

2017-03-06 Thread Gleb Smirnoff
  Kristof,

  this seems accidentially committed to stable branch. Please add it
to head.

And thanks a lot for the fix. Very likely this is my mistake back from 2012.

On Sun, Mar 05, 2017 at 01:14:18PM +, Kristof Provost wrote:
K> Author: kp
K> Date: Sun Mar  5 13:14:18 2017
K> New Revision: 314702
K> URL: https://svnweb.freebsd.org/changeset/base/314702
K> 
K> Log:
K>   pf: Fix a crash in low-memory situations
K>   
K>   If the call to pf_state_key_clone() in pf_get_translation() fails (i.e. 
there's
K>   no more memory for it) it frees skp. This is wrong, because skp is a
K>   pf_state_key **, so we need to free *skp, as is done later in the function.
K>   Getting it wrong means we try to free a stack variable of the calling
K>   pf_test_rule() function, and we panic.
K> 
K> Modified:
K>   stable/11/sys/netpfil/pf/pf_lb.c
K> 
K> Modified: stable/11/sys/netpfil/pf/pf_lb.c
K> 
==
K> --- stable/11/sys/netpfil/pf/pf_lb.c Sun Mar  5 12:06:45 2017
(r314701)
K> +++ stable/11/sys/netpfil/pf/pf_lb.c Sun Mar  5 13:14:18 2017
(r314702)
K> @@ -553,7 +553,7 @@ pf_get_translation(struct pf_pdesc *pd, 
K>  return (NULL);
K>  *nkp = pf_state_key_clone(*skp);
K>  if (*nkp == NULL) {
K> -uma_zfree(V_pf_state_key_z, skp);
K> +uma_zfree(V_pf_state_key_z, *skp);
K>  *skp = NULL;
K>  return (NULL);
K>  }
K> ___
K> svn-src-all@freebsd.org mailing list
K> https://lists.freebsd.org/mailman/listinfo/svn-src-all
K> To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"

-- 
Totus tuus, Glebius.
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314807 - head/lib/libc/tests/nss

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 22:46:49 2017
New Revision: 314807
URL: https://svnweb.freebsd.org/changeset/base/314807

Log:
  Move ATF_TC_WITHOUT_HEAD(getgrent) near the testcase it annotates
  
  MFC after:1 week
  Sponsored by: Dell EMC Isilon

Modified:
  head/lib/libc/tests/nss/getgr_test.c

Modified: head/lib/libc/tests/nss/getgr_test.c
==
--- head/lib/libc/tests/nss/getgr_test.cMon Mar  6 22:32:56 2017
(r314806)
+++ head/lib/libc/tests/nss/getgr_test.cMon Mar  6 22:46:49 2017
(r314807)
@@ -479,6 +479,7 @@ fin:
 
 #defineSNAPSHOT_FILE   "snapshot_grp"
 
+ATF_TC_WITHOUT_HEAD(getgrent);
 ATF_TC_BODY(getgrent, tc)
 {
 
@@ -530,7 +531,6 @@ ATF_TC_BODY(getgrnam_with_snapshot, tc)
ATF_REQUIRE(run_tests(SNAPSHOT_FILE, TEST_GETGRNAM) == 0);
 }
 
-ATF_TC_WITHOUT_HEAD(getgrent);
 ATF_TP_ADD_TCS(tp)
 {
 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314806 - head/sys/kern

2017-03-06 Thread Gleb Smirnoff
Author: glebius
Date: Mon Mar  6 22:32:56 2017
New Revision: 314806
URL: https://svnweb.freebsd.org/changeset/base/314806

Log:
  Fix compilation of r314784 on 32 bit.

Modified:
  head/sys/kern/kern_shutdown.c

Modified: head/sys/kern/kern_shutdown.c
==
--- head/sys/kern/kern_shutdown.c   Mon Mar  6 22:18:14 2017
(r314805)
+++ head/sys/kern/kern_shutdown.c   Mon Mar  6 22:32:56 2017
(r314806)
@@ -764,7 +764,7 @@ vpanic(const char *fmt, va_list ap)
 #ifdef SMP
printf("cpuid = %d\n", PCPU_GET(cpuid));
 #endif
-   printf("time = %ld\n", time_second);
+   printf("time = %jd\n", (intmax_t )time_second);
 #ifdef KDB
if (newpanic && trace_on_panic)
kdb_backtrace();
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314805 - in head/contrib/atf: atf-c atf-c++ atf-sh

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 22:18:14 2017
New Revision: 314805
URL: https://svnweb.freebsd.org/changeset/base/314805

Log:
  Remove *-api(3) manpages removed in ATF 0.21
  
  I overlooked the fact that these manpages had been removed upstream
  and replaced with their non *-api(3) equivalents. Follow upstream's
  lead and remove the unused manpages.
  
  MFC after:1 week
  Sponsored by: Dell EMC Isilon

Deleted:
  head/contrib/atf/atf-c++/atf-c++-api.3
  head/contrib/atf/atf-c/atf-c-api.3
  head/contrib/atf/atf-sh/atf-sh-api.3
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314804 - head/contrib/atf/atf-c++

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 22:08:47 2017
New Revision: 314804
URL: https://svnweb.freebsd.org/changeset/base/314804

Log:
  Fix issues noted by igor/manlint
  
  - Fix typos [1]:
  -- manged -> managed
  -- specifiying -> specifying
  - Escape '.' at start of lines using & to tell the roff processor
that the line isn't meant to be treated as a command [2].
  
  Bump .Dd for the change
  
  MFC after:1 week
  Reported by:  igor [1], manlint [2]
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-c++/atf-c++.3

Modified: head/contrib/atf/atf-c++/atf-c++.3
==
--- head/contrib/atf/atf-c++/atf-c++.3  Mon Mar  6 21:50:35 2017
(r314803)
+++ head/contrib/atf/atf-c++/atf-c++.3  Mon Mar  6 22:08:47 2017
(r314804)
@@ -22,7 +22,7 @@
 .\" IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-.Dd October 13, 2014
+.Dd March 6, 2017
 .Dt ATF-C++ 3
 .Os
 .Sh NAME
@@ -145,10 +145,10 @@ ATF provides a C++ programming interface
 C++-based test programs follow this template:
 .Bd -literal -offset indent
 extern "C" {
-.Ns ... C-specific includes go here ...
+\&... C-specific includes go here ...
 }
 
-.Ns ... C++-specific includes go here ...
+\&... C++-specific includes go here ...
 
 #include 
 
@@ -182,7 +182,7 @@ ATF_TEST_CASE_BODY(tc3)
 ... third test case's body ...
 }
 
-.Ns ... additional test cases ...
+\&... additional test cases ...
 
 ATF_INIT_TEST_CASES(tcs)
 {
@@ -202,7 +202,7 @@ To define test cases, one can use the
 .Fn ATF_TEST_CASE_WITH_CLEANUP
 or the
 .Fn ATF_TEST_CASE_WITHOUT_HEAD
-macros, which take a single parameter specifiying the test case's
+macros, which take a single parameter specifying the test case's
 name.
 .Fn ATF_TEST_CASE ,
 requires to define a head and a body for the test case,
@@ -232,7 +232,7 @@ opening and closing brackets.
 Additionally, the
 .Fn ATF_TEST_CASE_NAME
 macro can be used to obtain the name of the class corresponding to a
-particular test case, as the name is internally manged by the library to
+particular test case, as the name is internally managed by the library to
 prevent clashes with other user identifiers.
 Similarly, the
 .Fn ATF_TEST_CASE_USE
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314803 - head/contrib/atf/atf-c++

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:50:35 2017
New Revision: 314803
URL: https://svnweb.freebsd.org/changeset/base/314803

Log:
  Fix typos
  
  - specifiying -> specifying
  - manged -> managed
  
  Bump .Dd for the change
  
  MFC after:1 week
  Reported by:  igor
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-c++/atf-c++-api.3

Modified: head/contrib/atf/atf-c++/atf-c++-api.3
==
--- head/contrib/atf/atf-c++/atf-c++-api.3  Mon Mar  6 21:45:25 2017
(r314802)
+++ head/contrib/atf/atf-c++/atf-c++-api.3  Mon Mar  6 21:50:35 2017
(r314803)
@@ -26,7 +26,7 @@
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 .\"
-.Dd March 2, 2014
+.Dd March 6, 2017
 .Dt ATF-C++-API 3
 .Os
 .Sh NAME
@@ -206,7 +206,7 @@ To define test cases, one can use the
 .Fn ATF_TEST_CASE_WITH_CLEANUP
 or the
 .Fn ATF_TEST_CASE_WITHOUT_HEAD
-macros, which take a single parameter specifiying the test case's
+macros, which take a single parameter specifying the test case's
 name.
 .Fn ATF_TEST_CASE ,
 requires to define a head and a body for the test case,
@@ -236,7 +236,7 @@ opening and closing brackets.
 Additionally, the
 .Fn ATF_TEST_CASE_NAME
 macro can be used to obtain the name of the class corresponding to a
-particular test case, as the name is internally manged by the library to
+particular test case, as the name is internally managed by the library to
 prevent clashes with other user identifiers.
 Similarly, the
 .Fn ATF_TEST_CASE_USE
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314802 - head/contrib/atf/atf-c

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:45:25 2017
New Revision: 314802
URL: https://svnweb.freebsd.org/changeset/base/314802

Log:
  Fix atf-c-api(3) manpage issues
  
  - Fix typo (specifiying -> specifying).
  - Remove surrounding ellipses in i.e. section and add a comma before
and after the i.e. reference.
  
  Bump .Dd for the change
  
  MFC after:1 week
  Reported by:  igor
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-c/atf-c-api.3

Modified: head/contrib/atf/atf-c/atf-c-api.3
==
--- head/contrib/atf/atf-c/atf-c-api.3  Mon Mar  6 21:43:47 2017
(r314801)
+++ head/contrib/atf/atf-c/atf-c-api.3  Mon Mar  6 21:45:25 2017
(r314802)
@@ -261,7 +261,7 @@ To define test cases, one can use the
 .Fn ATF_TC_WITH_CLEANUP
 or the
 .Fn ATF_TC_WITHOUT_HEAD
-macros, which take a single parameter specifiying the test case's name.
+macros, which take a single parameter specifying the test case's name.
 .Fn ATF_TC ,
 requires to define a head and a body for the test case,
 .Fn ATF_TC_WITH_CLEANUP
@@ -301,7 +301,7 @@ library to do it for you.
 This is done by using the
 .Fn ATF_TP_ADD_TCS
 macro, which is passed the name of the object that will hold the test
-cases; i.e. the test program instance.
+cases, i.e., the test program instance.
 This name can be whatever you want as long as it is a valid variable
 identifier.
 .Pp
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314801 - head/contrib/atf/atf-c

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:43:47 2017
New Revision: 314801
URL: https://svnweb.freebsd.org/changeset/base/314801

Log:
  Fix igor/manlint issues with atf-c(3)
  
  - Remove surrounding ellipses in i.e. section and add a comma before
and after the i.e. reference [1].
  - Fix typo (specifiying -> specifying) [1].
  - Escape '.' at start of lines using & to tell the roff processor
that the line isn't meant to be treated as a command [2].
  
  Bump .Dd for the change
  
  MFC after:1 week
  Reported by:  igor [1], manlint [2]
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-c/atf-c.3

Modified: head/contrib/atf/atf-c/atf-c.3
==
--- head/contrib/atf/atf-c/atf-c.3  Mon Mar  6 21:39:57 2017
(r314800)
+++ head/contrib/atf/atf-c/atf-c.3  Mon Mar  6 21:43:47 2017
(r314801)
@@ -22,7 +22,7 @@
 .\" IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-.Dd October 13, 2014
+.Dd March 6, 2017
 .Dt ATF-C 3
 .Os
 .Sh NAME
@@ -203,7 +203,7 @@
 ATF provides a C programming interface to implement test programs.
 C-based test programs follow this template:
 .Bd -literal -offset indent
-.Ns ... C-specific includes go here ...
+\&... C-specific includes go here ...
 
 #include 
 
@@ -237,7 +237,7 @@ ATF_TC_BODY(tc3, tc)
 ... third test case's body ...
 }
 
-.Ns ... additional test cases ...
+\&... additional test cases ...
 
 ATF_TP_ADD_TCS(tp)
 {
@@ -259,7 +259,7 @@ To define test cases, one can use the
 .Fn ATF_TC_WITH_CLEANUP
 or the
 .Fn ATF_TC_WITHOUT_HEAD
-macros, which take a single parameter specifiying the test case's name.
+macros, which take a single parameter specifying the test case's name.
 .Fn ATF_TC ,
 requires to define a head and a body for the test case,
 .Fn ATF_TC_WITH_CLEANUP
@@ -299,7 +299,7 @@ library to do it for you.
 This is done by using the
 .Fn ATF_TP_ADD_TCS
 macro, which is passed the name of the object that will hold the test
-cases; i.e. the test program instance.
+cases, i.e., the test program instance.
 This name can be whatever you want as long as it is a valid variable
 identifier.
 .Pp
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314800 - head/contrib/atf/atf-sh

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:39:57 2017
New Revision: 314800
URL: https://svnweb.freebsd.org/changeset/base/314800

Log:
  Fix issues with atf-check(1) found by igor and refer to atf-check(1)
  
  - Fix typo (specifiying -> specifying)
  - Add atf-check(1) to SEE ALSO section for completeness. It's mentioned
above, but by convention the SEE ALSO section should list all relevant
references to other tools and APIs.
  
  Bump .Dd for the change
  
  MFC after:1 week
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-sh/atf-sh-api.3

Modified: head/contrib/atf/atf-sh/atf-sh-api.3
==
--- head/contrib/atf/atf-sh/atf-sh-api.3Mon Mar  6 21:35:33 2017
(r314799)
+++ head/contrib/atf/atf-sh/atf-sh-api.3Mon Mar  6 21:39:57 2017
(r314800)
@@ -26,7 +26,7 @@
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 .\"
-.Dd March 2, 2014
+.Dd March 6, 2017
 .Dt ATF-SH-API 3
 .Os
 .Sh NAME
@@ -121,7 +121,7 @@ described in
 .Xr atf-test-case 4 .
 To define test cases, one can use the
 .Fn atf_test_case
-function, which takes a first parameter specifiying the test case's
+function, which takes a first parameter specifying the test case's
 name and instructs the library to set things up to accept it as a valid
 test case.
 The second parameter is optional and, if provided, must be
@@ -335,6 +335,7 @@ grep foo ls || atf_fail "foo file not fo
 atf_check -s exit:0 -o match:"^foo$" -e empty 'ls'
 .Ed
 .Sh SEE ALSO
+.Xr atf-check 1 ,
 .Xr atf-sh 1 ,
 .Xr atf-test-program 1 ,
 .Xr atf-test-case 4
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314799 - head/contrib/atf/atf-sh

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:35:33 2017
New Revision: 314799
URL: https://svnweb.freebsd.org/changeset/base/314799

Log:
  Fix manlint issues with atf-check(1)
  
  - Use `.Bf Em`/`.Ef` instead of prefixing lines with `.Em`. The forms
are equivalent with traditional roff, but unnecessarily verbose. The
former form applies the .Em macro to the enclosed block.
  - Move EXIT_STATUS section down so the section complies with section
ordering specified by mdoc(7) and enforced by manlint(1).
  
  Bump .Dd for the change
  
  MFC after:1 week
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-sh/atf-check.1

Modified: head/contrib/atf/atf-sh/atf-check.1
==
--- head/contrib/atf/atf-sh/atf-check.1 Mon Mar  6 21:30:06 2017
(r314798)
+++ head/contrib/atf/atf-sh/atf-check.1 Mon Mar  6 21:35:33 2017
(r314799)
@@ -22,7 +22,7 @@
 .\" IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-.Dd October 5, 2014
+.Dd March 6, 2017
 .Dt ATF-CHECK 1
 .Os
 .Sh NAME
@@ -40,10 +40,12 @@
 executes a given command and analyzes its results, including
 exit code, stdout and stderr.
 .Pp
-.Em Test cases must use
-.Em Xr atf-sh 3 Ns ' Ns s
-.Em Nm atf_check
-.Em builtin function instead of calling this utility directly.
+.Bf Em
+Test cases must use
+.Xr atf-sh 3 Ns ' Ns s
+.Nm atf_check
+builtin function instead of calling this utility directly.
+.Ef
 .Pp
 In the first synopsis form,
 .Nm
@@ -119,9 +121,6 @@ as a shell command line, executing it wi
 You should avoid using this flag if at all possible to prevent shell quoting
 issues.
 .El
-.Sh EXIT STATUS
-.Nm
-exits 0 on success, and other (unspecified) value on failure.
 .Sh ENVIRONMENT
 .Bl -tag -width ATFXSHELLXX -compact
 .It Va ATF_SHELL
@@ -129,6 +128,9 @@ Path to the system shell to be used when
 .Fl x
 is given to run commands.
 .El
+.Sh EXIT STATUS
+.Nm
+exits 0 on success, and other (unspecified) value on failure.
 .Sh EXAMPLES
 The following are sample invocations from within a test case.
 Note that we use the
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314798 - head/contrib/atf/atf-sh

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:30:06 2017
New Revision: 314798
URL: https://svnweb.freebsd.org/changeset/base/314798

Log:
  Fix out-of-order sections in atf-sh(1)
  
  - `.Op` must be used in the SYNOPSIS section, not the NAME section.
  - Move ATF_SHELL environment variable description up to first
ENVIRONMENT section. Garbage collect the duplicate ENVIRONMENT
section.
  
  Bump .Dd for the change
  
  MFC after:1 week
  Reported by:  manlint
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-sh/atf-sh.1

Modified: head/contrib/atf/atf-sh/atf-sh.1
==
--- head/contrib/atf/atf-sh/atf-sh.1Mon Mar  6 21:26:45 2017
(r314797)
+++ head/contrib/atf/atf-sh/atf-sh.1Mon Mar  6 21:30:06 2017
(r314798)
@@ -22,15 +22,15 @@
 .\" IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-.Dd September 27, 2014
+.Dd March 6, 2017
 .Dt ATF-SH 1
 .Os
 .Sh NAME
 .Nm atf-sh
-.Op Fl s Ar shell
 .Nd interpreter for shell-based test programs
 .Sh SYNOPSIS
 .Nm
+.Op Fl s Ar shell
 .Ar script
 .Sh DESCRIPTION
 .Nm
@@ -75,6 +75,8 @@ Should not be overridden other than for 
 Path to the system shell to be used in the generated scripts.
 Scripts must not rely on this variable being set to select a specific
 interpreter.
+.It Va ATF_SHELL
+Path to the system shell to be used in the generated scripts.
 .El
 .Sh EXAMPLES
 Scripts using
@@ -98,10 +100,5 @@ option afterwards as a
 .Bd -literal -offset indent
 #! /path/to/bin/atf-sh -s/bin/bash
 .Ed
-.Sh ENVIRONMENT
-.Bl -tag -width ATFXSHELLXX -compact
-.It Va ATF_SHELL
-Path to the system shell to be used in the generated scripts.
-.El
 .Sh SEE ALSO
 .Xr atf-sh 3
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314797 - head/contrib/atf/doc

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:26:45 2017
New Revision: 314797
URL: https://svnweb.freebsd.org/changeset/base/314797

Log:
  Fix grammar warning noted by igor
  
  Remove surrounding ellipses in e.g. section and add a comma before and after
  the e.g. reference.
  
  MFC after:1 week
  Reported by:  igor
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/doc/atf-test-case.4

Modified: head/contrib/atf/doc/atf-test-case.4
==
--- head/contrib/atf/doc/atf-test-case.4Mon Mar  6 21:24:55 2017
(r314796)
+++ head/contrib/atf/doc/atf-test-case.4Mon Mar  6 21:26:45 2017
(r314797)
@@ -22,7 +22,7 @@
 .\" IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-.Dd October 5, 2014
+.Dd March 6, 2017
 .Dt ATF-TEST-CASE 4
 .Os
 .Sh NAME
@@ -79,8 +79,8 @@ Upon termination, a test case reports a 
 reason describing why the test reported such status.
 The caller must ensure that the test case really performed the task that its
 status describes, as the test program may be bogus and therefore providing a
-misleading result (e.g. providing a result that indicates success but the
-error code of the program says otherwise).
+misleading result, e.g., providing a result that indicates success but the
+error code of the program says otherwise.
 .Pp
 The possible exit status of a test case are one of the following:
 .Bl -tag -width expectedXfailureXX
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314796 - head/contrib/atf/atf-sh

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 21:24:55 2017
New Revision: 314796
URL: https://svnweb.freebsd.org/changeset/base/314796

Log:
  Fix atf-sh(3) manpage issues
  
  - Fix spelling errors (specifiying -> specifying) [1]
  - Escape '.' at start of lines using & to tell the roff processor
that the line isn't meant to be treated as a command [2].
  
  Bump .Dd for the change
  
  MFC after:1 week
  Reported by:  igor [1], manlint [2]
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-sh/atf-sh.3

Modified: head/contrib/atf/atf-sh/atf-sh.3
==
--- head/contrib/atf/atf-sh/atf-sh.3Mon Mar  6 21:14:20 2017
(r314795)
+++ head/contrib/atf/atf-sh/atf-sh.3Mon Mar  6 21:24:55 2017
(r314796)
@@ -22,7 +22,7 @@
 .\" IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-.Dd October 13, 2014
+.Dd March 6, 2017
 .Dt ATF-SH 3
 .Os
 .Sh NAME
@@ -129,7 +129,7 @@ tc2_cleanup() {
 ... second test case's cleanup ...
 }
 
-.Ns ... additional test cases ...
+\&... additional test cases ...
 
 atf_init_test_cases() {
 atf_add_test_case tc1
@@ -144,7 +144,7 @@ described in
 .Xr atf-test-case 4 .
 To define test cases, one can use the
 .Nm atf_test_case
-function, which takes a first parameter specifiying the test case's
+function, which takes a first parameter specifying the test case's
 name and instructs the library to set things up to accept it as a valid
 test case.
 The second parameter is optional and, if provided, must be
@@ -334,7 +334,7 @@ atf_init_test_cases() {
 This other example shows how to include a file with extra helper functions
 in the test program:
 .Bd -literal -offset indent
-.Ns ... definition of test cases ...
+\&... definition of test cases ...
 
 atf_init_test_cases() {
 . $(atf_get_srcdir)/helper_functions.sh
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314795 - head/contrib/llvm/lib/Analysis

2017-03-06 Thread Dimitry Andric
Author: dim
Date: Mon Mar  6 21:14:20 2017
New Revision: 314795
URL: https://svnweb.freebsd.org/changeset/base/314795

Log:
  Reapply r287232 from upstream llvm trunk (by Daniil Fukalov):
  
[SCEV] limit recursion depth of CompareSCEVComplexity
  
Summary:
CompareSCEVComplexity goes too deep (50+ on a quite a big unrolled
loop) and runs almost infinite time.
  
Added cache of "equal" SCEV pairs to earlier cutoff of further
estimation. Recursion depth limit was also introduced as a parameter.
  
Reviewers: sanjoy
  
Subscribers: mzolotukhin, tstellarAMD, llvm-commits
  
Differential Revision: https://reviews.llvm.org/D26389
  
  Pull in r296992 from upstream llvm trunk (by Sanjoy Das):
  
[SCEV] Decrease the recursion threshold for CompareValueComplexity
  
Fixes PR32142.
  
r287232 accidentally increased the recursion threshold for
CompareValueComplexity from 2 to 32.  This change reverses that
change by introducing a separate flag for CompareValueComplexity's
threshold.
  
  The latter revision fixes the excessive compile times for skein_block.c.

Modified:
  head/contrib/llvm/lib/Analysis/ScalarEvolution.cpp

Modified: head/contrib/llvm/lib/Analysis/ScalarEvolution.cpp
==
--- head/contrib/llvm/lib/Analysis/ScalarEvolution.cpp  Mon Mar  6 21:06:55 
2017(r314794)
+++ head/contrib/llvm/lib/Analysis/ScalarEvolution.cpp  Mon Mar  6 21:14:20 
2017(r314795)
@@ -127,6 +127,16 @@ static cl::opt MulOpsInlineThr
 cl::desc("Threshold for inlining multiplication operands into a SCEV"),
 cl::init(1000));
 
+static cl::opt MaxSCEVCompareDepth(
+"scalar-evolution-max-scev-compare-depth", cl::Hidden,
+cl::desc("Maximum depth of recursive SCEV complexity comparisons"),
+cl::init(32));
+
+static cl::opt MaxValueCompareDepth(
+"scalar-evolution-max-value-compare-depth", cl::Hidden,
+cl::desc("Maximum depth of recursive value complexity comparisons"),
+cl::init(2));
+
 
//===--===//
 //   SCEV class definitions
 
//===--===//
@@ -475,8 +485,8 @@ bool SCEVUnknown::isOffsetOf(Type *&CTy,
 static int
 CompareValueComplexity(SmallSet, 8> &EqCache,
const LoopInfo *const LI, Value *LV, Value *RV,
-   unsigned DepthLeft = 2) {
-  if (DepthLeft == 0 || EqCache.count({LV, RV}))
+   unsigned Depth) {
+  if (Depth > MaxValueCompareDepth || EqCache.count({LV, RV}))
 return 0;
 
   // Order pointer values after integer values. This helps SCEVExpander form
@@ -537,21 +547,23 @@ CompareValueComplexity(SmallSetgetOperand(Idx),
- RInst->getOperand(Idx), DepthLeft - 1);
+ RInst->getOperand(Idx), Depth + 1);
   if (Result != 0)
 return Result;
-  EqCache.insert({LV, RV});
 }
   }
 
+  EqCache.insert({LV, RV});
   return 0;
 }
 
 // Return negative, zero, or positive, if LHS is less than, equal to, or 
greater
 // than RHS, respectively. A three-way result allows recursive comparisons to 
be
 // more efficient.
-static int CompareSCEVComplexity(const LoopInfo *const LI, const SCEV *LHS,
- const SCEV *RHS) {
+static int CompareSCEVComplexity(
+SmallSet, 8> &EqCacheSCEV,
+const LoopInfo *const LI, const SCEV *LHS, const SCEV *RHS,
+unsigned Depth = 0) {
   // Fast-path: SCEVs are uniqued so we can do a quick equality check.
   if (LHS == RHS)
 return 0;
@@ -561,6 +573,8 @@ static int CompareSCEVComplexity(const L
   if (LType != RType)
 return (int)LType - (int)RType;
 
+  if (Depth > MaxSCEVCompareDepth || EqCacheSCEV.count({LHS, RHS}))
+return 0;
   // Aside from the getSCEVType() ordering, the particular ordering
   // isn't very important except that it's beneficial to be consistent,
   // so that (a + b) and (b + a) don't end up as different expressions.
@@ -570,7 +584,11 @@ static int CompareSCEVComplexity(const L
 const SCEVUnknown *RU = cast(RHS);
 
 SmallSet, 8> EqCache;
-return CompareValueComplexity(EqCache, LI, LU->getValue(), RU->getValue());
+int X = CompareValueComplexity(EqCache, LI, LU->getValue(), RU->getValue(),
+   Depth + 1);
+if (X == 0)
+  EqCacheSCEV.insert({LHS, RHS});
+return X;
   }
 
   case scConstant: {
@@ -605,11 +623,12 @@ static int CompareSCEVComplexity(const L
 
 // Lexicographically compare.
 for (unsigned i = 0; i != LNumOps; ++i) {
-  long X = CompareSCEVComplexity(LI, LA->getOperand(i), RA->getOperand(i));
+  int X = CompareSCEVComplexity(EqCacheSCEV, LI, LA->getOperand(i),
+RA->getOperand(i), Depth + 1);
   if (X != 0)
 return X;
 }
-
+

svn commit: r314794 - head/lib/libmd

2017-03-06 Thread Bryan Drewery
Author: bdrewery
Date: Mon Mar  6 21:06:55 2017
New Revision: 314794
URL: https://svnweb.freebsd.org/changeset/base/314794

Log:
  Fix bootstrapping libmd on older systems after r314709.
  
  This follows another fix to bootstrap libmd after r313404.  The
  MD5FileChunk prototype is needed to build libmd, but it is
  only reliably in the src tree's sys/md5.h header.  Rather than
  polluting the legacy build with this header for the entire build,
  just symlink it in here for now as is done in the elftoolchain
  build.  Libmd is already referencing other src tree headers by
  its used of CFLAGS+= ${SRCTOP}/sys/crypto/sha2.  This, and
  other uses of CFLAGS+= ${SRCTOP}/sys..., may later change to
  be in the legacy mechanism.
  
  Reported by:  bde, ian, sjg
  Tested by:ian

Modified:
  head/lib/libmd/Makefile

Modified: head/lib/libmd/Makefile
==
--- head/lib/libmd/Makefile Mon Mar  6 20:54:21 2017(r314793)
+++ head/lib/libmd/Makefile Mon Mar  6 21:06:55 2017(r314794)
@@ -72,6 +72,13 @@ CLEANFILES+= md[245]hl.c md[245].ref md[
skein256.ref skein512.ref skein1024.ref \
skeindriver
 
+# Need src tree sys/md5.h for MD5FileChunk prototype on older systems.
+SRCS+= sys/md5.h
+CLEANDIRS= sys
+CFLAGS+=   -I.
+sys/md5.h: ${SRCTOP}/sys/${.TARGET} .NOMETA
+   ln -sf ${.ALLSRC} ${.TARGET}
+
 # Define WEAK_REFS to provide weak aliases for libmd symbols
 #
 # Note that the same sources are also used internally by libcrypt,
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


RE: svn commit: r314789 - stable/11/sys/dev/qlxgbe

2017-03-06 Thread Somayajulu, David
Hi Rodney,
I was worried about the same as well. The reason it looks funky is that the 
following two lines have a 8 spaces instead of a tab.
>  bus_dmamem_free(dma_buf->dma_tag, dma_buf->dma_b, dma_buf->dma_map);
>  bus_dma_tag_destroy(dma_buf->dma_tag);

While 
> + bus_dmamap_unload(dma_buf->dma_tag, dma_buf->dma_map);
Uses a tab instead. 

Thanks
David S.

-Original Message-
From: Rodney W. Grimes [mailto:free...@pdx.rh.cn85.dnsmgr.net] 
Sent: Monday, March 06, 2017 12:53 PM
To: David C Somayajulu 
Cc: src-committ...@freebsd.org; svn-src-all@freebsd.org; 
svn-src-sta...@freebsd.org; svn-src-stable...@freebsd.org
Subject: Re: svn commit: r314789 - stable/11/sys/dev/qlxgbe

> Author: davidcs
> Date: Mon Mar  6 20:25:33 2017
> New Revision: 314789
> URL: https://svnweb.freebsd.org/changeset/base/314789
> 
> Log:
>   MFC r314062
>   add bus_dmamap_unload in ql_free_dmabuf()
> 
> Modified:
>   stable/11/sys/dev/qlxgbe/ql_os.c
> Directory Properties:
>   stable/11/   (props changed)
> 
> Modified: stable/11/sys/dev/qlxgbe/ql_os.c 
> ==
> --- stable/11/sys/dev/qlxgbe/ql_os.c  Mon Mar  6 19:55:07 2017
> (r314788)
> +++ stable/11/sys/dev/qlxgbe/ql_os.c  Mon Mar  6 20:25:33 2017
> (r314789)
> @@ -735,6 +735,7 @@ ql_alloc_dmabuf_exit:
>  void
>  ql_free_dmabuf(qla_host_t *ha, qla_dma_t *dma_buf)  {
> + bus_dmamap_unload(dma_buf->dma_tag, dma_buf->dma_map);
>  bus_dmamem_free(dma_buf->dma_tag, dma_buf->dma_b, dma_buf->dma_map);
>  bus_dma_tag_destroy(dma_buf->dma_tag);
>  }

That looks as if this file has incorrect leading white space?

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314793 - head/contrib/atf/atf-c

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 20:54:21 2017
New Revision: 314793
URL: https://svnweb.freebsd.org/changeset/base/314793

Log:
  Fix ATF_TP_ADD_TCS example in atf-c-api(3)
  
  ATF_TP_ADD_TC should use `tp` as the second argument, not `tcs`, as
  ATF_TP_ADD_TCS uses `tp` as its first argument.
  
  Bump .Dd for the change.
  
  MFC after:1 week
  Sponsored by: Dell EMC Isilon

Modified:
  head/contrib/atf/atf-c/atf-c-api.3

Modified: head/contrib/atf/atf-c/atf-c-api.3
==
--- head/contrib/atf/atf-c/atf-c-api.3  Mon Mar  6 20:47:53 2017
(r314792)
+++ head/contrib/atf/atf-c/atf-c-api.3  Mon Mar  6 20:54:21 2017
(r314793)
@@ -26,7 +26,7 @@
 .\" OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
 .\" IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 .\"
-.Dd March 2, 2014
+.Dd March 6, 2017
 .Dt ATF-C-API 3
 .Os
 .Sh NAME
@@ -243,9 +243,9 @@ ATF_TC_BODY(tc3, tc)
 
 ATF_TP_ADD_TCS(tp)
 {
-ATF_TP_ADD_TC(tcs, tc1);
-ATF_TP_ADD_TC(tcs, tc2);
-ATF_TP_ADD_TC(tcs, tc3);
+ATF_TP_ADD_TC(tp, tc1);
+ATF_TP_ADD_TC(tp, tc2);
+ATF_TP_ADD_TC(tp, tc3);
 ... add additional test cases ...
 
 return atf_no_error();
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314789 - stable/11/sys/dev/qlxgbe

2017-03-06 Thread Rodney W. Grimes
> Author: davidcs
> Date: Mon Mar  6 20:25:33 2017
> New Revision: 314789
> URL: https://svnweb.freebsd.org/changeset/base/314789
> 
> Log:
>   MFC r314062
>   add bus_dmamap_unload in ql_free_dmabuf()
> 
> Modified:
>   stable/11/sys/dev/qlxgbe/ql_os.c
> Directory Properties:
>   stable/11/   (props changed)
> 
> Modified: stable/11/sys/dev/qlxgbe/ql_os.c
> ==
> --- stable/11/sys/dev/qlxgbe/ql_os.c  Mon Mar  6 19:55:07 2017
> (r314788)
> +++ stable/11/sys/dev/qlxgbe/ql_os.c  Mon Mar  6 20:25:33 2017
> (r314789)
> @@ -735,6 +735,7 @@ ql_alloc_dmabuf_exit:
>  void
>  ql_free_dmabuf(qla_host_t *ha, qla_dma_t *dma_buf)
>  {
> + bus_dmamap_unload(dma_buf->dma_tag, dma_buf->dma_map); 
>  bus_dmamem_free(dma_buf->dma_tag, dma_buf->dma_b, dma_buf->dma_map);
>  bus_dma_tag_destroy(dma_buf->dma_tag);
>  }

That looks as if this file has incorrect leading white space?

-- 
Rod Grimes rgri...@freebsd.org
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314792 - stable/9/sys/dev/qlxgbe

2017-03-06 Thread David C Somayajulu
Author: davidcs
Date: Mon Mar  6 20:47:53 2017
New Revision: 314792
URL: https://svnweb.freebsd.org/changeset/base/314792

Log:
  MFC r314062
  add bus_dmamap_unload in ql_free_dmabuf()

Modified:
  stable/9/sys/dev/qlxgbe/ql_os.c
Directory Properties:
  stable/9/   (props changed)
  stable/9/sys/   (props changed)

Modified: stable/9/sys/dev/qlxgbe/ql_os.c
==
--- stable/9/sys/dev/qlxgbe/ql_os.c Mon Mar  6 20:35:03 2017
(r314791)
+++ stable/9/sys/dev/qlxgbe/ql_os.c Mon Mar  6 20:47:53 2017
(r314792)
@@ -735,6 +735,7 @@ ql_alloc_dmabuf_exit:
 void
 ql_free_dmabuf(qla_host_t *ha, qla_dma_t *dma_buf)
 {
+   bus_dmamap_unload(dma_buf->dma_tag, dma_buf->dma_map); 
 bus_dmamem_free(dma_buf->dma_tag, dma_buf->dma_b, dma_buf->dma_map);
 bus_dma_tag_destroy(dma_buf->dma_tag);
 }
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314791 - stable/10/sys/dev/qlxgbe

2017-03-06 Thread David C Somayajulu
Author: davidcs
Date: Mon Mar  6 20:35:03 2017
New Revision: 314791
URL: https://svnweb.freebsd.org/changeset/base/314791

Log:
  MFC r314062
  add bus_dmamap_unload in ql_free_dmabuf()

Modified:
  stable/10/sys/dev/qlxgbe/ql_os.c
Directory Properties:
  stable/10/   (props changed)

Modified: stable/10/sys/dev/qlxgbe/ql_os.c
==
--- stable/10/sys/dev/qlxgbe/ql_os.cMon Mar  6 20:32:17 2017
(r314790)
+++ stable/10/sys/dev/qlxgbe/ql_os.cMon Mar  6 20:35:03 2017
(r314791)
@@ -735,6 +735,7 @@ ql_alloc_dmabuf_exit:
 void
 ql_free_dmabuf(qla_host_t *ha, qla_dma_t *dma_buf)
 {
+   bus_dmamap_unload(dma_buf->dma_tag, dma_buf->dma_map); 
 bus_dmamem_free(dma_buf->dma_tag, dma_buf->dma_b, dma_buf->dma_map);
 bus_dma_tag_destroy(dma_buf->dma_tag);
 }
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314790 - head

2017-03-06 Thread Bryan Drewery
Author: bdrewery
Date: Mon Mar  6 20:32:17 2017
New Revision: 314790
URL: https://svnweb.freebsd.org/changeset/base/314790

Log:
  Added comments for why nmtree/libmd are bootstrapped.

Modified:
  head/Makefile.inc1

Modified: head/Makefile.inc1
==
--- head/Makefile.inc1  Mon Mar  6 20:25:33 2017(r314789)
+++ head/Makefile.inc1  Mon Mar  6 20:32:17 2017(r314790)
@@ -1618,6 +1618,8 @@ ${_bt}-usr.bin/m4: ${_bt}-lib/libopenbsd
 ${_bt}-usr.bin/lex: ${_bt}-usr.bin/m4
 .endif
 
+# r245440 mtree -N support added
+# r313404 requires sha384.h for libnetbsd, added to libmd in r292782
 .if ${BOOTSTRAPPING} < 1100093
 _nmtree=   lib/libmd \
lib/libnetbsd \
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314789 - stable/11/sys/dev/qlxgbe

2017-03-06 Thread David C Somayajulu
Author: davidcs
Date: Mon Mar  6 20:25:33 2017
New Revision: 314789
URL: https://svnweb.freebsd.org/changeset/base/314789

Log:
  MFC r314062
  add bus_dmamap_unload in ql_free_dmabuf()

Modified:
  stable/11/sys/dev/qlxgbe/ql_os.c
Directory Properties:
  stable/11/   (props changed)

Modified: stable/11/sys/dev/qlxgbe/ql_os.c
==
--- stable/11/sys/dev/qlxgbe/ql_os.cMon Mar  6 19:55:07 2017
(r314788)
+++ stable/11/sys/dev/qlxgbe/ql_os.cMon Mar  6 20:25:33 2017
(r314789)
@@ -735,6 +735,7 @@ ql_alloc_dmabuf_exit:
 void
 ql_free_dmabuf(qla_host_t *ha, qla_dma_t *dma_buf)
 {
+   bus_dmamap_unload(dma_buf->dma_tag, dma_buf->dma_map); 
 bus_dmamem_free(dma_buf->dma_tag, dma_buf->dma_b, dma_buf->dma_map);
 bus_dma_tag_destroy(dma_buf->dma_tag);
 }
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314788 - vendor/NetBSD/bmake/20170301

2017-03-06 Thread Simon J. Gerraty
Author: sjg
Date: Mon Mar  6 19:55:07 2017
New Revision: 314788
URL: https://svnweb.freebsd.org/changeset/base/314788

Log:
  tag bmake-20170301

Added:
  vendor/NetBSD/bmake/20170301/
 - copied from r314787, vendor/NetBSD/bmake/dist/
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314787 - in vendor/NetBSD/bmake/dist: . PSD.doc mk unit-tests

2017-03-06 Thread Simon J. Gerraty
Author: sjg
Date: Mon Mar  6 19:54:54 2017
New Revision: 314787
URL: https://svnweb.freebsd.org/changeset/base/314787

Log:
  Import bmake-20170301

Modified:
  vendor/NetBSD/bmake/dist/ChangeLog
  vendor/NetBSD/bmake/dist/Makefile
  vendor/NetBSD/bmake/dist/PSD.doc/tutorial.ms
  vendor/NetBSD/bmake/dist/bmake.1
  vendor/NetBSD/bmake/dist/bmake.cat1
  vendor/NetBSD/bmake/dist/dir.c
  vendor/NetBSD/bmake/dist/main.c
  vendor/NetBSD/bmake/dist/make.1
  vendor/NetBSD/bmake/dist/meta.c
  vendor/NetBSD/bmake/dist/mk/ChangeLog
  vendor/NetBSD/bmake/dist/mk/dirdeps.mk
  vendor/NetBSD/bmake/dist/mk/dpadd.mk
  vendor/NetBSD/bmake/dist/mk/install-mk
  vendor/NetBSD/bmake/dist/mk/meta.stage.mk
  vendor/NetBSD/bmake/dist/mk/meta2deps.py
  vendor/NetBSD/bmake/dist/mk/prog.mk
  vendor/NetBSD/bmake/dist/mk/subdir.mk
  vendor/NetBSD/bmake/dist/mk/sys.mk
  vendor/NetBSD/bmake/dist/mk/sys.vars.mk
  vendor/NetBSD/bmake/dist/os.sh
  vendor/NetBSD/bmake/dist/parse.c
  vendor/NetBSD/bmake/dist/unit-tests/varmisc.exp
  vendor/NetBSD/bmake/dist/unit-tests/varmisc.mk
  vendor/NetBSD/bmake/dist/var.c

Modified: vendor/NetBSD/bmake/dist/ChangeLog
==
--- vendor/NetBSD/bmake/dist/ChangeLog  Mon Mar  6 19:39:31 2017
(r314786)
+++ vendor/NetBSD/bmake/dist/ChangeLog  Mon Mar  6 19:54:54 2017
(r314787)
@@ -1,3 +1,32 @@
+2017-03-01  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170301
+ Merge with NetBSD make, pick up
+ o main.c: use -C arg as is rather than getcwd()
+   if they identify the same directory.
+ o parse.c: ensure loadfile buffer is \n terminated in non-mmap case
+
+2017-02-01  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170201
+ Merge with NetBSD make, pick up
+ o var.c: allow :_=var and avoid use of special context.
+
+2017-01-30  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170130
+ Merge with NetBSD make, pick up
+ o var.c: add :range and :_
+ o main.c: partially initialize Dir_* before MainParseArgs()
+   can be called.
+   If -V, skip Main_ExportMAKEFLAGS()
+
+2017-01-14  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20170114
+ Merge with NetBSD make, pick up
+ o var.c: allow specifying the utc value used by :{gm,local}time
+
 2016-12-12  Simon J. Gerraty  
 
* Makefile (_MAKE_VERSION): 20161212

Modified: vendor/NetBSD/bmake/dist/Makefile
==
--- vendor/NetBSD/bmake/dist/Makefile   Mon Mar  6 19:39:31 2017
(r314786)
+++ vendor/NetBSD/bmake/dist/Makefile   Mon Mar  6 19:54:54 2017
(r314787)
@@ -1,7 +1,7 @@
-#  $Id: Makefile,v 1.77 2016/12/12 07:34:19 sjg Exp $
+#  $Id: Makefile,v 1.81 2017/03/01 17:01:23 sjg Exp $
 
 # Base version on src date
-_MAKE_VERSION= 20161212
+_MAKE_VERSION= 20170301
 
 PROG=  bmake
 

Modified: vendor/NetBSD/bmake/dist/PSD.doc/tutorial.ms
==
--- vendor/NetBSD/bmake/dist/PSD.doc/tutorial.msMon Mar  6 19:39:31 
2017(r314786)
+++ vendor/NetBSD/bmake/dist/PSD.doc/tutorial.msMon Mar  6 19:54:54 
2017(r314787)
@@ -1,4 +1,4 @@
-.\"$NetBSD: tutorial.ms,v 1.12 2014/09/30 21:33:14 christos Exp $
+.\"$NetBSD: tutorial.ms,v 1.13 2017/03/01 13:05:11 kre Exp $
 .\" Copyright (c) 1988, 1989, 1993
 .\"The Regents of the University of California.  All rights reserved.
 .\"
@@ -117,6 +117,15 @@
 .de No
 .br
 .ne 0.5i
+.ie n \{\
+.nr g3 \w'NOTE '
+.po -\\n(g3u
+.br
+NOTE
+.br
+.po +\\n(g3u
+.\}
+.el \{\
 .po -0.5i
 .br
 .mk 
@@ -148,12 +157,14 @@
 .rt 
 .ft \\n(g3
 .ps \\n(g4
+.\}
 ..
 .de Bp
 .ie !\\n(.$ .IP \(bu 2
 .el .IP "\&" 2
 ..
-.po +.3i
+.ie n .po +\w'NOTE  'u
+.el .po +.3i
 .TL
 PMake \*- A Tutorial
 .AU

Modified: vendor/NetBSD/bmake/dist/bmake.1
==
--- vendor/NetBSD/bmake/dist/bmake.1Mon Mar  6 19:39:31 2017
(r314786)
+++ vendor/NetBSD/bmake/dist/bmake.1Mon Mar  6 19:54:54 2017
(r314787)
@@ -1,4 +1,4 @@
-.\"$NetBSD: make.1,v 1.263 2016/08/26 23:37:54 dholland Exp $
+.\"$NetBSD: make.1,v 1.266 2017/02/01 18:39:27 sjg Exp $
 .\"
 .\" Copyright (c) 1990, 1993
 .\"The Regents of the University of California.  All rights reserved.
@@ -29,7 +29,7 @@
 .\"
 .\"from: @(#)make.18.4 (Berkeley) 3/19/94
 .\"
-.Dd August 26, 2016
+.Dd February 1, 2017
 .Dt BMAKE 1
 .Os
 .Sh NAME
@@ -1205,18 +1205,28 @@ safely through recursive invocations of
 .Nm .
 .It Cm \&:R
 Replaces each word in the variable with everything but its suffix.
-.It Cm \&:gmtime
+.It Cm \&:range[=count]
+The value is an integer sequence representing the words of the original
+value, or the supplied
+.Va count .
+.It Cm \&:gmtime[=utc]
 The value is a format st

Re: svn commit: r314373 - in head: . etc/defaults etc/rc.d lib/libc/regex share/man/man4/man4.i386 share/man/man5 sys/amd64/conf sys/boot/forth sys/compat/svr4 sys/conf sys/dev/streams sys/i386/conf s

2017-03-06 Thread Gleb Smirnoff
  Ben and Mark,

  thanks for explanation! I'll document that 1200023 also marks removal of SVR4.

On Tue, Feb 28, 2017 at 05:50:53PM -0600, Mark Linimon wrote:
M> On Tue, Feb 28, 2017 at 01:30:44PM -0800, Gleb Smirnoff wrote:
M> > How can I check the __FreeBSD_version in a port Makefile? My understanding
M> > is that there is no standard way for such thing.
M> 
M> There are hundreds of examples in port Makefiles.  I suppose the PH will need
M> to be updated to include some of them.  It is hinted at under "INCLUDE" in
M> https://www.freebsd.org/doc/en/books/porters-handbook/dads-noinstall.html
M> but not made specific.
M> 
M> Some quick examples:
M> 
M>   devel/cloudabi-toolchain/Makefile:.if ${OSVERSION} >= 1100100
M> 
M>   devel/cvs-syncmail/Makefile:.if ${OPSYS} == FreeBSD && ${OSVERSION} > 
100
M> 
M>   devel/trio/Makefile.orig:# NB: OSVERSION was not incremented for r308559, 
so we use the earlier
M>   devel/trio/Makefile.orig:# 1200014 as a surrogate for now.
M>   devel/trio/Makefile.orig:.if ${OSVERSION} < 1100506 || ( ${OSVERSION} >= 
120 && ${OSVERSION} < 1200014 )
M>   devel/trio/Makefile.orig:BROKEN_aarch64= needs fixes from r308375, 
r308487, and/or r308559
M>   devel/trio/Makefile.orig:.endif
M> 
M>   emulators/i386-wine/Makefile.inc:.if ${OPSYS} != FreeBSD || 
(!(${OSVERSION} < 100) && !(${OSVERSION} >= 1003000 && ${OSVERSION} < 
110) && !(${OSVERSION} >= 1100121 && ${OSVERSION} < 120) && 
!(${OSVERSION} >= 1200019 && ${OSVERSION} < 130))
M> 
M>   lang/ruby22/Makefile:.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 
1100032) && (${ARCH} == "amd64" || ${ARCH} == "i386")
M> 
M>   lang/tcc/Makefile:.if ${CC:T:M*clang*} || ${OSVERSION} >= 124
M> 
M>   sysutils/e2fsprogs/Makefile:.if !empty(PORT_OPTIONS:MNOTESTS) && (${OPSYS} 
== FreeBSD) && (${OSVERSION} >= 110 || ((${ARCH} != i386) && (${ARCH} != 
amd64)))
M> 
M> However, I am kind of shocked that this is not well understood --
M> especially after I have tried so many times to convince src committers
M> to update FreeBSD_version in case of src changes that affect (e.g. break)
M> ports.
M> 
M> These are the kinds of things that ports committers have to use to work
M> around changes in the src tree.  Skipping OSVERSION updates makes this
M> work more complicated.
M> 
M> mcl

-- 
Totus tuus, Glebius.
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314709 - head

2017-03-06 Thread Warner Losh
On Mon, Mar 6, 2017 at 12:32 PM, Ian Lepore  wrote:
> On Mon, 2017-03-06 at 11:15 -0800, Rodney W. Grimes wrote:
>> [ Charset ISO-8859-1 unsupported, converting... ]
>> >
>> > On Mon, 2017-03-06 at 10:32 -0800, Rodney W. Grimes wrote:
>> > >
>> > > [ Charset ISO-8859-1 unsupported, converting... ]
>> > > >
>> > > >
>> > > > On Sun, 2017-03-05 at 19:12 -0800, Bryan Drewery wrote:
>> > > > >
>> > > > >
>> > > > > On 3/5/17 3:41 PM, Warner Losh wrote:
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > > On Sun, Mar 5, 2017 at 2:16 PM, Bryan Drewery > > > > > > ebsd
>> > > > > > .org
>> > > > > > >
>> > > > > > >
>> > > > > > > wrote:
>> > > > > > >
>> > > > > > > Author: bdrewery
>> > > > > > > Date: Sun Mar??5 21:16:50 2017
>> > > > > > > New Revision: 314709
>> > > > > > > URL: https://svnweb.freebsd.org/changeset/base/314709
>> > > > > > >
>> > > > > > > Log:
>> > > > > > > ? Fix bootstrapping mtree after r313404 for older
>> > > > > > > systems.
>> > > > > > >
>> > > > > > > ? r313404 made libnetbsd require sha384.h from
>> > > > > > > libmd.??Libmd
>> > > > > > > added it in
>> > > > > > > ? r292782.??Update BOOTSTRAPPING to account for this.
>> > > > > > >
>> > > > > > > ? Reported by:??bde
>> > > > > > > ? Reviewed by:??ngie
>> > > > > > >
>> > > > > > > Modified:
>> > > > > > > ? head/Makefile.inc1
>> > > > > > >
>> > > > > > > Modified: head/Makefile.inc1
>> > > > > > > =
>> > > > > > > 
>> > > > > > > 
>> > > > > > > =
>> > > > > > > --- head/Makefile.inc1??Sun Mar??5 19:56:20
>> > > > > > > 2017(r314708)
>> > > > > > > +++ head/Makefile.inc1??Sun Mar??5 21:16:50
>> > > > > > > 2017(r314709)
>> > > > > > > @@ -1618,10 +1618,12 @@ ${_bt}-usr.bin/m4: ${_bt}-
>> > > > > > > lib/libopenbsd
>> > > > > > > ?${_bt}-usr.bin/lex: ${_bt}-usr.bin/m4
>> > > > > > > ?.endif
>> > > > > > >
>> > > > > > > -.if ${BOOTSTRAPPING} < 126
>> > > > > > > -_nmtree=???lib/libnetbsd \
>> > > > > > I've been trying to document the bootstrapping stuff inline
>> > > > > > like
>> > > > > >
>> > > > > > # r313404 made libnetbsd require libmd
>> > > > > Definitely.??I forgot about that.??I think my change is
>> > > > > incomplete
>> > > > > and
>> > > > > need to chase down a 2nd failure report.??I'll add the
>> > > > > comment
>> > > > > once
>> > > > > that
>> > > > > is figured out.
>> > > > >
>> > > > I tracked this down to the fact that the prototype
>> > > >
>> > > > ? char * MD5FileChunk(const char *, char *, off_t, off_t);
>> > > >
>> > > > does not exist in /usr/include/sys/md5.h on older systems. ?I
>> > > > don't
>> > > > see
>> > > > any straightforward way to declare that a header file from the
>> > > > /usr/include hierarchy is a bootstrap item that needs a newer
>> > > > version
>> > > > from the source tree being compiled. ?It looks like such a
>> > > > header
>> > > > would
>> > > > have to go into the obj/.../tmp/legacy/usr/include to get used
>> > > > in
>> > > > the
>> > > > boostrap compile, I just don't see how you get a file installed
>> > > > there
>> > > > early enough in bootstrap.
>> > > One way around this is to use the old concept of /usr/include
>> > > symlinks
>> > > into the src tree, not sure if you can still do that or not, but
>> > > something like
>> > > (cd /usr/src/include; make install SHARED=symlinks)
>> > >
>> > > A bootstrapping regresssion test I use to run was to rm -r
>> > > /usr/include/*
>> > > before a buildworld run, that would find these issues so they
>> > > could
>> > > be fixed before they become forgotten.
>> > > ?
>> > Making my live 10-stable system's /usr/include have symlinks into a
>> > 11-
>> > or 12- source tree is just not an option in any way. ?The first
>> > question would be "which source tree" because I have like a dozen
>> > of
>> > them, not a single one of them rooted at /usr/src (which is an
>> > empty
>> > dir).
>> I dont know that the support of CUrrent -2 building -current with
>> a bootstraping include issue is ever going to be workable.  You
>> could try to build a proper include tree someplace to use, this
>> can be done with
>> (cd; usr/src/include; make install DESTDIR=/my/new/tree)  This
>> well not touch your /usr/include, but give you a proper include tree,
>> now the work is to get buildworld to use that include tree.
>>
>> If buildworld has degnerated to using stuff out of /usr/include
>> that also needs to be fixed ASAP.
>>
>> >
>> >
>> > This can't be the first time in 30+ years that system header files
>> > had
>> > to participate in the process of bootstrapping early build tools,
>> > but I
>> > don't see any machinery in Makefile.inc1 for dealing with it.
>> Happens often, hence why I had that regression test.   But
>> bootstrapping
>> on Current-2 has never been supported and probably never well be
>> supported.
>
> I'm aware that we officially only support building from current-1, but
> we've worked hard to do much better than that for many ye

Re: svn commit: r314709 - head

2017-03-06 Thread Warner Losh
On Mon, Mar 6, 2017 at 12:34 PM, Bryan Drewery  wrote:
> There is also a lot of demand for building from Linux or OSX.  That will
> require additional bootstrapping.  Either way, we'll never get away from
> bootstrapping, and the cost of keeping current-2 support is pretty low.

Yes. And in this case the workaround should be pretty trival. As I
noted elsewhere, we've supported bootstrapping from current-2 since
~FreeBSD 6.x. Juniper needed it for a long time and they maintained it
in the tree. The cost is generally tiny (though there has been one
issue with clang that required an upgrade to the host compiler due to
a bug in the host compiler so that it could compile the compiler).
This should be fixed. Glad to see Ian's on it.

Warner
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


svn commit: r314786 - in head/sys/dev/mpr: . mpi

2017-03-06 Thread Alexander Motin
Author: mav
Date: Mon Mar  6 19:39:31 2017
New Revision: 314786
URL: https://svnweb.freebsd.org/changeset/base/314786

Log:
  Import mpr(4) driver P12 to P14 diff from vendor site.
  
  This is mostly a version bump to stay in version number sync with firmware.
  The only change there was cosmetic:  Display degraded speed message upon
  receiving Active Cable Exception Event with DEGRADED reason code.
  
  Discussed with:   slm@
  MFC after:1 week

Modified:
  head/sys/dev/mpr/mpi/mpi2_ioc.h
  head/sys/dev/mpr/mpr_sas_lsi.c
  head/sys/dev/mpr/mpr_table.c
  head/sys/dev/mpr/mprvar.h

Modified: head/sys/dev/mpr/mpi/mpi2_ioc.h
==
--- head/sys/dev/mpr/mpi/mpi2_ioc.h Mon Mar  6 19:33:15 2017
(r314785)
+++ head/sys/dev/mpr/mpi/mpi2_ioc.h Mon Mar  6 19:39:31 2017
(r314786)
@@ -688,7 +688,10 @@ typedef struct _MPI26_EVENT_DATA_ACTIVE_
   MPI2_POINTER pMpi26EventDataActiveCableExcept_t;
 
 /* defines for ReasonCode field */
-#define MPI26_EVENT_ACTIVE_CABLE_INSUFFICIENT_POWER (0x00)
+#define MPI26_EVENT_ACTIVE_CABLE_INSUFFICIENT_POWER(0x00)
+#define MPI26_EVENT_ACTIVE_CABLE_PRESENT   (0x01) 
+#define MPI26_EVENT_ACTIVE_CABLE_DEGRADED  (0x02) 
+
 
 
 /* Hard Reset Received Event data */

Modified: head/sys/dev/mpr/mpr_sas_lsi.c
==
--- head/sys/dev/mpr/mpr_sas_lsi.c  Mon Mar  6 19:33:15 2017
(r314785)
+++ head/sys/dev/mpr/mpr_sas_lsi.c  Mon Mar  6 19:39:31 2017
(r314786)
@@ -651,14 +651,26 @@ skip_fp_send:
ace_event_data =
(pMpi26EventDataActiveCableExcept_t)fw_event->event_data;
 
-   if (ace_event_data->ReasonCode ==
-   MPI26_EVENT_ACTIVE_CABLE_INSUFFICIENT_POWER) {
-   mpr_printf(sc, "Currently an active cable with "
+   switch(ace_event_data->ReasonCode) {
+   case MPI26_EVENT_ACTIVE_CABLE_INSUFFICIENT_POWER:
+   {
+   mpr_printf(sc, "Currently a cable with "
"ReceptacleID %d cannot be powered and device "
"connected to this active cable will not be seen. "
"This active cable requires %d mW of power.\n",
ace_event_data->ReceptacleID,
ace_event_data->ActiveCablePowerRequirement);
+   break;
+   }
+   case MPI26_EVENT_ACTIVE_CABLE_DEGRADED:
+   {
+   mpr_printf(sc, "Currently a cable with "
+   "ReceptacleID %d is not running at optimal speed "
+   "(12 Gb/s rate)\n", ace_event_data->ReceptacleID);
+   break;
+   }
+   default:
+   break;
}
break;
}

Modified: head/sys/dev/mpr/mpr_table.c
==
--- head/sys/dev/mpr/mpr_table.cMon Mar  6 19:33:15 2017
(r314785)
+++ head/sys/dev/mpr/mpr_table.cMon Mar  6 19:39:31 2017
(r314786)
@@ -95,6 +95,12 @@ struct mpr_table_lookup mpr_event_names[
{"SasPhyCounter",   0x22},
{"GpioInterrupt",   0x23},
{"HbdPhyEvent", 0x24},
+   {"SasQuiesce",  0x25},
+   {"SasNotifyPrimitive",  0x26},
+   {"TempThreshold",   0x27},
+   {"HostMessage", 0x28},
+   {"PowerPerformanceChange",  0x29},
+   {"CableEvent",  0x34},
{NULL, 0},
{"Unknown Event", 0}
 };

Modified: head/sys/dev/mpr/mprvar.h
==
--- head/sys/dev/mpr/mprvar.h   Mon Mar  6 19:33:15 2017(r314785)
+++ head/sys/dev/mpr/mprvar.h   Mon Mar  6 19:39:31 2017(r314786)
@@ -33,7 +33,7 @@
 #ifndef _MPRVAR_H
 #define _MPRVAR_H
 
-#define MPR_DRIVER_VERSION "13.01.00.00-fbsd"
+#define MPR_DRIVER_VERSION "15.01.00.00-fbsd"
 
 #define MPR_DB_MAX_WAIT2500
 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314709 - head

2017-03-06 Thread Warner Losh
On Mon, Mar 6, 2017 at 12:15 PM, Rodney W. Grimes
 wrote:
> Happens often, hence why I had that regression test.   But bootstrapping
> on Current-2 has never been supported and probably never well be supported.

We do support it. We've supported it since FreeBSD 6.x. It's
completely workable.

Warner
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314709 - head

2017-03-06 Thread Bryan Drewery
On 3/6/17 11:32 AM, Ian Lepore wrote:
> On Mon, 2017-03-06 at 11:15 -0800, Rodney W. Grimes wrote:
>> [ Charset ISO-8859-1 unsupported, converting... ]
>>>
>>> On Mon, 2017-03-06 at 10:32 -0800, Rodney W. Grimes wrote:

 [ Charset ISO-8859-1 unsupported, converting... ]
>
>
> On Sun, 2017-03-05 at 19:12 -0800, Bryan Drewery wrote:
>>
>>
>> On 3/5/17 3:41 PM, Warner Losh wrote:
>>>
>>>
>>>
>>> On Sun, Mar 5, 2017 at 2:16 PM, Bryan Drewery >> ebsd
>>> .org


 wrote:

 Author: bdrewery
 Date: Sun Mar??5 21:16:50 2017
 New Revision: 314709
 URL: https://svnweb.freebsd.org/changeset/base/314709

 Log:
 ? Fix bootstrapping mtree after r313404 for older
 systems.

 ? r313404 made libnetbsd require sha384.h from
 libmd.??Libmd
 added it in
 ? r292782.??Update BOOTSTRAPPING to account for this.

 ? Reported by:??bde
 ? Reviewed by:??ngie

 Modified:
 ? head/Makefile.inc1

 Modified: head/Makefile.inc1
 =
 
 
 =
 --- head/Makefile.inc1??Sun Mar??5 19:56:20
 2017(r314708)
 +++ head/Makefile.inc1??Sun Mar??5 21:16:50
 2017(r314709)
 @@ -1618,10 +1618,12 @@ ${_bt}-usr.bin/m4: ${_bt}-
 lib/libopenbsd
 ?${_bt}-usr.bin/lex: ${_bt}-usr.bin/m4
 ?.endif

 -.if ${BOOTSTRAPPING} < 126
 -_nmtree=???lib/libnetbsd \
>>> I've been trying to document the bootstrapping stuff inline
>>> like
>>>
>>> # r313404 made libnetbsd require libmd
>> Definitely.??I forgot about that.??I think my change is
>> incomplete
>> and
>> need to chase down a 2nd failure report.??I'll add the
>> comment
>> once
>> that
>> is figured out.
>>
> I tracked this down to the fact that the prototype
>
> ? char * MD5FileChunk(const char *, char *, off_t, off_t);
>
> does not exist in /usr/include/sys/md5.h on older systems. ?I
> don't
> see
> any straightforward way to declare that a header file from the
> /usr/include hierarchy is a bootstrap item that needs a newer
> version
> from the source tree being compiled. ?It looks like such a
> header
> would
> have to go into the obj/.../tmp/legacy/usr/include to get used
> in
> the
> boostrap compile, I just don't see how you get a file installed
> there
> early enough in bootstrap.
 One way around this is to use the old concept of /usr/include
 symlinks
 into the src tree, not sure if you can still do that or not, but
 something like
 (cd /usr/src/include; make install SHARED=symlinks)

 A bootstrapping regresssion test I use to run was to rm -r
 /usr/include/*
 before a buildworld run, that would find these issues so they
 could
 be fixed before they become forgotten.
 ?
>>> Making my live 10-stable system's /usr/include have symlinks into a
>>> 11-
>>> or 12- source tree is just not an option in any way. ?The first
>>> question would be "which source tree" because I have like a dozen
>>> of
>>> them, not a single one of them rooted at /usr/src (which is an
>>> empty
>>> dir).
>> I dont know that the support of CUrrent -2 building -current with
>> a bootstraping include issue is ever going to be workable.  You
>> could try to build a proper include tree someplace to use, this
>> can be done with
>> (cd; usr/src/include; make install DESTDIR=/my/new/tree)  This
>> well not touch your /usr/include, but give you a proper include tree,
>> now the work is to get buildworld to use that include tree.
>>
>> If buildworld has degnerated to using stuff out of /usr/include
>> that also needs to be fixed ASAP.
>>
>>>
>>>
>>> This can't be the first time in 30+ years that system header files
>>> had
>>> to participate in the process of bootstrapping early build tools,
>>> but I
>>> don't see any machinery in Makefile.inc1 for dealing with it.
>> Happens often, hence why I had that regression test.   But
>> bootstrapping
>> on Current-2 has never been supported and probably never well be
>> supported.
> 
> I'm aware that we officially only support building from current-1, but
> we've worked hard to do much better than that for many years.
> 
> The only time I can think of it breaking in the last 10-12 years was
> late in the 10-current cycle we reached a point where I could no longer
> build 10-current on an 8-stable system.  That was a special case due to
> the cutover from gcc to clang and all the related changes.  (Even with
> that, I had it "almost working" but decided not to finish it and commit
> all the changes involved because they would have just gotten in the way
> of other mod

Re: svn commit: r314785 - head/usr.sbin/cxgbetool

2017-03-06 Thread Ngie Cooper (yaneurabeya)

> On Mar 6, 2017, at 11:33, Ngie Cooper  wrote:
> 
> Author: ngie
> Date: Mon Mar  6 19:33:15 2017
> New Revision: 314785
> URL: https://svnweb.freebsd.org/changeset/base/314785
> 
> Log:
>  Fix some trivial manlint warnings
> 
>  Sentences should begin on new lines, per manlint.
> 
>  Bump .Dd for the change
> 
>  MFC after:   1 month
>  Reviewed by: bcr
>  Reported by: make manlint
>  Sponsored by:Dell EMC Isilon

Differential Revision:  https://reviews.freebsd.org/D9884


signature.asc
Description: Message signed with OpenPGP using GPGMail


Re: svn commit: r314709 - head

2017-03-06 Thread Ian Lepore
On Mon, 2017-03-06 at 11:13 -0800, Bryan Drewery wrote:
> On 3/6/17 10:58 AM, Ian Lepore wrote:
> > 
> > On Mon, 2017-03-06 at 10:32 -0800, Rodney W. Grimes wrote:
> > > 
> > > [ Charset ISO-8859-1 unsupported, converting... ]
> > > > 
> > > > 
> > > > On Sun, 2017-03-05 at 19:12 -0800, Bryan Drewery wrote:
> > > > > 
> > > > > 
> > > > > On 3/5/17 3:41 PM, Warner Losh wrote:
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > On Sun, Mar 5, 2017 at 2:16 PM, Bryan Drewery  > > > > > ebsd
> > > > > > .org
> > > > > > > 
> > > > > > > 
> > > > > > > wrote:
> > > > > > > 
> > > > > > > Author: bdrewery
> > > > > > > Date: Sun Mar??5 21:16:50 2017
> > > > > > > New Revision: 314709
> > > > > > > URL: https://svnweb.freebsd.org/changeset/base/314709
> > > > > > > 
> > > > > > > Log:
> > > > > > > ? Fix bootstrapping mtree after r313404 for older
> > > > > > > systems.
> > > > > > > 
> > > > > > > ? r313404 made libnetbsd require sha384.h from
> > > > > > > libmd.??Libmd
> > > > > > > added it in
> > > > > > > ? r292782.??Update BOOTSTRAPPING to account for this.
> > > > > > > 
> > > > > > > ? Reported by:??bde
> > > > > > > ? Reviewed by:??ngie
> > > > > > > 
> > > > > > > Modified:
> > > > > > > ? head/Makefile.inc1
> > > > > > > 
> > > > > > > Modified: head/Makefile.inc1
> > > > > > > =
> > > > > > > 
> > > > > > > 
> > > > > > > =
> > > > > > > --- head/Makefile.inc1??Sun Mar??5 19:56:20
> > > > > > > 2017(r314708)
> > > > > > > +++ head/Makefile.inc1??Sun Mar??5 21:16:50
> > > > > > > 2017(r314709)
> > > > > > > @@ -1618,10 +1618,12 @@ ${_bt}-usr.bin/m4: ${_bt}-
> > > > > > > lib/libopenbsd
> > > > > > > ?${_bt}-usr.bin/lex: ${_bt}-usr.bin/m4
> > > > > > > ?.endif
> > > > > > > 
> > > > > > > -.if ${BOOTSTRAPPING} < 126
> > > > > > > -_nmtree=???lib/libnetbsd \
> > > > > > I've been trying to document the bootstrapping stuff inline
> > > > > > like
> > > > > > 
> > > > > > # r313404 made libnetbsd require libmd
> > > > > Definitely.??I forgot about that.??I think my change is
> > > > > incomplete
> > > > > and
> > > > > need to chase down a 2nd failure report.??I'll add the
> > > > > comment
> > > > > once
> > > > > that
> > > > > is figured out.
> > > > > 
> > > > I tracked this down to the fact that the prototype
> > > > 
> > > > ? char * MD5FileChunk(const char *, char *, off_t, off_t);
> > > > 
> > > > does not exist in /usr/include/sys/md5.h on older systems. ?I
> > > > don't
> > > > see
> > > > any straightforward way to declare that a header file from the
> > > > /usr/include hierarchy is a bootstrap item that needs a newer
> > > > version
> > > > from the source tree being compiled. ?It looks like such a
> > > > header
> > > > would
> > > > have to go into the obj/.../tmp/legacy/usr/include to get used
> > > > in
> > > > the
> > > > boostrap compile, I just don't see how you get a file installed
> > > > there
> > > > early enough in bootstrap.
> > > One way around this is to use the old concept of /usr/include
> > > symlinks
> > > into the src tree, not sure if you can still do that or not, but
> > > something like
> > > (cd /usr/src/include; make install SHARED=symlinks)
> > > 
> > > A bootstrapping regresssion test I use to run was to rm -r
> > > /usr/include/*
> > > before a buildworld run, that would find these issues so they
> > > could
> > > be fixed before they become forgotten.
> > >  
> > Making my live 10-stable system's /usr/include have symlinks into a
> > 11-
> > or 12- source tree is just not an option in any way.  The first
> > question would be "which source tree" because I have like a dozen
> > of
> > them, not a single one of them rooted at /usr/src (which is an
> > empty
> > dir).
> > 
> > This can't be the first time in 30+ years that system header files
> > had
> > to participate in the process of bootstrapping early build tools,
> > but I
> > don't see any machinery in Makefile.inc1 for dealing with it.
> > 
> > -- Ian
> > 
> We use some special hacks in some places.  Such as most of the
> elftoolchain build.  It just symlinks the minimal headers it needs
> into
> its .OBJDIR and uses -I${.OBJDIR} to pick them up.  This is done
> rather
> than the legacy method so that we don't pollute all of the
> bootstrapping
> with these headers; we really want the system headers for all of
> bootstrapping where possible since we are building *current native
> system tools*.
> 
> libmd is already violating this by including some source directories
> directly, but they should be harmless since they are really just
> prototypes for the libmd that is being built.
> 
> > 
> > CFLAGS+= -I${.CURDIR} -I${SRCTOP}/sys/crypto/sha2
> > CFLAGS+= -I${SRCTOP}/sys/crypto/skein
> In the case of the current bootstrap failure, it's probably more than
> just this 1 function that is causing problems, but what I'm
> suggesting is at
> https://people.freebsd.org/~bdrewery/patches/libmd-sys-md5.h.patch
> 
> 

I've 

svn commit: r314785 - head/usr.sbin/cxgbetool

2017-03-06 Thread Ngie Cooper
Author: ngie
Date: Mon Mar  6 19:33:15 2017
New Revision: 314785
URL: https://svnweb.freebsd.org/changeset/base/314785

Log:
  Fix some trivial manlint warnings
  
  Sentences should begin on new lines, per manlint.
  
  Bump .Dd for the change
  
  MFC after:1 month
  Reviewed by:  bcr
  Reported by:  make manlint
  Sponsored by: Dell EMC Isilon

Modified:
  head/usr.sbin/cxgbetool/cxgbetool.8

Modified: head/usr.sbin/cxgbetool/cxgbetool.8
==
--- head/usr.sbin/cxgbetool/cxgbetool.8 Mon Mar  6 19:14:08 2017
(r314784)
+++ head/usr.sbin/cxgbetool/cxgbetool.8 Mon Mar  6 19:33:15 2017
(r314785)
@@ -31,7 +31,7 @@
 .\"
 .\" $FreeBSD$
 .\"
-.Dd February 1, 2013
+.Dd March 6, 2017
 .Dt CXGBETOOL 8
 .Os
 .Sh NAME
@@ -133,7 +133,8 @@ or
 .Va dev.cxgbe.%d.ofld_rxq.%d.fl.cntxt_id Ns .
 Note that freelists are egress queues too.
 .It Ar flm_cntxt_id
-context id of a freelist manager.  The FLM context id is displayed in the
+context id of a freelist manager.
+The FLM context id is displayed in the
 egress context dump of a freelist as FLMcontextID.
 .El
 .It Cm filter mode Op Ar match-criteria ...
@@ -379,7 +380,8 @@ The card's memory map is available in
 .Va dev.t4nex.%d.misc.meminfo Ns .
 .It Bro Cm reg | reg64 Brc Ar addr Ns Op Ar =val
 .It Cm regdump Op Ar register-block ...
-Display contents of device registers.  One or more
+Display contents of device registers.
+One or more
 .Ar register-block
 can be specified to limit the registers displayed.
 The default is to display registers for all blocks.
@@ -400,7 +402,8 @@ A non-zero value will enable "minmax" mo
 .Pp
 NOTE:  Many (most) of the parameters and constraints are adapter-specific
 - for instance the number of channels and classes which are available
-whether various modes are implemented, etc.  Consult the adapter documentation 
for specific information on any limitations.
+whether various modes are implemented, etc.
+Consult the adapter documentation for specific information on any limitations.
 .El
 .It Cm sched-class params Op Ar param Ar value
 Configure parameters for a scheduling class.
@@ -471,7 +474,8 @@ The weight to be used for a weighted-rou
 The average packet size will be used to compute scheduler constraints for a 
rate-limited scheduler class hierarchy.
 .Pp
 NOTE:  Many (most) of the parameters and constraints are adapter-specific - 
for instance the number of channels and classes which are available,
-whether various modes are implemented, etc.  Consult the adapter documentation 
for specific information on any limitations.
+whether various modes are implemented, etc.
+Consult the adapter documentation for specific information on any limitations.
 .El
 .It Cm sched-queue Ar port queue class
 Bind the indicated port's NIC TX
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"


Re: svn commit: r314709 - head

2017-03-06 Thread Ian Lepore
On Mon, 2017-03-06 at 11:15 -0800, Rodney W. Grimes wrote:
> [ Charset ISO-8859-1 unsupported, converting... ]
> > 
> > On Mon, 2017-03-06 at 10:32 -0800, Rodney W. Grimes wrote:
> > > 
> > > [ Charset ISO-8859-1 unsupported, converting... ]
> > > > 
> > > > 
> > > > On Sun, 2017-03-05 at 19:12 -0800, Bryan Drewery wrote:
> > > > > 
> > > > > 
> > > > > On 3/5/17 3:41 PM, Warner Losh wrote:
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > On Sun, Mar 5, 2017 at 2:16 PM, Bryan Drewery  > > > > > ebsd
> > > > > > .org
> > > > > > > 
> > > > > > > 
> > > > > > > wrote:
> > > > > > > 
> > > > > > > Author: bdrewery
> > > > > > > Date: Sun Mar??5 21:16:50 2017
> > > > > > > New Revision: 314709
> > > > > > > URL: https://svnweb.freebsd.org/changeset/base/314709
> > > > > > > 
> > > > > > > Log:
> > > > > > > ? Fix bootstrapping mtree after r313404 for older
> > > > > > > systems.
> > > > > > > 
> > > > > > > ? r313404 made libnetbsd require sha384.h from
> > > > > > > libmd.??Libmd
> > > > > > > added it in
> > > > > > > ? r292782.??Update BOOTSTRAPPING to account for this.
> > > > > > > 
> > > > > > > ? Reported by:??bde
> > > > > > > ? Reviewed by:??ngie
> > > > > > > 
> > > > > > > Modified:
> > > > > > > ? head/Makefile.inc1
> > > > > > > 
> > > > > > > Modified: head/Makefile.inc1
> > > > > > > =
> > > > > > > 
> > > > > > > 
> > > > > > > =
> > > > > > > --- head/Makefile.inc1??Sun Mar??5 19:56:20
> > > > > > > 2017(r314708)
> > > > > > > +++ head/Makefile.inc1??Sun Mar??5 21:16:50
> > > > > > > 2017(r314709)
> > > > > > > @@ -1618,10 +1618,12 @@ ${_bt}-usr.bin/m4: ${_bt}-
> > > > > > > lib/libopenbsd
> > > > > > > ?${_bt}-usr.bin/lex: ${_bt}-usr.bin/m4
> > > > > > > ?.endif
> > > > > > > 
> > > > > > > -.if ${BOOTSTRAPPING} < 126
> > > > > > > -_nmtree=???lib/libnetbsd \
> > > > > > I've been trying to document the bootstrapping stuff inline
> > > > > > like
> > > > > > 
> > > > > > # r313404 made libnetbsd require libmd
> > > > > Definitely.??I forgot about that.??I think my change is
> > > > > incomplete
> > > > > and
> > > > > need to chase down a 2nd failure report.??I'll add the
> > > > > comment
> > > > > once
> > > > > that
> > > > > is figured out.
> > > > > 
> > > > I tracked this down to the fact that the prototype
> > > > 
> > > > ? char * MD5FileChunk(const char *, char *, off_t, off_t);
> > > > 
> > > > does not exist in /usr/include/sys/md5.h on older systems. ?I
> > > > don't
> > > > see
> > > > any straightforward way to declare that a header file from the
> > > > /usr/include hierarchy is a bootstrap item that needs a newer
> > > > version
> > > > from the source tree being compiled. ?It looks like such a
> > > > header
> > > > would
> > > > have to go into the obj/.../tmp/legacy/usr/include to get used
> > > > in
> > > > the
> > > > boostrap compile, I just don't see how you get a file installed
> > > > there
> > > > early enough in bootstrap.
> > > One way around this is to use the old concept of /usr/include
> > > symlinks
> > > into the src tree, not sure if you can still do that or not, but
> > > something like
> > > (cd /usr/src/include; make install SHARED=symlinks)
> > > 
> > > A bootstrapping regresssion test I use to run was to rm -r
> > > /usr/include/*
> > > before a buildworld run, that would find these issues so they
> > > could
> > > be fixed before they become forgotten.
> > > ?
> > Making my live 10-stable system's /usr/include have symlinks into a
> > 11-
> > or 12- source tree is just not an option in any way. ?The first
> > question would be "which source tree" because I have like a dozen
> > of
> > them, not a single one of them rooted at /usr/src (which is an
> > empty
> > dir).
> I dont know that the support of CUrrent -2 building -current with
> a bootstraping include issue is ever going to be workable.  You
> could try to build a proper include tree someplace to use, this
> can be done with
> (cd; usr/src/include; make install DESTDIR=/my/new/tree)  This
> well not touch your /usr/include, but give you a proper include tree,
> now the work is to get buildworld to use that include tree.
> 
> If buildworld has degnerated to using stuff out of /usr/include
> that also needs to be fixed ASAP.
> 
> > 
> > 
> > This can't be the first time in 30+ years that system header files
> > had
> > to participate in the process of bootstrapping early build tools,
> > but I
> > don't see any machinery in Makefile.inc1 for dealing with it.
> Happens often, hence why I had that regression test.   But
> bootstrapping
> on Current-2 has never been supported and probably never well be
> supported.

I'm aware that we officially only support building from current-1, but
we've worked hard to do much better than that for many years.

The only time I can think of it breaking in the last 10-12 years was
late in the 10-current cycle we reached a point where I could no longer
build 10-current

  1   2   >