Re: svn commit: r359046 - head/share/mk

2020-03-18 Thread Brooks Davis
On Wed, Mar 18, 2020 at 12:29:24PM +0900, Hiroki Sato wrote:
> Brooks Davis  wrote
>   in <202003171817.02hihwdy035...@repo.freebsd.org>:
> 
> br> Author: brooks
> br> Date: Tue Mar 17 18:17:32 2020
> br> New Revision: 359046
> br> URL: https://svnweb.freebsd.org/changeset/base/359046
> br>
> br> Log:
> br>   Support SUBDIR.${MK_FOO}.${MK_BAR} expresssions.
> br>
> br>   This allows simplification of Makefiles where some SUBDIR entries depend
> br>   on two things (e.g. something that depends on C++ and some other knob).
> 
>  Just my two cents, but SUBDIR.${MK_FOO:M${MK_BAR}:M${MK_BAZ}}= dir
>  should do the trick.  I am not sure how many variables we need to
>  support in practice, adding ".yes.yes..." in bsd.subdir.mk looks less
>  flexible to me.

IMO that's lousy from a readability perspective.  It's remotely
conceivable that supporting three variables might make sense, but more
seems vanishingly unlikely and even so, it's trivial to add more cases.

-- Brooks


signature.asc
Description: PGP signature


Re: svn commit: r359046 - head/share/mk

2020-03-17 Thread Hiroki Sato
Brooks Davis  wrote
  in <202003171817.02hihwdy035...@repo.freebsd.org>:

br> Author: brooks
br> Date: Tue Mar 17 18:17:32 2020
br> New Revision: 359046
br> URL: https://svnweb.freebsd.org/changeset/base/359046
br>
br> Log:
br>   Support SUBDIR.${MK_FOO}.${MK_BAR} expresssions.
br>
br>   This allows simplification of Makefiles where some SUBDIR entries depend
br>   on two things (e.g. something that depends on C++ and some other knob).

 Just my two cents, but SUBDIR.${MK_FOO:M${MK_BAR}:M${MK_BAZ}}= dir
 should do the trick.  I am not sure how many variables we need to
 support in practice, adding ".yes.yes..." in bsd.subdir.mk looks less
 flexible to me.

br>   Discussed with:   imp, jhb
br>   Obtained from:CheriBSD
br>   MFC after:3 days
br>   Sponsored by: DARPA
br>
br> Modified:
br>   head/share/mk/bsd.subdir.mk
br>
br> Modified: head/share/mk/bsd.subdir.mk
br> 
==
br> --- head/share/mk/bsd.subdir.mk Tue Mar 17 17:28:12 2020
(r359045)
br> +++ head/share/mk/bsd.subdir.mk Tue Mar 17 18:17:32 2020
(r359046)
br> @@ -16,8 +16,8 @@
br>  #
br>  # SUBDIR   A list of subdirectories that should be built as well.
br>  #  Each of the targets will execute the same target in the
br> -#  subdirectories. SUBDIR.yes is automatically appended
br> -#  to this list.
br> +#  subdirectories. SUBDIR.yes and SUBDIR.yes.yes are
br> +#  automatically appended to this list.
br>  #
br>  # +++ targets +++
br>  #
br> @@ -122,8 +122,8 @@ install:beforeinstall realinstall afterinstall
br>  # SUBDIR recursing may be disabled for MK_DIRDEPS_BUILD
br>  .if !target(_SUBDIR)
br>
br> -.if defined(SUBDIR) || defined(SUBDIR.yes)
br> -SUBDIR:=${SUBDIR} ${SUBDIR.yes}
br> +.if defined(SUBDIR) || defined(SUBDIR.yes) || defined(SUBDIR.yes.yes)
br> +SUBDIR:=${SUBDIR} ${SUBDIR.yes} ${SUBDIR.yes.yes}
br>  SUBDIR:=${SUBDIR:u}
br>  .endif
br>
br>


pgpAVwhKvtlsX.pgp
Description: PGP signature


svn commit: r359046 - head/share/mk

2020-03-17 Thread Brooks Davis
Author: brooks
Date: Tue Mar 17 18:17:32 2020
New Revision: 359046
URL: https://svnweb.freebsd.org/changeset/base/359046

Log:
  Support SUBDIR.${MK_FOO}.${MK_BAR} expresssions.
  
  This allows simplification of Makefiles where some SUBDIR entries depend
  on two things (e.g. something that depends on C++ and some other knob).
  
  Discussed with:   imp, jhb
  Obtained from:CheriBSD
  MFC after:3 days
  Sponsored by: DARPA

Modified:
  head/share/mk/bsd.subdir.mk

Modified: head/share/mk/bsd.subdir.mk
==
--- head/share/mk/bsd.subdir.mk Tue Mar 17 17:28:12 2020(r359045)
+++ head/share/mk/bsd.subdir.mk Tue Mar 17 18:17:32 2020(r359046)
@@ -16,8 +16,8 @@
 #
 # SUBDIR   A list of subdirectories that should be built as well.
 #  Each of the targets will execute the same target in the
-#  subdirectories. SUBDIR.yes is automatically appended
-#  to this list.
+#  subdirectories. SUBDIR.yes and SUBDIR.yes.yes are
+#  automatically appended to this list.
 #
 # +++ targets +++
 #
@@ -122,8 +122,8 @@ install:beforeinstall realinstall afterinstall
 # SUBDIR recursing may be disabled for MK_DIRDEPS_BUILD
 .if !target(_SUBDIR)
 
-.if defined(SUBDIR) || defined(SUBDIR.yes)
-SUBDIR:=${SUBDIR} ${SUBDIR.yes}
+.if defined(SUBDIR) || defined(SUBDIR.yes) || defined(SUBDIR.yes.yes)
+SUBDIR:=${SUBDIR} ${SUBDIR.yes} ${SUBDIR.yes.yes}
 SUBDIR:=${SUBDIR:u}
 .endif
 
___
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"