A few fields have an open-coded length. Use the defines for this purpose
instead.

Signed-off-by: Simon Glass <s...@chromium.org>
Reviewed-by: Bin Meng <bmeng...@gmail.com>
---

(no changes since v1)

 include/acpi/acpi_table.h | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/include/acpi/acpi_table.h b/include/acpi/acpi_table.h
index 9fba6536f50..3a243bf19ce 100644
--- a/include/acpi/acpi_table.h
+++ b/include/acpi/acpi_table.h
@@ -13,6 +13,7 @@
 #ifndef __ACPI_TABLE_H__
 #define __ACPI_TABLE_H__
 
+#include <dm/acpi.h>
 #include <linux/bitops.h>
 
 #define RSDP_SIG               "RSD PTR "      /* RSDP pointer signature */
@@ -48,7 +49,7 @@ struct acpi_rsdp {
 
 /* Generic ACPI header, provided by (almost) all tables */
 struct __packed acpi_table_header {
-       char signature[4];      /* ACPI signature (4 ASCII characters) */
+       char signature[ACPI_NAME_LEN];  /* ACPI signature (4 ASCII chars) */
        u32 length;             /* Table length in bytes (incl. header) */
        u8 revision;            /* Table version (not ACPI version!) */
        volatile u8 checksum;   /* To make sum of entire table == 0 */
@@ -263,7 +264,7 @@ struct __packed acpi_fadt {
 
 /* FACS (Firmware ACPI Control Structure) */
 struct acpi_facs {
-       char signature[4];              /* "FACS" */
+       char signature[ACPI_NAME_LEN];  /* "FACS" */
        u32 length;                     /* Length in bytes (>= 64) */
        u32 hardware_signature;         /* Hardware signature */
        u32 firmware_waking_vector;     /* Firmware waking vector */
-- 
2.28.0.681.g6f77f65b4e-goog

Reply via email to