[U-Boot] [PATCH] ARM change name of defines for AT91 arm926ejs

2010-02-24 Thread Achim Ehrlich
Configuration defines should be preceeded with CONFIG_SYS_. Renamed
some at91 specific defines to conform to this naming convention:

AT91_CPU_NAME to CONFIG_SYS_AT91_CPU_NAME
AT91_MAIN_CLOCK to CONFIG_SYS_AT91_MAIN_CLOCK

Signed-off-by: Achim Ehrlich aehrl...@taskit.de
---
 board/atmel/at91cap9adk/at91cap9adk.c   |2 +-
 board/atmel/at91sam9261ek/at91sam9261ek.c   |2 +-
 board/atmel/at91sam9263ek/at91sam9263ek.c   |2 +-
 board/atmel/at91sam9m10g45ek/at91sam9m10g45ek.c |2 +-
 board/atmel/at91sam9rlek/at91sam9rlek.c |2 +-
 board/esd/otc570/otc570.c   |2 +-
 board/ronetix/pm9261/pm9261.c   |2 +-
 board/ronetix/pm9263/pm9263.c   |2 +-
 cpu/arm926ejs/at91/clock.c  |2 +-
 cpu/arm926ejs/at91/cpu.c|8 
 include/asm-arm/arch-at91/at91cap9.h|2 +-
 include/asm-arm/arch-at91/at91rm9200.h  |2 +-
 include/asm-arm/arch-at91/at91sam9260.h |4 ++--
 include/asm-arm/arch-at91/at91sam9261.h |2 +-
 include/asm-arm/arch-at91/at91sam9263.h |2 +-
 include/asm-arm/arch-at91/at91sam9g45.h |2 +-
 include/asm-arm/arch-at91/at91sam9rl.h  |2 +-
 include/configs/afeb9260.h  |2 +-
 include/configs/at91cap9adk.h   |2 +-
 include/configs/at91sam9260ek.h |2 +-
 include/configs/at91sam9261ek.h |2 +-
 include/configs/at91sam9263ek.h |2 +-
 include/configs/at91sam9m10g45ek.h  |2 +-
 include/configs/at91sam9rlek.h  |2 +-
 include/configs/cpu9260.h   |2 +-
 include/configs/pm9261.h|4 ++--
 include/configs/pm9263.h|2 +-
 include/configs/sbc35_a9g20.h   |2 +-
 include/configs/tny_a9260.h |2 +-
 29 files changed, 34 insertions(+), 34 deletions(-)

diff --git a/board/atmel/at91cap9adk/at91cap9adk.c 
b/board/atmel/at91cap9adk/at91cap9adk.c
index 9f73df6..258d1ea 100644
--- a/board/atmel/at91cap9adk/at91cap9adk.c
+++ b/board/atmel/at91cap9adk/at91cap9adk.c
@@ -282,7 +282,7 @@ void lcd_show_board_info(void)
lcd_printf ((C) 2008 ATMEL Corp\n);
lcd_printf (at91supp...@atmel.com\n);
lcd_printf (%s CPU at %s MHz\n,
-   AT91_CPU_NAME,
+   CONFIG_SYS_AT91_CPU_NAME,
strmhz(temp, get_cpu_clk_rate()));
 
dram_size = 0;
diff --git a/board/atmel/at91sam9261ek/at91sam9261ek.c 
b/board/atmel/at91sam9261ek/at91sam9261ek.c
index 7ead2b8..de5cfae 100644
--- a/board/atmel/at91sam9261ek/at91sam9261ek.c
+++ b/board/atmel/at91sam9261ek/at91sam9261ek.c
@@ -217,7 +217,7 @@ void lcd_show_board_info(void)
lcd_printf ((C) 2008 ATMEL Corp\n);
lcd_printf (at91supp...@atmel.com\n);
lcd_printf (%s CPU at %s MHz\n,
-   AT91_CPU_NAME,
+   CONFIG_SYS_AT91_CPU_NAME,
strmhz(temp, get_cpu_clk_rate()));
 
dram_size = 0;
diff --git a/board/atmel/at91sam9263ek/at91sam9263ek.c 
b/board/atmel/at91sam9263ek/at91sam9263ek.c
index 8ab45af..5cd7aa7 100644
--- a/board/atmel/at91sam9263ek/at91sam9263ek.c
+++ b/board/atmel/at91sam9263ek/at91sam9263ek.c
@@ -218,7 +218,7 @@ void lcd_show_board_info(void)
lcd_printf ((C) 2008 ATMEL Corp\n);
lcd_printf (at91supp...@atmel.com\n);
lcd_printf (%s CPU at %s MHz\n,
-   AT91_CPU_NAME,
+   CONFIG_SYS_AT91_CPU_NAME,
strmhz(temp, get_cpu_clk_rate()));
 
dram_size = 0;
diff --git a/board/atmel/at91sam9m10g45ek/at91sam9m10g45ek.c 
b/board/atmel/at91sam9m10g45ek/at91sam9m10g45ek.c
index 45a14a9..edfb627 100644
--- a/board/atmel/at91sam9m10g45ek/at91sam9m10g45ek.c
+++ b/board/atmel/at91sam9m10g45ek/at91sam9m10g45ek.c
@@ -217,7 +217,7 @@ void lcd_show_board_info(void)
lcd_printf ((C) 2008 ATMEL Corp\n);
lcd_printf (at91supp...@atmel.com\n);
lcd_printf (%s CPU at %s MHz\n,
-   AT91_CPU_NAME,
+   CONFIG_SYS_AT91_CPU_NAME,
strmhz(temp, get_cpu_clk_rate()));
 
dram_size = 0;
diff --git a/board/atmel/at91sam9rlek/at91sam9rlek.c 
b/board/atmel/at91sam9rlek/at91sam9rlek.c
index 7013ba2..e374917 100644
--- a/board/atmel/at91sam9rlek/at91sam9rlek.c
+++ b/board/atmel/at91sam9rlek/at91sam9rlek.c
@@ -157,7 +157,7 @@ void lcd_show_board_info(void)
lcd_printf ((C) 2008 ATMEL Corp\n);
lcd_printf (at91supp...@atmel.com\n);
lcd_printf (%s CPU at %s MHz\n,
-   AT91_CPU_NAME,
+   CONFIG_SYS_AT91_CPU_NAME,
strmhz(temp, get_cpu_clk_rate()));
 
dram_size = 0;
diff --git a/board/esd/otc570/otc570.c b/board/esd/otc570/otc570.c
index 056df37..3fe28cb 100644
--- a/board/esd/otc570/otc570.c
+++ b/board/esd/otc570/otc570.c
@@ 

Re: [U-Boot] [PATCH] ARM change name of defines for AT91 arm926ejs

2010-02-24 Thread Tom
Achim Ehrlich wrote:
 Configuration defines should be preceeded with CONFIG_SYS_. Renamed
 some at91 specific defines to conform to this naming convention:
 
 AT91_CPU_NAME to CONFIG_SYS_AT91_CPU_NAME
 AT91_MAIN_CLOCK to CONFIG_SYS_AT91_MAIN_CLOCK
 
 Signed-off-by: Achim Ehrlich aehrl...@taskit.de

Thank you.
I have pushed this to arm/master
Tom
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH] ARM change name of defines for AT91 arm926ejs

2010-02-23 Thread Tom
Achim Ehrlich wrote:
   AT91_CPU_NAME to CONFIG_SYS_AT91_CPU_NAME
   AT91_MAIN_CLOCK to CONFIG_SYS_AT91_MAIN_CLOCK
 

Please expand the comment to explain why this change is necessary.
Tom
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot