[U-Boot] [PATCH] README: Clarify difference of CONFIG_WATCHDOG and CONFIG_HW_WATCHDOG

2011-04-27 Thread Detlev Zundel
Now that we have the documentation, the code should be changed to reflect
it ;)

Asd far as I can see, these are the places where HW_WATCHDOG is used
instead of WATCHDOG:

arch/blackfin/cpu/blackfin/watchdog.c
arch/m68k/cpu/mcf547x_8x/cpu.c

The relevant maintainers are on CC.

Signed-off-by: Detlev Zundel 
Cc: Mike Frysinger 
Cc: TsiChungLiew 
---
 README |   17 -
 1 files changed, 12 insertions(+), 5 deletions(-)

diff --git a/README b/README
index cdbb9de..63f5647 100644
--- a/README
+++ b/README
@@ -1,5 +1,5 @@
 #
-# (C) Copyright 2000 - 2009
+# (C) Copyright 2000 - 2011
 # Wolfgang Denk, DENX Software Engineering, w...@denx.de.
 #
 # See file CREDITS for list of people who contributed to this
@@ -719,10 +719,17 @@ The following options need to be configured:
 - Watchdog:
CONFIG_WATCHDOG
If this variable is defined, it enables watchdog
-   support. There must be support in the platform specific
-   code for a watchdog. For the 8xx and 8260 CPUs, the
-   SIU Watchdog feature is enabled in the SYPCR
-   register.
+   support for the SoC. There must be support in the SoC
+   specific code for a watchdog. For the 8xx and 8260
+   CPUs, the SIU Watchdog feature is enabled in the SYPCR
+   register.  When supported for a specific SoC is
+   available, then no further board specific code should
+   be needed to use it.
+
+   CONFIG_HW_WATCHDOG
+   When using a watchdog circuitry external to the used
+   SoC, then define this variable and provide board
+   specific code for the "hw_watchdog_reset" function.
 
 - U-Boot Version:
CONFIG_VERSION_VARIABLE
-- 
1.7.4.4

___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH] README: Clarify difference of CONFIG_WATCHDOG and CONFIG_HW_WATCHDOG

2011-04-27 Thread Mike Frysinger
On Wed, Apr 27, 2011 at 11:25, Detlev Zundel wrote:
> Now that we have the documentation, the code should be changed to reflect
> it ;)
>
> Asd far as I can see, these are the places where HW_WATCHDOG is used
> instead of WATCHDOG:

the trouble is that watchdog.h doesnt seem to match, nor does the
name.  "hardware" means to me "hardware" as in "the cpu hardware".

#ifdef CONFIG_HW_WATCHDOG
...
#else
/*
 * Maybe a software watchdog?
 */
...
#endif

i dont see how a watchdog in the SoC could be a "software" watchdog or
a "non-hardware" watchdog.

the watchdog system is a legacy mess, so probably be easier to just
gut the whole thing.
-mike
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH] README: Clarify difference of CONFIG_WATCHDOG and CONFIG_HW_WATCHDOG

2011-04-29 Thread Detlev Zundel
Hi Mike,

> On Wed, Apr 27, 2011 at 11:25, Detlev Zundel wrote:
>> Now that we have the documentation, the code should be changed to reflect
>> it ;)
>>
>> Asd far as I can see, these are the places where HW_WATCHDOG is used
>> instead of WATCHDOG:
>
> the trouble is that watchdog.h doesnt seem to match, nor does the
> name.  "hardware" means to me "hardware" as in "the cpu hardware".

Yes, I understand that the situation is not 100% ideal, but I do not
share your pessimism.  Currently we should straighten out the
inconsistencies present in the code and then subsequently we can think
about aligning it with what we agree on to be a good name for.

>
> #ifdef CONFIG_HW_WATCHDOG
> ...
> #else
> /*
>  * Maybe a software watchdog?
>  */
> ...
> #endif
>
> i dont see how a watchdog in the SoC could be a "software" watchdog or
> a "non-hardware" watchdog.

True, we should align the comments in here also - I'll se if I can come
up with something sensible.

> the watchdog system is a legacy mess, so probably be easier to just
> gut the whole thing.

A agree that the naming is not ideal, but this isn't a good enough
argument for removing it.  Apart from that, this feature is used in many
commercial systems...

Cheers
  Detlev

-- 
config LGUEST
If unsure, say N.  If curious, say M.  If masochistic, say Y.
 -- linux/drivers/lguest/Kconfig
--
DENX Software Engineering GmbH,  MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich,  Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-40 Fax: (+49)-8142-66989-80 Email: d...@denx.de
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH] README: Clarify difference of CONFIG_WATCHDOG and CONFIG_HW_WATCHDOG

2011-04-29 Thread Mike Frysinger
On Friday, April 29, 2011 07:06:56 Detlev Zundel wrote:
> > On Wed, Apr 27, 2011 at 11:25, Detlev Zundel wrote:
> >> Now that we have the documentation, the code should be changed to
> >> reflect it ;)
> >> 
> >> Asd far as I can see, these are the places where HW_WATCHDOG is used
> > 
> >> instead of WATCHDOG:
> > the trouble is that watchdog.h doesnt seem to match, nor does the
> > name.  "hardware" means to me "hardware" as in "the cpu hardware".
> 
> Yes, I understand that the situation is not 100% ideal, but I do not
> share your pessimism.

it isnt pessimism ... it's a fact that the documentation does not match the 
source, nor is the source clear.

> > > the watchdog system is a legacy mess, so probably be easier to just
> > gut the whole thing.
> 
> A agree that the naming is not ideal, but this isn't a good enough
> argument for removing it.  Apart from that, this feature is used in many
> commercial systems...

i didnt mean remove it and not provide equivalent functionality.  there should 
be a single CONFIG_WATCHDOG and every different watchdog driver should have 
its own CONFIG_WATCHDOG_FOO define.
-mike


signature.asc
Description: This is a digitally signed message part.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH] README: Clarify difference of CONFIG_WATCHDOG and CONFIG_HW_WATCHDOG

2011-05-12 Thread Wolfgang Denk
Dear Detlev Zundel,

In message <1303917959-32324-1-git-send-email-...@denx.de> you wrote:
> Now that we have the documentation, the code should be changed to reflect
> it ;)
> 
> Asd far as I can see, these are the places where HW_WATCHDOG is used
> instead of WATCHDOG:
> 
> arch/blackfin/cpu/blackfin/watchdog.c
> arch/m68k/cpu/mcf547x_8x/cpu.c
> 
> The relevant maintainers are on CC.
> 
> Signed-off-by: Detlev Zundel 
> Cc: Mike Frysinger 
> Cc: TsiChungLiew 
> ---
>  README |   17 -
>  1 files changed, 12 insertions(+), 5 deletions(-)

Applied, thanks.

Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: w...@denx.de
Be careful what you wish for. You never know who will be listening.
  - Terry Pratchett, _Soul Music_
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot