Change in v4:
- rename ssr to gpio_psr in struct gpio_regs
- remove useless change in mxc_gpio.c

Change in v3:
- rebase on u-boot-imx (instead of u-boot)
- fix conflit with "mxc: Make gpio_get_value() use PSR"

Philippe Reynes (2):
  gpio: add gpio api support to mx27 (v4)
  imx27lite: update with gpio api change (v4)

 arch/arm/cpu/arm926ejs/mx27/generic.c     |   11 +++---
 arch/arm/include/asm/arch-mx27/gpio.h     |   55 +++++++++++++++++++++++++++++
 arch/arm/include/asm/arch-mx27/imx-regs.h |   30 ++++------------
 board/logicpd/imx27lite/imx27lite.c       |    5 +--
 drivers/gpio/mxc_gpio.c                   |    8 +++--
 include/configs/imx27lite-common.h        |    5 +++
 6 files changed, 80 insertions(+), 34 deletions(-)
 create mode 100644 arch/arm/include/asm/arch-mx27/gpio.h

-- 
1.7.4.4

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to