Re: [U-Boot] [PATCH 00/30] Keymile boards mainlining, part 2 (resend)

2011-05-03 Thread Valentin Longchamp
Hello,

Valentin Longchamp wrote:
> This series is the second effort of merging the Keymile boards support
> back into mainline.
> 
> Most of the patches are only keymile relevant and should only affect our
> boards.
> 
> There are also patches for the i2c deblocking support and cramfs for ARM.

We have split the whole series so that it gets easier to apply through 
the various trees:

1) the i2c patches were sent by Heiko and already applied
2) lib, vsprintf: introduce strict_strtoul and cramfs: make cramfs 
usable without a NOR flash are (or already have been) resent as 
standalone patches
3) Holger is going to send a series for km82xx changes
4) Holger is going to send a series with the keymile changes
5) I will send a series with the ARM/marvell changes

I hope this will simplify the review and merging of these patches into 
mainline.

Best Regards

Valentin

> 
> The whole series is based on current denx-master with the our first patch
> series posted by Heiko that was reviewed previous weeks and should still
> be merged during the current merge window:
> 
> http://lists.denx.de/pipermail/u-boot/2011-April/089530.html
> 
> Heiko Schocher (5):
>   lib, vsprintf: introduce strict_strtoul
>   arm/km: add CRAMFS support for keymile boards
>   cramfs: make cramfs usable without a NOR flash
>   i2c, soft_i2c: deblock bus if switching to another i2c bus
>   arm, powerpc, keymile boards: move keymile specific header in subdir
> 
> Holger Brunck (18):
>   km/common: remove hdlc_enet implementation
>   powerpc/km82xx: cleanup coding style for mgcoge.c
>   powerpc/km82xx: rename mgcoge files to km82xx
>   powerpc/km82xx: move SDRAM config to board config
>   powerpc/km82xx: adapt CONFIG_SYSSYPCR to manual
>   powerpc/km82xx: rename mgcoge2ne to mgcoge3ne board support
>   poweprc/km82xx: add board specific environment variable
>   arm/km: add addbootcount environment variable
>   arm/km: remove last_stage_init and unneeded printouts
>   arm/km: add second serial interface for kirkwood
>   common/hush: make get_local_var visible for other users
>   km/common: implement setboardid as a command
>   km/common: add pnvramsize to default environment
>   km/common: fix coding style issues in generic header
>   km/common: simplify default environment
>   arm/km: rename mgcoge2un to mgcoge3un
>   arm/km: change default settings for egiga on mgcoge3un
>   arm/km: update mgcoge3un board support
> 
> Huber, Andreas (1):
>   powerpc/km82xx: add DIP switch detection
> 
> Stefan Bigler (1):
>   i2c: add i2c deblock sequence before and after every mux config
> 
> Thomas Herzmann (2):
>   km/common: fix initial_boot_bank for bootpackages
>   km/common: replace env var checkboardidlist by function
> 
> Valentin Longchamp (3):
>   arm/km: add mkimage config file for uart download
>   arm/km: add BootROM config files for memphis SDRAM
>   arm/km: disable ls (through jffs2 support)
> 
>  MAINTAINERS|4 +-
>  board/keymile/common/common.c  |  156 ++-
>  board/keymile/common/common.h  |   84 +++-
>  board/keymile/common/keymile_hdlc_enet.c   |  620 
> 
>  board/keymile/{mgcoge => km82xx}/Makefile  |3 +-
>  board/keymile/km82xx/km82xx.c  |  373 ++
>  board/keymile/km_arm/km_arm.c  |   93 +++-
>  board/keymile/km_arm/kwbimage-memphis-uart.cfg |  197 
>  board/keymile/km_arm/kwbimage-memphis.cfg  |  197 
>  board/keymile/km_arm/kwbimage-uart.cfg |  179 +++
>  board/keymile/mgcoge/mgcoge.c  |  333 -
>  board/keymile/mgcoge/mgcoge_hdlc_enet.c|  276 ---
>  board/keymile/scripts/README   |   25 +
>  board/keymile/scripts/debug-arm-env.txt|2 +
>  board/keymile/scripts/debug-common-env.txt |9 +
>  board/keymile/scripts/debug-ppc-env.txt|2 +
>  boards.cfg |6 +-
>  common/cmd_cramfs.c|   12 +-
>  common/cmd_i2c.c   |   12 +
>  common/hush.c  |3 +-
>  drivers/i2c/soft_i2c.c |1 +
>  drivers/net/mvgbe.h|2 +
>  fs/cramfs/cramfs.c |4 +
>  include/_exports.h |1 +
>  include/common.h   |1 +
>  include/configs/{ => km}/keymile-common.h  |  175 +--
>  include/configs/{ => km}/km-powerpc.h  |   12 +-
>  include/configs/{ => km}/km82xx-common.h   |   29 +-
>  include/configs/{ => km}/km8321-common.h   |0
>  include/configs/{ => km}/km83xx-common.h   |0
>  include/configs/{ => km}/km_arm.h  |   25 +-
>  include/configs/kmeter1.h  |2 +-
>  include/configs/kmsupx5.h  |2 +-
>  include/configs/mgcoge.h 

[U-Boot] [PATCH 00/30] Keymile boards mainlining, part 2 (resend)

2011-04-08 Thread Valentin Longchamp
This series is the second effort of merging the Keymile boards support
back into mainline.

Most of the patches are only keymile relevant and should only affect our
boards.

There are also patches for the i2c deblocking support and cramfs for ARM.

The whole series is based on current denx-master with the our first patch
series posted by Heiko that was reviewed previous weeks and should still
be merged during the current merge window:

http://lists.denx.de/pipermail/u-boot/2011-April/089530.html

Heiko Schocher (5):
  lib, vsprintf: introduce strict_strtoul
  arm/km: add CRAMFS support for keymile boards
  cramfs: make cramfs usable without a NOR flash
  i2c, soft_i2c: deblock bus if switching to another i2c bus
  arm, powerpc, keymile boards: move keymile specific header in subdir

Holger Brunck (18):
  km/common: remove hdlc_enet implementation
  powerpc/km82xx: cleanup coding style for mgcoge.c
  powerpc/km82xx: rename mgcoge files to km82xx
  powerpc/km82xx: move SDRAM config to board config
  powerpc/km82xx: adapt CONFIG_SYSSYPCR to manual
  powerpc/km82xx: rename mgcoge2ne to mgcoge3ne board support
  poweprc/km82xx: add board specific environment variable
  arm/km: add addbootcount environment variable
  arm/km: remove last_stage_init and unneeded printouts
  arm/km: add second serial interface for kirkwood
  common/hush: make get_local_var visible for other users
  km/common: implement setboardid as a command
  km/common: add pnvramsize to default environment
  km/common: fix coding style issues in generic header
  km/common: simplify default environment
  arm/km: rename mgcoge2un to mgcoge3un
  arm/km: change default settings for egiga on mgcoge3un
  arm/km: update mgcoge3un board support

Huber, Andreas (1):
  powerpc/km82xx: add DIP switch detection

Stefan Bigler (1):
  i2c: add i2c deblock sequence before and after every mux config

Thomas Herzmann (2):
  km/common: fix initial_boot_bank for bootpackages
  km/common: replace env var checkboardidlist by function

Valentin Longchamp (3):
  arm/km: add mkimage config file for uart download
  arm/km: add BootROM config files for memphis SDRAM
  arm/km: disable ls (through jffs2 support)

 MAINTAINERS|4 +-
 board/keymile/common/common.c  |  156 ++-
 board/keymile/common/common.h  |   84 +++-
 board/keymile/common/keymile_hdlc_enet.c   |  620 
 board/keymile/{mgcoge => km82xx}/Makefile  |3 +-
 board/keymile/km82xx/km82xx.c  |  373 ++
 board/keymile/km_arm/km_arm.c  |   93 +++-
 board/keymile/km_arm/kwbimage-memphis-uart.cfg |  197 
 board/keymile/km_arm/kwbimage-memphis.cfg  |  197 
 board/keymile/km_arm/kwbimage-uart.cfg |  179 +++
 board/keymile/mgcoge/mgcoge.c  |  333 -
 board/keymile/mgcoge/mgcoge_hdlc_enet.c|  276 ---
 board/keymile/scripts/README   |   25 +
 board/keymile/scripts/debug-arm-env.txt|2 +
 board/keymile/scripts/debug-common-env.txt |9 +
 board/keymile/scripts/debug-ppc-env.txt|2 +
 boards.cfg |6 +-
 common/cmd_cramfs.c|   12 +-
 common/cmd_i2c.c   |   12 +
 common/hush.c  |3 +-
 drivers/i2c/soft_i2c.c |1 +
 drivers/net/mvgbe.h|2 +
 fs/cramfs/cramfs.c |4 +
 include/_exports.h |1 +
 include/common.h   |1 +
 include/configs/{ => km}/keymile-common.h  |  175 +--
 include/configs/{ => km}/km-powerpc.h  |   12 +-
 include/configs/{ => km}/km82xx-common.h   |   29 +-
 include/configs/{ => km}/km8321-common.h   |0
 include/configs/{ => km}/km83xx-common.h   |0
 include/configs/{ => km}/km_arm.h  |   25 +-
 include/configs/kmeter1.h  |2 +-
 include/configs/kmsupx5.h  |2 +-
 include/configs/mgcoge.h   |   35 ++-
 include/configs/{mgcoge2ne.h => mgcoge3ne.h}   |   57 ++-
 include/configs/{mgcoge2un.h => mgcoge3un.h}   |   37 ++-
 include/configs/suen3.h|2 +-
 include/configs/suen8.h|2 +-
 include/configs/suvd3.h|2 +-
 include/configs/tuda1.h|2 +-
 include/configs/tuxa1.h|2 +-
 include/exports.h  |1 +
 include/hush.h |1 +
 include/i2c.h  |2 -
 lib/vsprintf.c |   47 ++
 45 files changed, 1531 insertions(+), 1499 deletions(-)
 delete mode 100644 board/keymile/common/keymile_hdlc_enet.c
 rename board/key