Re: [U-Boot] [PATCH 1/2] DaVinci: rename gpio_defs.h to gpio.h

2011-07-18 Thread Paulraj, Sandeep

 Hi Laurence,
 
 Le 15/07/2011 13:27, Laurence Withers a écrit :
  In preparation for a generic GPIO driver for the DA8xx processors,
  renameasm/arch/gpio_defs.h  toasm/arch/gpio.h  and fix up all files
  which include it.
 
  Signed-off-by: Laurence Witherslwith...@guralp.com
  ---
arch/arm/include/asm/arch-davinci/gpio.h  |   66
 +
arch/arm/include/asm/arch-davinci/gpio_defs.h |   66 -
 
 
 This is a rename, so use 'git mv...' and 'git format-patch -C' to let
 git and readers know it is.
 


I didn't see an updated patch for this?
Are you planning on sending one?

--Sandeep


___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH 1/2] DaVinci: rename gpio_defs.h to gpio.h

2011-07-18 Thread Albert ARIBAUD
Hi Sandeep,

Le 18/07/2011 15:02, Paulraj, Sandeep a écrit :

 Hi Laurence,

 Le 15/07/2011 13:27, Laurence Withers a écrit :
 In preparation for a generic GPIO driver for the DA8xx processors,
 renameasm/arch/gpio_defs.h   toasm/arch/gpio.h   and fix up all files
 which include it.

 Signed-off-by: Laurence Witherslwith...@guralp.com
 ---
arch/arm/include/asm/arch-davinci/gpio.h  |   66
 +
arch/arm/include/asm/arch-davinci/gpio_defs.h |   66 -
 

 This is a rename, so use 'git mv...' and 'git format-patch -C' to let
 git and readers know it is.



 I didn't see an updated patch for this?
 Are you planning on sending one?

It was sent: http://patchwork.ozlabs.org/patch/104953/

 --Sandeep

Amicalement,
-- 
Albert.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH 1/2] DaVinci: rename gpio_defs.h to gpio.h

2011-07-18 Thread Mike Frysinger
On Sat, Jul 16, 2011 at 05:11, Albert ARIBAUD wrote:
 Le 15/07/2011 13:27, Laurence Withers a écrit :
 In preparation for a generic GPIO driver for the DA8xx processors,
 renameasm/arch/gpio_defs.h  toasm/arch/gpio.h  and fix up all files
 which include it.

 Signed-off-by: Laurence Witherslwith...@guralp.com
 ---
   arch/arm/include/asm/arch-davinci/gpio.h      |   66 
 +
   arch/arm/include/asm/arch-davinci/gpio_defs.h |   66 
 -

 This is a rename, so use 'git mv...' and 'git format-patch -C' to let
 git and readers know it is.

the `git mv` is unnecessary.  the -C/-M options to
format-patch/send-email should be sufficient.
-mike
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH 1/2] DaVinci: rename gpio_defs.h to gpio.h

2011-07-16 Thread Albert ARIBAUD
Hi Laurence,

Le 15/07/2011 13:27, Laurence Withers a écrit :
 In preparation for a generic GPIO driver for the DA8xx processors,
 renameasm/arch/gpio_defs.h  toasm/arch/gpio.h  and fix up all files
 which include it.

 Signed-off-by: Laurence Witherslwith...@guralp.com
 ---
   arch/arm/include/asm/arch-davinci/gpio.h  |   66 
 +
   arch/arm/include/asm/arch-davinci/gpio_defs.h |   66 
 -

This is a rename, so use 'git mv...' and 'git format-patch -C' to let 
git and readers know it is.

Amicalement,
-- 
Albert.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH 1/2] DaVinci: rename gpio_defs.h to gpio.h

2011-07-16 Thread Laurence Withers
On Sat, Jul 16, 2011 at 11:11:15AM +0200, Albert ARIBAUD wrote:
 This is a rename, so use 'git mv...' and 'git format-patch -C' to let
 git and readers know it is.

Hi Albert,

Thanks for the tip. I reposted a v2 with this.

Bye for now,
-- 
Laurence Withers, lwith...@guralp.comhttp://www.guralp.com/
Direct tel:+447753988197 or tel:+44408643   Software Engineer
General support queries: supp...@guralp.com CMG-DCM CMG-EAM CMG-NAM
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


[U-Boot] [PATCH 1/2] DaVinci: rename gpio_defs.h to gpio.h

2011-07-15 Thread Laurence Withers
In preparation for a generic GPIO driver for the DA8xx processors,
rename asm/arch/gpio_defs.h to asm/arch/gpio.h and fix up all files
which include it.

Signed-off-by: Laurence Withers lwith...@guralp.com
---
 arch/arm/include/asm/arch-davinci/gpio.h  |   66 +
 arch/arm/include/asm/arch-davinci/gpio_defs.h |   66 -
 board/davinci/dm355leopard/dm355leopard.c |2 +-
 board/davinci/dm365evm/dm365evm.c |2 +-
 drivers/usb/musb/da8xx.h  |2 +-
 5 files changed, 69 insertions(+), 69 deletions(-)
 create mode 100644 arch/arm/include/asm/arch-davinci/gpio.h
 delete mode 100644 arch/arm/include/asm/arch-davinci/gpio_defs.h

diff --git a/arch/arm/include/asm/arch-davinci/gpio.h 
b/arch/arm/include/asm/arch-davinci/gpio.h
new file mode 100644
index 000..1be2ac2
--- /dev/null
+++ b/arch/arm/include/asm/arch-davinci/gpio.h
@@ -0,0 +1,66 @@
+/*
+ * Copyright (C) 2009 Texas Instruments Incorporated
+ *
+ * See file CREDITS for list of people who contributed to this
+ * project.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of
+ * the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+ * MA 02111-1307 USA
+ */
+#ifndef _GPIO_DEFS_H_
+#define _GPIO_DEFS_H_
+
+#ifndef CONFIG_SOC_DA8XX
+#define DAVINCI_GPIO_BINTEN0x01C67008
+#define DAVINCI_GPIO_BANK010x01C67010
+#define DAVINCI_GPIO_BANK230x01C67038
+#define DAVINCI_GPIO_BANK450x01C67060
+#define DAVINCI_GPIO_BANK670x01C67088
+
+#else /* CONFIG_SOC_DA8XX */
+#define DAVINCI_GPIO_BINTEN0x01E26008
+#define DAVINCI_GPIO_BANK010x01E26010
+#define DAVINCI_GPIO_BANK230x01E26038
+#define DAVINCI_GPIO_BANK450x01E26060
+#define DAVINCI_GPIO_BANK670x01E26088
+#endif /* CONFIG_SOC_DA8XX */
+
+struct davinci_gpio {
+   unsigned int dir;
+   unsigned int out_data;
+   unsigned int set_data;
+   unsigned int clr_data;
+   unsigned int in_data;
+   unsigned int set_rising;
+   unsigned int clr_rising;
+   unsigned int set_falling;
+   unsigned int clr_falling;
+   unsigned int intstat;
+};
+
+struct davinci_gpio_bank {
+   int num_gpio;
+   unsigned int irq_num;
+   unsigned int irq_mask;
+   unsigned long *in_use;
+   unsigned long base;
+};
+
+#define davinci_gpio_bank01 ((struct davinci_gpio *)DAVINCI_GPIO_BANK01)
+#define davinci_gpio_bank23 ((struct davinci_gpio *)DAVINCI_GPIO_BANK23)
+#define davinci_gpio_bank45 ((struct davinci_gpio *)DAVINCI_GPIO_BANK45)
+#define davinci_gpio_bank67 ((struct davinci_gpio *)DAVINCI_GPIO_BANK67)
+
+#endif
diff --git a/arch/arm/include/asm/arch-davinci/gpio_defs.h 
b/arch/arm/include/asm/arch-davinci/gpio_defs.h
deleted file mode 100644
index 1be2ac2..000
--- a/arch/arm/include/asm/arch-davinci/gpio_defs.h
+++ /dev/null
@@ -1,66 +0,0 @@
-/*
- * Copyright (C) 2009 Texas Instruments Incorporated
- *
- * See file CREDITS for list of people who contributed to this
- * project.
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation; either version 2 of
- * the License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
- * MA 02111-1307 USA
- */
-#ifndef _GPIO_DEFS_H_
-#define _GPIO_DEFS_H_
-
-#ifndef CONFIG_SOC_DA8XX
-#define DAVINCI_GPIO_BINTEN0x01C67008
-#define DAVINCI_GPIO_BANK010x01C67010
-#define DAVINCI_GPIO_BANK230x01C67038
-#define DAVINCI_GPIO_BANK450x01C67060
-#define DAVINCI_GPIO_BANK670x01C67088
-
-#else /* CONFIG_SOC_DA8XX */
-#define DAVINCI_GPIO_BINTEN0x01E26008
-#define DAVINCI_GPIO_BANK010x01E26010
-#define DAVINCI_GPIO_BANK230x01E26038
-#define DAVINCI_GPIO_BANK450x01E26060
-#define DAVINCI_GPIO_BANK670x01E26088
-#endif /* CONFIG_SOC_DA8XX */
-
-struct davinci_gpio {
-   unsigned int dir;
-   unsigned int out_data;
-   unsigned int