Re: [U-Boot] [PATCH v5 00/21] sf: Updates on flash detection

2016-11-01 Thread York
I am out for a conference. Will take a look when I get back.

York

On Nov 1, 2016 13:07, "Jagan Teki"  wrote:

> On Sun, Oct 30, 2016 at 11:16 PM, Jagan Teki  wrote:
> > Updated spi_flash_info table in sync with Linux, and removed
> > legacy and unsupported code.
> >
> > Changes for v5:
> > - Add dataflash fixes in this series
> > - Rebase to master
> >
> > Changes for v4:
> > - Rebase to master
> >
> > Changes for v3:
> > - New patches
> > - Fix checkpatch.pl
> > - Fix BIT positions in spi.h
> > - Fix ti_qspi.c mode
> > - Fix commit Nit: s/becuase/because
> >
> > Changes for v2:
> > - New patches.
> >
> > Testing:
> > $ git clone git://git.denx.de/u-boot-spi.git
> > $ cd u-boot-spi
> > $ git checkout -b next origin/next
> >
> > Jagan Teki (21):
> >   sf: Adopt flash table INFO macro from Linux
> >   sf: Simplify lock ops detection code
> >   sf: sandbox: Use JEDEC_MFR|ID in id exctract
> >   sf: Cleanup spi_flash_info{}
> >   sf: Cleanup sf_params
> >   sf: nr_sectors -> n_sectors
> >   sf: Add SPI_FLASH_MAX_ID_LEN
> >   sf: Increase max id length by 1 byte
> >   sf: Add INFO6 flash_info macro
> >   sf: params: Add S25FS256S_64K spi flash support
> >   sf: Remove legacy idcode detection code
> >   sf: Remove non-meaningful comments
> >   sf: Rename sf_params.c to spi_flash_ids
> >   sf: ids: Use small letter's with flash name
> >   sf: ids: Use small letter in ext_jedec
> >   sf: Rename few local functions
> >   spi: Remove dual flash code
> >   sf: dataflash: Remove unneeded spi data
> >   sf: dataflash: Move flash id detection into jedec_probe
> >   sf: dataflash: Fix add_dataflash return logic
> >   sf: dataflash: Minor cleanups
>
> York, can you test this with dataflash?
>
> thanks!
> --
> Jagan Teki
> Free Software Engineer | www.openedev.com
> U-Boot, Linux | Upstream Maintainer
> Hyderabad, India.
>
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH v5 00/21] sf: Updates on flash detection

2016-11-01 Thread Jagan Teki
On Sun, Oct 30, 2016 at 11:16 PM, Jagan Teki  wrote:
> Updated spi_flash_info table in sync with Linux, and removed
> legacy and unsupported code.
>
> Changes for v5:
> - Add dataflash fixes in this series
> - Rebase to master
>
> Changes for v4:
> - Rebase to master
>
> Changes for v3:
> - New patches
> - Fix checkpatch.pl
> - Fix BIT positions in spi.h
> - Fix ti_qspi.c mode
> - Fix commit Nit: s/becuase/because
>
> Changes for v2:
> - New patches.
>
> Testing:
> $ git clone git://git.denx.de/u-boot-spi.git
> $ cd u-boot-spi
> $ git checkout -b next origin/next
>
> Jagan Teki (21):
>   sf: Adopt flash table INFO macro from Linux
>   sf: Simplify lock ops detection code
>   sf: sandbox: Use JEDEC_MFR|ID in id exctract
>   sf: Cleanup spi_flash_info{}
>   sf: Cleanup sf_params
>   sf: nr_sectors -> n_sectors
>   sf: Add SPI_FLASH_MAX_ID_LEN
>   sf: Increase max id length by 1 byte
>   sf: Add INFO6 flash_info macro
>   sf: params: Add S25FS256S_64K spi flash support
>   sf: Remove legacy idcode detection code
>   sf: Remove non-meaningful comments
>   sf: Rename sf_params.c to spi_flash_ids
>   sf: ids: Use small letter's with flash name
>   sf: ids: Use small letter in ext_jedec
>   sf: Rename few local functions
>   spi: Remove dual flash code
>   sf: dataflash: Remove unneeded spi data
>   sf: dataflash: Move flash id detection into jedec_probe
>   sf: dataflash: Fix add_dataflash return logic
>   sf: dataflash: Minor cleanups

York, can you test this with dataflash?

thanks!
-- 
Jagan Teki
Free Software Engineer | www.openedev.com
U-Boot, Linux | Upstream Maintainer
Hyderabad, India.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


[U-Boot] [PATCH v5 00/21] sf: Updates on flash detection

2016-10-30 Thread Jagan Teki
Updated spi_flash_info table in sync with Linux, and removed
legacy and unsupported code.

Changes for v5:
- Add dataflash fixes in this series
- Rebase to master

Changes for v4:
- Rebase to master

Changes for v3:
- New patches
- Fix checkpatch.pl
- Fix BIT positions in spi.h
- Fix ti_qspi.c mode
- Fix commit Nit: s/becuase/because

Changes for v2:
- New patches.

Testing:
$ git clone git://git.denx.de/u-boot-spi.git
$ cd u-boot-spi
$ git checkout -b next origin/next

Jagan Teki (21):
  sf: Adopt flash table INFO macro from Linux
  sf: Simplify lock ops detection code
  sf: sandbox: Use JEDEC_MFR|ID in id exctract
  sf: Cleanup spi_flash_info{}
  sf: Cleanup sf_params
  sf: nr_sectors -> n_sectors
  sf: Add SPI_FLASH_MAX_ID_LEN
  sf: Increase max id length by 1 byte
  sf: Add INFO6 flash_info macro
  sf: params: Add S25FS256S_64K spi flash support
  sf: Remove legacy idcode detection code
  sf: Remove non-meaningful comments
  sf: Rename sf_params.c to spi_flash_ids
  sf: ids: Use small letter's with flash name
  sf: ids: Use small letter in ext_jedec
  sf: Rename few local functions
  spi: Remove dual flash code
  sf: dataflash: Remove unneeded spi data
  sf: dataflash: Move flash id detection into jedec_probe
  sf: dataflash: Fix add_dataflash return logic
  sf: dataflash: Minor cleanups

 drivers/mtd/spi/Makefile|   2 +-
 drivers/mtd/spi/sandbox.c   |  11 +-
 drivers/mtd/spi/sf.c|   4 -
 drivers/mtd/spi/sf_dataflash.c  | 178 ++
 drivers/mtd/spi/sf_internal.h   |  58 +-
 drivers/mtd/spi/sf_params.c | 238 ++--
 drivers/mtd/spi/spi_flash.c | 226 --
 drivers/mtd/spi/spi_flash_ids.c | 176 +
 include/linux/err.h |   5 +
 include/spi.h   |   6 -
 10 files changed, 500 insertions(+), 404 deletions(-)
 create mode 100644 drivers/mtd/spi/spi_flash_ids.c

-- 
2.7.4

___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot