Re: [U-Boot] [PATCH v5 2/9] Rename run_command() to builtin_run_command()

2012-03-06 Thread Wolfgang Denk
Dear Simon Glass,

In message 1329285566-30386-3-git-send-email-...@chromium.org you wrote:
 The current run_command() is only one of the parsing options - the other
 is hush. We should not call run_command() when the hush parser is being
 used. So we rename this function to better explain its purpose.
 
 Signed-off-by: Simon Glass s...@chromium.org
 ---
 Changes in v4:
 - Minor comment change for call to builtin_run_command()
 
 Changes in v5:
 - Adjust commit message to make it easier for Mike to grok
 
  arch/arm/cpu/arm926ejs/kirkwood/cpu.c |2 +-
  board/esd/common/auto_update.c|2 +-
  board/esd/common/cmd_loadpci.c|2 +-
  board/esd/du440/du440.c   |2 +-
  common/cmd_bedbug.c   |2 +-
  common/cmd_bootm.c|2 +-
  common/cmd_source.c   |4 ++--
  common/main.c |9 +
  include/common.h  |2 +-
  9 files changed, 14 insertions(+), 13 deletions(-)

Applied, thanks.

Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH, MD: Wolfgang Denk  Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: w...@denx.de
Of all possible committee reactions to any  given  agenda  item,  the
reaction  that will occur is the one which will liberate the greatest
amount of hot air.-- Thomas L. Martin
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH v5 2/9] Rename run_command() to builtin_run_command()

2012-03-05 Thread Mike Frysinger
Acked-by: Mike Frysinger vap...@gentoo.org
-mike


signature.asc
Description: This is a digitally signed message part.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


[U-Boot] [PATCH v5 2/9] Rename run_command() to builtin_run_command()

2012-02-14 Thread Simon Glass
The current run_command() is only one of the parsing options - the other
is hush. We should not call run_command() when the hush parser is being
used. So we rename this function to better explain its purpose.

Signed-off-by: Simon Glass s...@chromium.org
---
Changes in v4:
- Minor comment change for call to builtin_run_command()

Changes in v5:
- Adjust commit message to make it easier for Mike to grok

 arch/arm/cpu/arm926ejs/kirkwood/cpu.c |2 +-
 board/esd/common/auto_update.c|2 +-
 board/esd/common/cmd_loadpci.c|2 +-
 board/esd/du440/du440.c   |2 +-
 common/cmd_bedbug.c   |2 +-
 common/cmd_bootm.c|2 +-
 common/cmd_source.c   |4 ++--
 common/main.c |9 +
 include/common.h  |2 +-
 9 files changed, 14 insertions(+), 13 deletions(-)

diff --git a/arch/arm/cpu/arm926ejs/kirkwood/cpu.c 
b/arch/arm/cpu/arm926ejs/kirkwood/cpu.c
index 8f04ddb..54d15ea 100644
--- a/arch/arm/cpu/arm926ejs/kirkwood/cpu.c
+++ b/arch/arm/cpu/arm926ejs/kirkwood/cpu.c
@@ -227,7 +227,7 @@ static void kw_sysrst_action(void)
 
debug(Starting %s process...\n, __FUNCTION__);
 #if !defined(CONFIG_SYS_HUSH_PARSER)
-   ret = run_command (s, 0);
+   ret = builtin_run_command(s, 0);
 #else
ret = parse_string_outer(s, FLAG_PARSE_SEMICOLON
  | FLAG_EXIT_FROM_LOOP);
diff --git a/board/esd/common/auto_update.c b/board/esd/common/auto_update.c
index fc60545..4cc15fa 100644
--- a/board/esd/common/auto_update.c
+++ b/board/esd/common/auto_update.c
@@ -169,7 +169,7 @@ int au_do_update(int i, long sz)
k++;
}
 
-   run_command(addr, 0);
+   builtin_run_command(addr, 0);
return 0;
}
 
diff --git a/board/esd/common/cmd_loadpci.c b/board/esd/common/cmd_loadpci.c
index 8f4ad84..c2bf279 100644
--- a/board/esd/common/cmd_loadpci.c
+++ b/board/esd/common/cmd_loadpci.c
@@ -110,7 +110,7 @@ int do_loadpci(cmd_tbl_t *cmdtp, int flag, int argc, char * 
const argv[])
 * Call run_cmd
 */
printf(running command at addr 0x%s ...\n, addr);
-   run_command((char*)la, 0);
+   builtin_run_command((char *)la, 0);
break;
 
default:
diff --git a/board/esd/du440/du440.c b/board/esd/du440/du440.c
index 426321e..75fb200 100644
--- a/board/esd/du440/du440.c
+++ b/board/esd/du440/du440.c
@@ -831,7 +831,7 @@ int do_time(cmd_tbl_t *cmdtp, int flag, int argc, char * 
const argv[])
*d = '\0';
 
start = get_ticks();
-   ret = run_command (cmd, 0);
+   ret = builtin_run_command(cmd, 0);
end = get_ticks();
 
printf(ticks=%ld\n, (ulong)(end - start));
diff --git a/common/cmd_bedbug.c b/common/cmd_bedbug.c
index 87b108f..0228ee8 100644
--- a/common/cmd_bedbug.c
+++ b/common/cmd_bedbug.c
@@ -237,7 +237,7 @@ void bedbug_main_loop (unsigned long addr, struct pt_regs 
*regs)
if (len == -1)
printf (INTERRUPT\n);
else
-   rc = run_command (lastcommand, flag);
+   rc = builtin_run_command(lastcommand, flag);
 
if (rc = 0) {
/* invalid command or not repeatable, forget it */
diff --git a/common/cmd_bootm.c b/common/cmd_bootm.c
index d5745b1..2e3e159 100644
--- a/common/cmd_bootm.c
+++ b/common/cmd_bootm.c
@@ -1046,7 +1046,7 @@ int do_bootd(cmd_tbl_t *cmdtp, int flag, int argc, char * 
const argv[])
int rcode = 0;
 
 #ifndef CONFIG_SYS_HUSH_PARSER
-   if (run_command(getenv(bootcmd), flag)  0)
+   if (builtin_run_command(getenv(bootcmd), flag)  0)
rcode = 1;
 #else
if (parse_string_outer(getenv(bootcmd),
diff --git a/common/cmd_source.c b/common/cmd_source.c
index 16a627a..481241c 100644
--- a/common/cmd_source.c
+++ b/common/cmd_source.c
@@ -179,7 +179,7 @@ source (ulong addr, const char *fit_uname)
if (*line) {
debug (** exec: \%s\\n,
line);
-   if (run_command (line, 0)  0) {
+   if (builtin_run_command(line, 0)  0) {
rcode = 1;
break;
}
@@ -189,7 +189,7 @@ source (ulong addr, const char *fit_uname)
++next;
}
if (rcode == 0  *line)
-   rcode = (run_command(line, 0) = 0);
+   rcode = (builtin_run_command(line, 0) = 0);
}
 #endif
free (cmd);
diff --git