[U-Boot] [RFC 0/3] omap3evm: Add support for quick boot

2010-10-28 Thread Sanjeev Premi
This series is based on the comments received [1] on
my earlier submission[2].

Intent of sending as RFC is to thrash out the ideas
and then send a formal patch.

More details in individual patch description.

  [1] http://marc.info/?l=u-bootm=128818733126234w=2
  [2] http://marc.info/?l=u-bootm=128818664024766w=2

There could be compilation issues as I have not tried
building the u-boot with these changes; but will sort
them (if any) for final submission.

Sanjeev Premi (3):
  omap3evm: Move generic config options in common file
  omap3evm: Update configuration to use common definitions
  omap3evm: Add support for quick boot

 include/configs/omap3_evm_common.h |  269 
 include/configs/omap3_evm_full.h   |  160 +
 include/configs/omap3_evm_quick.h  |  155 +
 3 files changed, 584 insertions(+), 0 deletions(-)
 create mode 100644 include/configs/omap3_evm_common.h
 create mode 100644 include/configs/omap3_evm_full.h
 create mode 100644 include/configs/omap3_evm_quick.h

-- 
1.7.2.2

___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [RFC 0/3] omap3evm: Add support for quick boot

2010-10-28 Thread Wolfgang Denk
Dear Sanjeev Premi,

In message 1288283919-3837-1-git-send-email-pr...@ti.com you wrote:
 This series is based on the comments received [1] on
 my earlier submission[2].
 
 Intent of sending as RFC is to thrash out the ideas
 and then send a formal patch.

Sorry, as you submitted this I see only 3 completely new files without
relation to each other nor with any relation to the existing code.

I suggest the following approach:

Patch 1: move common code out of include/configs/omap3_evm.h into a
 new file include/configs/omap3_evm_common.h; this patch
 should result in exactly the same code for the board as we
 have now.

 Do not rename omap3_evm.h into omap3_evm_full.h; this makes
 no sense to me. omap3_evm.h is and remains the default
 configuration.

Patch 2: Create a new file omap3_evm_quick.h, which contains the
 speed optimized configuration settings.  Get rid of all the 

#ifndef FOO
#define FOO
#endif

 stuff there. This is a plain simple and fixed configuration,
 so this is not needed.

You may even consider to splitting this more - into
omap3_evm_quick_nand.h and omap3_evm_quick_mmc.h to eliminate even
more of the #ifdeffery.

Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH, MD: Wolfgang Denk  Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: w...@denx.de
A modem is a baudy house.
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [RFC 0/3] omap3evm: Add support for quick boot

2010-10-28 Thread Premi, Sanjeev
 -Original Message-
 From: Wolfgang Denk [mailto:w...@denx.de] 
 Sent: Thursday, October 28, 2010 10:24 PM
 To: Premi, Sanjeev
 Cc: u-boot@lists.denx.de
 Subject: Re: [U-Boot] [RFC 0/3] omap3evm: Add support for quick boot
 
 Dear Sanjeev Premi,
 
 In message 1288283919-3837-1-git-send-email-pr...@ti.com you wrote:
  This series is based on the comments received [1] on
  my earlier submission[2].
  
  Intent of sending as RFC is to thrash out the ideas
  and then send a formal patch.
 
 Sorry, as you submitted this I see only 3 completely new files without
 relation to each other nor with any relation to the existing code.
 
 I suggest the following approach:
 
 Patch 1: move common code out of include/configs/omap3_evm.h into a
new file include/configs/omap3_evm_common.h; this patch
should result in exactly the same code for the board as we
have now.
 
  Do not rename omap3_evm.h into omap3_evm_full.h; this makes
  no sense to me. omap3_evm.h is and remains the default
  configuration.

[sp] Since I was also moving the related config options next to each
 other - as against current spread. I couldn't make much sens of
 patch. Thought it could be confusing to others as well.
 Appears, I was wrong!

 
 Patch 2: Create a new file omap3_evm_quick.h, which contains the
speed optimized configuration settings.  Get rid of all the 
 
   #ifndef FOO
   #define FOO
   #endif
   
stuff there. This is a plain simple and fixed configuration,
so this is not needed.

[sp] Sorry, I didn't clean this up considering the focus would be on
 the first 2 patches.

 
 You may even consider to splitting this more - into
 omap3_evm_quick_nand.h and omap3_evm_quick_mmc.h to eliminate even
 more of the #ifdeffery.

[sp] That's a good idea. Will have it implemented tomorrow morning.

best regards,
Sanjeev

 
 Best regards,
 
 Wolfgang Denk
 
 -- 
 DENX Software Engineering GmbH, MD: Wolfgang Denk  Detlev Zundel
 HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
 Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: w...@denx.de
 A modem is a baudy house.
 
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [RFC 0/3] omap3evm: Add support for quick boot

2010-10-28 Thread Wolfgang Denk
Dear Premi, Sanjeev,

In message b85a65d85d7eb246be421b3fb0fbb593023475e...@dbde02.ent.ti.com you 
wrote:

   Do not rename omap3_evm.h into omap3_evm_full.h; this makes
   no sense to me. omap3_evm.h is and remains the default
   configuration.
 
 [sp] Since I was also moving the related config options next to each
  other - as against current spread. I couldn't make much sens of
  patch. Thought it could be confusing to others as well.
  Appears, I was wrong!

Please don't do this in the same patch. Do it as a separate commit
either before or after splitting the config files.


Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH, MD: Wolfgang Denk  Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: w...@denx.de
You can observe a lot just by watching.  - Yogi Berra
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot