Re: [U-Boot] [v2 PATCH 13/14] cmd: qfw: rename QEMU_FW_CFG to CMD_QFW

2016-05-19 Thread Miao Yan
2016-05-20 10:30 GMT+08:00 Bin Meng :
> Hi Miao,
>
> On Fri, May 20, 2016 at 10:07 AM, Miao Yan  wrote:
>> Hi Bin,
>>
>> 2016-05-19 17:08 GMT+08:00 Bin Meng :
>>> Hi Miao,
>>>
>>> the title should say: CMD_QEMU_FW_CFG
>>>
>>> I can fix this when applying.
>>>
>>> On Wed, May 18, 2016 at 5:39 PM, Miao Yan  wrote:
 Align macro names with the rest of qfw code

>>>
>>> and I believe it's better to squash this commit into patch#8 in this
>>> series, as they both rename QEMU_FW_CFG to QFW.
>>
>> Thanks. Do I need a v3 ?
>>
>
> If you have time, let's do a v3 which saves my time. Sorry :(

OK, no problem.

Miao

>
> Regards,
> Bin
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [v2 PATCH 13/14] cmd: qfw: rename QEMU_FW_CFG to CMD_QFW

2016-05-19 Thread Bin Meng
Hi Miao,

On Fri, May 20, 2016 at 10:07 AM, Miao Yan  wrote:
> Hi Bin,
>
> 2016-05-19 17:08 GMT+08:00 Bin Meng :
>> Hi Miao,
>>
>> the title should say: CMD_QEMU_FW_CFG
>>
>> I can fix this when applying.
>>
>> On Wed, May 18, 2016 at 5:39 PM, Miao Yan  wrote:
>>> Align macro names with the rest of qfw code
>>>
>>
>> and I believe it's better to squash this commit into patch#8 in this
>> series, as they both rename QEMU_FW_CFG to QFW.
>
> Thanks. Do I need a v3 ?
>

If you have time, let's do a v3 which saves my time. Sorry :(

Regards,
Bin
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [v2 PATCH 13/14] cmd: qfw: rename QEMU_FW_CFG to CMD_QFW

2016-05-19 Thread Miao Yan
Hi Bin,

2016-05-19 17:08 GMT+08:00 Bin Meng :
> Hi Miao,
>
> the title should say: CMD_QEMU_FW_CFG
>
> I can fix this when applying.
>
> On Wed, May 18, 2016 at 5:39 PM, Miao Yan  wrote:
>> Align macro names with the rest of qfw code
>>
>
> and I believe it's better to squash this commit into patch#8 in this
> series, as they both rename QEMU_FW_CFG to QFW.

Thanks. Do I need a v3 ?


Thanks,
Miao


>
>> Signed-off-by: Miao Yan 
>> ---
>>  cmd/Kconfig| 2 +-
>>  cmd/Makefile   | 2 +-
>>  configs/qemu-x86_defconfig | 2 +-
>>  drivers/misc/Kconfig   | 2 +-
>>  4 files changed, 4 insertions(+), 4 deletions(-)
>>
>
> Reviewed-by: Bin Meng 
>
> [snip]
>
> Regards,
> Bin
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [v2 PATCH 13/14] cmd: qfw: rename QEMU_FW_CFG to CMD_QFW

2016-05-19 Thread Bin Meng
Hi Miao,

the title should say: CMD_QEMU_FW_CFG

I can fix this when applying.

On Wed, May 18, 2016 at 5:39 PM, Miao Yan  wrote:
> Align macro names with the rest of qfw code
>

and I believe it's better to squash this commit into patch#8 in this
series, as they both rename QEMU_FW_CFG to QFW.

> Signed-off-by: Miao Yan 
> ---
>  cmd/Kconfig| 2 +-
>  cmd/Makefile   | 2 +-
>  configs/qemu-x86_defconfig | 2 +-
>  drivers/misc/Kconfig   | 2 +-
>  4 files changed, 4 insertions(+), 4 deletions(-)
>

Reviewed-by: Bin Meng 

[snip]

Regards,
Bin
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


[U-Boot] [v2 PATCH 13/14] cmd: qfw: rename QEMU_FW_CFG to CMD_QFW

2016-05-18 Thread Miao Yan
Align macro names with the rest of qfw code

Signed-off-by: Miao Yan 
---
 cmd/Kconfig| 2 +-
 cmd/Makefile   | 2 +-
 configs/qemu-x86_defconfig | 2 +-
 drivers/misc/Kconfig   | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/cmd/Kconfig b/cmd/Kconfig
index 01870cb..d51645c 100644
--- a/cmd/Kconfig
+++ b/cmd/Kconfig
@@ -593,7 +593,7 @@ config CMD_SOUND
 sound init   - set up sound system
 sound play   - play a sound
 
-config CMD_QEMU_FW_CFG
+config CMD_QFW
bool "qfw"
select QFW
help
diff --git a/cmd/Makefile b/cmd/Makefile
index 0b7f7a2..1bbd14f 100644
--- a/cmd/Makefile
+++ b/cmd/Makefile
@@ -105,7 +105,7 @@ endif
 obj-y += pcmcia.o
 obj-$(CONFIG_CMD_PORTIO) += portio.o
 obj-$(CONFIG_CMD_PXE) += pxe.o
-obj-$(CONFIG_CMD_QEMU_FW_CFG) += qfw.o
+obj-$(CONFIG_CMD_QFW) += qfw.o
 obj-$(CONFIG_CMD_READ) += read.o
 obj-$(CONFIG_CMD_REGINFO) += reginfo.o
 obj-$(CONFIG_CMD_REISER) += reiser.o
diff --git a/configs/qemu-x86_defconfig b/configs/qemu-x86_defconfig
index a813e5b..45bb3ec 100644
--- a/configs/qemu-x86_defconfig
+++ b/configs/qemu-x86_defconfig
@@ -20,7 +20,7 @@ CONFIG_CMD_DHCP=y
 # CONFIG_CMD_NFS is not set
 CONFIG_CMD_PING=y
 CONFIG_CMD_TIME=y
-CONFIG_CMD_QEMU_FW_CFG=y
+CONFIG_CMD_QFW=y
 CONFIG_CMD_BOOTSTAGE=y
 CONFIG_CMD_EXT2=y
 CONFIG_CMD_EXT4=y
diff --git a/drivers/misc/Kconfig b/drivers/misc/Kconfig
index fa53700..c40f6b5 100644
--- a/drivers/misc/Kconfig
+++ b/drivers/misc/Kconfig
@@ -142,6 +142,6 @@ config QFW
bool
help
  Hidden option to enable QEMU fw_cfg interface. This will be selected 
by
- either CONFIG_CMD_QEMU_FW_CFG or CONFIG_GENERATE_ACPI_TABLE.
+ either CONFIG_CMD_QFW or CONFIG_GENERATE_ACPI_TABLE.
 
 endmenu
-- 
1.9.1

___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot