Re: 1 button for mutliuses

2005-06-13 Thread Levi Kendall
I like the suggestions that have been given so far, and I'll have to
considering switching to that method myself but the way I've been
doing this is by creating 2 buttons on top of each other and then each
button hides itself and shows the other.  The scripts for the buttons
would look as shown below, and you can leave the label and such of
each one intact individually.  This is just another option.

-- play button script
on mouseUp

  -- do something

  set the visible of btn "pause" to true
  set the visible of me to false
end mouseUp


-- pause button script
on mouseUp

  -- do something

  set the visible of btn "play" to true
  set the visible of me to false
end mouseUp
___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution


Re: 1 button for mutliuses

2005-06-04 Thread Jim Lyons
Concerning changing the name of objects:  Since we get to have both 
names and labels on objects in Revolution, I like to leave the name 
unchanged -- "play/pause" or some such -- and change the label to show 
the state of the button.


Jim Lyons

On Jun 3, 2005, at 10:20 PM, Tom McGrath wrote:


Make a button and name it "Play" without the quotes then put this
script into it:

on mouseUp
if (the short name of me is "Play") then
set the name of me to "Pause"
-- pause script for player goes here
--play stop audioClip "Trust No One" -- or pause
else
set the name of me to "Play"
-- play script for player goes here
--play audioClip "Trust No One"
end if
end mouseUp

Tom

On Jun 3, 2005, at 8:20 PM, [EMAIL PROTECTED] wrote:


So does that mean I would have to insert all of this code into the
Script
part?
And for the ID, what would an example look like x.x like on the C:/
Drive or
something like that.. I'm sorry, I'm just kinda confused
---

set the name of me to "Play"
set the name of me to "Pause"
set the icon of me to 1000 ## the ID of an image you want to use

on mouseUp
if (the short name of me is "Play") then
...
else
...
end if
end mouseUp
___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution




Thomas J. McGrath III


___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution


Re: 1 button for mutliuses

2005-06-03 Thread Thomas McGrath III

Hey Buddy,

Make a button and name it "Play" without the quotes then put this 
script into it:


on mouseUp
if (the short name of me is "Play") then
set the name of me to "Pause"
-- pause script for player goes here
--play stop audioClip "Trust No One" -- or pause
else
set the name of me to "Play"
-- play script for player goes here
--play audioClip "Trust No One"
end if
end mouseUp

Tom

On Jun 3, 2005, at 8:20 PM, [EMAIL PROTECTED] wrote:

So does that mean I would have to insert all of this code into the 
Script

part?
And for the ID, what would an example look like x.x like on the C:/ 
Drive or

something like that.. I'm sorry, I'm just kinda confused
---

set the name of me to "Play"
set the name of me to "Pause"
set the icon of me to 1000 ## the ID of an image you want to use

on mouseUp
if (the short name of me is "Play") then
...
else
...
end if
end mouseUp
___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution




Thomas J. McGrath III
SCS
1000 Killarney Dr.
Pittsburgh, PA 15234
412-885-8541
___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution


Re: 1 button for mutliuses

2005-06-03 Thread Buddyb3ar22
So does that mean I would have to insert all of this code into the Script 
part? 
And for the ID, what would an example look like x.x like on the C:/ Drive or 
something like that.. I'm sorry, I'm just kinda confused
---
 
set the name of me to "Play"
set the name of me to "Pause"
set the icon of me to 1000 ## the ID of an image you want to use

on mouseUp
if (the short name of me is "Play") then
...
else
...
end if
end mouseUp
___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution


Re: 1 button for mutliuses

2005-06-03 Thread Brian Yennie

Buddy,

In order to use the one button for multiple functions, you'll need to 
set some information about it.


For example, when the user hits play, change its "name" and its "icon" 
property.

It will still be the same button, just appear differently to the user.

Here are some pieces:

set the name of me to "Play"
set the name of me to "Pause"
set the icon of me to 1000 ## the ID of an image you want to use

on mouseUp
   if (the short name of me is "Play") then
  ...
   else
  ...
   end if
end mouseUp

HTH,
Brian

I have a question, lets say you want only one button for a play and 
pause
function, If a player was playing, the button would say "Pause" and 
when you
pressed it, the button would pause the player and the word on it would 
change to

"Play", Vise versa
Someone tried to explain this before, but I don't really get what they 
meant

by what they said
Thanks, (You can call me buddy)
___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution




___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution


1 button for mutliuses

2005-06-03 Thread Buddyb3ar22
I have a question, lets say you want only one button for a play and pause 
function, If a player was playing, the button would say "Pause" and when you 
pressed it, the button would pause the player and the word on it would change 
to 
"Play", Vise versa 
Someone tried to explain this before, but I don't really get what they meant 
by what they said
Thanks, (You can call me buddy)
___
use-revolution mailing list
use-revolution@lists.runrev.com
http://lists.runrev.com/mailman/listinfo/use-revolution