Re: Flink POJO documentation for primitive boolean state variables

2022-01-27 Thread Alexander Fedulov
Hi Mac,

I just verified that objects with isXXX methods indeed will be interpreted
as POJOs. Would you be willing to contribute a documentation update?
Here are some guidelines: [1].

[1]  https://flink.apache.org/contributing/contribute-documentation.html



Thanks,

Alexander Fedulov



On Thu, Jan 27, 2022 at 9:07 AM Makhanchan Pandey <
makhanchanpan...@gmail.com> wrote:

> Hi all,
>
> Just wanted to follow up on this again :) Thanks in advance.
>
> Regards,
> Mac Pandey
>
>
>
> On Tue, Jan 25, 2022 at 12:59 PM Makhanchan Pandey <
> makhanchanpan...@gmail.com> wrote:
>
>> Hi all,
>>
>> For Flink to treat a model class as a special POJO type, these are the
>> documented conditions:
>> https://nightlies.apache.org/flink/flink-docs-release-1.13/docs/dev/serialization/types_serialization/#pojos
>>
>> It says the following:
>>
>>-
>>
>>All fields are either public or must be accessible through getter and
>>setter functions. For a field called foo the getter and setter
>>methods must be named getFoo() and setFoo().
>>
>>
>> We have boolean fields in our model class:
>> public class Input {
>>   private boolean open;
>> }
>>
>> As per this we are forced to create an accessor getOpen( ) while the
>> standard Javabeans convention would be isOpen().
>>
>> We ran some tests with both isOpen and getOpen and both seem to be
>> recognized as POJO.
>>
>> Could we get confirmation that using isOpen() is valid here? And that
>> this primitive boolean case is just not been documented in the above link?
>>
>>
>> Regards,
>> Mac Pandey
>>
>>
>>
>>
>>
>>
>>


Re: Flink POJO documentation for primitive boolean state variables

2022-01-27 Thread Makhanchan Pandey
Hi all,

Just wanted to follow up on this again :) Thanks in advance.

Regards,
Mac Pandey



On Tue, Jan 25, 2022 at 12:59 PM Makhanchan Pandey <
makhanchanpan...@gmail.com> wrote:

> Hi all,
>
> For Flink to treat a model class as a special POJO type, these are the
> documented conditions:
> https://nightlies.apache.org/flink/flink-docs-release-1.13/docs/dev/serialization/types_serialization/#pojos
>
> It says the following:
>
>-
>
>All fields are either public or must be accessible through getter and
>setter functions. For a field called foo the getter and setter methods
>must be named getFoo() and setFoo().
>
>
> We have boolean fields in our model class:
> public class Input {
>   private boolean open;
> }
>
> As per this we are forced to create an accessor getOpen( ) while the
> standard Javabeans convention would be isOpen().
>
> We ran some tests with both isOpen and getOpen and both seem to be
> recognized as POJO.
>
> Could we get confirmation that using isOpen() is valid here? And that this
> primitive boolean case is just not been documented in the above link?
>
>
> Regards,
> Mac Pandey
>
>
>
>
>
>
>