[webkit-changes] [234647] trunk/Tools

2018-08-07 Thread utatane . tea
Title: [234647] trunk/Tools








Revision 234647
Author utatane@gmail.com
Date 2018-08-07 03:59:40 -0700 (Tue, 07 Aug 2018)


Log Message
Unreviewed, add a new address to my configuration

* Scripts/webkitpy/common/config/contributors.json:

Modified Paths

trunk/Tools/ChangeLog
trunk/Tools/Scripts/webkitpy/common/config/contributors.json




Diff

Modified: trunk/Tools/ChangeLog (234646 => 234647)

--- trunk/Tools/ChangeLog	2018-08-07 10:01:18 UTC (rev 234646)
+++ trunk/Tools/ChangeLog	2018-08-07 10:59:40 UTC (rev 234647)
@@ -1,3 +1,9 @@
+2018-08-07  Yusuke Suzuki  
+
+Unreviewed, add a new address to my configuration
+
+* Scripts/webkitpy/common/config/contributors.json:
+
 2018-08-06  David Quesada  
 
 webkitdirs.pm should default to iPhone SE for 64-bit testing


Modified: trunk/Tools/Scripts/webkitpy/common/config/contributors.json (234646 => 234647)

--- trunk/Tools/Scripts/webkitpy/common/config/contributors.json	2018-08-07 10:01:18 UTC (rev 234646)
+++ trunk/Tools/Scripts/webkitpy/common/config/contributors.json	2018-08-07 10:59:40 UTC (rev 234647)
@@ -5964,6 +5964,7 @@
},
"Yusuke Suzuki" : {
   "emails" : [
+ "yusukesuz...@slowstart.org",
  "utatane@gmail.com"
   ],
   "expertise" : "JIT Compilers, CSS JIT, _javascript_/ECMAScript",
@@ -6097,4 +6098,4 @@
   ],
   "status" : "reviewer"
}
-}
\ No newline at end of file
+}






___
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes


[webkit-changes] [234588] trunk

2018-08-06 Thread utatane . tea
Title: [234588] trunk








Revision 234588
Author utatane@gmail.com
Date 2018-08-06 00:59:13 -0700 (Mon, 06 Aug 2018)


Log Message
Implement self.queueMicrotask in Workers
https://bugs.webkit.org/show_bug.cgi?id=188247

Reviewed by Ryosuke Niwa.

Source/WebCore:

This patch adds support for self.queueMicrotask to workers.

Tests: http/wpt/workers/queue-microtask.any.html
   http/wpt/workers/queue-microtask.any.worker.html

* bindings/js/JSWorkerGlobalScopeCustom.cpp:
(WebCore::JSWorkerGlobalScope::queueMicrotask):
* page/DOMWindow.idl:
Move queueMicrotask declaration to WindowOrWorkerGlobalScope.idl.
* page/WindowOrWorkerGlobalScope.idl:

LayoutTests:

* http/wpt/workers/queue-microtask.any-expected.txt: Added.
* http/wpt/workers/queue-microtask.any.html: Added.
* http/wpt/workers/queue-microtask.any.js: Added.
(promise_test):
(promise_test.):
(queueMicrotask.promise_test):
(test):
* http/wpt/workers/queue-microtask.any.worker-expected.txt: Added.
* http/wpt/workers/queue-microtask.any.worker.html: Added.

Modified Paths

trunk/LayoutTests/ChangeLog
trunk/Source/WebCore/ChangeLog
trunk/Source/WebCore/bindings/js/JSWorkerGlobalScopeCustom.cpp
trunk/Source/WebCore/page/DOMWindow.idl
trunk/Source/WebCore/page/WindowOrWorkerGlobalScope.idl


Added Paths

trunk/LayoutTests/http/wpt/workers/queue-microtask.any-expected.txt
trunk/LayoutTests/http/wpt/workers/queue-microtask.any.html
trunk/LayoutTests/http/wpt/workers/queue-microtask.any.js
trunk/LayoutTests/http/wpt/workers/queue-microtask.any.worker-expected.txt
trunk/LayoutTests/http/wpt/workers/queue-microtask.any.worker.html




Diff

Modified: trunk/LayoutTests/ChangeLog (234587 => 234588)

--- trunk/LayoutTests/ChangeLog	2018-08-06 06:43:51 UTC (rev 234587)
+++ trunk/LayoutTests/ChangeLog	2018-08-06 07:59:13 UTC (rev 234588)
@@ -1,3 +1,20 @@
+2018-08-05  Yusuke Suzuki  
+
+Implement self.queueMicrotask in Workers
+https://bugs.webkit.org/show_bug.cgi?id=188247
+
+Reviewed by Ryosuke Niwa.
+
+* http/wpt/workers/queue-microtask.any-expected.txt: Added.
+* http/wpt/workers/queue-microtask.any.html: Added.
+* http/wpt/workers/queue-microtask.any.js: Added.
+(promise_test):
+(promise_test.):
+(queueMicrotask.promise_test):
+(test):
+* http/wpt/workers/queue-microtask.any.worker-expected.txt: Added.
+* http/wpt/workers/queue-microtask.any.worker.html: Added.
+
 2018-08-05  Rob Buis  
 
 [GTK][WPE] Fetch tests assert in SubresourceLoader::didReceiveResponse()


Added: trunk/LayoutTests/http/wpt/workers/queue-microtask.any-expected.txt (0 => 234588)

--- trunk/LayoutTests/http/wpt/workers/queue-microtask.any-expected.txt	(rev 0)
+++ trunk/LayoutTests/http/wpt/workers/queue-microtask.any-expected.txt	2018-08-06 07:59:13 UTC (rev 234588)
@@ -0,0 +1,6 @@
+
+PASS Queued microtasks should be drained before executing macrotasks 
+PASS queueMicrotask's callback has zero arguments and self as |this| 
+PASS queueMicrotask and Promise uses the same Microtask queue 
+PASS queueMicrotask should reject non-function arguments 
+


Added: trunk/LayoutTests/http/wpt/workers/queue-microtask.any.html (0 => 234588)

--- trunk/LayoutTests/http/wpt/workers/queue-microtask.any.html	(rev 0)
+++ trunk/LayoutTests/http/wpt/workers/queue-microtask.any.html	2018-08-06 07:59:13 UTC (rev 234588)
@@ -0,0 +1 @@
+
\ No newline at end of file


Added: trunk/LayoutTests/http/wpt/workers/queue-microtask.any.js (0 => 234588)

--- trunk/LayoutTests/http/wpt/workers/queue-microtask.any.js	(rev 0)
+++ trunk/LayoutTests/http/wpt/workers/queue-microtask.any.js	2018-08-06 07:59:13 UTC (rev 234588)
@@ -0,0 +1,93 @@
+promise_test(() => {
+var counter = 0;
+self.queueMicrotask(() => {
+assert_equals(counter++, 1);
+self.queueMicrotask(() => {
+assert_equals(counter++, 2);
+});
+});
+var promise = new Promise((resolve, reject) => {
+setTimeout(() => {
+assert_equals(counter++, 3);
+resolve();
+}, 0);
+});
+assert_equals(counter++, 0);
+return promise;
+}, `Queued microtasks should be drained before executing macrotasks`);
+
+promise_test(() => {
+return new Promise((resolve, reject) => {
+self.queueMicrotask(function () {
+try {
+assert_equals(arguments.length, 0);
+assert_equals(this, self);
+self.queueMicrotask(function () {
+try {
+assert_equals(this, self);
+self.queueMicrotask(function () {
+'use strict';
+try {
+assert_equals(this, undefined);
+resolve();
+} catch (e) {
+reject(e);
+ 

[webkit-changes] [234493] trunk/Source/WebCore

2018-08-01 Thread utatane . tea
Title: [234493] trunk/Source/WebCore








Revision 234493
Author utatane@gmail.com
Date 2018-08-01 21:24:11 -0700 (Wed, 01 Aug 2018)


Log Message
Unreviewed, revert TransformationMatrix::operator== change
https://bugs.webkit.org/show_bug.cgi?id=188197

This change partially revert cleaning up of TransformationMatrix since memcmp does not
follow double comparison algorithm. So semantics was accidentally changed.

* platform/graphics/transforms/TransformationMatrix.h:
(WebCore::TransformationMatrix::operator== const):

Modified Paths

trunk/Source/WebCore/ChangeLog
trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h




Diff

Modified: trunk/Source/WebCore/ChangeLog (234492 => 234493)

--- trunk/Source/WebCore/ChangeLog	2018-08-02 04:10:43 UTC (rev 234492)
+++ trunk/Source/WebCore/ChangeLog	2018-08-02 04:24:11 UTC (rev 234493)
@@ -1,5 +1,16 @@
 2018-08-01  Yusuke Suzuki  
 
+Unreviewed, revert TransformationMatrix::operator== change
+https://bugs.webkit.org/show_bug.cgi?id=188197
+
+This change partially revert cleaning up of TransformationMatrix since memcmp does not
+follow double comparison algorithm. So semantics was accidentally changed.
+
+* platform/graphics/transforms/TransformationMatrix.h:
+(WebCore::TransformationMatrix::operator== const):
+
+2018-08-01  Yusuke Suzuki  
+
 Unreviewed, rename TransformationMatrix::Identity to TransformationMatrix::identity
 https://bugs.webkit.org/show_bug.cgi?id=188204
 


Modified: trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h (234492 => 234493)

--- trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h	2018-08-02 04:10:43 UTC (rev 234492)
+++ trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h	2018-08-02 04:24:11 UTC (rev 234493)
@@ -337,7 +337,22 @@
 
 bool operator==(const TransformationMatrix& m2) const
 {
-return memcmp(&m_matrix[0][0], &m2.m_matrix[0][0], sizeof(Matrix4)) == 0;
+return (m_matrix[0][0] == m2.m_matrix[0][0] &&
+m_matrix[0][1] == m2.m_matrix[0][1] &&
+m_matrix[0][2] == m2.m_matrix[0][2] &&
+m_matrix[0][3] == m2.m_matrix[0][3] &&
+m_matrix[1][0] == m2.m_matrix[1][0] &&
+m_matrix[1][1] == m2.m_matrix[1][1] &&
+m_matrix[1][2] == m2.m_matrix[1][2] &&
+m_matrix[1][3] == m2.m_matrix[1][3] &&
+m_matrix[2][0] == m2.m_matrix[2][0] &&
+m_matrix[2][1] == m2.m_matrix[2][1] &&
+m_matrix[2][2] == m2.m_matrix[2][2] &&
+m_matrix[2][3] == m2.m_matrix[2][3] &&
+m_matrix[3][0] == m2.m_matrix[3][0] &&
+m_matrix[3][1] == m2.m_matrix[3][1] &&
+m_matrix[3][2] == m2.m_matrix[3][2] &&
+m_matrix[3][3] == m2.m_matrix[3][3]);
 }
 
 bool operator!=(const TransformationMatrix& other) const { return !(*this == other); }






___
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes


[webkit-changes] [234492] trunk/Source/WebCore

2018-08-01 Thread utatane . tea
Title: [234492] trunk/Source/WebCore








Revision 234492
Author utatane@gmail.com
Date 2018-08-01 21:10:43 -0700 (Wed, 01 Aug 2018)


Log Message
Unreviewed, rename TransformationMatrix::Identity to TransformationMatrix::identity
https://bugs.webkit.org/show_bug.cgi?id=188204

Follow the coding style.

* platform/graphics/GraphicsLayer.cpp:
(WebCore::GraphicsLayer::transform const):
(WebCore::GraphicsLayer::childrenTransform const):
* platform/graphics/transforms/TransformationMatrix.cpp:
* platform/graphics/transforms/TransformationMatrix.h:

Modified Paths

trunk/Source/WebCore/ChangeLog
trunk/Source/WebCore/platform/graphics/GraphicsLayer.cpp
trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.cpp
trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h




Diff

Modified: trunk/Source/WebCore/ChangeLog (234491 => 234492)

--- trunk/Source/WebCore/ChangeLog	2018-08-02 03:55:47 UTC (rev 234491)
+++ trunk/Source/WebCore/ChangeLog	2018-08-02 04:10:43 UTC (rev 234492)
@@ -1,5 +1,18 @@
 2018-08-01  Yusuke Suzuki  
 
+Unreviewed, rename TransformationMatrix::Identity to TransformationMatrix::identity
+https://bugs.webkit.org/show_bug.cgi?id=188204
+
+Follow the coding style.
+
+* platform/graphics/GraphicsLayer.cpp:
+(WebCore::GraphicsLayer::transform const):
+(WebCore::GraphicsLayer::childrenTransform const):
+* platform/graphics/transforms/TransformationMatrix.cpp:
+* platform/graphics/transforms/TransformationMatrix.h:
+
+2018-08-01  Yusuke Suzuki  
+
 Add self.queueMicrotask(f) on DOMWindow
 https://bugs.webkit.org/show_bug.cgi?id=188212
 


Modified: trunk/Source/WebCore/platform/graphics/GraphicsLayer.cpp (234491 => 234492)

--- trunk/Source/WebCore/platform/graphics/GraphicsLayer.cpp	2018-08-02 03:55:47 UTC (rev 234491)
+++ trunk/Source/WebCore/platform/graphics/GraphicsLayer.cpp	2018-08-02 04:10:43 UTC (rev 234492)
@@ -294,7 +294,7 @@
 
 const TransformationMatrix& GraphicsLayer::transform() const
 {
-return m_transform ? *m_transform : TransformationMatrix::Identity;
+return m_transform ? *m_transform : TransformationMatrix::identity;
 }
 
 void GraphicsLayer::setTransform(const TransformationMatrix& matrix)
@@ -307,7 +307,7 @@
 
 const TransformationMatrix& GraphicsLayer::childrenTransform() const
 {
-return m_childrenTransform ? *m_childrenTransform : TransformationMatrix::Identity;
+return m_childrenTransform ? *m_childrenTransform : TransformationMatrix::identity;
 }
 
 void GraphicsLayer::setChildrenTransform(const TransformationMatrix& matrix)


Modified: trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.cpp (234491 => 234492)

--- trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.cpp	2018-08-02 03:55:47 UTC (rev 234491)
+++ trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.cpp	2018-08-02 04:10:43 UTC (rev 234492)
@@ -70,7 +70,7 @@
 
 const double SMALL_NUMBER = 1.e-8;
 
-const TransformationMatrix TransformationMatrix::Identity { };
+const TransformationMatrix TransformationMatrix::identity { };
 
 // inverse(original_matrix, inverse_matrix)
 //


Modified: trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h (234491 => 234492)

--- trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h	2018-08-02 03:55:47 UTC (rev 234491)
+++ trunk/Source/WebCore/platform/graphics/transforms/TransformationMatrix.h	2018-08-02 04:10:43 UTC (rev 234492)
@@ -118,7 +118,7 @@
 
 WEBCORE_EXPORT TransformationMatrix(const AffineTransform&);
 
-static const TransformationMatrix Identity;
+static const TransformationMatrix identity;
 
 void setMatrix(double a, double b, double c, double d, double e, double f)
 {






___
webkit-changes mailing list
webkit-changes@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-changes


[webkit-changes] [234491] trunk

2018-08-01 Thread utatane . tea
Title: [234491] trunk








Revision 234491
Author utatane@gmail.com
Date 2018-08-01 20:55:47 -0700 (Wed, 01 Aug 2018)


Log Message
Add self.queueMicrotask(f) on DOMWindow
https://bugs.webkit.org/show_bug.cgi?id=188212

Reviewed by Ryosuke Niwa.

Source/_javascript_Core:

* CMakeLists.txt:
* _javascript_Core.xcodeproj/project.pbxproj:
* Sources.txt:
* runtime/JSGlobalObject.cpp:
(JSC::enqueueJob):
* runtime/JSMicrotask.cpp: Renamed from Source/_javascript_Core/runtime/JSJob.cpp.
(JSC::createJSMicrotask):
Export them to WebCore.

(JSC::JSMicrotask::run):
* runtime/JSMicrotask.h: Renamed from Source/_javascript_Core/runtime/JSJob.h.
Add another version of JSMicrotask which does not have arguments.

Source/WebCore:

This patch adds self.queueMicrotask(f) in DOMWindow, which takes a function and enqueue it into microtask queue.
We do not add this to Worker's global scope since our worker does not support microtasks correctly.

Tests: js/dom/queue-microtask-window.html

* bindings/js/JSDOMWindowCustom.cpp:
(WebCore::JSDOMWindow::queueMicrotask):
Post a microtask to JSC's microtask mechanism. This will eventually go to WebCore's MicrotaskQueue code.

* page/DOMWindow.idl:

LayoutTests:

* js/dom/queue-microtask-window-expected.txt: Added.
* js/dom/queue-microtask-window.html: Added.

Modified Paths

trunk/LayoutTests/ChangeLog
trunk/Source/_javascript_Core/CMakeLists.txt
trunk/Source/_javascript_Core/ChangeLog
trunk/Source/_javascript_Core/_javascript_Core.xcodeproj/project.pbxproj
trunk/Source/_javascript_Core/Sources.txt
trunk/Source/_javascript_Core/runtime/JSGlobalObject.cpp
trunk/Source/WebCore/ChangeLog
trunk/Source/WebCore/bindings/js/JSDOMWindowCustom.cpp
trunk/Source/WebCore/page/DOMWindow.idl


Added Paths

trunk/LayoutTests/js/dom/queue-microtask-window-expected.txt
trunk/LayoutTests/js/dom/queue-microtask-window.html
trunk/Source/_javascript_Core/runtime/JSMicrotask.cpp
trunk/Source/_javascript_Core/runtime/JSMicrotask.h


Removed Paths

trunk/Source/_javascript_Core/runtime/JSJob.cpp
trunk/Source/_javascript_Core/runtime/JSJob.h




Diff

Modified: trunk/LayoutTests/ChangeLog (234490 => 234491)

--- trunk/LayoutTests/ChangeLog	2018-08-02 02:19:04 UTC (rev 234490)
+++ trunk/LayoutTests/ChangeLog	2018-08-02 03:55:47 UTC (rev 234491)
@@ -1,3 +1,13 @@
+2018-08-01  Yusuke Suzuki  
+
+Add self.queueMicrotask(f) on DOMWindow
+https://bugs.webkit.org/show_bug.cgi?id=188212
+
+Reviewed by Ryosuke Niwa.
+
+* js/dom/queue-microtask-window-expected.txt: Added.
+* js/dom/queue-microtask-window.html: Added.
+
 2018-08-01  Ryosuke Niwa  
 
 REGRESSION(r227983): fast/dom/adopt-node-crash-2.html is flaky


Added: trunk/LayoutTests/js/dom/queue-microtask-window-expected.txt (0 => 234491)

--- trunk/LayoutTests/js/dom/queue-microtask-window-expected.txt	(rev 0)
+++ trunk/LayoutTests/js/dom/queue-microtask-window-expected.txt	2018-08-02 03:55:47 UTC (rev 234491)
@@ -0,0 +1,7 @@
+
+
+PASS Queued microtasks should be drained before executing macrotasks 
+PASS queueMicrotask's callback has zero arguments and self as |this| 
+PASS queueMicrotask and Promise uses the same Microtask queue 
+PASS queueMicrotask should reject non-function arguments 
+


Added: trunk/LayoutTests/js/dom/queue-microtask-window.html (0 => 234491)

--- trunk/LayoutTests/js/dom/queue-microtask-window.html	(rev 0)
+++ trunk/LayoutTests/js/dom/queue-microtask-window.html	2018-08-02 03:55:47 UTC (rev 234491)
@@ -0,0 +1,110 @@
+
+
+
+self.queueMicrotask works in Window
+
+
+
+