[webkit-dev] Changing names of new WebGL extensions

2013-07-02 Thread Karol Swiniarski
Hi all,

First of all I would like to say hi to everyone - it's my first post in this
list ;-)

There has been recently approved WebGL extensions by Khronos:
WEBGL_depth_texture, WEBGL_compressed_texture_s3tc, WEBGL_lose_context.

I created a patch which changes old prefixes from WEBKIT_WEBGL_ to WEBGL_

https://bugs.webkit.org/show_bug.cgi?id=117786

It has been reviewed, and so far, not accepted.

This change complies with latest WebGL standard and may break some
backward-compatibility.

What's the process of pushing such changes to Webkit? Who is responsible for
changing names? Can this change be applied any soon?

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Remove CSS_IMAGE_ORIENTATION Feature Guard

2013-07-02 Thread Brent Fulgham
Hi Everyone,

I haven't seen any action on https://bugs.webkit.org/show_bug.cgi?id=116555 (or 
https://bugs.webkit.org/show_bug.cgi?id=92330) in the past month.

I'd like to remove this logic unless there is some activity here.  We can 
always add it back in from SVN history if someone does want to work on it.

I'll submit a patch to remove this code on July 17th unless something changes.

Thanks,

-Brent



On Jun 4, 2013, at 10:15 PM, Gyuyoung Kim wrote:

> Hi,
> 
> I'm interested in this feature. So, I took Bug 92330 over. Though I rebased 
> the feature according to review comments, this feature doesn't work yet. So, 
> I have investigated why it doesn't work. However, unfortunately, I need to 
> have time a little further. If there is no big reason this patch should be 
> removed, I'd like to support this feature.
> 
> Gyuyoung.
> On Jun 5, 2013 9:45 AM, "Mike Lawther"  wrote:
> Fwiw, the original author is no longer working on Blink, and the code has 
> been removed from there.
> 
> mike
> 
> On Jun 5, 2013 1:24 AM, "Brent Fulgham"  wrote:
> We have code in WebKit that is protected by the ENABLE(CSS_IMAGE_ORIENTATION) 
> guard, but no active WebKit ports seem to enable this feature.
> 
> Is anyone currently working on (or planning to work on) this feature?
> 
> Since this CSS feature is currently in an early draft form, and is likely to 
> change, we may not want to retain this dead code as it will most likely 
> become obsolete very quickly.
> 
> If no one wants to claim ownership of this feature in the next few days, I 
> will submit a patch to remove the dead code.
> 
> Thanks,
> 
> -Brent
> ___
> webkit-dev mailing list
> webkit-dev@lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev
> 
> ___
> webkit-dev mailing list
> webkit-dev@lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev
> 

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Fuzzinator, a mutation based web fuzzer

2013-07-02 Thread Dean Jackson

On 27/06/2013, at 2:48 AM, Renáta Hodován  wrote:

> On 06/26/2013 12:30 AM, Zoltan Horvath wrote:
>> Hey Reni,
>> 
>> This project sounds cool! I think you will answer some of my questions in 
>> your blog post, so I don't ask just one now...
>> 
>> Do you know the date it's going to be published?
>> 
> Hopefully next week you can read it ;)

Is it out yet?

Dean

___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-07-02 Thread Maciej Stachowiak

On Jul 1, 2013, at 7:31 PM, Brady Eidson  wrote:

> 
> On Jul 1, 2013, at 5:27 PM, Ryosuke Niwa  wrote:
> 
>> I concur.  Maybe
>> StyleResolver* styleResolverIfExists()
>> StyleResolver& styleResolver()
>> ?
> 
> I concur with this.
> 
> For this entire discussion, this is where I was hoping it was headed.

I like. Maybe we should use this naming pattern and type signature even when 
only one or the other variant exists?

Regards,
Maciej




___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev


Re: [webkit-dev] Remove CSS_IMAGE_ORIENTATION Feature Guard

2013-07-02 Thread Gyuyoung Kim
Hi Brent,

Sorry for no activity on this. This work was pushed back on the my priority
list. Thus, I agree to remove this feature if nobody(including me) submits
meaningful patch until July 17th.

Gyuyoung.


On Wed, Jul 3, 2013 at 3:05 AM, Brent Fulgham  wrote:

> Hi Everyone,
>
> I haven't seen any action on
> https://bugs.webkit.org/show_bug.cgi?id=116555 (or
> https://bugs.webkit.org/show_bug.cgi?id=92330) in the past month.
>
> I'd like to remove this logic unless there is some activity here.  We can
> always add it back in from SVN history if someone does want to work on it.
>
> I'll submit a patch to remove this code on July 17th unless something
> changes.
>
> Thanks,
>
> -Brent
>
>
>
> On Jun 4, 2013, at 10:15 PM, Gyuyoung Kim wrote:
>
> Hi,
>
> I'm interested in this feature. So, I took Bug 92330 over. Though I
> rebased the feature according to review comments, this feature doesn't work
> yet. So, I have investigated why it doesn't work. However, unfortunately, I
> need to have time a little further. If there is no big reason this patch
> should be removed, I'd like to support this feature.
>
> Gyuyoung.
>  On Jun 5, 2013 9:45 AM, "Mike Lawther"  wrote:
>
>> Fwiw, the original author is no longer working on Blink, and the code has
>> been removed from there.
>>
>> mike
>> On Jun 5, 2013 1:24 AM, "Brent Fulgham"  wrote:
>>
>>> We have code in WebKit that is protected by the
>>> ENABLE(CSS_IMAGE_ORIENTATION) guard, but no active WebKit ports seem to
>>> enable this feature.
>>>
>>> Is anyone currently working on (or planning to work on) this feature?
>>>
>>> Since this CSS feature is currently in an early draft form, and is
>>> likely to change, we may not want to retain this dead code as it will most
>>> likely become obsolete very quickly.
>>>
>>> If no one wants to claim ownership of this feature in the next few days,
>>> I will submit a patch to remove the dead code.
>>>
>>> Thanks,
>>>
>>> -Brent
>>> ___
>>> webkit-dev mailing list
>>> webkit-dev@lists.webkit.org
>>> https://lists.webkit.org/mailman/listinfo/webkit-dev
>>>
>>
>> ___
>> webkit-dev mailing list
>> webkit-dev@lists.webkit.org
>> https://lists.webkit.org/mailman/listinfo/webkit-dev
>>
>>
>
___
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev