Re: [whatwg] input type="location" proposals
2010/6/18 Eitan Adler : > These are two separate proposals and I both could co-exist one as > type="location" and the other as type="gps" Even though this sounds pretty nice to me, something critical should be figured out before going deeper. Precisely: 1. Maps are heavy to get, this means UA should heavily cache and/or it should own whole maps data (huge!) 2. If 1) didn't exist because UA can, for instance, get maps data in a blink of an eye: whose data are we gonna use? 3. Maps data are often non-free and non-open, reliable maps data are always non-free and non-open. My 2c... -- Bye, Michelangelo
Re: [whatwg] Form validation against invisible controls
Il giorno 14/giu/2010, alle ore 12.40, Ian Hickson ha scritto: > Incorrect use of "required" in HTML4-era documents also seems to be the > common problem Chrome ran into -- at the risk of starting a bikeshed > discussion, does anyone have any good suggestions for alternative names? I believe "mandatory" would keep the same semantic and clarity "required" does. -- Bye, Michelangelo
Re: [whatwg] validationMessage
2009/11/20 Scott González : > following that same logic wouldn't you come to the conclusion that date > inputs should not display calendars because they need to be localized? You're speaking about a very different scenario, use cases and data types. Let's focus our discussion to validationMessage for now. validationMessage returns "something" in a localized fashion related to UA's locale. This means that we have two major issues from my point of view: 1. decontextualization: page's locale may differ from UA's locale; 2. heterogeneity: actual specs rely too much on implementors and different localizations. 1. Decontextualization As I and Peter pointed out it's quite nonsense. Except for the obvious difference between page content (eg: let's say "English") and validation message content (eg: let's say "Italian"), it's most illogical: would you ever fill a form in a language you don't understand just relying on validation hints from your UA? Ok, let's say you accomplish such task after N attempts: what do you THINK you're gonna submit? Perhaps you thought to be filling a form to register to a forum while you were unconsciously filling, instead, a "malicious" form. 2. Heterogeneity Even if objections in 1. hadn't reasons to exist we would have a (de jure) HTML spec with no common validation messages: UA X, in locale L1 would have some strings; UA Y, in the same locale, would have other strings. It's not generic and it's not "ruled" enough. Thus far there're much better ways to accomplish the same task; for what it's worth, my opinion is that validationMessage has very few reasons to exist at all. UAs can come up with their own desired way of advising users of validation errors and authors can enforce such communication in the way they prefer: we all love ValidityState's validation flags.:) -- Bye, Michelangelo
Re: [whatwg] validationMessage
Hi, pardon me but it seems almost nonsense to me: would users fill forms in a language they can't even understand? For instance: I'm italian, I speak Italian and English but I'm required to fill a form in Swahili. I would understand validation messages for sure (they would come from my UA) but I couldn't understand why they don't satisfy their constraints, what I'm supposed to fill and when I should submit the form. A clarification is needed. Il giorno 10/nov/2009, alle ore 23.37, Scott González ha scritto: > Wouldn't the UA be written for a specific language that would be independent > of the language the page's content is written in? For example, a user in > Spain would be using a UA with a Spanish locale (the UA's menus, dialogs, > button labels, etc. would all be in Spanish). If that user were to visit a > page written in French wouldn't the content generated by the UA still be in > Spanish? So an alert would contain a message in French, but a button in > Spanish. I would expect the same thing to happen with validation messages. > > As for the suggestion of the validation message just being a constant, you > can just check the validity state if you want to provide custom messages. > > > On Tue, Nov 10, 2009 at 4:23 PM, Michelangelo De Simone > wrote: > Hi, > > I've been dealing with the validationMessage implementation in WebKit. As > some of WebKit member pointed out it's quite unusual for an attribute to > "return a suitably *localized message* that the user agent would show the > user". > > Couldn't such behavior be potentially heterogeneous among UAs and > localizations? > > What is the rationale about this choice? A simpler behavior with a > predetermined list of return values (eg: i.validationMessage == VALUEMISSING) > could be much more efficient for authors and implementors to deal with, IMHO. > > Thank you for your feedbacks. > -- > Bye, Michelangelo > > > > -- Bye, Michelangelo
[whatwg] validationMessage
Hi, I've been dealing with the validationMessage implementation in WebKit. As some of WebKit member pointed out it's quite unusual for an attribute to "return a suitably *localized message* that the user agent would show the user". Couldn't such behavior be potentially heterogeneous among UAs and localizations? What is the rationale about this choice? A simpler behavior with a predetermined list of return values (eg: i.validationMessage == VALUEMISSING) could be much more efficient for authors and implementors to deal with, IMHO. Thank you for your feedbacks. -- Bye, Michelangelo
Re: [whatwg] HTML 5 buttons and constraint validation
Il giorno 07/set/2009, alle ore 06.56, Alex Vincent ha scritto: There's a possible disconnect between and . The former is barred from constraint validation, but the latter is not. (Section 4.10). Is this intentional? I guess it's a mistake; actual implementation of willValidate flag on WebKit assumes that both of them (button and type=button) are barred from validation. -- Bye, Michelangelo
Re: [whatwg] formNoValidate/novalidate/willValidate
2009/8/26 Dean Edwards : > "novalidate" sticks out like a sore thumb. Can we change it to "noValidate". > It's only mentioned in the IDL so maybe it's a typo. I agree, it seems a typo. I'm gonna prepare a patch for WebKit to correct that in case specs are modified. -- Bye, Michelangelo
Re: [whatwg] Comments on the definition of a valid e-mail address
2009/8/24 Peter Kasting : > I am mentoring a student who is writing a patch for this in WebKit as we > speak -- we were just discussing the implementation yesterday and I believe > he hopes to have it out for review tomorrow. The mentored student has published the patch and is waiting for comments, however this is the pattern I've used: dotAtomText = [a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)* Value is "valid" if matches entirely dotAtomText"@"dotAtomText. Every feedback will be appreciated. -- Bye, Michelangelo
Re: [whatwg] Text areas with pattern attributes?
2009/8/24 Peter Kasting : > I think "pattern" is significantly less valuable than "maxlength", but it > wouldn't be too difficult to add support for it. I vote weakly against. More than that I'm a little concerned about potential performance drawbacks: having a pattern to be applied completely on a veeery long textarea could be a problem, such things can't be left to authors' good will. IMO. -- Bye, Michelangelo
Re: [whatwg] Text areas with pattern attributes?
2009/8/19 Jonas Sicking : > So for the pattern attribute, a use case would be on a site that > accepts US addresses (for example a store that only ships within the > US), the site could use a textarea together with a pattern that > matches US addresses. That would be a most unusual scenario IMO: I've never encountered such a format. Postal addresses are usually quite "structured", I guess nobody would impose a pattern on a single giant address (textarea), instead multiple form elements (input) could be used together to compose a postal address, even to provide a finer grain check on user's data. My two cents. -- Bye, Michelangelo
[whatwg] HTML5 requiredAttr pseudoclasses?
Hi, sorry for the dumb question, but what happened to ":required" and ":optional" pseudoclasses in HTML5 spec? I cant' find them out since WF2 has been declared as "obsolete". Thank you. -- Bill Cosby - "A word to the wise ain't necessary - it's the stupid ones that need the advice."