Re: winecfg: Add handling for drive options

2005-05-17 Thread Mike McCormack
James Hawkins wrote:
 case WM_COMMAND:
-if (HIWORD(wParam) == EN_CHANGE)
+switch (HIWORD(wParam))
 {
I don't know if it's just my opinion, but case statements within case 
statements make the code more difficult to read.  Would you consider 
creating a new function instead?  eg.

case WM_COMMAND:
OnCommand( dialog, HIWORD(wParam), LOWORD(wParam) );
break;
Mike


MSN Webcam

2005-05-17 Thread Maarten Lankhorst
Status: Nearly complete, need testers.
http://wiki.winehq.org/MSN_Messenger_webcam_support
You need the native quartz dll, which get installed with internet 
explorer, as the builtin quartz doesn't work properly when changing 
media format on initialisation. IFilterGraph Reconnect isn't 
implemented, and for some reason *looks strangely at Robert* instead of 
a FIXME() there's a TRACE telling it is a stub...



Re: comctl32: Move mouse tracking to MouseMove

2005-05-17 Thread Dimi Paun
On Tue, 2005-05-17 at 23:18 -0500, James Hawkins wrote:
> Changelog
> * Store the click point in LISTVIEW_INFO.
> * Move mouse tracking to MouseMove.
> * Use DragDetect instead of TrackMouse.
> * Remove the unused TrackMouse function.

I think you've sent the wrong patch...

-- 
Dimi Paun <[EMAIL PROTECTED]>
Lattica, Inc.




Re: Corrected the priority of operators for LISTVIEW_GetNextItem function.

2005-05-17 Thread Dmitry Timoshkov
<[EMAIL PROTECTED]> wrote:

> Changelog:
> 
> *   dlls/comctl32/listview.c
> 
> Corrected the priority of operators for LISTVIEW_GetNextItem function.

> --- dlls/comctl32/listview.c 2005-04-14 22:58:24.0 +0900
> +++ dlls/comctl32/listview.c 2005-05-16 11:29:08.003084512 +0900
> @@ -5665,7 +5665,7 @@
>   * so it's worth optimizing */
>  if (uFlags & LVNI_FOCUSED)
>  {
> - if (!(LISTVIEW_GetItemState(infoPtr, infoPtr->nFocusedItem, uMask) & uMask) 
> == uMask) return -1;
> + if (!((LISTVIEW_GetItemState(infoPtr, infoPtr->nFocusedItem, uMask) & 
> uMask) == uMask)) return -1;

Wouldn't it be more readable and less confusing in the below form?

if ((LISTVIEW_GetItemState(infoPtr, infoPtr->nFocusedItem, uMask) & uMask) != 
uMask) return -1;


-- 
Dmitry.




Re: storage32.c fix for big endian arch

2005-05-17 Thread Phil Krylov
Please disregard, Pierre d'Herbemont already sent the same few hours
before :)

-- Ph.

On Tue, 17 May 2005 21:41:41 +0400
Phil Krylov <[EMAIL PROTECTED]> wrote:

> ChangeLog:
> 
> Fixed storage32.c compilation in big endian architectures.
> 
> Patch:
> 
> Index: dlls/ole32/storage32.c
> ===
> RCS file: /home/wine/wine/dlls/ole32/storage32.c,v
> retrieving revision 1.87
> diff -p -u -r1.87 storage32.c
> --- dlls/ole32/storage32.c14 May 2005 11:06:44 -  1.87
> +++ dlls/ole32/storage32.c17 May 2005 17:20:06 -
> @@ -4130,8 +4130,8 @@ void StorageUtl_ReadULargeInteger(const 
>  ULARGE_INTEGER tmp;
>  
>  memcpy(&tmp, buffer + offset, sizeof(ULARGE_INTEGER));
> -value->LowPart = htole32(tmp.HighPart);
> -value->HighPart = htole32(tmp.LowPart);
> +value->u.LowPart = htole32(tmp.u.HighPart);
> +value->u.HighPart = htole32(tmp.u.LowPart);
>  #else
>  memcpy(value, buffer + offset, sizeof(ULARGE_INTEGER));
>  #endif
> @@ -4143,8 +4143,8 @@ void StorageUtl_WriteULargeInteger(BYTE*
>  #ifdef WORDS_BIGENDIAN
>  ULARGE_INTEGER tmp;
>  
> -tmp.LowPart = htole32(value->HighPart);
> -tmp.HighPart = htole32(value->LowPart);
> +tmp.u.LowPart = htole32(value->u.HighPart);
> +tmp.u.HighPart = htole32(value->u.LowPart);
>  memcpy(buffer + offset, &tmp, sizeof(ULARGE_INTEGER));
>  #else
>  memcpy(buffer + offset, value, sizeof(ULARGE_INTEGER));
> 
> 



Re: [crypt32] implementation of CryptProtectData/CryptUnprotectData

2005-05-17 Thread Kees Cook
On Tue, May 17, 2005 at 02:34:53PM +0900, Mike McCormack wrote:
> >ChangeLog:
> > Implements a best-guess of CryptProtectData/CryptUnprotectData.
> 
> Wow. That's alot of work :)

Heh, yeah, it has been.  But, I want it to get accepted, so I'll keep
working on it.  :)

> This patch looks OK to me at a quick glance, but if it's not applied, 
> please consider breaking it up.  At least that way, you'll have less to 
> submit next time round.

Okay, cool.  Alexandre, please let me know if breaking it up is
prefered, or if you want stuff arranged in some other way.  I'm all ears
for suggestions.  :)

-- 
Kees Cook@outflux.net



Re: [Fwd: Relationship between Wine and the proprietary versions.]

2005-05-17 Thread Dimitrie Paun
From: "Brian Vincent" <[EMAIL PROTECTED]>
> I think we need to get the scripts first.  
> Do you already have them? 

They are in the tools/ module in the WineHQ CVS:
http://cvs.winehq.org/cvsweb/tools/

Namely 'make_winehq' and 'wine_release'.

-- 
Dimi Paun <[EMAIL PROTECTED]>
Lattica, Inc.



Re: [Fwd: Relationship between Wine and the proprietary versions.]

2005-05-17 Thread Brian Vincent
On 5/17/05, Dimitrie Paun <[EMAIL PROTECTED]> wrote:
> > I also added an entry for how to update the FAQ since it's recently
> > changed.  That leads me to ask - has WineHQ been updated to build the
> > FAQ/docs from SF rather than WineHQ CVS?
> 
> No, I haven't had time to rewrite those scripts.
> If someone is kind enough to help out on this one,
> I'd really appreciate it.

I think we need to get the scripts first.  Do you already have them? 
I thought Newman kept them in a non-cvs-accessible location on WineHQ.
 I don't have time to work on them either, but if someone saw the
scripts they might be so inclined.

-Brian




Re: Added the callback item processing for LISTVIEW_EndEditLabelT function.

2005-05-17 Thread Dimitrie Paun
> Added the callback item processing for LISTVIEW_EndEditLabelT function.
(B
(BI think this would be a bit more explicit and correct (is_textW() returns
(Bfalse
(Bif pszText == NULL) if the test is the other way around:
(B
(B+if (lpItem && lpItem->hdr.pszText == LPSTR_TEXTCALLBACKW)
(B+{
(B+LISTVIEW_InvalidateItem(infoPtr, infoPtr->nEditLabelItem);
(B+}
(B+else
(B+{
(B+ZeroMemory(&dispInfo, sizeof(dispInfo));
(B+dispInfo.item.mask = LVIF_TEXT;
(B+dispInfo.item.iItem = infoPtr->nEditLabelItem;
(B+dispInfo.item.iSubItem = 0;
(B+dispInfo.item.pszText = pszText;
(B+dispInfo.item.cchTextMax = textlenT(pszText, isW);
(B+return LISTVIEW_SetItemT(infoPtr, &dispInfo.item, isW);
(B+}
(B
(B-- 
(BDimi.

Re: [Fwd: Relationship between Wine and the proprietary versions.]

2005-05-17 Thread Dimitrie Paun
From: "Brian Vincent" <[EMAIL PROTECTED]>

> Submitted to wine-patches.  The account I mailed it from isn't
> subscribed, so it may take a while to get moderated on.

Many thanks!

> I also added an entry for how to update the FAQ since it's recently
> changed.  That leads me to ask - has WineHQ been updated to build the
> FAQ/docs from SF rather than WineHQ CVS?

No, I haven't had time to rewrite those scripts.
If someone is kind enough to help out on this one,
I'd really appreciate it.

-- 
Dimi Paun <[EMAIL PROTECTED]>
Lattica, Inc.



Re: [Fwd: Relationship between Wine and the proprietary versions.]

2005-05-17 Thread Brian Vincent
On 5/16/05, Dimi Paun <[EMAIL PROTECTED]> wrote:
> I've got this request on wine-faq list (deleted the name, don't
> know if they want to be on wine-devel). Anyone care to write
> a small blurb about this?

Submitted to wine-patches.  The account I mailed it from isn't
subscribed, so it may take a while to get moderated on.

I also added an entry for how to update the FAQ since it's recently
changed.  That leads me to ask - has WineHQ been updated to build the
FAQ/docs from SF rather than WineHQ CVS?

-Brian




Wiki

2005-05-17 Thread Robert van Herk
Just wanted to say, that the wiki is great! It makes it much easier to 
pick a project to work on.

Robert


Re: Corrected the determination of capturing inside EDIT_WM_MouseMove function.

2005-05-17 Thread Dimitrie Paun
> Corrected the determination of capturing inside EDIT_WM_MouseMove
(Bfunction.
(B
(B> - if (GetCapture() != es->hwndSelf)
(B> + if (GetCapture() != es->hwndSelf || !es->bCaptureState)
(B
(BCan we have
(B  GetCapture() == es->hwndSelf && !es->bCaptureState
(B
(BIf so, isn't this an invalid state? How do we get there?
(B
(B-- 
(BDimi.

Re: Added the feature to change row height in owner draw controls.

2005-05-17 Thread Dimitrie Paun
> Added the feature to change row height in owner draw controls.
(B
(BThe indentation looks a bit funky on this one -- can you please
(Buse 4-space indentation?
(B
(B-- 
(BDimi.

Re: A better Beep

2005-05-17 Thread Marcelo Duarte
Whats happens if a program calls bepp with invalid values for dwFreq and 
dwDur on a linux console?
(the programmer thinks that dwFreq and dwDur are ignored by Win95).

David Lee Lambert escreveu:
Changelog:
 Support beeping with the PC speaker when running from the Linux console
 


--- dlls/kernel/console.c.v1_39 Fri May 13 15:38:16 2005
+++ dlls/kernel/console.c   Fri May 13 21:02:19 2005
@@ -193,9 +193,19 @@
 */
BOOL WINAPI Beep( DWORD dwFreq, DWORD dwDur )
{
-static const char beep = '\a';
-/* dwFreq and dwDur are ignored by Win95 */
-if (isatty(2)) write( 2, &beep, 1 );
+   if (strcmp(getenv("TERM"),"linux")==0 && isatty(2)) {
+  /* the Linux console supports setting frequency and duration */
+  char szBeep[50];
+  snprintf(szBeep,50,"\x1B[10;%d]\x1B[11;%d]\a",(int)dwFreq,(int)dwDur);
+  write( 2, szBeep, strlen(szBeep) );
+  usleep(dwDur*1000);
+   } else if (isatty(2)) {
+  /* dwFreq and dwDur are ignored by Win95 */
+  static const char beep = '\a';
+  write( 2, &beep, 1 );
+   } else {
+  /* TODO: we could play a .wav file instead... */
+   }
return TRUE;
}
 




Re: exeCryptor [JT]

2005-05-17 Thread Vitaly Lipatov
Ð ÑÐÐÐÑ ÐÑ 16 ÐÐÐ 2005 16:15 Mike Hearn ÑÐÐ(a):
> The lack of any decent copy protection on Linux *is* a problem. There is
> Shiva but it's quite old and has a crack available for it. The problem is,
What about HASP protection? It supports USB HASP key under Linux.
http://www.aladdin.com/hasp/default.asp

-- 
Vitaly Lipatov, ALT Linux Team
Russia, Saint-Petersburg, www.etersoft.ru