Re: dead stores in netapi32

2008-11-19 Thread Kai Blin
On Wednesday 19 November 2008 00:10:52 Juan Lang wrote:
  Does that netbios code actually work? IIRC you need to bind to port 137
  to do netbios requests.

 That's not strictly true, you can be a client without binding to port
 137.  You just can't advertise any services.  I haven't tried it
 myself in a long, long time, though I did hear from a couple people
 that were using it successfully a few years ago.

Oh, ok. I've only ever seen 137 in traces, but I guess that makes sense on 
Windows, where browsing is a system service anyway.

Thanks for pointing that out, Juan.

Ricardo, I'm currently looking at the netapi32 files you pointed out.

Thanks for the catch.

Cheers,
Kai

-- 
Kai Blin
WorldForge developer  http://www.worldforge.org/
Wine developerhttp://wiki.winehq.org/KaiBlin
Samba team member http://www.samba.org/samba/team/
--
Will code for cotton.


signature.asc
Description: This is a digitally signed message part.



Re: Fedora 9 and MingW

2008-11-19 Thread Hans Leidekker
On Tuesday 18 November 2008 22:48:11 Paul Vriens wrote:

 https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=61801forum=11
 
 I've installed these rpm's but the executables use a different naming 
 convention: i686-pc-mingw32* instead of what we check for: i686-mingw32*.
 
 Should we add this to our configure?

Looks promising! If Fedora accepts it under that name it's certainly
worthwhile to add it to configure.

 -Hans




RE: netapi32: Actually return a couple of return values.

2008-11-19 Thread ricardo filipe

it seems you two fixed the same, juan sent a patch in a previous wine-devel 
email.
you might want to check that because you two have different solutions for the 
first problem, line 415.

 From: [EMAIL PROTECTED]
 Date: Wed, 19 Nov 2008 12:41:50 +0100
 Subject: netapi32: Actually return a couple of return values.
 To: [EMAIL PROTECTED]
 
 
 ricardo filipe [EMAIL PROTECTED] found a couple of dead return
 value assignments in nbt.c and netbios.c
 
 Fix up these error paths.
 ---
  dlls/netapi32/nbt.c |   12 +++-
  dlls/netapi32/netbios.c |2 +-
  2 files changed, 12 insertions(+), 2 deletions(-)

_
Receba GRÁTIS as mensagens do Messenger no seu celular quando você estiver 
offline. Conheça  o MSN Mobile!
http://mobile.live.com/signup/signup2.aspx?lc=pt-br


Regarding ./configure file

2008-11-19 Thread shanmukha sainath addepalli
Sir/Madam,

I need to add few functions related to libwnck. It requires some header
files to be included. I included them in wine source code. But when compiled
it says header files not found. I haven't updated configure file. How can i
update it?
please tell me what r the changes that i need to made?

Regards,
Sainath.



Re: dlls/oleaut32: add tests for OleLoadPictureFile(Ex)

2008-11-19 Thread Jeremy Drake
On Tue, 18 Nov 2008, Michael Karcher wrote:

 Looks OK to me, but what happened to your finding about
 INET_E_RESOURCE_NOT_FOUND? Was it a red herring?

I saw that on XP, but I couldn't reproduce it on Windows 2000.  I need to
investigate this further.  Is there a mechansim to do
windows-version-specific tests?

  I ended up having to add OleLoadPicutreFile and OleLoadPictureFileEx to
  the .spec and .c files as actual functions (for now just returning
  E_NOTIMPL) in order to get the test to even compile.
 Might be that they don't appear in the ELF export table otherwise, and
 as we don't crossbuild the tests, the imports are done by the ELF
 linker/loader. BTW: In general, if you add stubs like this, please add a
 FIXME call showing the parameters and saying stub.

How do I show the VARIANT in the FIXME call?

 This fragment repeats over and over, sometimes with PICTYPE_BITMAP
 instead. Might be worth refactoring that into a function. todo_wine
 works for function boundaries. If you refactor, you should pass that
 function __LINE__ information and print it in your OK calls to know
 which of the tests is failing if something fails.

 You do a lot of tests like this. Setting disp to (void*)0xdeadbeef
 instead before allows you to differentiate between disp unmodified and
 disp explicitly set to zero.

Good ideas.  I'll do that.







Re: dlls/msxml3: check some dead store results (llvm/clang)

2008-11-19 Thread Paul Vriens
ricardo filipe wrote:
 only return value checking in this patch.
 
 _
 Confira vídeos com notícias do NY Times, gols direto do Lance, 
 videocassetadas e muito mais no MSN Video!
 http://video.msn.com/?mkt=pt-br
 
 
 
 
 
You are mixing tabs and spaces.

-- 
Cheers,

Paul.




RE: Regarding ./configure file

2008-11-19 Thread Stefan Dösinger
Don't modify ./configure directly, edit configure.ac instead. The autoconf
documentation describes how this file works. configure is then created from
configure.ac by running autoconf

 

 

From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]
On Behalf Of shanmukha sainath addepalli
Sent: Tuesday, November 18, 2008 10:27 AM
To: wine-devel@winehq.org
Subject: Regarding ./configure file

 

Sir/Madam,

I need to add few functions related to libwnck. It requires some header
files to be included. I included them in wine source code. But when compiled
it says header files not found. I haven't updated configure file. How can i
update it?
please tell me what r the changes that i need to made?

Regards,
Sainath.




spec file syntax for VARIANT parameter

2008-11-19 Thread Jeremy Drake
In order to implement OleLoadPictureFile and OleLoadPictureFileEx, it will
be necessary to change their entries in oleaut32.spec from stub to
stdcall.  The stdcall syntax wants a list of parameter types, which puts
these functions in an unususal situation: they take a VARIANT (which is a
struct, in case anyone is not familiar) by value as their first parameter.
There does not seem to be any type defined in the spec file that fits this
situation.  I have been using ptr in my last couple of patches which add
stub implementations for these functions, but when I tried to build this
on cygwin I got errors like:
undefined reference to [EMAIL PROTECTED]'
undefined reference to [EMAIL PROTECTED]'

Looking at the functions that are present in the .o file, I see they are
really [EMAIL PROTECTED] and [EMAIL PROTECTED]  Changing the
spec file to list each VARIANT as 4 longs fixes these errors.

My question is, should my next version of the patch list the VARIANT as 4
longs, or is there some better way to specify this that I'm not aware of?
If not, is there a comment syntax for the spec file where I can explain
why there are 4 long params where there should be one VARIANT?

Thanks
Jeremy





Re: spec file syntax for VARIANT parameter

2008-11-19 Thread Marcus Meissner
On Wed, Nov 19, 2008 at 01:11:05PM -0800, Jeremy Drake wrote:
 In order to implement OleLoadPictureFile and OleLoadPictureFileEx, it will
 be necessary to change their entries in oleaut32.spec from stub to
 stdcall.  The stdcall syntax wants a list of parameter types, which puts
 these functions in an unususal situation: they take a VARIANT (which is a
 struct, in case anyone is not familiar) by value as their first parameter.
 There does not seem to be any type defined in the spec file that fits this
 situation.  I have been using ptr in my last couple of patches which add
 stub implementations for these functions, but when I tried to build this
 on cygwin I got errors like:
 undefined reference to [EMAIL PROTECTED]'
 undefined reference to [EMAIL PROTECTED]'

Hmm, use as much long specifiers to fit the VARIANT struct (number of 
bytes/4).
I think VARIANT has 16 byte, so use long long long long.
 
 My question is, should my next version of the patch list the VARIANT as 4
 longs, or is there some better way to specify this that I'm not aware of?
 If not, is there a comment syntax for the spec file where I can explain
 why there are 4 long params where there should be one VARIANT?

Currently no other way.

Ciao, Marcus




Re: Regarding ./configure file

2008-11-19 Thread Massimo Del Fedele
I've looked into configure and configure.ac and I've seen that configure 
is quite more recent than configure.ac and it seems to have been 
changed manually. Am I wrong ?

Max


Stefan Dösinger ha scritto:
 Don't modify ./configure directly, edit configure.ac instead. The 
 autoconf documentation describes how this file works. configure is then 
 created from configure.ac by running autoconf
 
  
 
  
 
 *From:* [EMAIL PROTECTED] 
 [mailto:[EMAIL PROTECTED] *On Behalf Of *shanmukha sainath 
 addepalli
 *Sent:* Tuesday, November 18, 2008 10:27 AM
 *To:* wine-devel@winehq.org
 *Subject:* Regarding ./configure file
 
  
 
 Sir/Madam,
 
 I need to add few functions related to libwnck. It requires some header 
 files to be included. I included them in wine source code. But when 
 compiled it says header files not found. I haven't updated configure 
 file. How can i update it?
 please tell me what r the changes that i need to made?
 
 Regards,
 Sainath.
 
 
 
 
 





Re: dlls/ole32: fixed dead assignments (llvm/clang)

2008-11-19 Thread Rob Shearman
2008/11/18 ricardo filipe [EMAIL PROTECTED]:
 @@ -1951,6 +1951,12 @@ HRESULT WINAPI CoRegisterClassObject(
  newClass-pMarshaledData,
  flags  
 (REGCLS_MULTIPLEUSE|REGCLS_MULTI_SEPARATE),
  newClass-RpcRegistration);
 + MSHLFLAGS_TABLESTRONG);

This won't compile.

 +  if (hr) {
 +  FIXME(RPC_StartLocalServer failed, %x!\n,hr);

You should change this to:
ERR(RPC_StartLocalServer failed with error 0x%x\n,hr);

 +  return hr;
 +  }
 +
}
return S_OK;
  }
 diff --git a/dlls/ole32/ole16.c b/dlls/ole32/ole16.c
 index a8fa59b..21fb1fb 100644
 --- a/dlls/ole32/ole16.c
 +++ b/dlls/ole32/ole16.c
 @@ -598,13 +598,13 @@ HRESULT WINAPI CLSIDFromProgID16(LPCOLESTR16 progid, 
 LPCLSID riid)

   buf = HeapAlloc(GetProcessHeap(),0,strlen(progid)+8);
   sprintf(buf,%s\\CLSID,progid);
 - if ((err=RegOpenKeyA(HKEY_CLASSES_ROOT,buf,xhkey))) {
 + if (RegOpenKeyA(HKEY_CLASSES_ROOT,buf,xhkey)) {

Since you are changing this anyway, you should explicitly compare the
result against ERROR_SUCCESS to improve readability of the code here.

   HeapFree(GetProcessHeap(),0,buf);
  return CO_E_CLASSSTRING;
   }
   HeapFree(GetProcessHeap(),0,buf);
   buf2len = sizeof(buf2);
 - if ((err=RegQueryValueA(xhkey,NULL,buf2,buf2len))) {
 + if (RegQueryValueA(xhkey,NULL,buf2,buf2len)) {

Ditto.

   RegCloseKey(xhkey);
  return CO_E_CLASSSTRING;
   }


-- 
Rob Shearman




Re: dlls/rpcrt4: fixed dead increments (llvm/clang)

2008-11-19 Thread Rob Shearman
2008/11/18 ricardo filipe [EMAIL PROTECTED]:
 diff --git a/dlls/rpcrt4/rpc_transport.c b/dlls/rpcrt4/rpc_transport.c
 index 3d66740..815ed64 100644
 --- a/dlls/rpcrt4/rpc_transport.c
 +++ b/dlls/rpcrt4/rpc_transport.c
 @@ -479,7 +479,6 @@ static size_t rpcrt4_ncacn_np_get_top_of_tower(unsigned 
 char *tower_data,
  memcpy(tower_data, networkaddr, networkaddr_size);
  else
  tower_data[0] = 0;
 -tower_data += networkaddr_size;

  return size;
  }
 @@ -692,7 +691,6 @@ static size_t rpcrt4_ncalrpc_get_top_of_tower(unsigned 
 char *tower_data,
  pipe_floor-count_rhs = endpoint_size;

  memcpy(tower_data, endpoint, endpoint_size);
 -tower_data += endpoint_size;

  return size;
  }

These increments are intentional in case the code is copy and pasted
and some more data is added to the end, so please don't remove them.

-- 
Rob Shearman




Re: dlls/rpcrt4: fixed dead increments (llvm/clang)

2008-11-19 Thread Michael Stefaniuc
Rob Shearman wrote:
 2008/11/18 ricardo filipe [EMAIL PROTECTED]:
 diff --git a/dlls/rpcrt4/rpc_transport.c b/dlls/rpcrt4/rpc_transport.c
 index 3d66740..815ed64 100644
 --- a/dlls/rpcrt4/rpc_transport.c
 +++ b/dlls/rpcrt4/rpc_transport.c
 @@ -479,7 +479,6 @@ static size_t rpcrt4_ncacn_np_get_top_of_tower(unsigned 
 char *tower_data,
  memcpy(tower_data, networkaddr, networkaddr_size);
  else
  tower_data[0] = 0;
 -tower_data += networkaddr_size;

  return size;
  }
 @@ -692,7 +691,6 @@ static size_t rpcrt4_ncalrpc_get_top_of_tower(unsigned 
 char *tower_data,
  pipe_floor-count_rhs = endpoint_size;

  memcpy(tower_data, endpoint, endpoint_size);
 -tower_data += endpoint_size;

  return size;
  }
 
 These increments are intentional in case the code is copy and pasted
 and some more data is added to the end, so please don't remove them.
But those are dead code in the actual context and thus distract the 
reader. Shouldn't those be made comments instead?

bye
michael