Re: [PATCH] Label verbosity levels.
From: max On 03/19/2011 08:42 PM, Joris Huizer wrote: > On 03/19/2011 11:32 PM, Vitaliy Margolen wrote: >> On 03/18/2011 09:24 PM, m...@mtew.isa-geek.net wrote: >>> - if ($opt_verbose> 0) >>> - { >>> -print "Processing ".$spec_name."\n"; >>> - } >>> + print "Processing ".$spec_name."\n" >>> +if $opt_verbose q>= $VERBOSE_INPUT; >> >> Please don't do this reverse notation. It's much more confusing to most >> people who are not too familiar with Perl. >> >> Also you changing logic, by replacing ">" (greater then) with ">=" (greater >> of equal. This is a big no-no to combine any logical changes with cleanup >> changes. > > This doesn't seem to change logic as $VERBOSE_INPUT equals 1 ( $VERBOSE_QUIET > equals 0 ) > Correct. The clean-up involves two counter-acting logic changes. The change from > to >= is countered by increasing the target number by one. The result is that the number itself has the designated meaning. Before the number was one less than level needed to change the affect. There is no _functional_ change. The suffix logical form is not that difficult to understand. It shifts the emphasis from the conditional as the thing of primary import to the message being conveyed, where it belongs. On the other hand if anybody can come up with better names for the levels, PLEASE comment! Max
Re: [1/2] msvcrt: Implement _mbsupr_s (try2).
Dnia piątek, 18 marca 2011, Dan Kegel napisał(a): > But you could do a few tests. It's ok if some of them are todo_wine. > - Dan I've added some simple test and you have completly right to add them. The original libraries works different from what documentation says... Fourth try was send couple minutes ago. I really hope this is last one. -- Konrad Rzepecki (Hannibal)
Re: [PATCH] Label verbosity levels.
On 03/19/2011 11:32 PM, Vitaliy Margolen wrote: On 03/18/2011 09:24 PM, m...@mtew.isa-geek.net wrote: - if ($opt_verbose> 0) - { -print "Processing ".$spec_name."\n"; - } + print "Processing ".$spec_name."\n" +if $opt_verbose>= $VERBOSE_INPUT; Please don't do this reverse notation. It's much more confusing to most people who are not too familiar with Perl. Also you changing logic, by replacing ">" (greater then) with ">=" (greater of equal. This is a big no-no to combine any logical changes with cleanup changes. This doesn't seem to change logic as $VERBOSE_INPUT equals 1 ( $VERBOSE_QUIET equals 0 )
Re: [PATCH] Label verbosity levels.
On 03/18/2011 09:24 PM, m...@mtew.isa-geek.net wrote: - if ($opt_verbose> 0) - { -print "Processing ".$spec_name."\n"; - } + print "Processing ".$spec_name."\n" +if $opt_verbose>= $VERBOSE_INPUT; Please don't do this reverse notation. It's much more confusing to most people who are not too familiar with Perl. Also you changing logic, by replacing ">" (greater then) with ">=" (greater of equal. This is a big no-no to combine any logical changes with cleanup changes.
GSOC-Introduction
Hi there I am Sanket Patel I can code well in C If Anything is say to Implement I have good skill in coding in C At all And can Use Efficient C help topics.