Re: [PATCH v3 0/7] Add O_DENY* support for VFS and CIFS/NFS

2013-03-01 Thread David Laight
On Thu, Feb 28, 2013 at 01:53:25PM -0800, Andy Lutomirski wrote:
  O_DENYMAND - to switch on/off three flags above.
 
 O_DENYMAND doesn't deny anything.  Would a name like O_RESPECT_DENY be
 better?

Possibly rename to O_CHECK_DENY ?

David

-- 
David Laight: da...@l8s.co.uk




Re: [PATCH] Add support for -Ttext-segment linker flag to set image base of a dll.

2013-03-01 Thread Alexandre Julliard
Tijl Coosemans t...@coosemans.org writes:

 ---
  configure.ac| 2 ++
  tools/winegcc/winegcc.c | 8 
  2 files changed, 10 insertions(+)

This would have to be done based on the target platform, not on a
configure check.

-- 
Alexandre Julliard
julli...@winehq.org




Re: mmdevapi: Prevent 64 bit overflow within a few days of audio device use. (try 2)

2013-03-01 Thread Michael Stefaniuc
Hello Joerg,

On 03/01/2013 10:22 AM, joerg-cyril.hoe...@t-systems.com wrote:
 The idea to replace X * numerator / denominator
 by X / den * mul + remainder from euclidian division
 came from
 http://blog.airsource.co.uk/index.php/2010/03/15/quelle-heure-est-il/
 
 M. Stefaniuc suggested an inline function. The MulDiv64 inline has the benefit
 of ensuring unsigned arithmetic, matching GetPosition UINT64 output.
My idea was to have the whole if else in an inline function.
But I see that even the whole functionality can move to a helper.
Something like this:

static inline ULONGLONG get_qpctime(void)
{
LARGE_INTEGER stamp, freq;
QueryPerformanceCounter(stamp);
QueryPerformanceFrequency(freq);
if(freq.QuadPart == 1000)
return stamp.QuadPart;
else
return stamp.QuadPart / freq.QuadPart * 1000
  + stamp.QuadPart % freq.QuadPart * 1000 /
freq.QuadPart;
}

bye
michael




Re: ieframe: Fixed tests on IE10.

2013-03-01 Thread Marvin
Hi,

While running your changed tests on Windows, I think I found new failures.
Being a bot and all I'm not very good at pattern recognition, so I might be
wrong, but could you please double-check?
Full results can be found at
http://testbot.winehq.org/JobDetails.pl?Key=24562

Your paranoid android.


=== WNT4WSSP6 (32 bit webbrowser) ===
Timeout

=== W2KPROSP4 (32 bit webbrowser) ===
webbrowser.c:2613: Test failed: expected GetOverridesKeyPath
webbrowser.c:2618: Test failed: expected Invoke_SETSECURELOCKICON
webbrowser.c:2619: Test failed: expected Invoke_FILEDOWNLOAD
webbrowser.c:3052: Test failed: doc_disp == NULL
webbrowser: unhandled exception c005 at 00402F21




Re: d3dx9 [patch 1/2]: Implement D3DXSHEvalConeLight

2013-03-01 Thread Matteo Bruni
2013/3/1 Nozomi Kodama nozomi.kod...@yahoo.com:
 Why is this patch marked as not applied by the testbot?
 In my computer, with the latest git, it applies fine.

 Is there a problem with testbot?

 Nozomi



Yeah, the old testbot has some issues. FWIW the patches applied just
fine for me.

Now, I know I'm going to be a PITA, but:

+red_expected = test[l].red_out;
...
+hr = D3DXSHEvalConeLight(order, dir, test[l].radius,
1.7f, 2.6f, 3.5f, red_expected, green_expected, blue_expected);
...
+ok(relative_error(expected, red_expected[j])  admitted_error,

isn't really better than the previous patch. What I meant is that the
variables storing the output of D3DXSHEvalConeLight should be named in
a way that shows it's the output of the function and what we want to
test, while the variables with the expected values (the values a good
implementation of the function should return and that you use to
assess whether the implementation is working correctly) should be
named accordingly too. So you went from calling everything out to
calling everything expected, which doesn't help much ;)
I'd just remove the red_expected variable and use test[l].red_out
directly. Same for green and blue of course.




mmdevapi: Prevent 64 bit overflow within a few days of audio device use. (try 2)

2013-03-01 Thread Joerg-Cyril.Hoehle
Michael Stefaniuc wrote:
My idea was to have the whole if else in an inline function.

That's understandable.  However in this particular case, we know that in Wine 
QueryPerfFrequency now yields 1000, thus Muldiv64 is dead code actually.
So I decided to keep the
if (freq == 1000) return idem;
in the main code and delegate the unused MulDiv to an auxiliary.

In winmm:waveform, things are a little different, and I was indeed considering
integrating the if (num==den) /* typically num = den = samples per second */
into the MulDiv64, should I add one there too.

A general purpose MulDiv however, should not waste cycles performing this 
particular check.

Regards,
 Jörg Höhle





Re: [PATCH 3/3] msvcrt: Added stdin close/open tests

2013-03-01 Thread Marvin
Hi,

While running your changed tests on Windows, I think I found new failures.
Being a bot and all I'm not very good at pattern recognition, so I might be
wrong, but could you please double-check?
Full results can be found at
http://testbot.winehq.org/JobDetails.pl?Key=24564

Your paranoid android.


=== WVISTAADM (32 bit file) ===
Failure running script in VM: The specified guest user must be logged in 
interactively to perform this operation




Re: Use accented letters in their names.

2013-03-01 Thread Tae Wong
The authors file is outdated and you want this updated with the
missing authors. Andrej Znidarsic should have Slovenian accented
letters for his last name.

On 2/4/13, Tae Wong seotaewon...@gmail.com wrote:
 You will want to use accented letters in their authors names.

 Caolan McNamara
 Ferenc Wagner
 Marko Nikolic

 Every once and a while the GNOME Live website is down with an error on
 Netscape called “The operation timed out when attempting to contact .”
 - This paragraph should have a website name. You want to be unbanned
 in Amaterasu Translations and the DOS ain’t dead forums.





Re: gdiplus: GdipDrawString should handle alignment in both directions in a similar way. Take 2.

2013-03-01 Thread Vincent Povirk
Sorry, I'm still not sure this is going to work. It seems to me that
different lines will have to be offset by different amounts, and it's
not clear to me how that's going to happen without the alignment logic
in gdip_format_string.

I'm also wondering if a change to the alignment logic in
gdip_format_string is going to break MeasureCharacterRanges.