RE: [PATCH V3 5/13] hid: use time_is_after_jiffies() instead of open coding it

2022-02-15 Thread
 
>>On Tue, Feb 15, 2022 at 2:56 AM Qing Wang  wrote:
>>
>> From: Wang Qing 
>>
>> Use the helper function time_is_{before,after}_jiffies() to improve
>> code readability.
>>
>> Signed-off-by: Wang Qing 
>> Acked-by: Srinivas Pandruvada 
>
>FWIW, this one is
>Acked-by: Benjamin Tissoires 
>
>Wang, is there any plan to take this series through the trivial tree

That's why I batch them in a series, but I don't know how to take 
this series through the trivial tree directly.

I would appreciate if you could help.

Thanks,
Wang

>or should each maintainer take the matching patches?
>
>Cheers,
>Benjamin
>
>> ---
>>  drivers/hid/intel-ish-hid/ipc/ipc.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/hid/intel-ish-hid/ipc/ipc.c 
>> b/drivers/hid/intel-ish-hid/ipc/ipc.c
>> index 8ccb246..15e1423
>> --- a/drivers/hid/intel-ish-hid/ipc/ipc.c
>> +++ b/drivers/hid/intel-ish-hid/ipc/ipc.c
>> @@ -578,7 +578,7 @@ static void _ish_sync_fw_clock(struct ishtp_device *dev)
>> static unsigned long    prev_sync;
>> uint64_t    usec;
>>
>> -   if (prev_sync && jiffies - prev_sync < 20 * HZ)
>> +   if (prev_sync && time_is_after_jiffies(prev_sync + 20 * HZ))
>> return;
>>
>> prev_sync = jiffies;
>> --
>> 2.7.4
>>


RE: [PATCH V2 00/13] use time_is_xxx() instead of jiffies judgment

2022-02-13 Thread
 
>>On Thu, Feb 10, 2022 at 06:30:23PM -0800, Qing Wang wrote:
>> From: Wang Qing 
>> 
>> It is better to use time_is_xxx() directly instead of jiffies judgment
>> for understanding.
>
>Hi Wang,
>
>"judgement" doesn't really make sense as a description to an English
>speaker.  The following a commit desription (for all of these series)
>is probably going to be a bit more understable:
>
>Use the helper function time_is_{before,after}_jiffies() to improve
>code readability.
>
>Cheers,
>
>   - Ted

I see, it will be corrected in V3.
I'll wait a few days if there are any other disagreements.

Thanks,
Qing