Re: [PATCH] xfree86/modes: Fixed memory leak in xf86InitialConfiguration

2011-03-10 Thread keithp
On Thu, 10 Mar 2011 11:07:35 +0200, Erkki Seppala erkki.sepp...@vincit.fi 
wrote:

 Also, I don't think it can be a CRLF-issue, because the Internet text
 message format prohibits lines with CRLF and the mail isn't encoded in
 any special way. (In any case, my email agent shows that all messages
 have CRLF-terminated lines, and git am doesn't worry about those
 files.)

Oh. You sent it to my intel email address. I'll bet exchange mangled
it. I hadn't even thought to check that. kei...@keithp.com is a far
better plan for useful email. Sigh.

-- 
keith.pack...@intel.com


pgp5dF8iWE9vq.pgp
Description: PGP signature
___
xorg-devel@lists.x.org: X.Org development
Archives: http://lists.x.org/archives/xorg-devel
Info: http://lists.x.org/mailman/listinfo/xorg-devel

Re: [PULL] Linux and bus subsystem cleanups

2009-11-10 Thread keithp
Excerpts from Adam Jackson's message of Tue Nov 10 11:43:21 -0800 2009:

 Adam Jackson (7):

   bus: Fix open-coded implementation of xf86MakeNewMapping

This leaves vp uninitialized. You need to keep calling
getVidMapRec

   bus: Change xf86MakeNewMapping prototype to match reality

If no drivers use it, please remove it from the ABI.

   linux: PCI_DOM_MASK is 0xff everywhere.

The kernel allows for 16 bits here; do we need to fix this? Or
can we live with only 8 (yes, I know that would require
actually fixing the code)?

   bus: remove some dead struct fields
   linux: mmap'd i/o space per domain, if it exists, is 64k
   linux: MAX_DOMAINS is 256.
   linux: Remove pre-2.6 PCI interface support.

All of these seem fine.

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PULL] Linux and bus subsystem cleanups

2009-11-10 Thread keithp
Excerpts from Adam Jackson's message of Tue Nov 10 14:06:47 -0800 2009:

 Slightly easier said than done.  sdksyms.sh pretty much wants _every_
 definition in sdk headers to be prefaced with _X_EXPORT, last time I
 read it.  So it'd need to be in a new header, or we'd need to fix
 sdksyms.sh.

It's under XF86_OS_PRIVS in the header; how about moving all of those
to xf86OSpriv.h instead?

 I'm of the opinion that the shell script is far far worse than the
 static list we had before, in that it actually grew the ABI.  The joke
 is that it did so in the name of being able to use -fvisibility=hidden
 to seal off more of the ABI!  Some kind of massive misunderstanding of
 the problem.

Soon, it won't matter -- the whole ABI will be private to non-server
components.

 that's the kind of ABI break I'd like merged drivers for.

Given that we've only supported 8 bits in the past (due to the 32-bit
encoding we use), I'd say we can 'ignore' this for now and plan on
moving to the structure later on.

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PATCH] Remove lnx_font.c and lnx.h

2009-11-05 Thread keithp
Excerpts from Matt Turner's message of Thu Nov 05 09:38:53 -0800 2009:

 So can we kill it? I remember reading about an X developer who
 suggested that the way to remove code was to silently break it and see
 if anyone complains. :)

Yeah, but the key there is to make it look like an accident. In any
case I'd love to know what Daniel was thinking in his original
comment.

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PATCH] Remove lnx_font.c and lnx.h

2009-11-05 Thread keithp
Excerpts from Tiago Vignatti's message of Thu Nov 05 19:19:18 -0800 2009:

 hummm I've never seen any not-so-much-recently driver doing such console 
 font saving, specially for multiseat setups.
 
 Reviewed-by: Tiago Vignatti tiago.vigna...@nokia.com

Thanks, Tiago and Matt.

-- 
keith.pack...@intel.com
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PATCH] Abstract calls to in/out with IN/OUT macros

2009-11-01 Thread keithp
Excerpts from Matt Turner's message of Sun Nov 01 11:01:20 -0800 2009:
 This will allow us to include sys/io.h and use libc's in/out when
 available.

That's a fine goal, but given the ambiguity between Linux and BSD on
the outb argument ordering, I've got some suggestions

  #ifdef linux
 -/* for Linux on Alpha, we use the LIBC _inx/_outx routines */
 -/* note that the appropriate setup via ioperm needs to be done */
 -/*  *before* any inx/outx is done. */
 +# include sys/io.h
 +# define OUTB(port, val) outb((val), (port))
 +# define OUTW(port, val) outw((val), (port))
 +# define OUTL(port, val) outl((val), (port))

Please use inline functions instead of macros. Also, please make it
obvious that these macros belong to X.org and are not brought from
some other package. Further, it would be nice to have them
self-documenting as far as argument order somehow, perhaps

static inline void xorg_outb_port_val(uint16_t port, uint8_t val)

(suggestions welcome here, I just want to make people aware of any
ordering change here).

What isn't clear is how this affects the current API; ideally, we'd
make all existing drivers using whatever old names they've got
continue to compile, but with warnings so that developers will know
what to do to fix them.

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PATCH] Remove lnx_font.c and lnx.h

2009-11-01 Thread keithp
Excerpts from Matt Turner's message of Sun Nov 01 12:22:44 -0800 2009:
 I couldn't find any version of the X xserver that ever used lnx_font.c
 so let's delete it. I tried contacting its author, Egbert, multiple
 times on IRC and email [*] but never got any response. It also hasn't
 been seriously touched since January 2005.

The only reference I've found to this is an ubuntu bug:

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/105822

which seems to have conflicting reports about what this is good
for. I'm of the opinion that the graphics driver should be responsible
for returning the card to its original state (and hence the X server
shouldn't be doing anything with console fonts). It would be nice to
know whether there are drivers which aren't successfully restoring the
entire console font though, and for whom a helper function of this
sort would be useful.

Daniels reportedly commented that this code would break multi-card
uses, although I'm not entirely sure why that would be the case,
unless that referred to multi-seat instead.

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PATCH] Abstract calls to in/out with IN/OUT macros

2009-11-01 Thread keithp
Excerpts from Mark Kettenis's message of Sun Nov 01 13:19:04 -0800 2009:

 While I sympathise with your attempt to clean up the mess in
 compiler.h, this will break at least one driver (xf86-video-i128).

A fine example of why we want to merge the drivers into the server :-)

In any case, for now, I'd rather see an ABI/API compatible change that
has the server get at the system io functions through a standard api
while still providing the old interfaces so that drivers continue to
build unchanged. Having those old interfaces work through the new
standard API would be great if possible. Marking those as 'deprecated'
so that the compiler emits a warning would be a nice bonus.

I should start a wiki page about how we want to change the driver
API/ABI...

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PATCH] [alpha] Remove unused code, _dense_* functions, iobase stuff

2009-11-01 Thread keithp
Excerpts from Michael Cree's message of Sun Nov 01 15:33:18 -0800 2009:

 I'm happy to test this, but it may be a couple of days before I can do  
 so.

Cool! Send a note when you figure out whether you think this is ready
for master, and include a a suitable '-by:' tag for git (either
Tested-by or Reviewed-by, or both).

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel


Re: [PATCH] glx: swrast can do GLX 1.4 too

2009-10-29 Thread keithp
Excerpts from Adam Jackson's message of Thu Oct 29 11:01:29 -0700 2009:

 +screen-base.GLXmajor = 1;
 +screen-base.GLXminor = 4;
 +

Should this define be in a header somewhere?

-- 
keith.pack...@intel.com


signature.asc
Description: PGP signature
___
xorg-devel mailing list
xorg-devel@lists.x.org
http://lists.x.org/mailman/listinfo/xorg-devel